none
SP3 fails to update

    Question

  •  

    We have about 700 workstations and most downloaded and installed Windows Xp SP3 fine. However we have 70 clients, all same laptop model HP 8430 and same clone that fail during the installation of SP3. When it tries installing The Event log shows this :

    Installation Failure: Windows failed to install the following update with error 0x80242007: Windows XP Service Pack 3 (KB936929).

    Researching the problem got me to the point where I know it's timing out before the install completes. I cannot figure out why. Here is the WindowsUpdate.log transcript. Can anybody help?

     

    Forced install timer expired for scheduled install
    2008-08-06 04:00:10:340 1516 b14 AU UpdateDownloadProperties: 0 download(s) are still in progress.
    2008-08-06 04:00:10:340 1516 b14 AU #############
    2008-08-06 04:00:10:340 1516 b14 AU ## START ##  AU: Install updates
    2008-08-06 04:00:10:340 1516 b14 AU #########
    2008-08-06 04:00:10:340 1516 b14 AU   # Initiating scheduled install
    2008-08-06 04:00:10:340 1516 b14 AU   # Approved updates = 1
    2008-08-06 04:00:10:340 1516 b14 AU <<## SUBMITTED ## AU: Install updates / installing updates [CallId = {0B2E8046-E976-466C-8D52-979BA7541778}]
    2008-08-06 04:00:10:340 1516 cf8 Agent *************
    2008-08-06 04:00:10:340 1516 cf8 Agent ** START **  Agent: Installing updates [CallerId = AutomaticUpdates]
    2008-08-06 04:00:10:340 1516 cf8 Agent *********
    2008-08-06 04:00:10:340 1516 cf8 Agent   * Updates to install = 1
    2008-08-06 04:00:12:184 1516 cf8 Agent   *   Title = Windows XP Service Pack 3 (KB936929)
    2008-08-06 04:00:12:184 1516 cf8 Agent   *   UpdateId = {34B52415-A5BA-41E9-8072-9D2DEE8B22A9}.105
    2008-08-06 04:00:12:184 1516 cf8 Agent   *     Bundles 1 updates:
    2008-08-06 04:00:12:184 1516 cf8 Agent   *       {782E2486-9C69-408C-8ACE-22EEE7A21D2F}.105
    2008-08-06 04:00:41:904 1516 cf8 DnldMgr Preparing update for install, updateId = {782E2486-9C69-408C-8ACE-22EEE7A21D2F}.105.
    2008-08-06 04:00:41:951 5988 d30 Misc ===========  Logging initialized (build: 7.1.6001.65, tz: -0400)  ===========
    2008-08-06 04:00:41:951 5988 d30 Misc   = Process: C:\WINDOWS\system32\wuauclt.exe
    2008-08-06 04:00:41:951 5988 d30 Misc   = Module: C:\WINDOWS\system32\wuaueng.dll
    2008-08-06 04:00:41:951 5988 d30 Handler :::::::::::::
    2008-08-06 04:00:41:951 5988 d30 Handler :: START ::  Handler: Windows Patch Install
    2008-08-06 04:00:41:982 5988 d30 Handler :::::::::
    2008-08-06 04:00:41:982 5988 d30 Handler   : Updates to install = 1
    2008-08-06 04:00:41:982 5988 d30 Handler   : Installing update {782E2486-9C69-408C-8ACE-22EEE7A21D2F}.105
    2008-08-06 04:00:41:982 5988 63c Handler Installing with parameters=-q -z -er, sandbox=C:\WINDOWS\SoftwareDistribution\Download\47969d2fe0fce908ef09aeb98cd53a17.

    Friday, August 08, 2008 8:52 PM

All replies

  • The small section of log file did not contain anything informative.  But try http://support.microsoft.com/kb/943144 as a first line of approach.

    Friday, August 08, 2008 10:22 PM
  •  

    Thanks for the response rdhw. Unfortunately that article didn't help. I also left out a few details. The main problem occurs when SP3 tries to install when the user shuts down the machine. It just stays at the "Installing Update 1 of 1" window and never shuts down. The snippet I posted on my original post from the windowsupdate.log is what happens when it tries installing the update. After it times out the next line jumps right back to downloading the update again and it continues like that with no error reported in the update log. Also running SP3 manually from the executable works fine.
    Monday, August 11, 2008 2:48 PM
  • I don't know for sure, but maybe SP3 cannot be installed at shutdown: there are normally some user interaction dialogues to be clicked through.

    Monday, August 11, 2008 3:17 PM