none
How do I disable zip folders in Windows 7?

    Question

  • I like to use a third-party archive application, so I really don't like how by default Windows makes zip files expand automatically in Windows Explorer and show up in the folder view.

    So... How do I disable zip folders in Windows 7?

    ---------
    In XP and Vista, I was able to find solutions to remove this "feature" 

    In XP, I simply did...

    regsvr32 /u zipfldr.dll

    In Vista, I had to remove a couple registry entries:

    Windows Registry Editor Version 5.00
    ; Disable ZIP support in Windows Vista
    ; restart Windows after applying this patch
    [-HKEY_CLASSES_ROOT\CLSID\{E88DCCE0-B7B3-11d1-A9F0-00AA0060FA31}]
    [-HKEY_CLASSES_ROOT\CLSID\{0CD7A5C0-9F37-11CE-AE65-08002B2E1262}]

    I don't want to guess and delete the wrong registry entries if someone else knows which ones I need to remove.

    Wednesday, January 21, 2009 2:31 AM

Answers

  • EDIT - I HAVE FOUND A SOLUTION

    After considerable browsing (thank you, Google), I have a solution that works. It is based on fixes for Vista, but works 100% for my Windows 7 64-bit install. 

    You will need to edit your registry (delete 2 different keys), so I highly recommend you back up your registry or better yet, make an image of your OS drive (probably C:\). I use Norton Ghost 2003 (only from a NG 2003 boot floppy) and have never had a single problem. Norton Ghost does not have to be installed on your system for this to work (in fact, it will stall due to compatibility issues). 

    First a note regarding the various reg tweaks that are available for download (e.g., "vistaunzip.reg"). These will NOT work - undoubtedly due to ownership/permissions issues. 

    The following two (2) keys need to be deleted fromthe registry:

    For zip files delete the regkey
    HKEY_CLASSES_ROOT\CLSID\{E88DCCE0-B7B3-11d1-A9F0-00AA0060FA31}

    For cab files delete
    HKEY_CLASSES_ROOT\CLSID\{0CD7A5C0-9F37-11CE-AE65-08002B2E1262}

    When you try to delete them, you will almost certainly get an "access denied" or "failed" type of message. Before you can delete them, you need to change the permissions/ownership of these two keys. Here is how to do it:

    01 - open regedit from the RUN console

    02 - navigate to the first key that needs to be deleted (HKEY_CLASSES_ROOT\CLSID\{E88DCCE0- B7B3-11d1-A9F0-00AA0060FA31})

    03 - right click on the key and select "Permissions"

    04 - click on "Advanced"

    05 - click on the "Ownership" tab

    06 - in the "change owner to" section, highlight your username

    07 - check the box for "replace owner on subcontainers and objects"

    08 - click on "Apply"

    09 - Click "OK"

    10 - Under "Security" tab, highlight your username and check the box for "Allow Full Control" (located mid-menu in the "Permissions For Administrators" section)

    11 - click "Apply" and "OK"

    12 - you can now delete the registry key. MAKE SURE YOU ARE ON THE CORRECT KEY!

    13 - repeat the process for the 2nd key.

    14 - reboot (changes will NOT take effect until you reboot

    15 - VOILA! NO MORE ZIP FOLDERS! woohoo!

    16 - thanks to the original solvers of this problem, whomever they may be.

    *********************************************************************************

    I would like the same help that deedvd is seeking. How do I DISABLE the zip folder function? I do NOT want my zip files to appear as "folders". Why anyone in Redmond thought this was a brilliant idea is beyond me. It adds to clutter and makes file browsing a lot less enjoyable. I simply want my zip files to appear as files - with the ".zip" extension. Just like every other file. The responses to deepdvd were probably as frustrating to him as they are to me. Changing the default program for zip files is IRRELEVANT. It only changes whether Windows or some third party app (7Zip, Izarc, etc) OPENS the files. They continue to show up as folders.  I tried the unregister script (earlier thread)

    "Running regsvr32 /u %windir%\system32\zipfldr.dll should be enough to disable zip functionality. Then just run your 3rd party archite application and let it re-register archive files." and it did not work. I got the same error that deeddvd got "The module "C:\Windows\system32\zipfldr.dll" was loaded but the entry-point DllUnregisterServer was not found.

    Make sure that "C:\Windows\system32\zipfldr.dll" is a valid DLL or OCX file and then try again."

    I would love to find a resolution to this problem. If anyone out there knows how to DISABLE the zipfolder function, please post the solution. I am thanking you in advance.
    • Proposed as answer by svenn99 Friday, February 06, 2009 7:30 PM
    • Marked as answer by Arie SlobMVP, Editor Friday, November 06, 2009 12:39 AM
    Friday, February 06, 2009 5:27 PM

All replies

  • The one I use is Winzip (PAID registered user since 1995 and have latest version as well)
    Just run the winzip install program.

    Wednesday, January 21, 2009 2:44 AM
  • @Chitchatjf,    Are you saying that your Folder View doesn't look like this?

    I don't want any zip files to appear as subfolders as you can see on the left, so I just want to confirm that you are saying it doesn't do that after you install WinZip?  

    Or, if anyone else knows how to fix (disable) this in Windows 7, please let me know
    Wednesday, January 21, 2009 3:02 AM
  • Take a look at 7zip. It handles RAR and a bunch more.
    Thursday, January 22, 2009 2:02 PM
  • Wouldn't the world be more wonderful if we stayed on topic?

    How do I DISABLE zip folders in Windows 7 ??
    Wednesday, January 28, 2009 8:03 AM
  • Right click the zip file. then mouse over to open with. then chose default program. then pick the zip software you want to use from the list. or go to the start menu and click on default programs under the control panel button.
    Wednesday, January 28, 2009 6:25 PM
  • EDIT - I HAVE FOUND A SOLUTION

    After considerable browsing (thank you, Google), I have a solution that works. It is based on fixes for Vista, but works 100% for my Windows 7 64-bit install. 

    You will need to edit your registry (delete 2 different keys), so I highly recommend you back up your registry or better yet, make an image of your OS drive (probably C:\). I use Norton Ghost 2003 (only from a NG 2003 boot floppy) and have never had a single problem. Norton Ghost does not have to be installed on your system for this to work (in fact, it will stall due to compatibility issues). 

    First a note regarding the various reg tweaks that are available for download (e.g., "vistaunzip.reg"). These will NOT work - undoubtedly due to ownership/permissions issues. 

    The following two (2) keys need to be deleted fromthe registry:

    For zip files delete the regkey
    HKEY_CLASSES_ROOT\CLSID\{E88DCCE0-B7B3-11d1-A9F0-00AA0060FA31}

    For cab files delete
    HKEY_CLASSES_ROOT\CLSID\{0CD7A5C0-9F37-11CE-AE65-08002B2E1262}

    When you try to delete them, you will almost certainly get an "access denied" or "failed" type of message. Before you can delete them, you need to change the permissions/ownership of these two keys. Here is how to do it:

    01 - open regedit from the RUN console

    02 - navigate to the first key that needs to be deleted (HKEY_CLASSES_ROOT\CLSID\{E88DCCE0- B7B3-11d1-A9F0-00AA0060FA31})

    03 - right click on the key and select "Permissions"

    04 - click on "Advanced"

    05 - click on the "Ownership" tab

    06 - in the "change owner to" section, highlight your username

    07 - check the box for "replace owner on subcontainers and objects"

    08 - click on "Apply"

    09 - Click "OK"

    10 - Under "Security" tab, highlight your username and check the box for "Allow Full Control" (located mid-menu in the "Permissions For Administrators" section)

    11 - click "Apply" and "OK"

    12 - you can now delete the registry key. MAKE SURE YOU ARE ON THE CORRECT KEY!

    13 - repeat the process for the 2nd key.

    14 - reboot (changes will NOT take effect until you reboot

    15 - VOILA! NO MORE ZIP FOLDERS! woohoo!

    16 - thanks to the original solvers of this problem, whomever they may be.

    *********************************************************************************

    I would like the same help that deedvd is seeking. How do I DISABLE the zip folder function? I do NOT want my zip files to appear as "folders". Why anyone in Redmond thought this was a brilliant idea is beyond me. It adds to clutter and makes file browsing a lot less enjoyable. I simply want my zip files to appear as files - with the ".zip" extension. Just like every other file. The responses to deepdvd were probably as frustrating to him as they are to me. Changing the default program for zip files is IRRELEVANT. It only changes whether Windows or some third party app (7Zip, Izarc, etc) OPENS the files. They continue to show up as folders.  I tried the unregister script (earlier thread)

    "Running regsvr32 /u %windir%\system32\zipfldr.dll should be enough to disable zip functionality. Then just run your 3rd party archite application and let it re-register archive files." and it did not work. I got the same error that deeddvd got "The module "C:\Windows\system32\zipfldr.dll" was loaded but the entry-point DllUnregisterServer was not found.

    Make sure that "C:\Windows\system32\zipfldr.dll" is a valid DLL or OCX file and then try again."

    I would love to find a resolution to this problem. If anyone out there knows how to DISABLE the zipfolder function, please post the solution. I am thanking you in advance.
    • Proposed as answer by svenn99 Friday, February 06, 2009 7:30 PM
    • Marked as answer by Arie SlobMVP, Editor Friday, November 06, 2009 12:39 AM
    Friday, February 06, 2009 5:27 PM
  • Tim, this is not an answer to the question, not even close. Notice it has no votes as helpful. Using some other program, be it Winzip, Winrar, 7-Zip or whatever does not disable the zip folders that clutter Explorer. I know they are helpful for simple users but for anyone even approaching a power user they are not. Microsoft needs to provide simple Explorer settings to turn these off, it's long overdue. Anyone there at Microsoft pay attention to these things? I'm almost surprised that turning file extension display on doesn't take a registry modification. That has a selection in Explorer and so should zip folders.

    Looks like svenn99 finally has an answer to this. Now that I figure I'll be running the RC until release I needed a solution.
    Thursday, May 07, 2009 1:20 AM
  • Why is Zandor's reply marked as the answer?!?  It is completely off track.

    Thanks sven99.  Your procedure did not work completely (I also had to give myself full control of the reg key) but it got me on the right track.

    BTW Why doesn't MS make an option to turn them off.  Zip folders have been a huge annoyance since I first tried XP.  If you have a directory with lots of zip files containing lots of files then it can take many minutes to open the directory to just look at it.  And Windows Explorer basically dies if the directory is on a network drive or a CD.


    Also note that the original poster said that
    regsvr32 /u zipfldr.dll
    fixes the problem under XP.   This is not exactly true.  It does fix it temporarilly but it comes back the next time you reboot.

    Monday, June 22, 2009 12:32 AM

  • Also note that the original poster said that
    regsvr32 /u zipfldr.dll
    fixes the problem under XP.   This is not exactly true.  It does fix it temporarilly but it comes back the next time you reboot.

    I wouldn't normally respond to an old thread, but the above is complete ROT. Once the command is run it stays that way until the opposite command (without the '/u') is run.

    DrT
    Thursday, January 07, 2010 1:47 AM
  • Thanks for help, but unfortunately it did not work for me.

    Microsoft should left user to define it.

    Friday, September 09, 2011 8:44 PM
  • Try Windows Seven Forums and search for zip.

    http://www.sevenforums.com/#windows-7-help-support

    Thats how i disabled mine.  took a few trys with the instruction.

    Sunday, September 11, 2011 12:11 AM
  • Great!

    There should really have been an option to disable this via Tools -> Folder options dialog.

    There is a very little addition to the resolution. I came across this article during the middle of some work so didn't want to restart my PC. I noticed that killing explorer.exe from Task Manager and then restarting the same (e.g. File -> New Task (Run ...) from Task Manager) makes this change effective.


    RS

    Wednesday, July 04, 2012 7:16 AM
  • I did that, confirmed the correct keys, rebooted several times, and still had the default 'create new zipped folders' in the context menus.  Unfortunately, I also could not open any zipped folders that were created before or after your fix.  Clicking the mouse on a zipped folder did absolutely nothing, not even an error message.  Worse, the create new folder option disappeared from explorer windows.   I tried to download fixes, but they came in zipped folders that I could not open!  I had to restore my registry and start over.  My temporary workaround until I can find something that actually works is to make a copy of an empty unzipped folder and copy it when I need a new folder.

    It is a real pain to try to work with the W7 zipped folders when copying large documents into them, which can take a very long time.  I really don't need zipped folders since I have nearly unlimited file space for my needs, and the headaches I've had with the update that set 'create new folder' in the context mouse menu to zipped folders is one of the worst 'fixes' I've had to suffer from MS. 

    If someone has found a way to turn the 'create new folder' in the context mouse menu and Explorer windows back to regular folders, I would love to hear from you.

    Wednesday, June 19, 2013 6:23 PM
  • Thank you for passing on this information! It works in Windows 8 64-bit, too. To make restoration of the key easier, I just changed it's name to "Was {E88DCCE0-B7B3-11d1-A9F0-00AA0060FA31}". So far, there have been no issues, and folders open without displaying all the ZIP files in the left pane (or pain, as it were). CAB files are less common, but that fix should work for that, too.


    • Edited by MoishePippik Thursday, July 11, 2013 7:00 PM grammar correction
    Thursday, July 11, 2013 5:45 AM
  • Hi, svenn99! Here is a suggestion to get around the permissions problem.

    1) Click on the Start button

    2) On the "Search programs and files" field, type "regedit".

    3) DO NOT click on "regedit.exe" or press Enter on your keyboard! You have to right-click on it.

    4) Select the option "Run as administrator" from the drop-down menu.

    5) Confirm the security warning prompts that will appear.

    6) Now you can search for the keys in regedit and delete them without permission problems.

    By the way, once you have deleted the keys and restarted your system, you will have to assign a new application to open the files with ".ZIP" extensions.

    I highly recommend the totally free and open source "7zip". Besides being fast and opening several other compression formats such as RAR, it also has it's own compression format which tend to be 15% more efficient than the best RAR compression rate.






    21 hours 5 minutes ago