none
A folder won't delete

    Question

  • I have microsoft vista ultimate. There is a folder that just refuses to be deleted.

    I try, and try, and try, and each time it shows as deleted, I empty the recylce bin, and when I restart, the **** folder is there...

     

    any ideas will be highly appreciated.

     

    Vampmaster

    Tuesday, May 15, 2007 4:05 PM

Answers

  • Here is what worked for me. Change the folder name. Then delete it. It may be that this worked for me because I first went to the command prompt (cmd) and deleted the folder from there (using the original folder name that kept reappearing), but it came right back after I rebooted. It seemed something was referring to that folder name, so that's why I changed it (I named it something like "ghhhdjfh" so that it wouldn't be like any file or folder name on my system - don't know if this helped).

    Finally - it's gone!

    So if changing the folder name and deleting doesn't work, change it back to the original name. Go to the command prompt and delete the original folder name that keeps reappearing. Note that you may have to reboot to know if the folder will show up again. Then change the folder name and then delete it.

    Note that when I say delete from the command prompt, if you don't know how to do this, look it up online - place "Windows command prompt" in the search engine so that you don't get lessons about other systems such as Linux. But basically, you need to know the file path to the folder you want to delete. Go to the Windows icon (start) on the bottom left of your desktop; click it and place "cmd" in the text field (don't use the quotes). A black window will appear. It will default to a path and you need to change the path to the one you need. If it defaults to c:\Users\Personal> then go to your computer and find your way to that path; then figure out how to get from there to your offending folder. It may be something like c:\Users\Personal\Desktop\offending folder name here.

    You want to stop one short of the folder name - for instance, if the above is the correct path, you'd change the path in the command window to c:\Users\Personal\Desktop>

    When you get to one short of where your offending folder is then delete the folder using the del command followed by a space and the folder name. Hit enter on your keyboard to enter the command.

    To change the path in the command window, use "cd" which means change directory. You can only add one directory at a time. If you need to go up/back one directory, you use "cd .."

    So if the default path at the command window is c:\Users\Personal> and you want to get to c:\Users\Personal\Desktop\offending folder name, you would add to the end of the command as follows:

     c:\Users\Personal>cd Desktop

    Then hit enter on your keyboard

    Keep doing this "cd" command to change the path one directory at a time.

    When you are one short of the offending folder, write

    c:\Users\Personal\Desktop>del folder name here

    For the above, don't write "folder name here" - instead write the actual name of the folder you're trying to delete.

    If the path you want to get to is  c:\Users\Public\Public Music\folder name

    then write  c:\Users\Personal>cd ..

    Hit enter on your keyboard. The two dots tell the system to go back one directory.

    The screen will change to  c:\Users>

    Then write c:\Users>cd Public

    Hit enter on your keyboard. The screen will now show  c:\Users\Public>

    Then write  c:\Users\Public>cd Public Music

    The screen will now show c:\Users\Public\Public Music>

    Now write c:\Users\Public\Public Music>del folder name here

    Hit enter on your keyboard. The folder should now be deleted from the system - at least officially. Now you may need to reboot and if the folder appears again, change it's name and then delete it.


    Sunday, July 17, 2011 4:59 PM

All replies

  • SAME THING HAPPENS TO ME..any solutions?
    • Proposed as answer by JS921 Sunday, July 17, 2011 4:52 PM
    • Unproposed as answer by JS921 Sunday, July 17, 2011 4:52 PM
    Sunday, June 17, 2007 5:05 PM
  • Hi,

    Firstly, make sure this folder is not used by Windows or any other application. As it might be used by an application you use frequently or by Windows. If it's not used by Windows or any other application, turn of UAC from control panel then try to delete it.

     

    Good luck

    Tuesday, June 19, 2007 1:11 PM
  • Make sure you have administrator privilages, and if so and it still is displaying and does not belong to the Windows System, it could be some sort of malware, try running Windows Defender.

     

    http://www.microsoft.com/athome/security/spyware/software/default.mspx

    Thursday, June 28, 2007 5:35 AM
  • which folder ? path ??

    ensure its not a critical one.

    try deleting in safe mode.

    else it cud be malware infection too...

    Sunday, July 08, 2007 7:31 AM
  • Very sorry for bumping an old thread, but I have been having the same problem with a particular folder for quite a few months now! It's also on my desktop and used to contain about 5 music files that I ripped from a CD of my own composed tracks. It is now and has been empty since when the problem first started.

    I delete... It goes to recycle bin... I empty bin... reboot... and guess what? it's back... Every time!

    I've tried all of the above and have double checked everything! I've tried running defender and a few other anti-virus programs I have installed many times! Both before and after deleting the folder! It still reappears after reboot!

    So, if anyone has any further solutions or suggestions for getting rid of this bugger then please let me / us know!

    Thanks in advance! Wink
    Tuesday, August 26, 2008 3:00 AM
  • I know this thread is old but as I was looking for an answer to the same problem I found this open thread.

    For me fixing the problem was as simple as figuring out that the folder was being deleted but being recreated every time I started up Windows media player.  In the ripping options I had the folder specified as the folder I was trying to delete.  If WMP couldn't find the folder (i.e. I'd deleted it) it simply created a new one.  The solution, simply change the preferred rip to location and the deleted folder stays deleted.

    Hope this helps someone.
    Wednesday, August 19, 2009 10:50 PM
  • I just had this problem and tried looking for an answer online, nothing worked like others are experiencing.

     

    I found a nifty way to get rid of certain folders if they keep returning.  In the Explorer window on the left in the libraries section you can right click the "Music/Pictures/Documents/Videos" categories and select "Properties."  From here it seems that if a folder is listed, it will never go away.  Remove the folders from these lists and you'll be able to delete them.

     

    Also, check any other programs that may have included the folder you can't delete in a playlist of some kind, windows media player seems to be bad about that.

    Thursday, June 23, 2011 5:06 PM
  • You can download and run the program Handle, that you can find at the following web address

    http://technet.microsoft.com/it-it/sysinternals/bb896655

    Bye.


    Luigi Bruno
    Monday, July 04, 2011 10:49 PM
  • Hi

     

    Same thing is happening with me i have some unknown folders in C drive with strange names e:g "5e0c553df0df74ae5a03747a1be63b" and whenever i try to delete them they dont . (i think they are the updates of vista not sure) . and when i shoutdown pc it says to install updates and shutdown when i choose that it never shutdown and keep showing it processing ( worst experience was my pc was in this condition for 12 hrs )


    if the post helpful please mark it right else feel free to correct me
    Tuesday, July 05, 2011 11:58 AM
  • Here is what worked for me. Change the folder name. Then delete it. It may be that this worked for me because I first went to the command prompt (cmd) and deleted the folder from there (using the original folder name that kept reappearing), but it came right back after I rebooted. It seemed something was referring to that folder name, so that's why I changed it (I named it something like "ghhhdjfh" so that it wouldn't be like any file or folder name on my system - don't know if this helped).

    Finally - it's gone!

    So if changing the folder name and deleting doesn't work, change it back to the original name. Go to the command prompt and delete the original folder name that keeps reappearing. Note that you may have to reboot to know if the folder will show up again. Then change the folder name and then delete it.

    Note that when I say delete from the command prompt, if you don't know how to do this, look it up online - place "Windows command prompt" in the search engine so that you don't get lessons about other systems such as Linux. But basically, you need to know the file path to the folder you want to delete. Go to the Windows icon (start) on the bottom left of your desktop; click it and place "cmd" in the text field (don't use the quotes). A black window will appear. It will default to a path and you need to change the path to the one you need. If it defaults to c:\Users\Personal> then go to your computer and find your way to that path; then figure out how to get from there to your offending folder. It may be something like c:\Users\Personal\Desktop\offending folder name here.

    You want to stop one short of the folder name - for instance, if the above is the correct path, you'd change the path in the command window to c:\Users\Personal\Desktop>

    When you get to one short of where your offending folder is then delete the folder using the del command followed by a space and the folder name. Hit enter on your keyboard to enter the command.

    To change the path in the command window, use "cd" which means change directory. You can only add one directory at a time. If you need to go up/back one directory, you use "cd .."

    So if the default path at the command window is c:\Users\Personal> and you want to get to c:\Users\Personal\Desktop\offending folder name, you would add to the end of the command as follows:

     c:\Users\Personal>cd Desktop

    Then hit enter on your keyboard

    Keep doing this "cd" command to change the path one directory at a time.

    When you are one short of the offending folder, write

    c:\Users\Personal\Desktop>del folder name here

    For the above, don't write "folder name here" - instead write the actual name of the folder you're trying to delete.

    If the path you want to get to is  c:\Users\Public\Public Music\folder name

    then write  c:\Users\Personal>cd ..

    Hit enter on your keyboard. The two dots tell the system to go back one directory.

    The screen will change to  c:\Users>

    Then write c:\Users>cd Public

    Hit enter on your keyboard. The screen will now show  c:\Users\Public>

    Then write  c:\Users\Public>cd Public Music

    The screen will now show c:\Users\Public\Public Music>

    Now write c:\Users\Public\Public Music>del folder name here

    Hit enter on your keyboard. The folder should now be deleted from the system - at least officially. Now you may need to reboot and if the folder appears again, change it's name and then delete it.


    Sunday, July 17, 2011 4:59 PM