locked
Remote Desktop Connection for Mac OS X cannot connect to Windows 8.1

    Question

  • I'm using Remote Desktop Connection for Mac 2.1.1 on Mac OS X 10.8.4 to connect to Windows 8.1 (Pro Preview Evaluation Build 9431), the connection is failed with error message "Remote Desktop Connection cannot verify the identity of the computer that you want to connect to." This issue doesn't occur when connecting to Windows 8 desktop, and I can connect to Windows 8.1 from Remote Desktop Connection for Windows/Linux. Why this issue only occurs on Mac OS X?


    Thursday, August 01, 2013 3:43 AM

Answers

  • I've managed to connect to the 8.1 preview build 9431 with my Mac Remote Desktop Connection.

    Here's what I did:

    1. Make sure the firewall allows the RDP connection (already stated before)
    2. Open the Management Console (mmc.exe) 
    3. Add the 'Local Computer Policy' snap-in
    4. Goto:
      - Computer Configuration
      - Administrative Templates
      - Windows Components
      - Remote Desktop Services
      - Remote Desktop Session Host
      - Security
    5. Change the following two settings from their default (be aware that there might be a reason that MSFT has decided to set them to default. It might be advisable to revise those settings after a new Mac RDP client has been released)
      - 'Require use of specific for remote desktop (RDP) connections' from 'Default' to 'Enabled', then select 'RDP' in the options pane
      - 'Require user authentication for remote connections by using Network Level Authentications' to 'Disabled'
    6. Restart the 'Remote Desktop Service' or simply restart the computer
    7. Voila! I can use my Mac RDP client 2.1.1 (110309) with Windows 8.1 build 9431

    Wednesday, August 21, 2013 11:56 AM

All replies

  • The reason you get this error is because you are using a newer version of remote desktop than what the remote computer is using. to connect regardless of any authentication process, set your remote desktop client to connect even if there is not authentication.

    On Remote Desktop go to Options then click on the Advanced tab and under “if the actual verification does not meet minimum policy requirements”choose Connect and don’t warn me.


    Juke Chou
    TechNet Community Support

    Monday, August 05, 2013 3:29 AM
    Moderator
  • Thanks for your reply. 

    Your solution is for Remote Desktop Connection on Windows OS. But my issue doesn't reproduce on Windows OS, it only reproduce on Mac OS X with Remote Desktop Connection for Mac 2.1.1

    And I have tried to checked "Always connect, even if authentication fails" from Preferences->Security tab, but it still cannot resolve my issue. 


    Tuesday, August 06, 2013 9:40 AM
  • i too am having this problem, i have the latest RDP client for mac and all the windows updates for my windows 8.1 machine. 

    i believe we have to wait until microsoft releases an update for their RDP app on mac. 

    Monday, August 19, 2013 11:24 PM
  • I've managed to connect to the 8.1 preview build 9431 with my Mac Remote Desktop Connection.

    Here's what I did:

    1. Make sure the firewall allows the RDP connection (already stated before)
    2. Open the Management Console (mmc.exe) 
    3. Add the 'Local Computer Policy' snap-in
    4. Goto:
      - Computer Configuration
      - Administrative Templates
      - Windows Components
      - Remote Desktop Services
      - Remote Desktop Session Host
      - Security
    5. Change the following two settings from their default (be aware that there might be a reason that MSFT has decided to set them to default. It might be advisable to revise those settings after a new Mac RDP client has been released)
      - 'Require use of specific for remote desktop (RDP) connections' from 'Default' to 'Enabled', then select 'RDP' in the options pane
      - 'Require user authentication for remote connections by using Network Level Authentications' to 'Disabled'
    6. Restart the 'Remote Desktop Service' or simply restart the computer
    7. Voila! I can use my Mac RDP client 2.1.1 (110309) with Windows 8.1 build 9431

    Wednesday, August 21, 2013 11:56 AM
  • you know what it worked for me
    Thursday, August 22, 2013 3:48 PM
  • That's work for me. Thank you very much!
    Monday, September 16, 2013 7:13 AM
  • I had the same issue when I upgraded my laptop from Windows 8 to Windows 8.1.  The MS Office 2011 for Mac OS X RDC client did this.  Your fix worked.  Microsoft needs to test their own software better. 

    Thanks for the workaround.

    Sunday, September 22, 2013 7:44 AM
  • "Group Policy Objects" is "Local computer policy"

    Tam
    Thursday, September 26, 2013 7:21 PM
  • Brilliant - works a treat - saved my bacon there - many thanks.
    Sunday, September 29, 2013 1:52 PM
  • I had the same problem with Win8.1 Enterprise RTM, and this solution worked.  Thank you.
    Thursday, October 03, 2013 8:22 PM
  • Great Work! Thanks for this info worked great connection my Mac to Windows 8.1 Enterprise
    Sunday, October 06, 2013 1:06 AM