locked
Network Unlock

    Question

  • “Windows 8 Consumer Preview installation running on UEFI firmware with UEFI DHCP drivers” is a requirement for Network Unlock. 

    I have Windows 8 CP up and running on UEFI, but I have no idea how to verify that it has UEFI DHCP drivers.  Network Monitor on the DHCP server and the WDS server shows NO network activity at all (and if I force a legacy PXE boot it works fine).

    I am guessing that my Dell Laptop does not support this, but I’d love to *know* its my Laptop, and not a configuration error. 

    Has anyone worked with this before?

    Thanks,

    Jeremy


    Jeremy

    Monday, May 14, 2012 3:55 PM

Answers

All replies

  • Hi,

    From the document, we can see “This feature requires the client hardware to have a DHCP driver implemented in its UEFI firmware.”. Based on my understanding, this should be hardware related. Please contact the manufacture for help.

    Understand and Troubleshoot BitLocker in Windows Server "8" Beta

    http://www.microsoft.com/en-us/download/details.aspx?id=29032

    Hope this helps.

    Thanks.

    Nicholas Li

    TechNet Community Support

    Monday, May 21, 2012 4:04 AM
  • For NKP, the win8 client should be using UEFI 2.3.1

    BitLocker Network Unlock has the following software and hardware requirements that must be met before you can use it:

    Client computer requirements

    • A DHCP driver that is implemented in the UEFI firmware
    • Trusted Platform Module (TPM) 1.2 or TPM 2.0
    • BitLocker enabled on the operating system volume

    Windows Deployment Services server requirements

    • BitLocker Network Unlock feature installed (only available in windows server 2012)
    • 2,048-bit RSA public/private key pair X.509 certificate present in FVENKP certificate store

    Domain controller requirements

    • Copy of the BitLocker Network Unlock Certificate from the Windows Deployment Services server on the domain controller to set Group Policy settings for Network Unlock. (2012 server)

    I hope this clarifies.


    Manoj Sehgal

    Wednesday, July 04, 2012 4:33 AM