none
Windows detected a hard disk problem,how to close the message

    Question

  • When I open my windows 7, the message of "Windows detected a hard disk problem" appears. Even I restart computer. Does sombody know how to close the message forever?


    akira32 編程之家 Yahoo http://tw.myblog.yahoo.com/akira32-akira32
    Tuesday, June 29, 2010 4:26 PM

Answers

  • Please open gpedit.msc. Navigate to Computer Configuration\Administrative Templates\System\Troubleshooting and Diagnostics\Disk Diagnostic\
     
    Double Click on “Disk diagnostic: configure execution level”, set it to “disabled”. “Not configured” is enabled by default.

    Arthur Xie - MSFT
    • Marked as answer by akira32 Wednesday, June 30, 2010 4:33 PM
    Wednesday, June 30, 2010 7:59 AM
    Moderator

All replies

  • Please open gpedit.msc. Navigate to Computer Configuration\Administrative Templates\System\Troubleshooting and Diagnostics\Disk Diagnostic\
     
    Double Click on “Disk diagnostic: configure execution level”, set it to “disabled”. “Not configured” is enabled by default.

    Arthur Xie - MSFT
    • Marked as answer by akira32 Wednesday, June 30, 2010 4:33 PM
    Wednesday, June 30, 2010 7:59 AM
    Moderator
  • Thank you! My problem had solved.
    akira32 編程之家 Yahoo http://tw.myblog.yahoo.com/akira32-akira32
    Wednesday, June 30, 2010 4:33 PM
  • I have a similar problem on my Lenovo laptop running Win 7 Home Premium. When I start my Windows 7, a message of "Windows detected a hard disk problem" appears and asks me to perform a System backup. I followed the instruction to backup my system disk and created a disk image. I also ran a CHKDSK on both my two partitions and found no disk problems. I restarted my laptop multiple times but the message still showed up every single time. I can click "Cancel" to get rid of the message, but I try to follow your advice to close the message forever.

    I typed gpedit.msc in the "Search programs and files" field but I was not able to launch the local computer policy editor. It saids no "items found". Is there any other way I can launch gpedit.msc? Or can I fix this issue in some other ways? Any help or advice is much appreciated!  

    Monday, May 09, 2011 10:04 PM
  • may be it does't work for win7 home. i read " If you are running visota home, you do not have group policy so cannot use gpedit.msc"
    Tuesday, September 27, 2011 5:22 AM
  • Thank for this answer.  I am running Windows 8 and it still works!  Never would I find this iprogram myself.
    Saturday, May 25, 2013 2:01 AM