none
microphone doesn't work in 7

    Question

  • my brother is a big skype user and its very annoying for him to have both his microphones not work. one is an analog headset that plugs into the sound card, and the other is a usb microphone built into his monitor.  when i open the recording devices menu, under both microphones where it should say "ready", it says currently unavailable. i've made sure to check the box so that windows listens to this device. both microphones also worked flawlessly under vista home premium.
    Sunday, January 18, 2009 11:22 PM

Answers

  • i'm having a problem with my mic in windows 7 too.
    I have a core i7 system with 6GB of memory and an Auzentech Prelude soundcard

    my problem seems to be related to the ammount of memory i have installed...

    if i use 2x2gb the microphone works. but add another 2gb and it stops completely (no movement in the soundbars and skype says my mic is not plugged in), and removing the mem does not restore functionality - only way i've found so far is to reinstall windows 7


    just FYI, the MIC works fine in Vista x64 with all 6GB of memory


    Tuesday, January 20, 2009 5:52 PM

All replies

  • Skype has a new version of it's software on their web site.   I had to downlown this version and install before my microphone worked.
    took a little tweeking, but was able to finally get it to work.
    Monday, January 19, 2009 3:45 AM
  • the problem isn't only with skype though. it's with windows in general. the same problem applies across all programs.
    Monday, January 19, 2009 8:00 PM
  •  

    Hi,

     

    Do you have speakers? Can they work on Windows 7? If not, I am afraid that the cause is your current sound card driver is incompatible with Windows 7. You may need to update your sound card driver to test the result.

     

    You can run Windows Update to install available driver updates or download the latest driver directly from the sound card manufacturer’s website.

     

    Tim Quan - MSFT

     

    Tuesday, January 20, 2009 7:18 AM
  • Had the same problem with my built-in mic. Went to realtek homepage to look for newest drivers and found them. After install it helped to solve the problem, because ive tried before with vista drivers and vista SP1 drivers and that didnt work, installer crashed always.
    Tuesday, January 20, 2009 8:53 AM
  • Similar issue here.  Have tried W7, 64 and 32.  Sound worked perfectly on my Asus P5n-e mainboard.  Microphone was hit and miss if it would work.  Installed the correct drivers from Asus for each OS -- same thing, if the sound application would even run.  USB microphone/web cam never did work correctly.  Was detected by W7 but no drivers installed (not unexpected!).  I installed the correct drivers for each OS from Hercules,  but still could not get video up and the microphone either did not work or just produced noise.  Skype 4 beta at least worked, but without reliable sound was worthless.  Vista Home Premium 32 (what I run normally) has no issues with the hardware.
    Tuesday, January 20, 2009 2:36 PM
  • i'm having a problem with my mic in windows 7 too.
    I have a core i7 system with 6GB of memory and an Auzentech Prelude soundcard

    my problem seems to be related to the ammount of memory i have installed...

    if i use 2x2gb the microphone works. but add another 2gb and it stops completely (no movement in the soundbars and skype says my mic is not plugged in), and removing the mem does not restore functionality - only way i've found so far is to reinstall windows 7


    just FYI, the MIC works fine in Vista x64 with all 6GB of memory


    Tuesday, January 20, 2009 5:52 PM
  • I have similar set up to Paul's. Windows 7 64-bit on a Core i7 system with 12 gigs of ram. I have a Creative Sound Blaster x-fi Fatality series card with the latest windows 7 beta drivers. The microphone shows as "currently unavailable" even though it is plugged in. This works fine on my Vista Ultimate 64-bit with no problems. MS needs to fix this. I play a lot of games and if they want me to test 7, then this HAS to work. 
    • Proposed as answer by Davais Monday, May 18, 2009 3:02 PM
    Wednesday, March 04, 2009 9:03 PM
  •   Have had no luck in getting the Microphone in my headset to work. To help expedite a resolution and alleviate some of the more common issues here is some background…

     

      My system is a desktop, setup as a duel boot rig with a separate hard drive for each OS (XP Pro and Win7). Everything works fine booted up in XP Pro but in Windows 7 I have been unable to get the Mic. to work. The RC version of Windows 7 Ultimate 64-bit was installed on a fresh drive and was not upgraded from another OS, I’m running all the current Win7 updates and the latest driver for my sound card from Creative Labs SoundBlaster for 64-bit Windows 7 as of 8/2. I have read thru several threads and tried all the configuration setting like the following one…

     

    [quote]

    Right click on the speaker at the bottom Right of your screen..
    -- Click on the Recording Devices
    A window Titled Sound will open

    if there is no contents in the Sound window, Right Click
    inside that window and then click on "Show Disabled Devices " ...

    any disabled device mic/aux/Stereo Mix will then show up..
    To enable one or the other Right click on the Stereo Mix and click on Enable ,

    then
    Right click on the device again, and Select "Set as Default Device "

    if you do not see anything you have not installed the drivers correctly
    Uninstall drivers, restart Windows then attempt to install the drivers again..

    You can also, double click on the Mic/Stereo Mix (after enabled)..
    a window will pop up...
    Click on the tab "Levels " in the Stereo Mix to un-mute your Mic or to adjust the sound..

    [/quote]

     

    Unfortunately with no change. The Mic. isn’t muted, the level is set high, and I’ve tried it with Boost On and Boost Off with no change. The mic. Setup wizard reports there is a problem and received no input from the microphone. Also the motherboards onboard sound is disabled in the BIOS incase you were headed there. The fact that the same exact hardware setup works fine with Win XP but not with Win 7 should remove any hardware possible problems and leave only Software/Driver/OS issues. Please help as the inability to use my Microphone is a deal breaker on weather I upgrade in October or not and its issues like this that kept me from upgrading to Vista.

     

    Here is a list of my hardware…

    Manufacturer: Me

    Processor: Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz (8 CPUs), ~2.7GHz

    Memory: 6144MB RAM

    Hard Drive: 1442 GB Total

    Video Card: NVIDIA GeForce GTX 285

    Monitor: 22" Wide Screen DELL 2208WFP

    Sound Card: Creative SB Audigy 2

    Speakers/Headphones: Klipsch

    Keyboard: Logitech G15

    Mouse: Logitech G5

    Mouse Surface: Anything

    Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7100)

    Motherboard: EVGA X58

    Computer Case: Antec 1200

     

    • Proposed as answer by BR1060 Tuesday, August 04, 2009 5:08 PM
    Sunday, August 02, 2009 8:18 PM
  • In Windows 7 -> click on Start Menu and type 'Sound'.  Go to the Sound Properties then click on 'Recording'.  Open the properties of the microphone (if it is available) and change the boost to MAX.  This should resolve your issue.
    Tuesday, August 04, 2009 5:08 PM
  • hi - I can't get my mic to work either.

    It was working last night (first day w/ Windows 7) today I booted up and it wouldn't work.
    I tried changing the settings in Ventrillo (the program that I noticed the problem in)
    NO luck.  I tried changing the settings in Control Panel/Sound/Recording
    I tried every setting...no luck.

    I reseated by sound card, tried all the ports/jacks

    The mic does not work. I tried using the mic in Sound Recorder and it still didn't work.

    One note - I do not have the "boost" option in my Sound/Recording windows.

    I am using an Altec Lansing headset w/ microphone - the sound is fine.  As I mentioned earlier - the mic worked on Windows Xp and alson for my first night on Windows 7.

    I've uninstalled and reinstalled the sound card drivers, the device manager assures me that the latest/best drivers are installed.

    My Sound card is a Sound Blaster Live 24 bit.

    This is really frustrating...


    One suggestion - the microphone volume slider/level should be easier to get to - Why do you have to go through Sound/Recording/Properties/Levels

    Make it available in the same way the playback devices are - one click from the taskbar.

    Which reminds me - yes I've checked - the microphone volume level is at max and is not muted.
    Again - no boost option for me (not sure why???)

    Please help!
    Monday, August 10, 2009 2:40 AM
  • I have similar set up to Paul's. Windows 7 64-bit on a Core i7 system with 12 gigs of ram. I have a Creative Sound Blaster x-fi Fatality series card with the latest windows 7 beta drivers. The microphone shows as "currently unavailable" even though it is plugged in. This works fine on my Vista Ultimate 64-bit with no problems. MS needs to fix this. I play a lot of games and if they want me to test 7, then this HAS to work. 

    I have same problem.... "currently unavailable" it is greyed out...... this sux.. it's kinda hard to play BF2 with my friends with no mic.. :(
    Monday, August 10, 2009 2:45 PM
  • Hello there!
    I'm trying Windows 7 RC build 7100. And i have to say i'm really liking it.
    No particular problems so far, except for some sound related issues.
    One of those was the unavaible mic.
    Well for all of you having this problem, be sure that your line-in in the recording tab is disabled, and put your mic as default recording device.
    It worked for me. I can't have both (line in and mic) avaible at the same time.

    • Proposed as answer by KEDLogic Friday, August 28, 2009 7:22 PM
    Saturday, August 22, 2009 9:50 PM
  • Hi.
    I've a similar issue that I HAVE found a solution for. Question: are you plugging your mic into the front of the pc?


    BTW I did not mean to propose that answer. Sorry.
    Friday, August 28, 2009 7:26 PM
  • Davide Cecchi's answer worked for me. I disabled Line In in Recording. Just make sure you hit Ok all the way to the top (til the window disappears). This is kinda workaround instead of a hard fix coz we're supposed to have both Mic and Line In working.
    Friday, October 23, 2009 5:46 AM
  • I tried the Sound Recorders on my laptop with Windows 7 Pro and on my desktop with Windows 7 Ultimate.  Both did not record sound.  Both computers worked prior to my upgrade.  Windows Diagnostics found nothing wrong.  What could be wrong?  I took the microphone and the speaker to another system running XP Pro to test the sound recording and it worked fine so it proved the equipment was fine.  What else I could do?
    Friday, November 20, 2009 10:39 AM
  • Go to this link and read the connect a microphone drop down, helped me a bit just have to play with it.

    http://windows.microsoft.com/en-US/windows7/Connect-a-microphone-music-player-or-other-audio-device-to-your-computer
    Monday, November 23, 2009 5:22 AM
  • It didn't fix my problem.

    I tried step 4 and I couldn't hear myself.  My Microphone Properties has no Microphone Boost.

    I know my equipment is all right.  I tested it with an XP Computer and I used it on VOIP phone call on the same laptop when it was installed with XP.

    The speaker is all right.
    Tuesday, November 24, 2009 12:20 AM
  • Do you have to pay for the new drivers?
    Friday, December 18, 2009 8:02 PM
  • No, you don't have to get new drivers. Just find a way to open up your sound driver's audio control panel, go to your microphone and change it from Line-In Plugin to your Microphone, and it worked for me.
    Wednesday, April 07, 2010 10:32 AM
  • I have the same problem, mic doesnt work but the sound is fine.

    It was working, but then just stopped one day, for no reason, still works on XP, I have tried everything I can think off, it still shows my mic as plugged in, I have mic boost full up, but nothing.  I have Line In disabled, so it is not that.  It's not on mute and I have tried all ports.

    Tuesday, April 20, 2010 10:37 AM
  • I cant believe so many people can have this issue and still there's no solution. Has anyone found a solution that works to this issue?, or has another thread started up? 
    • Proposed as answer by SFX412 Friday, May 28, 2010 1:16 PM
    Wednesday, May 26, 2010 8:06 AM
  • You see, this is proof microsoft wants to make our pc's glorified word processors, Force us to game exclusively on the 360.

    But here the thing I dont just use the mic for games. I use dragon very often, and My x fi crapped out on me so I am on the realtek audio onboard. and where before the mic worked without peer. I can not get the damned thing to work.

    Well microsoft , you can bite my shiny metall ____!!!

    Stop counting your billions of dollars and fix our mics!!! or use said billions to hotlink sources on the net  by which other people who are not paid to fix these issues have. So we can at least have a false sense of you really do care.

     

    which judging by the person above  and the length of time between posts, you don't.

    Friday, May 28, 2010 1:23 PM
  • I got the same issue. I have a Dell Inspiron 1525 with a built in Mic. It worked fine on Vista, but it's not working properly on Win 7.

    By reading above, it seems like I'm not alone in this.

    Saturday, May 29, 2010 9:37 PM
  • Dell may have a new pilot for Win7.
     
    "US-Marine" a écrit dans le message de news:cba9b5ba-0c62-4c79-aa78-488f378b871f...

    I got the same issue. I have a Dell Inspiron 1525 with a built in Mic. It worked fine on Vista, but it's not working properly on Win 7.

    By reading above, it seems like I'm not alone in this.


    gaetanfo
    • Proposed as answer by maxi.noman Monday, July 12, 2010 8:04 AM
    Saturday, May 29, 2010 9:55 PM
  • when i performed ur procedure.....!!

    In the Recording Devices, when i click on show disabled devices... then als nting is displayed in tht window...

    And when i install the sound drivers whch came along wit the system then mic is wrking bt sound is nt wrking proprly... (Like sound clarity is 10%, lot of distrubance and very slow....)

    Tuesday, June 08, 2010 10:11 AM
  • When I switched from XP 64bit to Win 7, I had to manually install the drivers for my sound card (Creative XFi Xtreme Gamer) to get any sound at all. Even after the drivers were installed, the mic didn't work at all until I enable mic boost (+20 dB). Enabling that solved my problems.
    Saturday, August 21, 2010 2:26 PM
  • Same problems here too ..... Microphone wont work, either available or not. Windows 7 64 and Audigy 2 Value. It works just fine with XP 32 on the same rig.
    Thursday, November 04, 2010 11:31 PM
  • Thank you so much Davide...I had been trying to resolve this problem for the last 10 days...and nothing helped but your solution! Thanks...
    Saturday, November 13, 2010 12:37 PM
  • thanx so much kz ..my mic has already working for recording...mwah...
    Monday, December 20, 2010 1:24 AM
  • ok so check this video out and subscribe http://www.youtube.com/watch?v=8JW0rri0Gss 

    then add me on msn like the video aswell then on msn i will tell you what to do to fix your mic ive had the same problem 

    Tuesday, February 22, 2011 1:33 PM
  • Yes this works for your microphone,

    but as you say it doesn't for your line-in and microphone at the same time.

    Windows 7 only allow to enable one recording device at the same time,
    while windows xp allowed to set the microphone as a recording device and the line-in as a listening device.
    which worked fine.

    Now the default device is the only available device, for listening and for recording.


    Kleajmp
    • Proposed as answer by Kleajmp Monday, August 08, 2011 4:46 PM
    Monday, August 08, 2011 4:46 PM
  • Am using Win 7 & Gigabyte -H61M-D2-B3 Motherboard. Soumd card PCI Express Sound Blaster X-Fi Xtreme Audio, Speakers working not issue, Microphone  not working can some one help me please .

    GS

     

    Sunday, August 28, 2011 11:03 PM