none
Where did the "File Types" tab in Folder Options go?

    Question

  • I noticed this is missing in Vista. I did find the Default Applications control panel, but that does not fully replace the functionality. Am I missing something or do we have to do this manually in the registry now?
    Thursday, September 14, 2006 5:38 PM

All replies

  • You're right, the File Types tab is gone. There are two ways to get to the functionality that was in this tab in XP:

    1.The right-click "Open With" command for individual files. For more information about this, open Help and find the topic called "Change the program that opens a type of file."

    2. Open the Control panel and visit Default Programs. There are a few settings there, such as "Set your default programs" and "Associate a file type with a program."

    Thursday, September 21, 2006 7:30 PM
  • Thanks, but I as I mentioned in my previous post, I am well aware of the "Default Programs" Control Panel applet, and the File Types dialog did more than just change the default program. I was able to create new custom actions, such as "Open Command Prompt" and the like. Where can I find this stuff in Vista?

    Saturday, September 23, 2006 12:17 AM
  • I've got to admit I was pretty shocked when I saw that the File Types tab was gone, and replaced with the new Vista control panel applet that is much more limited in functionality. 

    For example: how do you DELETE a file association in Vista? 

    Tuesday, October 03, 2006 8:58 PM
  • Hopefully, Microsoft will release a Power Toy that replicates some of the functionality from the missing "File Types" tab in "Folder Options" on Windows Vista. Until then, here is some information on a piece of shareware that may help out with File Types in Vista.

    http://www.annoyances.org/exec/show/article01-500

    Wednesday, November 29, 2006 6:49 PM
  • Argh! I just got a new machine with Vista Business, and one of the first things I wanted to do was create a "Command prompt here..." action for folders (and drives). This situation is ridiculous. I don't want to have to install a "toy" to provide basic functionality!
     
    Wednesday, March 21, 2007 5:29 AM
  • you have to do everything through the registry now. I've spent over 5 hours adding keys manually, changing icons, re-associating extensions with apps etc., just because the gui has been removed from vista. have to admit though, it never worked as it should in previous systems, so I am not really sad that it's gone
    Friday, March 23, 2007 6:51 AM
  • A post in an unrelated thread (and comments above) provided a partial answer. Most of the "File Types" functionality is there, but got moved to the Default Programs tool in Control Panel.

     

    Go to Control Panel and launch the Default Programs tool, then click the link for "Associate a file type or protocol with a program".

     

    After you scroll and select a file type, click Change Program. In the Open With dialog, the recommended programs will be listed above the line and "other" programs below. This may initially be empty. But before you click Browse, try clicking the down caret button and it will populate with other programs that might include the one you're looking for.

     

    This works only for associations - there appears to be no way to specify the text for a context menu item, or to specify how arguments are passed. And, the system types like "Folder" aren't listed at all - just actual extensions and protocols.

     

    My interim solution is Creative Elements' Power Tool. Using that I could associate the Folder type with cmd.exe - but the command session is not opening in the selected directory ("%1") as was the case under XP. If you right-click a folder in the Folders list, it always opens in %Windir%System32. If you right-click a folder in the files list, it opens in the parent folder, not the folder you clicked on. You get the same behavior defining the command on the "Directory" file type.

     

    I'm not sure how "%1" will work for files associated with other programs, but for cmd.exe it saves a few CD commands...

    Wednesday, March 28, 2007 3:06 AM
  • Copy the following into notepad and save as a .reg file.  Then double click the .reg file.  It will add the Command Prompt Here to your right click menu for folders and drives.

     

    Windows Registry Editor Version 5.00

     

    [HKEY_CLASSES_ROOT\Folder\shell\Cmd Here]
    @=”Command &Prompt Here”

     

    [HKEY_CLASSES-ROOT\Folder\shell\Cmd Here\command]
    @=”cmd.exe /k pushd %L”

     

    Monday, April 02, 2007 10:17 PM
  • The loss of the File Types dialog is a pain, but  'Command Prompt here' is now standard with a <Shift>+Right-click.  Works on folders, drives, and folder background.  The folder background command can be made to display with a plain right-click by deleting the value named 'Extended' found under this key:

     

    "HKCR\Directory\Background\shell\cmd"

     

    Hope this helps,

    Keith

     

    • Proposed as answer by ravi.kewl Wednesday, June 01, 2011 12:33 AM
    Wednesday, April 04, 2007 12:06 AM
  •  

    currently im in windows xp. my prob is, the folder options missing wen i go to tools in any folder. i read bout go into control panel to see whether it it there or not. it is not there. how do i get my folder options bck?
    Wednesday, November 14, 2007 6:28 AM
  •  

    If you press shift while right clicking, you more options on the context menu.  One of them is to open a command prompt at that location.
    Saturday, April 05, 2008 2:09 PM
  •  

    If I press shift while right clicking, I sometimes get more options on the context menu.  But, to open a command prompt at that location, is not one of them.

     

    Vista 32-bit Ultimate SP1

    Thursday, April 10, 2008 2:25 AM
  • The extended commands don't appear when right-clicking on folders in the Navigation Pane, only in the folder content display area.  If that's not the issue, check that you have the following registry entry:

     

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Directory\shell\cmd]
    @="@shell32.dll,-8506"
    "NoWorkingDirectory"=""

    [HKEY_CLASSES_ROOT\Directory\shell\cmd\command]
    @="cmd.exe /s /k pushd \"%V\""

     

     

    Saturday, April 12, 2008 3:34 AM
  • Try this fix and let me know

    1.Click on start
    2.Type NOTEPAD and hit enter (if Vista or select RUN and then Type NOTEPAD and Enter)
    3.In side the Note pad copy paste the content given below
    4.save that as "Nofolder.reg" (including the quotes)
    5.Run the .Reg file.
    6.Restart the computer and see if there is any changes

    CONTENT TO COPY IS BELOW THIS LINE(do not include this)


    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoFolderOptions"=dword:0000000

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
    "NoBrowserOptions"=dword:00000000
    Wednesday, April 23, 2008 9:36 AM
  • OK Thats not at all helpful, because I want Firefox to open my e-mail links, and the powers that be at microsoft have now made it impossible to do that, because you have made IE the only option to be the default program to deal with html.  Do you people know how annoying it is to have 2 browsers open at the same time, to do one job, thats just rediculous. Try throwing us a bone, and allowing us the choice to use whichever browser we want to use, for all our needs.
    Saturday, April 26, 2008 10:07 PM
  • Try this as well
    http://windowsxp.mvps.org/utils/IEFix.zip

    and
    1. Open Explorer
    2. Select Tools and then Folder Options
    3. Select the File Types tab
    4. Select Extension: (NONE), File Type: URL:HyperText Transfer Protocol
    5. Click Advanced toward the bottom of the window
    6. In the Edit File Type window, select open and click Edit
    7. Clear the check for DDE above the DDE message box (which should contain  "%1" or similar)
    8. Click OK, Click OK
    9. Repeat for File Type: HyperText Transfer Protocol with Privacy and FTP
    Windows XP and Vista allow you to control program defaults through Control Panel, Add and Remove Programs, Set Program Access and Defaults. If the above method fails, use this method to set the default browser.


    Use:
    http://support.microsoft.com/?kbid=821692

    and change the Iexplorer.exe to firefox location



    Sunday, April 27, 2008 11:14 AM
  • Try this website:

    http://itsvista.com/2007/03/ftype/

    Displays or modifies file types used in file extension associations.


    Monday, September 21, 2009 10:10 PM
  •  

    If you press shift while right clicking, you more options on the context menu.  One of them is to open a command prompt at that location.



    Fantastic! Thanks a lot for the hint! :)
    Sunday, November 08, 2009 11:51 AM
  • this is lame on Microsoft's part.
    Friday, June 18, 2010 4:28 AM
  • this may sound retarted but is there a way you could rip the file types interface from windows xp and transplant it into vista/7 through clever use of registery and hex edits like you do with the uxtheme.dll from the RC's ???? i have no clue as to wether or not the file types menue is it's own dll or what but i thought it was worth suggesting to someone who might be able to figure it out
    Friday, June 25, 2010 6:46 PM
  • This is ridiculous.

    It's all well and good removing this functionality for users of Vista Home editions but why remove this from Windows Server 2008??

    I want to customise various right click options for certain file types such as edit, open, import, etc and the file types menu just isn't there.
    What kind of idiots do they think run servers that they need to remove these capabilities from them?

    Tuesday, July 20, 2010 8:03 PM
  • In 2008, you can add a function to a folder using regedit. for example: to add a right click command prompt to a folder. make sure you do a registry backup before doing this. 

    1) start -> run -> regedit,

    2) go to HKEY_CLASSES_ROOT\Folder\shell

    3) right click on shell then cursor to "New" then "Key"

    4) Enter "Command_Prompt" for the key name ... without the quotes

    5) Left click on Command_Prompt (the key you just created) - on the right hand side double left click on where it says (Default) and enter Command Prompt for the Value Data Field (this is what will appear in the menu when you right click on a folder) then click OK

    6) Right click click on Command_Prompt  and cursor to "New" then "Key" and enter "command" for the key name ... without the quotes

    7) Left double click on (default) and enter cmd.exe  for the Value Data field, then click OK

    8) exit regedit

     

     

     

    Wednesday, August 11, 2010 9:03 PM
  • Oh boy... My prayers are finally answered

    Here's a good looking app that does just that (change icons and menu commands for file types) : http://defaultprogramseditor.com/download

    I found it here : http://www.winhelponline.com/blog/default-programs-editor-change-file-type-icon-windows-7-vista/
    • Proposed as answer by Bill Hudson Tuesday, May 31, 2011 8:14 PM
    Monday, October 11, 2010 12:24 PM
  • sheesh - what an old post - the functionality of the advanced button is indeed gone - just in case it helps someone else, here is what I did to work around my problem in ws2008 standard.  I am not suggesting that anyone actually do this, because editing the registery is dangerous, this is just what I did.

    I wanted to add the print function of irfanview as I have always done with windows xp by clicking the advaced button in file types. The actual command line goes something like this... c:\program files\irfanview\i_view32.exe <file_name> /print

    in HKCR\.jpeg the default key lists the type as jpegfile, moving on to HKCR\jpegfile\shell we find the keys edit, open, and printto. I right clicked on shell, and selected new, key and typed print. Right clicked on print and selected new, key and typed command.

    in HKCR\jpegfile\shell\print\command then just edit the default and place "c:\program files\irfanview\i_view32.exe" %1 /print as data and your done.

    in HKCR\jpegfile\shell\open\command place "c:\program files\irfanview\i_view32.exe" %1 in default as data and delete HKCR\jpegfile\shell\open\droptarget

    now when you right click on a .jpg or .jpeg file and select print it uses irfanview (in this case) and same with open or preview. I really miss the advanced button it must be in a .dll somewhere that we can just register eh?

    • Proposed as answer by econcepts Saturday, November 06, 2010 12:54 AM
    Saturday, November 06, 2010 12:54 AM
  • after a rather long search i actually finally found a gui utility that replaces the file types tab if anyone is interested.

    http://www.nirsoft.net/utils/file_types_manager.html

     

    Wednesday, February 23, 2011 4:52 AM
  • I had as similar issue that caused my InDesign files to open in Acrobat. I came across this free tool that fixed the problem in Windows 7.

    http://izt.name/soft/types/

    Thursday, May 12, 2011 7:14 PM
  • For several files, such as iFranView, I just went into the program itself and used the built-in file association option under settings (or whichever that program called it) I got most of the functionality back.  When in doubt, check the program you are trying to associate - they probably built it in for just this reason.

    As for custom icons and commands, that is what I'm working on now. I dearly want a different icon for the web page shortcuts I put on the desktop without editing each shortcut. You guys have given me some ideas where to look.

    Friday, May 13, 2011 4:50 PM
  • Nirsoft (as proposed by mike loeven above), I should have thought!

    Thank you very much for this tip!

     

    http://www.nirsoft.net/

    and

    http://www.nirsoft.net/utils/file_types_manager.html


    • Proposed as answer by Pere Fouras Friday, June 10, 2011 8:12 AM
    Friday, June 10, 2011 7:55 AM
  • Control Panel\All Control Panel Items\Default Programs\Set Associations
    Monday, December 31, 2012 1:25 PM
  • "

    I had as similar issue that caused my InDesign files to open in Acrobat. I came across this free tool that fixed the problem in Windows 7.

    http://izt.name/soft/types/

    "

    This is a great save EVEN if you've mistakenly changed the default open program of .EXE for instance to Notepad or Cute Html which I did (Doh!)  I downloaded the above, but it wouldn't run of course!! it just opened in a text editor....  So, I rechanged the 'openwith' setting on a right click and selected 'BROWSE' then changed the folder to ~\windows\system32\win.com    its a dos app command.  Thankfully it launched FileTypes and I was able to remove the association with the EXE class and everything returned to normal.

    Thanks @halftech2000 for saving my day with Windows 7


    Martin.

    Saturday, April 13, 2013 12:15 AM
  • I realize this is an old thread, but thanks very much for the "Power Tools" suggestion. It looks useful for many things, including Windows 7's lack of file context mangement (the removal of which I really cannot fathom). To other readers from the future, may I suggest NirSoft's FileTypesMan.
    Thursday, August 08, 2013 10:26 AM