none
Windows 7 Still Not (Always) Reconnecting to Mapped Drive

    Question

  • I have read a lot of posts on this, but here is my problem.

    I am using Windows 7.  I have a Western Digital My Book World, 1 TB NAS.   The drive is mapped correctly.  I have added credentials through the credentials manager in the Control Panel.  The credentials are being remembered after logoff, shut-down and re-boot.  If I shut-down and re-boot immediately, or, perhaps, within a 12 hour period, the machine will reconnect to the mapped drive at logon.  However, if more than 12 hours elapses between shut-down and re-boot, I get the now-very-familiar "could not connect to all network drives" message and both folders of the NAS are shown to be disconnected in Computer.  Of course, a click on the correct folder will connect.  That is a pain, and the rest of my family that uses this computer will not remember to do this every time.  It becomes quite a mess if iTunes is loaded with the NAS disconnected, since the music library obviously will not load and will then need to be re-selected the next time the program is started.  I do not expect the other family members to be able to remember each of these steps. 

    Thus, does anyone know each and every thing that must be done in Windows 7 to ensure that the mapped network drive will perpetually reconnect at logon?  I say "each and every thing" because I have found that this is a highly iterative process.  I keep discovering additional steps that need to be taken upon further and further "research."  There must be a more intuitive approach.

    Thanks in advance. 
    Saturday, December 26, 2009 9:18 PM

Answers

  • If WD cannot help on it, there is a workaround we can try. You may open Notepad and paste the following commands into Notepad.

    net use [driveletter]: /delete
    net use [driveletter]: \\server\share /user:[username] password /persistent:yes

    Please save this Notepad to a location with a name reconnect.bat.

    Then, launch Task Scheduler, you may create scheduled task to run this *.bat file. Probably you can set it to run after several hours.

    For more information regarding the “net use” command, please refer:

    Technet Library - Net use


    Arthur Xie - MSFT
    Thursday, December 31, 2009 3:35 AM
    Moderator

All replies

  • Such behaviors are controlled by the sever side. If you mapped a drive to a share in Windows Server system, you can set the auto disconnect period. For your reference:

    Mapped Network Drive Disconnects From Server

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    Therefore you may need to change settings for the My Book World drive to resolve this issue. I suggest you contact WD support for more information.


    Arthur Xie - MSFT
    Tuesday, December 29, 2009 8:42 AM
    Moderator
  • Hi,
    I have one of these WD World Book's too and had these kind of problems with Vista also. As I recall, they use a Linux system with samba. I could be wrong but I think I uncovered that when I was having the same problem. I just gave up using the World Book. Not only would the drive disconnect but the computers couldn't find the device on the network anymore. It would just fall off the network but if I unplugged the power from it and restarted it it would become accessible for a short while.
    It now collects dust. I was going to remove the tandem 500GB drive and use them else where but never got around to it.

    The bottom line is your not a victim of the Microsoft server side mapped resource time out dilemma.

    - Cory Curtis
    - Palmtek/Technoogies
    Tuesday, December 29, 2009 5:35 PM
  • Cory:

    Based on your response, I posted a variation my original message onto a WD forum.  WD's official "support," whether by phone or by e-mail, is not real helpful.  They blamed Windows for the problem, offered no real solution and only perpetuated the infinite loop to nowhere that is experienced by many people trying to solve what should be a simple problem.  A Google search of "reconnect mapped drive" yields a whole of complaining about mapped drives that do not reconnect at logon.  I have tried many suggestions, none of which have yet to solve the problem.        
    Tuesday, December 29, 2009 10:13 PM
  • If WD cannot help on it, there is a workaround we can try. You may open Notepad and paste the following commands into Notepad.

    net use [driveletter]: /delete
    net use [driveletter]: \\server\share /user:[username] password /persistent:yes

    Please save this Notepad to a location with a name reconnect.bat.

    Then, launch Task Scheduler, you may create scheduled task to run this *.bat file. Probably you can set it to run after several hours.

    For more information regarding the “net use” command, please refer:

    Technet Library - Net use


    Arthur Xie - MSFT
    Thursday, December 31, 2009 3:35 AM
    Moderator
  • Hi guys, I was having this problem with some vista machine, here is the fix I got from microsoft. It is some king of update but it works just fine. Look at it hope it works.

     

    http://support.microsoft.com/kb/933657
    Thursday, December 31, 2009 1:58 PM
  • Does not apply, its just for vista.
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Friday, January 01, 2010 6:26 AM
  • Arthur:

    I have tried this several times, to no avail.  The information concerning the "net use" command is somewhat ambiguous, and I may have written it incorrectly.  If we assume the following (which do not correspond to the actual information on the system), how would the "net use" command look:

    Drive letter:  z
    Server:  10.1.0.3
    Share:  public
    User:  Joe
    Password:  Smith

    Also, looking at the information on "net use," there is a reference to an "accounts" domain of "Dan" in the examples, such that the command is noted to be "net use d:\\server\share/user:Accounts\Dan."  I noticed in another thread the suggestion that the account noted in the credentials manager for this is "RemoteDomain."  Would that make a difference here?

    Thanks,
    Sunday, January 10, 2010 6:43 PM
  • Arthur:

    Here is some further data.

    Looking in the task library, the history of the task I created shows the same thing each time.  It first shows event 118, indicating that the task was triggered.  The log then shows, at the exact same time, event 101, showing that the task failed to launch.   Error value is 2147943645.  Under "last run result," the following text appears each time:  "The operation being requested was not performed because the user is not logged onto the network.  The specified service does not exist. (0x800704DD).

    In Computer, the machine is identified as JOE-PC Workgroup:WORKGROUP. 

    Any additional assistance will be appreciated.

    Thanks! 

    Tuesday, January 12, 2010 4:29 AM
  • In your case, the correct connecting command should be:

    net use z:\\10.1.0.3\public /user: 10.1.0.3\Dan Smith

    You can also add a new credential under “Windows Credentials” under “Control Panel\All Control Panel Items\Credential Manager”.

    Network address: 10.1.0.3
    User name: Joe
    Password: Smith

    After adding the credential, the “net use” command will simply be:

    net use z:\\10.1.0.3\public
     
    If the command failed to execute when log on, maybe your network connection is not established when the task runs. You can configure the task in Task Scheduler. Open the task, click the “Settings” tab, check the option “If the task fails, restart every:”, and choose the waiting time. The task will re-run after that time.


    Arthur Xie - MSFT
    Wednesday, January 13, 2010 2:59 AM
    Moderator
  • Arthur:

    It is still not working.  I have re-written the command several different times, in several different ways.  I checked the option "If the task fails, restart every" 1 minute.  The task, however, does not restart, according to the log. 

    I am running a very simple network here.  The computer logs onto the network every time on start-up, without any issue at all.  I have disabled "power save" in the NAS, so it is not hibernating, 

    This has been going on since September.  It is extremely frustrating.   It should not be that difficult.

    Any other suggestions?

    Thanks,
    Wednesday, January 13, 2010 6:53 AM
  • Can you try restarting explorer.exe when the issue occurs and see if the drives then show as connected?

    Wednesday, January 13, 2010 5:55 PM
  • That does not work, either.  Plus, it would not save time since I can click Computer and then click the un-connected drive to connect.  I would, however, like it to connect automatically on start up.  Any other suggestions?
    Friday, January 15, 2010 4:03 AM
  • One other thing, I disabled all firewalls to see if that might be the problem.  It is not.  The drive is still not reconnecting at start-up.  At this point, it is not reconnecting at all.
    Friday, January 15, 2010 4:08 AM
  • Hi Jeffrey, I was looking for a cleaner alternative to the task scheduler solution proposed, so after some research, I wrote a small executable that solves the 'disconnected network drive on startup' issue, at least for me.  I'd be interested if it solves it for you as well.  You can download it here:

    http://zornsoftware.talsit.info/?p=129
    • Edited by Mr. Bungle Sunday, March 07, 2010 9:50 PM added hyerlink
    Sunday, March 07, 2010 9:49 PM
  • Hi Arthur, I have been having the same problem and do not understand how to create a Scheduled Task out of the bat file that I created with the net use commands. Could you please run me through how to create one using the Windows 7 "Task Scheduler".

    Cheers,

    Rhys

    Friday, March 19, 2010 5:00 AM
  • Unfortunately, it did not work.  I have now tried it many times.  I had, I believe, run a successful "task" based on what Arthur wrote above.  It was working on one of my Windows 7 machines every time.  It worked intermittently on my other Windows 7 machine (which is further from my router0.  Now, it is not running on either machine at any time, although the task scheduler history notes no change in all in the success of the task starting and completing as against what it did when the drives were mapping successfully.

    Wednesday, March 31, 2010 12:47 AM
  •  

    Mr. Bungle:

     

    The only things of which I can think that have changed recently are the Windows 7 updates that I have downloaded recently.  Most of these are "security" in nature, which makes me think that some level of local security has either been added or changed that is preventing the network drive to connect automatically upon logon.  One would think that Microsoft could get this right so that this is not such a big problem.  There are hundreds, if not more, posts on various sites discussing this problem or variations thereof.  

    Any solution, from anyone, would be helpful.  Thus far, I have (i) mapped the drives many times, (ii) made sure all credentials are correct, (iii) created a task that previously worked and which is still be shown as running everytime the computer is booted, and (iv) run Mr. Bungle's executable file.  I have spent countless hours researching and trying to get this to work, but, now, to no avail.

     

    Thanks,

     

     

    Thursday, April 01, 2010 3:22 AM
  • I have exactly the same problem and have a WD 1tb NAS drive (blue rings)

    Sometimes it works perfect, but if I log off and log back on, or come back from hibernate it will give an error saying cannot connect to network drive.

    I will try the Zorn Fix and see if it works...

    Thursday, April 01, 2010 8:37 PM
  • I found that mine as software related. As soon as I uninstalled Zonealarm and installed a new firewall the problem went away...
    Tuesday, April 13, 2010 6:39 PM
  • Jeffry

    From the net use link someone put up before, I created a file in notepad called reconnect.bat which I just placed in my startup folder.

    The contents of that are.

    net use [drive letter]: \\SERVERNAME\MAPPEDFOLDER PASSWORD /user:SERVERNAME\USERNAME /persistent:yes

    This corresponds to the technet article here

    net use [Driveletter:] [\\ComputerName\ShareName] [Password] [/user:DomainName\UserName] /persistent:yes

    I am running windows 7 home premium 32 bit

    Just for good measure I created the mapped share first through the windows gui and then set up credentials by using the credentials manager.

    Worked every time so far.

    For your example it would be 

    net use z: \\10.1.0.3\public Smith /user:10.1.0.3\Joe /persistent:yes

    Saturday, May 08, 2010 8:57 PM
  • The net use process works, but my question is why do we have to set up what is basically a forced reconnect? 

    My Win 7 machine attempts to reconnect the network drives BEFORE it has established a network connection.  Can anyone shed some light on why this occurs and how to correct the issue?

    (Win 7 Pro 64-bit on a Dell OptiPlex 780)

    Wednesday, June 09, 2010 3:51 PM
  • In monitoring this over time, it appears that the "net use" process works -- sometimes -- but that the process described by Nivek2112 is the culprit of the frequent failures to logon.  I pretty much can tell exactly when logon will fail by watching the attempted reconnection to the network drives before the network connection is established.  Any light shed on this will be greatly appreciated.  This has been going on now for 8 months or so.

    Thanks!

    Wednesday, June 09, 2010 10:27 PM
  • I am just now beginning to use Windows 7 in a network environment and I am experienceing this same problem.

    I am moving directly from XP ... and I would note that if this scenario played out in XP then there would usually be an icon in the Windows Tray that would indicate that that the drive (share) was available, but not actually connected.  If you clicked on this icon (looks like a desktop computer) then you can connect to these available shares.

    Is this icon (or its functional equivalent) not available in Windows 7 ?

    Note that my mapped share is on an XP machine in a workgroup that the Windows 7 machine is NOT a part of..... (probably relevent)

    Tuesday, June 15, 2010 6:15 AM
  • To All,

    Here is what I have found.  This is a problem with Windows 7 and nothing else.  After several test and looking at forum after forum.  here is what I came up with.

    I have 3 machines.  1 (XP) and 2(Windows 7 recently loaded).  the 2 machines that I loaded Windows 7 (fresh) were both XP.  The 1 XP machine that is still XP for this post I will call File_Machine (because this is where I hold my files and map to from the other machines.

    1. When my other 2 machines were loaded with XP I have no problem with mapped drives.  No dropping or reconnection problems.

    2. I load Windows 7 on 1 of my machines and start noticing when I would shutdown or logoff it woudl hang at the log off screen and the only way to shutdown is a hard shutdown.  I knew it was related to a network connections not closing or something but could not isolate it.

    3. Installed Windows 7 one the other machine (oohh by the way 1 is Windows 7 Ultimate and the other is Professional).  I started experiencing the same problems with this machine mapping back the my File_Machine.

    4. Saw a post referencing the idle network connection disconnect feature in the Windows Operating system.. so I looked at my XP machine (File_machine) active sessions.

    5. I brought both windows 7 machine online and let them restore the network connections to the XP box.  after being idle for a while the sessions dropped because they were idle (this is normal and by default).  ok fine.. no problems there.

    6. here is the kicker.. when I went back to either Windows 7 machine and clicked on the mapped drive, it hung and would not reconnect to the share.  the share is fine and active.  The problem is the Windows 7 is not sending the correct signal to the system housing the share to reconnect.

    7. To confirm this I ran the following command on the XP (File_machine).. NET CONFIG SERVER /AUTODISCONNECT:-1  (this command disabled the autodisconnect feature in a network connection is idle).. the (-1) represents the duration to wait before disconnecting.  -1 is to disable.. I believe the number range is from 0 to 655555 or something.. representing seconds.

    8. after the was disabled there were no more dropped connections.

    9. set the number to 1 and tested again.. and the problem came back..

    What does this say.. Microsoft needs to look at Windows 7 reconnection attempt commands for idle connection and see what signal is being sent to the resource to say wake up and reconnect me because it's not working..

    Hopes this helps everyone and Hope MS reads this and looks into it.. You know have the info on how to recreate the problem.
    Wednesday, July 07, 2010 4:01 AM
  • To All,

    Here is what I have found.  This is a problem with Windows 7 and nothing else.  After several test and looking at forum after forum.  here is what I came up with.

    I have 3 machines.  1 (XP) and 2(Windows 7 recently loaded).  the 2 machines that I loaded Windows 7 (fresh) were both XP.  The 1 XP machine that is still XP for this post I will call File_Machine (because this is where I hold my files and map to from the other machines.

    1. When my other 2 machines were loaded with XP I have no problem with mapped drives.  No dropping or reconnection problems.

    2. I load Windows 7 on 1 of my machines and start noticing when I would shutdown or logoff it woudl hang at the log off screen and the only way to shutdown is a hard shutdown.  I knew it was related to a network connections not closing or something but could not isolate it.

    3. Installed Windows 7 one the other machine (oohh by the way 1 is Windows 7 Ultimate and the other is Professional).  I started experiencing the same problems with this machine mapping back the my File_Machine.

    4. Saw a post referencing the idle network connection disconnect feature in the Windows Operating system.. so I looked at my XP machine (File_machine) active sessions.

    5. I brought both windows 7 machine online and let them restore the network connections to the XP box.  after being idle for a while the sessions dropped because they were idle (this is normal and by default).  ok fine.. no problems there.

    6. here is the kicker.. when I went back to either Windows 7 machine and clicked on the mapped drive, it hung and would not reconnect to the share.  the share is fine and active.  The problem is the Windows 7 is not sending the correct signal to the system housing the share to reconnect.

    7. To confirm this I ran the following command on the XP (File_machine).. NET CONFIG SERVER /AUTODISCONNECT:-1  (this command disabled the autodisconnect feature in a network connection is idle).. the (-1) represents the duration to wait before disconnecting.  -1 is to disable.. I believe the number range is from 0 to 655555 or something.. representing seconds.

    8. after the was disabled there were no more dropped connections.

    9. set the number to 1 and tested again.. and the problem came back..

    What does this say.. Microsoft needs to look at Windows 7 reconnection attempt commands for idle connection and see what signal is being sent to the resource to say wake up and reconnect me because it's not working..

    Hopes this helps everyone and Hope MS reads this and looks into it.. You know have the info on how to recreate the problem.
    • Proposed as answer by What_I_Found Wednesday, July 07, 2010 4:03 AM
    Wednesday, July 07, 2010 4:02 AM
  • This is a great step forward in cornering the issue.  Hopefully this will help MS in coming figuring out a fix, on the Windows 7 side.  For the time being, I'm wondering what I can do to my two Win 7 x64 boxes if my mapped network drives happen to be off two D-Link DNS-323 NAS boxes, which happen to be running some Unix-like kernel (BSD?  Linux?).

    I've tried a multitude of things such as:

    • downgrading the authentication level local GPO
    • telling Avast 5 to ignore my mapped drive letters (both on-demand scan and shield configs)
    • setting the DNS-323 boxes not to sleep the hard disk
    none of which made a difference.
    Thursday, August 05, 2010 3:55 PM
  • Sad but true, this is just another reason why Microsoft should kill the Vista kernel.  The XP kernel was better for business.  I wish MS would take these type of problems more seriously.
    Monday, August 09, 2010 1:29 PM
  • My compliments for your efforts.

    I've also had a frustrating time with Windows 7 not connecting to the mapped drive on my Thecus NAS for my Genie Timeline backup.  I tried Zorn MapDrive and it didn't work.  Then I mucked around with Credential Manager not making any changes but it worked.  Then I uninstalled MapDrive and it still worked and hasn't failed since???!!!

    Could mucking around in Credentials Manager have changed something?

    Monday, January 03, 2011 8:29 PM
  • UPDATE

    The machine has just failed to connect to the network drive.

    Running MapDrive manually from the Desktop, which is where I moved the shortcut from the Startup folder, didn't work.

    Over to Microsoft.

    Tuesday, January 04, 2011 7:33 PM
  • I am having the same problem, Windows 7 x64, I am connected over VPN and can connect to shares on multiple servers, I will restart the computer and reconnect again to VPN and some shares will connect while others will not.  Sometimes clicking on one share on the same server will unlock the other share I am mapped to on the same server.  Definitely a Windows 7 problem.  Get on it MS, my company might just go all Mac if this continues.

     

    Tuesday, February 08, 2011 8:50 PM
  • Arthur, I found that the approach you suggested did not work as I, and many others, had hoped. The Credential Manager loads the info, but then "loses" it after a reboot/restart although the PERSISTENT:YES is included, and one is once again asked for their ID and password. What I did is to use the following command in a batch file:

    net use K: \\domain\c password /USER:domain\ID /PERSISTENT:NO

    If the batch file is placed on the desktop, one can execute the command as needed, or immediately upon booting. If a programmable keyboard is used the batch file can be executed when tied to on of the "My Favorites" key. Additionally, I can also disconnect a network drive quite easily without the red X displayed in Explorer. 

    If Microsoft ever gets to the point that the Credential Manager works as it should maybe a work-around will no longer be necessary. Who knows?? Phasr

    Thursday, March 03, 2011 2:48 AM
  • Having a work around for users on a network to connect to a persistent drive is unacceptable in a business environment. Microsoft needs to look at this and fix it. Not every company has the need to script mapped drives to every user, so there should be a way to do it on an individual basis without having to use a backdoor method. It would be really nice for a Microsoft representative to respond with either the reason it is designed this way, or an admission that it is broken and being fixed.
    Thursday, March 31, 2011 10:12 PM
  • I have had similar issues to all of the above ones. As with many people I found that by opening my computer and then opening the mapped network drive would cause immediate re-connect with no dramas. As a simple workaround I created shortcuts to the mapped drives and then placed those shortcuts into |Start|Programs|startup

    The net result is that everytime a user starts up windows everything will load and then the shortcut will be activated, thereby restoring the network drive connection. This does result in an explorer window popping open to display the contents of the network drive, but one click to close the open window and everyone can carry on as normal.

    Maybe not pretty or elegant but it worked for us.

     

    Tuesday, April 12, 2011 1:32 AM
  • I agree.  This issue was driving me crazy.  I tried all sorts of things.  I'd make a single change - document it and if problem was not fixed I'd usually undo the change and move on to the next change.    I finally just quit doing my VPN connection but then I knew that eventually I'd have to connect up again.  So, just for the heck of it I wrote a short batch file that would change to my network drives then sleep for 2 minutes and then change to my network drives again, over and over.  This has been working great. 

    Now I'm trying the above mentioned workaround:  net config server /autodisconnect:-1 and I'll be disabling my VPN loop script and we'll see what happens...but this has been such a pain and ANY WORKAROUND IS UNACCEPTABLE!

    JB

    Monday, May 02, 2011 10:17 PM
  • [some rather poor advice deleted]
    Arthur Xie - MSFT

    Marked As Answer byArthur Xie<abbr class="affil">Microsoft Contingent Staff</abbr><abbr class="affil">, Moderator</abbr>Monday, January 25, 2010 6:51 AM

    UNMARK AS ANSWER!!!

    Marking yourself as answer: very poor netiqette!

     


    plugh
    Monday, July 18, 2011 6:53 PM
  • I cannot, with any certainty, state that my approach below is a solution.

    I can state that it has worked for me for more that a year.

    I changed the  IP addresses in the router from dynamic to static and have had no problems reconnecting to every device/computer since doing this.  I, of course, made the necessary additions to the credentials manager, and mapped the drive(s). This has worked for me, and maybe it will help someone else. Phasr


    Phasr1 Sonoran Desert
    Monday, July 18, 2011 7:11 PM
  • Well, get used to that because that's just how it goes here.  People ask for solutions to problems. Users who have jumped to conclusions based on coincidence post incorrect answers.  Microsoft either seems to not undersrtand the problem and post unrelated and unhelpful answers or some absurdly complex workaround.  One thing that does NOT happen is microsoft identifying the problem and doing something about it.

     

     

     

    Wednesday, July 20, 2011 7:40 PM
  • It's been a few months so I'm just 'pinging' this thread to see if anything new has come about... has Microsoft fixed this?  I'm assuming NOT because it's happening to me also.  On a VPN connection, network drives only wake up if I click into them.
    Friday, December 02, 2011 12:14 PM
  • I've been having this issue ever since converting our XP workstations to Win 7 PRo x64.

    This is on a Windows Server 2008 domain.  The shared drives are on Server 2008R2 x64 and every time the Win7 machines reboot, the mapped drives show as disconnected.  Any shortcuts to documents on said drives will not work until the user manually dbl-clicks on the network drives and establishes the connection.

    If it's truly an issue where Win7 attempts to connect before the a network connection is made, it would seem simple enough for MS to add a delay to that.  I do run a logon.bat file at the domain level that remaps drives each time a person logs in.  Perhaps a delay in the logon.bat file might cause the connection to work.  I'll give it a shot and see.

    Thursday, December 08, 2011 4:06 PM
  • Hi:

    I have sort of a similar problem, wondering if you ever got it resolved.

    I may have a part resolution for you however.  I have a D-Link NAS and had a problem with it disappearing.  It turns out that in the NAS the "workgroup" has to be named the same as all of your computers in order to stay visible, and to wake up on activity.

    So mine is always visible now, and I have mapped drives to it for file backups, my only remaining issue, is that I set folder access permissions, and pass words for each user who will be using this NAS in order to store files and backup thier computer to it.

    Every time that my Windows 7 machine is shut down, and restarted, it forgets the password and I get the error network drive could not be reconnected.  I have to click on the drive, enter my user ID and password and then it reconnects.  Not a big deal, but it prevent my scheduled backups from running automatically.

    I have checked of the remember credentials box each time, but shutting down causes the dredentials to be lost so I am looking for a way, other than removing the password protection, to force the retention of the credentials.

    Anyone have a solution to this?

    Thanks in advance, Lance

    Saturday, February 11, 2012 5:03 PM
  • Hi:

    I have sort of a similar problem, wondering if you ever got it resolved.

    I may have a part resolution for you however.  I have a D-Link NAS and had a problem with it disappearing.  It turns out that in the NAS the "workgroup" has to be named the same as all of your computers in order to stay visible, and to wake up on activity.

    So mine is always visible now, and I have mapped drives to it for file backups, my only remaining issue, is that I set folder access permissions, and pass words for each user who will be using this NAS in order to store files and backup thier computer to it.

    Every time that my Windows 7 machine is shut down, and restarted, it forgets the password and I get the error network drive could not be reconnected.  I have to click on the drive, enter my user ID and password and then it reconnects.  Not a big deal, but it prevent my scheduled backups from running automatically.

    I have checked of the remember credentials box each time, but shutting down causes the dredentials to be lost so I am looking for a way, other than removing the password protection, to force the retention of the credentials.

    Anyone have a solution to this?

    Thanks in advance, Lance

    Saturday, February 11, 2012 5:04 PM
  • JeffryR25:

    All I can say is thanks to this forom, it spurred me to try another approach, and it is working.

    Ya HOOOOOO.

    So since you already have the mapping done;

    I followed the instruction found here to create a stored set of credentials :http://windows.microsoft.com/en-CA/windows7/Store-passwords-certificates-and-other-credentials-for-automatic-logon

    Using my info it looks like this, you will have to substitute yours:

    Internet or network address: \\DLINK-005AC\Volume_1

    Username:  Your Username on the NAS for the folder you are mapping

    Password:  Your password on the NAS for the folder you are mapping

    The problem with checking the save credentials box is it was adding the computer name to the front of the user ID and making the NAS reject the User ID as invalid.  So creating a credential forced it to use that one (I think).  IE: the username it was try ing to use to log onto the NAS to automaticall reconnect to the NAS on startup looked like this "COMPUTERNAME\USERNAME"

    So far so good.

    Lance

    • Proposed as answer by Jaramie Wednesday, February 29, 2012 2:42 AM
    Saturday, February 11, 2012 5:53 PM
  • That worked perfectly for me.

    I have four Windows 7 machines and only one has displayed this problen but creating a new credential from the user account section has sorted it.

    Thanks very much.

    Wednesday, March 07, 2012 8:02 PM
  • Hi all

    I've tried all of the suggested solutions, apart from creating batch files to get this working

    Microsoft, please treat this issue with far more severity

    As several people have suggested, this is a timing issue between the time it takes for Win7 to connect to the network, and the time taken for the mapped drives to try and establish a connection, resulting in the red x's

    Users shouldn't have to double click the disconnected drive to establish the connection, they didn't have to in XP. This is just a backwards step

    Please, please suggest a way that we can all adjust the timing values for this very, very annoying "quirk"

    It is driving end users mad with frustration

    Tuesday, April 10, 2012 12:32 PM
  • The network drive having a NETBIOS name is the problem you seem to have circumvented in this case, by replacing it with a fixed IP address....and I think I fix this in a similar way but with the LMHOSTS file, i.e a local Domain Name Lookup in the event there is no other way to determine a named network location.

    The reason I was looking here for a fix was because I have recently taken delivery of a nice new Lenovo x220 and lo and behold its the drive mapping problem...again. I've had (and fixed, and forgotten that I had fixed) this issue at least 4-5 times in the past on Windows7 machines I have setup, and it got the point where I had to make a note to myself in an email I could later search and find to solve the problem...however today I could not even recall the name of the file I needed to edit to fix the problem...but that's just old age.

    Very simply add a local hosts mapping between the IP address and the Drive Name in the LMHOSTS.SAM file located in the C:\Windows\System32\drivers\etc folder. You'll probably need to open Notepad first as Admin before it will let you save the file, then add a clean line somewhere above the first line to look something like; "192.168.x.y    NASNAME    #PRE". Just insert the IP address of the NAS (make sure its statically assigned by your router), the device name from your Credentials Manager and then the #PRE to make sure its pre-assigned and is there from the the get go.

    Fixed...maybe I'll find the reminder here next time I have to a Windows 7 install!!

    Friday, May 25, 2012 5:09 PM
  • Wow. Three years on, Microsoft still hasn't fixed this. I just bought a new desktop, and I'm having the same problem. But hey- every soccer mom trying to backup her kid's pictures ought to know to add a line to the LMHOSTS file, shouldn't they?

    Anyway, I did as you suggested, Robberbobbles, and screwed around with Credentials. I had already set it up as static.

    Seems to be working. Thanks, and good karma to you.

    Monday, July 23, 2012 12:21 AM
  • It's the same problem with Windows 8, still not fixed.
    Monday, September 03, 2012 10:29 AM
  • My problem is on a network drive. We have login scripts that map several other network drives but this one is not included. I add manually and it works for the day. The next time they need it usually 2 weeks later it doesn't reconnect. And I cannot reconnect it until I remove the entry in credentials manager under vault. I remove it from the vault and remap it and it works fine that day- repeat again 2 weeks later. Anyone have any ideas? I tried the batch file, setting in account settings. Nothing in this post has helped.

    I can't therefore it is MS

    Monday, September 24, 2012 5:53 PM
  • After reading everything on this I could and coming up with my own theory 'before' messing around with 'fixes', I have found something that appears to work for me today. I cannot check whether the fix will hold into the future- yet, but it is repeatable and can be demonstrated.

    Robberbobbles put me onto it.

    Essentially as many have pointed out, win7 tries to connect to network resources before it has full network connection (or at least that is how it looks) and the mapped drive seems to be hit with a red 'x' and yet it is mysteriously, actually able to be accessed.

    I have, like many others, set my NAS to a static IP, and mapped the NAS to reconnect at logon. My credentials were corrected with persistency at 'enterprise' etc and that solved some of the connectivity issues early on, but the red 'x' would still appear every time a full reboot was undertaken.

    I was thinking, why edit this wretched LMHOSTs file on every machine and why should I have to? Then it dawned on me. It is the IP to Device Name resolution that is causing the issue. Win7 doesn't actually know or remember and would need to confirm it all anyway before connecting. It doesn't have the network connection in anycase...or does it? We all know that the OS has network connection long before it tells us. It has an IP from the router and is connected to the router- the router and the NAS are connected and the NAS has a fixed IP- but win7 doesn't know its 'name'. And guess what, have used the 'name' to map the NAS drive, instead of its IP!

    Create a mapped NAS folder using the IP address (followed by whatever extensions to folders etc) instead of the NAME and it will work, everytime. I created 6, three via NAME and 3 via the IP address and all three suing the IP connected at startup and all three using the NAME gave me red 'x's.

    NAME in my case was NAS-SERVER and I had merely created a mapped drive by using \\NAS-SERVER\etc

    when I used \\192.168.0.9\etc all was fine! No 'x's and faied reconnects!

    The other thing to do is delete and then re-create credentials with the IP address instead of the NAME. Don't be tempted to 'edit' the credentials- that doesn't seem to work. Delete them and make new ones.
    Thursday, September 27, 2012 10:16 PM
  • I was having this same issue and my fix was to sync the time of the server who's share I was connecting to the time of the client. The time was off by 10 minutes. After both times were synced the share connected successfully. 

    Wednesday, October 03, 2012 6:16 PM
    • I found the answer today - and have been looking for months.

    Go to Control Panel - under System settings - GoTo Power Settings

    Then GoTo "Change when the computer sleeps"

    Here is where you find "Change Advanced Power Settings" Click it

    You may need to click on "change settings that are currently unavailable" to make changes below

    1) uncheck Hard disk - and change settings for the hard disk "while plugged in" to 180 minutes. The hard drive will go to sleep after 3 hours of non-use. Make longer if needed.

    2) uncheck Wireless adaptor - and change "Plugged in" to maximum performance

    3) uncheck Sleep - and make sure all "Plugged in" options read Never

    4) uncheck PCI Express and make sure everything is on Maximum

    I don't know if all 4 changes above are needed - but one of these changes seem to be working on five of our new computers that were putting the Red X on the connected Network drives. I hope someone at Microsoft puts this information out to the public –

    ALSO – you need to go into Device Manager – open your Network Card(s) (properties) – GoTo Power Management and uncheck the boxes suggesting the device can go to sleep.

    I can be reached at 973-292-0025

    Scott

    • Proposed as answer by Scotty-Guitar Wednesday, October 17, 2012 11:18 AM
    Wednesday, October 17, 2012 11:18 AM
  • This is the answer for most of you:

    1) Map Drive
       a) Enter Drive
       b) User Name
       c) Password
       d) Check boxes

    2) when it asks you for User name and Password again type:

    "computer name"\"User Name"

    or

    "IP Address"\"User Name"

    So for example, if your user name is Mike and the ip address of the network drive is 192.168.1.90 you would log on like so:

    192.168.1.90\Mike

    If your user name is Mike and the computer name is Mikes-PC you would log on like so:

    Mikes-PC\Mike

    If you do not know your computer name or ip address, look for where it says "Domain" in the log in box. That is your computer name or ip address for the network drive. And make sure you check the box that says remember credentials.

    If this solves your problem, let Microsoft know how they should hire us young guys in the USA instead of hiring people from other countries or out sourcing our jobs to other countries. How much is enough Mr. Gates!

    Sunday, December 09, 2012 7:05 AM
  • Can you repost the executable file. I have tried everything on this thread and beyond to no avail. This is my last hope. PLease!!!
    Monday, December 31, 2012 7:29 AM
  • For what is's worth, my findings on this sorry saga are as follows.

    Until recently, we were running WIN2000, WIN-XP and WIN7 machines on a Win2000 Domain all with fixed IP addresses.  All machines connected all Network Drives correctly at boot-up.   We migrated to a Windows 2008 Domain, and at the same time, went DHCP with the 2008DC acting as a DHCP server.  Windows 7 machines started to fail to connect the network drives at logon.  Various "fixes" were tried, including setting Group Policy to "wait for network before logon" to no avail.  At least some (if not all) the WIN7 machines failed to connect on boot.  Logging off and back on again allowed a successful connection, as did clicking the drives in Computer.  (All drives are mapped using the fixed IP addresses of the servers - these are not on DHCP)

    I reverted to fixed IP addressing on a couple of the WIN7 machines, and the problem went away.   Thus, I deduced that the extra time taken to obtain an IP address from the DHCP server was the root cause of the problem.  Why is the GP "wait for network to be ready before logon" being ignored?  Can anyone in Microsoft answer?  This problem does NOT occur with either WIN2000 or XP.  (I am still running WIN2000 server on an old, very slow machine and this reconnects all drives perfectly every time, as does XP on newish "fast" machines with the same spec as those running WIN7)

    BTW, a batch file on each machine doing 20 "DIR C:\Windows\System32 > nul" before the NET USE commands seems to work like a charm, but WHY is Win7 (and also WIN8) so recalitrant?  

    • Proposed as answer by ThePatrician1 Wednesday, January 23, 2013 4:41 PM
    Friday, January 04, 2013 11:01 AM
  • Win7 coping some files to DNS323 and Javelin NAS, went ok.  Then running a commandline program which read from NAS, paused the output, crashed that program, terminated using Task Manager, now drives no longer connecting.  Seems some cleanup didn't happen when the task crashed.  Right now my four mapped drivess blink from red to green to red constantly.

    I had (a long time ago) issues with DHCP leases expiring prematurely from a Netgear router, trashed copy jobs in progress, also messed up drive mappings.  Solution: Turned off DHCP on Netgear, used DNS323 instead.

    Sounds a bit like some out-of-order condition that doesn't reproduce with Microsofts favorite scripting test tools is causing the problem to not show up in their regression testing.

    Maybe someone can point out a way to completely reset the network stack without uninstalling the driver.  I did try some "net" commands but it doesn't allow me to.  I did try unplugging network cables+wifi - no luck there.

    FYI deleting the mappings did fix the visibility of the servers, which are both on static IPs.
    • Edited by HansSchulze Wednesday, October 30, 2013 5:49 AM
    Wednesday, October 30, 2013 5:39 AM
  • I had the problem along the same lines. All the various work-arounds and "fixes" did not resolve my issue, but I finally got it solved as per below.

    Mapped networked drives from my 2011 Windows Home Server would stay mapped on clients (Windows 7 computers) but required clicking on them in Explorer to "connect" them after every reboot. When rebooting, the window always popped up telling me network drives were not connected and a red X showed in Windows Explorer. This is a different issue than the connection being lost while logged on - i.e. losing persistence. Once I clicked on the folder and it was "connected" it never lost connectivity to the mapped drive.

    My fix was to make the usernames and passwords on WHS and the client computers the exact same. Once I did this then the mapped drives always connect after a reboot. No more messages popping up and needing to click on the folder in explorer to ensure the drive is connected.

    This probably won't help the OP, but may help other folks that are trying an internet search on this problem.

    Monday, November 18, 2013 2:55 AM
  • I faced the same issue two days back. Now I fixed that issue. follow these steps

     Open Control panel - user Account -manage your credentials -Add a windows credential-

    then one window will appear ,

    put your network address (Ex:\\servername\sharefoldername ) and your user name and password.

    Try these steps.

    Monday, January 20, 2014 10:44 AM
  • I faced the same issue two days back. Now I fixed that issue. follow these steps

     Open Control panel - user Account -manage your credentials -Add a windows credential-

    then one window will appear ,

    put your network address (Ex:\\servername\sharefoldername ) and your user name and password.

    Try these steps.

    Monday, January 20, 2014 10:45 AM
  • I've painfully researched this problem for months trying every solution from login scripts, batch files, schedules, mapdrive, net use, group policy drive maps, a Microsoft hotfix  etc but time and again the drives come up with the dreaded red X when I boot up, along with a tray message telling me that it could not reconnect all my network drives.

    Some research told me to ignore it, it wasn't a problem but in my case where I'm copying music to my NAS the software just would not recognise the drives without me going in to explorer and "waking up" the drive first, a time consuming and frustrating exercise. Frankly I was at the point giving in to the problem and waiting for the next service pack.

    This morning however I had an epiphany. I have never used Sync Center, as I had no need, but I thought what if I synchronise one folder / file in each of my mapped drives to force the pc to recognise it at start up.

    I created a folder in each of my mapped drives with a tiny txt file in it (in my case called sync.txt) and enabled Sync Center and set up a partnership with this tiny file in each mapped drive. I then rebooted and hoped.

    Voila, no tray message telling me it couldn't connect and no red X. My audio and video software works perfectly and many reboots later it is still working perfectly.

    I know it is a sort of workaround but I hope this works for you too. This problem has been a constant pain since I first mapped the drives. Time now to move on to the next item in event viewer....

    Saturday, January 25, 2014 2:22 PM
  • As well all know this problem has not been fixed. I tried to sync the file through sync center but get an error folder can't be synchronized because it resides on a remote drive.

    What can I do to fix the problem with a mapped drive that won't reconnect on boot up. I put my credentials in manager still no luck. Does anyone have a fix. This is a workgroup 3 pc with win 7 ultimate 64 bit with a WD Mycloud 4TB drive on 192.168.10.133 static ip.


    Chris Medina


    I found the problem on my system. After several support calls to WD with no help I figured it out. I had to map the hard drive to the name of my cloud hard drive and not the static IP address. As soon as I did this everything worked perfect. WD level 2 support contacted me to find out what steps I went through to fix the problem. I hope this may help someone.
    • Proposed as answer by Cmedina Tuesday, February 11, 2014 10:17 PM
    • Unproposed as answer by Cmedina Tuesday, February 11, 2014 10:17 PM
    • Edited by Cmedina Tuesday, February 11, 2014 10:20 PM Fix
    • Proposed as answer by Cmedina Tuesday, February 11, 2014 10:20 PM
    Monday, February 03, 2014 7:51 PM
  • I am having the very same problem did any of these fixes work for you?
    Thursday, March 20, 2014 3:04 PM

  • I have tried everything suggested, connected with the name of the device as well as the IP address. I do have it at a static IP. Only the WD does this, my Seagate and MS Server connect with no problems.

    The best solution I have found that works, write a bat file .

    Copy this paste into Notepad adjust to fit your drive letter, path, password and user name 


    {net use X: \\Drive_name_Or_IP password /USER:User_Login_Name}

    drive X should be your drive letter that is mapped, don't copy the brackets {only the inside info}..

    if you don't have a user and password, go to the device admin web user interface page,  and create one, I have tried this with no user name or password, I tried a public share and it still ask for this information.

    test the map line before you save it.


    click start in the search box type in cmd , Command window should open

    Copy the map line from notepad  {net use X: \\Drive_name_Or_IP password /USER:User_Login_Name}
    Right click on the Command window, and Paste (Ctrl-V will not paste)

    the spacing is important, this will tell you if this line will work or not,                                                                    
    adjust as needed until you receive a message that it is mapped. .
    if you receive message
    "System error 85 has occurred.
    The local device name is already in use." It was a sucess and your Map line is good.

    if you recieve
    "System error 53 has occurred.
    The network path was not found." continue to adjust until you recieve above message.

    Once we know our mapping cmd line is good, save to notepad, ( One can use @echo off  at the start but not absolutely needed, placing   pause at the end will keep the Cmd screen open, this file will open and close fast, if you want to see what is happening add pause )
    Make certain the first part of the line is the start, place the cursor behind the word "net" and hit back space until it there are no spaces at the start.

    Once all is good save as map.bat, what ever you want to name it,  the period.+bat is what is important, remove the .txt and name it whatever.bat  .. save somewhere ( desktop )
    then double click it, it should open.

    now save it to the start up folder location.... 
    click start> programs scroll down to >Start Up folder right click on it and select> Open
    Drag the map.bat file to this folder.
    ( the start up folder is located C:\Users\Your_PC_User_Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup )

    Now when you log into your PC, that file will excute, mapping the drive. If your using a lap top and your not on the network which this file is attempting to map, you should recieve an error, if you place pause at the end it will show otherwise the cmd window will go away.

    this is really easy to do, and simple and most improtantly it works.
    There are a few other ways to have this file execute on login, this is the simplest way. ( if you know how to add a start up fucntion to the registry, you probably are not reading this)


    • Edited by mickspace Saturday, May 03, 2014 4:48 PM
    Saturday, May 03, 2014 4:41 PM
  • JeffryR25:

    All I can say is thanks to this forom, it spurred me to try another approach, and it is working.

    Ya HOOOOOO.

    So since you already have the mapping done;

    I followed the instruction found here to create a stored set of credentials :http://windows.microsoft.com/en-CA/windows7/Store-passwords-certificates-and-other-credentials-for-automatic-logon

    Using my info it looks like this, you will have to substitute yours:

    Internet or network address: \\DLINK-005AC\Volume_1

    Username:  Your Username on the NAS for the folder you are mapping

    Password:  Your password on the NAS for the folder you are mapping

    The problem with checking the save credentials box is it was adding the computer name to the front of the user ID and making the NAS reject the User ID as invalid.  So creating a credential forced it to use that one (I think).  IE: the username it was try ing to use to log onto the NAS to automaticall reconnect to the NAS on startup looked like this "COMPUTERNAME\USERNAME"

    So far so good.

    Lance

    This worked perfectly.  This is why Microsoft has become so ineffective.  They are too big to know what each other is doing.  The somewhat easy answer was already available in their own knowledge base. Thanks for finding this and sharing it.
    Sunday, May 11, 2014 4:26 PM
  • We have the same problem at work.Extensive googling has shown that this is an on-going problem not related to any WD device, and we don't have any WD devices.

    Here is the only solution I have found that works. A bit of a pain, but it works. Details of the batch file are already discussed above, so I won't repeat them.

    On the link that starts your application (e.g., MyApp.exe), right-click the link, click Properties, and copy the contents of Target to Notepad. Also note the icon.

    DELETE the link.

    Create a batch file that does the following:

    Begin with @echo off Otherwise when the batch file runs all the commands will display.

    Use Net.exe to unmap the drive.

    Use Net.exe to remap the drive. Set it as Persistent. (And, no, doing so won't cure the problem!)

    Put the line you saved in Notepad as a command line.

    (Optional) Use Net.exe to unmap the drive.

    Save the file under an appropriate name, e.g., MyStuff.bat

    Create a shortcut to the batch file.

    Right-click on the shortcut, click Properties, Change icon.

    The icon you want is probably in the executable file that the Target you saved points to. Navigate the dialog to that file and select the icon.

    ===============

    Some clarifications:

    The reason you first undelete the mapping is in case the drive is already mapped.

    Sometimes you will get a message that the drive is in use. If so, it is already mapped. Just select the appropriate Y or N.

    When the dialog is exiting (after your program is finished), when it tries to unmap, you may get a dialog that files are open. I have found that this tends to not be true, despite the message. You can click Y or N. The next time the dialog is run it will try to unmap the drive, so either way it's not a problem. (I actually use Take Command Light Edition from JPSoft, which could be the cause of the extra warnings.)

    The benefit of this approach is that for non-techies, everything pretty much looks and works as expected. They click on the link they usually click on, and they don't have to remember any weird ritual to get the program to work.

    Friday, June 13, 2014 3:00 PM