none
Installing ADAM on Vista SP1

    Question

  • The other day I found steps on how to install ADAM on Vista and those steps were to copy the files over and run adaminstall.exe.  Well I just installed Vista SP1 on a machine and tried the same steps and adaminstall.exe failed to run. I could not find a hook in vssapi.dll which seems to be a newer version from Vista to Vista SP1.

    How do I get ADAM on Vista SP1 or is there something built in to Vista and Vista SP1 that will do the same job at ADAM.
    Thursday, April 03, 2008 2:45 PM

All replies

  • Those steps worked for me for a machien PRE-SP1 but after I installed SP1 on a machien, those steps will not work anymore.  The error I am getting with the vssapi.dll is:

    The procedure entry point ?Initialize@CVssJetWriter@@QAGJU_GUID@@PBG_N211@Z could not be located in the dynamic link library VSSAPI.dll

    So I think SP1 even broke the manul process of putting ADAM on vista unless I am doing something wrong, but this error message pops up when I try to run adaminstall.exe
    Thursday, April 03, 2008 4:06 PM
  • Anyone have a solution or atleast run into this problem? 

    Is there something else to use on Vista instead of ADAM?
    Friday, April 04, 2008 1:39 PM
  • I have not run into your problem, but I've run into a similar one using ntbackup - I'm trying to run it on vista sp1 and server 2008 (which is "automatically sp1"), and there seems to be some sort of incompatibility with vssapi.dll, which seems to be the same issue you're getting with ADAM.

     

    It seems something was changed with the volume shadow copy service in SP1, and it's breaking things which use to work in <= vista non-sp1.

     

    Thursday, April 10, 2008 2:00 PM
  • Scratch that - our problems seem to be slightly different.

     

    It seems that you are using the wrong version of vssapi.dll - you'll want to get an older version of the DLL, such as from a windows XP CD or windows server CD - simply extract the vssapi.dl_ file from the install sources.

     

    The problem I have (which you may have as well once you do the above) is that the old vssapi.dll file has incompatibilities with the new vss service.

     

    Thanks, microsoft Sad

     

    Thursday, April 10, 2008 2:59 PM
  •  Matronix wrote:
    Those steps worked for me for a machien PRE-SP1 but after I installed SP1 on a machien, those steps will not work anymore.  The error I am getting with the vssapi.dll is:

    The procedure entry point ?Initialize@CVssJetWriter@@QAGJU_GUID@@PBG_N211@Z could not be located in the dynamic link library VSSAPI.dll

    So I think SP1 even broke the manul process of putting ADAM on vista unless I am doing something wrong, but this error message pops up when I try to run adaminstall.exe

     

    Try this

    Monday, October 06, 2008 2:28 PM
  • Thank you Siudyk, copying the dll from XP to the ADAM folder on Vista worked for me!!
    Tuesday, March 10, 2009 5:39 PM
  • If this technique allows the installation of an adam instance, for me with VISTA SP1 up to date with hotfixes, the service crashes after startup. So this is totally unusable. And guess where the crash occurs ? in VSSAPI.DLL.

    I'm afraid that there is no solution to this problem.

    Olivier.
    Wednesday, April 22, 2009 7:34 AM