none
System does not go into Sleep (S3) automatically due to Slide Show gadget.

    Question

  • I noticed my Computer was not going into S3 Standby state automatically after 15 minutes. After using "powercfg -requests" I was able to determine the cause was related to files that were opened from a Share.

    I have my Slide Show gadget setup to open up pictures located on my Windows Home Server > Photos share because that's where I keep all my photos. However, doing this means a file is "opened" over the network and this basically stops Windows 7 from going into a S3 state automatically. I can get it to a S3 sleep state by manually clicking on Sleep though.

    Even with the Multimedia setting set to Allow Sleep, it still does not automatically go into a Sleep state. I do manually put it to sleep when I'm done most of the time. The problem is that Windows Home Server will wake my PC up during the backup time, and run an automatic backup. Which means that my computer ends up being on for most of the day.

    I've since, changed the Photo location on the gadget and disabled it, and rebooted. Now the network share that it was accessing is no longer listed by the command "powercfg -requests".

    I find this rather unfortunate, as I have a lot of photos I've been given in there from my Father and Mother and other sources, and so there are a lot of Photos there that I haven't seen yet. The Slide Show gadget running in the larger mode, was a great way to expose me to the pictures while I was doing other stuff like web surfing etc. If a photo came up that I hadn't seen, I could use the link to open it, and then easily browse through all the photos in that directory.
    Tuesday, October 27, 2009 2:42 PM

All replies

  • It may be the issue of the network adapter driver. You may upgrade the network adapter driver and see the result. If the driver is not for Windows 7 and it does not help on this issue, we may need to wait for new drivers.

    Meantime I suggest that you check if you have allowed the network adapter to awake the system from sleep. Please open Device Manager, expand the branch Network Adapters. Right-click on the network adapter and choose Properties. Click the Power Management tab, and check related settings.

    Please note that if the network adapter driver does not support, the settings will not be able to apply.


    Arthur Xie - MSFT
    Wednesday, October 28, 2009 8:46 AM
    Moderator
  • No, it's not related to the Network Driver. The PC Sleeps fine normally. If I manually put it to sleep, it will only wake up from a Magic Packet or other event (like keyboard or power button) as expected.

    After disabling the gadget, my computer now goes to sleep automatically. If it was an issue with the Network Driver, I wouldn't expect it to be fixed by disabling a gadget.

    EDIT: However, while the gadget is enabled and pointed to a UNC path, such as \\server\Photos\ it will not go into sleep mode at all. I have it set to sleep after 15 minutes, and it won't sleep automatically.
    Wednesday, October 28, 2009 9:13 PM
  • This issue does not occur on our side. I just suspect that your network adapter does not support S3 properly. Therefore you may upgrade the network adapter driver to the latest version. If the issue persists please upgrade the BIOS.

    You can also use the following command to check if the network adapter supports S3 in the current system.

    powercfg -DEVICEQUERY S3_supported


    Arthur Xie - MSFT
    Monday, November 02, 2009 4:13 AM
    Moderator
  • My Adapter supports S3. I just noticed something after further testing. When I run powercfg -requests this is what I get with the gadget running:
    "C:\Windows\system32>powercfg -requests
    DISPLAY:
    None.

    SYSTEM:
    [DRIVER] \FileSystem\rdbss
    A file has been opened across the network. File name: [\SERVER\Photos\House\Thumbs.db] Process ID: [1196]

    AWAYMODE:
    None."

    It looks like if the folder contains a Thumbs.db (the one the Gadget is currently pulling images from) in the shares that's hosing it up. So that might be the reason your not seeing it, if there are no Thumbs.db files on your Photos Share. I'll try removing the Thumbs.db folders from all the Shares and try again.
    Monday, November 02, 2009 5:03 AM
  • Guess that wasn't it. Used my XP PC to delete all Thumbs.db files, since Windows 7 is so awesome it doesn't let me right click a folder or share and Search it... bah.

    Anyhow powercfg -requests now shows .jpg files:
    C:\Windows\system32>powercfg -requests
    DISPLAY:
    None.

    SYSTEM:
    [DRIVER] \FileSystem\srvnet
    An active remote client has recently sent requests to this machine.
    [DRIVER] \FileSystem\rdbss
    A file has been opened across the network. File name: [\SERVER\Photos\House\IMG_0133.JPG] Process ID: [3016]
    [DRIVER] \FileSystem\rdbss
    A file has been opened across the network. File name: [\SERVER\Photos\House\IMG_0134.JPG] Process ID: [3016]

    AWAYMODE:
    None.
    ---------------------------------------------------

    So yeah... again... with the Gadget disabled, S3 STANDBY WORKS FINE.

    The powercfg -devicequery s3_supported brings back my Network adapter, along a multitude of other results. It's a:
    Realtek PCIe GBE Family Controller

    I guess if you can get Standby to happen automatically (AND NOT MANUALLY) with a Realtek NIC, then I'd like to know which driver version you are using and where I can get it from.
    Monday, November 02, 2009 5:20 AM
  • I've got the same issue. Never had this with Vista, but my Windows 7 won't go to sleep if there's a network file open. For me, the gadget is the slide show, viewing photos from my Windows Home Server. Not sure why the files are being opened, and really not sure why it takes forever to get them closed. I found a post at http://thegreenbutton.com/forums/t/75159.aspx?PageIndex=2 that talks about a registry modification to open up a new option in the power settings, allowing the computer to sleep while network files are open. Not sure the ramifications of that choice. I can't imagine it being a good thing.

     

    Sunday, November 08, 2009 5:25 AM
  • I had the same problem which started a few months ago, and had been driving me nuts.  Previously, the power options, including sleep function, worked perfectly.  Note that my Wake on Demand options were active because I do automatic backups and other maintenance at night.  That was not the problem.  The problem, now fixed, was that there had beenban error in my printing to the Adobe PDF printer and several documents were in that print queue.  After cancelling the documents, the sleep functions works as it should. 
    Sunday, April 11, 2010 6:22 PM
  • i have the same problem - i tested each gadget and the slideshow gadget is causing the problem. i have current drives and bios i actually cannot recall when the gadget was not preventing sleep because there was monitor calibration software that was preventing sleep - gadgets were the last thing i turned back on after i got sleep to work right and the s/w removed. agree - unfortunate. will likely resort to a standalone device
    Wednesday, January 26, 2011 9:36 PM
  • I've got the same issue. Never had this with Vista, but my Windows 7 won't go to sleep if there's a network file open. For me, the gadget is the slide show, viewing photos from my Windows Home Server. Not sure why the files are being opened, and really not sure why it takes forever to get them closed. I found a post at http://thegreenbutton.com/forums/t/75159.aspx?PageIndex=2 that talks about a registry modification to open up a new option in the power settings, allowing the computer to sleep while network files are open. Not sure the ramifications of that choice. I can't imagine it being a good thing.

    new link http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/wont-sleep-automatically-with-network-files-open/

    the setting is "allow sleep with remote opens" description: Allow your machine to go to sleep when files opened remotely have not been written to. So presumably the ramifications would be file corruption if your pc was writing to files over the network and went to sleep.

    Ive just set it on mine, will see if it works (am using win 7 media center.)

    • Proposed as answer by Zenon73 Tuesday, March 20, 2012 10:05 AM
    Saturday, February 25, 2012 1:33 PM