none
No DVD Dolby Digital surround sound in media player or media center in Windows 7

    Question

  • I mirrored my working config from my Vista 32 bit install into my Windows 7 64 bit install and a Windows 7 32 bit install, but can't get the Dolby Digital SPDIF coax output to work (just get static) in my Windows 7 install when playing a DVD.

    Notes:

    - Both Vista and Windows 7 are on the same PC, but on different partitions of the same hard drive.

    - standard stereo output works fine in Windows 7

    - Dolby Digital and DTS do work in Windows 7, but only in the Sound config window, not in any program.

    I have the latest Creative Audigy 2 ZS Soundblaster Windows 7 drivers installed (Creative Sound Blaster Audigy series driver 2.18.0011).

    Anyone have any suggestions on how to get the Dolby Digital / DTS output to work Windows 7 when playing a DVD?

    MY PC SPECS:
    CPU : Intel® Pentium® D 820 Processor (Dual-Core)64-bit processor with Intel® EM64T Technology. Each core operates at 2.80GHz | 2 x 1MB L2 cache | 800MHz FSB   
    Chipset : Intel® 945G DH (Viiv™)
    Memory : 2GB DDR2 dual channel, 533MHz (PC4200)
    Friday, July 31, 2009 2:50 PM

Answers

  • I dont believe its a creative issue, i have the same issue with realtek onboard. Devs just don't want to take responsibility for sounds issues in windows7.

    Tuesday, August 04, 2009 7:56 PM
  • Nate,
    You may be right. From what I've been hearing, Windows 7 is basically a cleaned up Windows Vista. DVD Dolby and DTS output work fine in my Vista install on the same machine (different partition, same hard drive). The driver install I downloaded from Creative says it's good for both Vista and Windows 7. Guess we'll just have to wait until the final Windows 7 is released October 22nd to see if that fixes it.
    Tuesday, August 04, 2009 10:52 PM

All replies

  • Hi,

     

    Thank you for posting.

     

    Please try the following to check the S/PDIF device:

     

    1.    Go to “Control Panel\Hardware and Sound” and click “Sound”.

    2.    In the opened dialogue box, switch to the “Playback” tab, right-click on the box listing the current devices, select Show Disabled Devices and see if the item “Digital Audio (S/PDIF)” will appear. If it appears, please enable it and set it as Default Device and see if it works.

     

    Considering the issue is related to the specific hardware, it is also recommended that you contact Creative and see if they have any constructive suggestions.

    Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Monday, August 03, 2009 4:36 AM
  • Thanks for the suggestion, but I already have the S/PDIF device set as the default. Dolby and DTS work in the test tab, but don't work in Media Player or Media Center.
    Tuesday, August 04, 2009 12:07 AM
  • Hi,

     

    Thank you for your update.

     

    Please right-click on the “Digital Audio (S/PDIF)” device and choose properties. Go to Advanced tab and check the two items under Exclusive Mode. Meanwhile, you may also check other properties of this device.

     

    Thanks.


    Nicholas Li - MSFT
    Tuesday, August 04, 2009 3:06 AM
  • The two items under Exclusive Mode are already checked.

    I unchecked them and retested. I'm now getting a 2.1 output (front left, right, and sub) though my receiver thinks the input is standard PCM 48KHZ. At least it's not static now.

    I then disabled the "Speaker" device and rebooted just to see if that would help at all. No such luck.

    I'm guessing it's Creative Labs issue that they need to fix in their next driver release.

    Thanks anyways.
    Tuesday, August 04, 2009 4:53 PM
  • I dont believe its a creative issue, i have the same issue with realtek onboard. Devs just don't want to take responsibility for sounds issues in windows7.

    Tuesday, August 04, 2009 7:56 PM
  • Nate,
    You may be right. From what I've been hearing, Windows 7 is basically a cleaned up Windows Vista. DVD Dolby and DTS output work fine in my Vista install on the same machine (different partition, same hard drive). The driver install I downloaded from Creative says it's good for both Vista and Windows 7. Guess we'll just have to wait until the final Windows 7 is released October 22nd to see if that fixes it.
    Tuesday, August 04, 2009 10:52 PM
  • Installed released version of Windows 7 home premium 32 bit and still the same issue, however I found this on the Creative Labs support page in regards to a Creative Audigy 2 ZS Soundblaster beta driver posted on Oct 1 2009:

    "Known Issues: Driver decoding and passthrough of Dolby®/DTS® audio does not work with Windows Media Player 12 in Windows 7. As a workaround, use a 3rd party software media player to playback DVDs."

    I tried some popular free 3rd party players (VLC, KMPlayer, Dvix) and none of them outputted 5.1 sound either.

    I then installed a trial version of Cyberlink PowerDVD 9 and now it works!! Of course Cyberlink wants $60-90 for the full version (not going to happen).

    At least I showed I can get 5.1 output in Windows 7 with my hardware.

    Now I just need Creative Labs and Microsoft to get together and work on a Windows Media Center and Windows Media Player fix so I don't have to fork out more money for something that should have worked right from the start!
    • Proposed as answer by Wee Todd Didd Wednesday, November 04, 2009 8:49 PM
    Friday, October 23, 2009 6:30 PM
  • This is what I've run into as well setting up a new HTPC.

    Win 7 x64 home premium RTM.

    Using the HDMI out of the video card to a 7.1 reciever, only using 5.1. 

    Configured Windows sound to use the HDMI out on the video card, configured speakers in the control panel sounds for 5.1
    The test for the speakers works correctly for all speakers and sub.

    Both Windows Media Player 32 and 64 bit versions play DVD's correctly with 5.1, receiver shows Dolby D.

    Windows Media Center is where the problem comes in.
    If I play a DVD in WMC the video gets choppy and crashes with an error of missing / problem  video drivers or codecs.  Should not be a problem because both WMP versions work correctly.

    WMC is defaulted to 2 channel speakers, and everything out of it is in all channels stereo.
    If I change the speakers settings to 5.1 and test, it only plays sound out of the left front speaker.  At this point it does not matter if I select pass or fail to the test, WMC no longer plays sounds until I close and reopen.  Speakers reset to 2 channel.
    If I change speakers to 7.1, there is no test option and there is no longer any sound unless I restart WMC.  Speakers reset to 2 channel.

    To get things working I had to set the speakers to 7.1 in the control panel. I disabled the missing L/R side speakers.
    Now I can set WMC to 5.1 or 7.1 and sound does work.  Receiver shows Dolby digital instead of stereo.
    DVD's now also play instead of crashing in Media Center.

    Beats me what is going on here, but this seems to have solved it for now.

    Now if I can only get Media Player to stop randomly loosing album art, another seemingly common complaint...



    Wednesday, November 04, 2009 9:16 PM
  • Exact same thing here. Windows 7 RC1, Creative Audigy 2 Platinum w/Audigy Drive. Using coax or optical SPDIF.

    Control Panel sound test outputs DTS and Dolby Digital fine. PowerDVD has setting for SPDIF passthrough which works fine.

    However, Media Center SPDIF passthrough will not work. It appears to be sending PCM audio. I have tried every setting in Media Center: analog 2 and 5.1 speakers as well as digital 2 and 5.1 speakers. Nothing will get this working. I have also tired using the Media Center codec changer and setting it to use FFDshow, but that didn't work either.

    My best guess is that Media Center is missing a setting to enable SPDIF passthrough for DD and DTS. Help me Microsoft.
    Wednesday, November 25, 2009 7:19 PM
  • Same here; brand new (built it Thursday) HTPC system runnning Windows 7 32, Gigabyte MB, Realtek LG Blue Ray Drive, SPDIF Out and Cyberlink 7. 

    When I test Dolby and dts through Win 7 Digital Output Test, my receiver recognizes the signal (as Dolby or dts) but sound only comes through my two front speakers (and subwoofer).  Under Digital Output Test/Advanced/Default Formt the only options are for two channels.  It seems I can't get anything but 2.1 no matter what I do. 

    I read elsewhere that the problem was with Cyberlik software and all I had to do was upgrade the software to Cyberlink 9 but now I am not so sure.
    Sunday, November 29, 2009 1:49 AM
  • in media center under setting for dvd audio turn of auto voulume. seem to fix it for me.
    • Proposed as answer by gmgj Thursday, March 18, 2010 12:59 PM
    Friday, December 25, 2009 2:03 AM
  • Turning "auto volume" off worked for me, thanks for the solutions.
    Saturday, January 02, 2010 12:39 AM

  • Changing DVD auto volume to off worked for me.  I want to thank all the posters who discovered and replied on this stupid glitch.  

    old guy
    Thursday, March 18, 2010 1:06 PM
  • Hello

    I had the same problem with DVD AUDIO (video works ok), on Windows 7 Ultimate x64

    This was my solution (Windows 7 Ultimate x64):

    In the notification area (right-hand side of the taskbar) right ckick on the "Volume" icon.

    Select "Playback Devices" ... This should open the "Playback" tab (default).

    For MY setup the default device was SPDIF (Optical out)

    Highlight your default device then click on the "Properties" Tab below it.

    Select the "Supported Formats" tab.

    OK... In the "Encoded Formats" box, un-tick... DTS Audio, Dolby Digital & Microsoft WMA Pro Audio.

    Then click ok.

    Restart your dvd with wmp 12, and this should work... it has for me

    Note: my sample rates are checked for 44.1 & 48.0kHz

             I am using Creative Inspire 5500 5.1 speakers via optical out

     

    Sunday, March 21, 2010 7:23 PM
  • Hi phlux85,

    I tried to follow your steps to solve my similar issue.  I got up to the par tthat says Select the "Supported Formats" tab then I got lost.  My system does not have that part.  Perhaps something is missing.

     

    Any suggestions?

     

    Thanks

    Thursday, February 03, 2011 1:17 PM
  • Thanks so much dude! I was going nuts with the exact same problem with my WMC, even switched to XBMC over this very issue. After your trick to set the speaker config as 7.1 but disable rear speakers, did the trick with WMC. Seems like a sloppy bug in WMC's multi-channel, digital audio format support. Kind of sad that Windows is treating DTS/Dolby audio support as 3rd class citizen, it is such an integral part of home theater experience - beats me why they won't make this brian dead simple in WMC
    Monday, February 14, 2011 12:59 AM