none
Multiple Desktop Folders ... Creating

    Question

  •  

    I'm having some trouble with Windows Vista. A problem has occured where multiple desktop folders are being constantly created and I don't why it's happening or what's causing it. When I click the extra the folders, they're empty and I have to keep clicking them to get to the actual desktop folder. I also cannot delete the extra empty folders...eek! Much help would be greatly appreciated.
    Sunday, September 28, 2008 7:17 AM

Answers

All replies

  • Could you let me know the names of the folders?

    Meanwhile, as the issue can be virus related, I suggest you try a free online virus scan on the following site:

    http://safety.live.com

    Meanwhile, if you need more help with virus-related issues, please contact Microsoft Product Support Services.

    For information about Security updates, visit the Microsoft Virus Solution and Security Center for resources and tools to keep your PC safe and healthy. If you are having issues with installing the update itself, visit Support for Microsoft Update for resources and tools to keep your PC updated with the latest updates.

    Monday, September 29, 2008 8:39 AM
  •  mrimpact wrote:

     

    I'm having some trouble with Windows Vista. A problem has occured where multiple desktop folders are being constantly created and I don't why it's happening or what's causing it. When I click the extra the folders, they're empty and I have to keep clicking them to get to the actual desktop folder. I also cannot delete the extra empty folders...eek! Much help would be greatly appreciated.

     

    I'm experimenting the same problem on a friend's computer. The duplicated folder is the "Immagini" one (it's an italian Windows Vista Home version running on a laptop, it should be the "Images"or "Pictures" folder). I've already tried with an online scan, but with no help.

     

    Any clue?

    Friday, October 10, 2008 1:48 PM
  • I had this same issue the earlier in this week and looked around various newsgroups for some help. The best indication of the underlying cause can be found in the following:

     

    Problems After You Create a Folder That Is Named "Desktop" on the Desktop in Windows XP
    »support.microsoft.com/kb/q323681/

     

    In my case I may have inadvertantly created a new desktop folder when I was trying to relocate some icons on my desktop - I really can't be sure. The result was that I ended up with a nested desktop folder of the form C:\Users\username\Documents\Desktop\Desktop, a desktop folder icon (slate-colored) located in C:\Users\username, and a folder called C:\Users\username\Desktop that contained all my original desktop items. If I right-clicked on the desktop folder icon and looked at properties, the location it pointed to was C:\Users\username\Documents\Desktop\Desktop. I copied all my desktop items out of C:\Users\username\Desktop and put them in C:\Users\username\Documents\Desktop\Desktop, and after that, my desktop screen looked normal.

     

    After looking at more posts, I finally arrived at the following prescription to get things back to normal:

    1. Right-click on the desktop folder icon under C:\Users\username and select "Properties"
    2. Select the Location tab and confirm that it is now pointing to C:\Users\username\Documents\Desktop\Desktop
    3. Click the Restore Default button
    4. When prompted, confirm that you want to move the contents of the old location to the new location (note that you only want to do this if the old location does indeed contain your desktop items)
    5. Confirm that your desktop looks correct, C:\Users\username\Desktop contains your desktop items, and C:\Users\username\Documents\Desktop\Desktop is empty.
    6. Restart your computer in Safe Mode with command prompt (restart and hit F8 frequently during rebooting to get the option)
    7. Once logged in, use the command prompt to navigate down and delete C:\Users\username\Documents\Desktop\Desktop and C:\Users\username\Documents\Desktop from your folder tree - I was not able to do this without going into Safe Mode, probably becasue the OS was confused about the identity of the Desktop folder.
    8. Restart your computer in normal mode and you should be back to normal.

    Good luck!

     

    Thursday, October 16, 2008 12:34 AM
  • I use Windows Vista and today had the same problem. Been trying to sort it all day. If I put anything on the desktop now the location is C:\Users\User\Desktop\Desktop\Desktop. Its driving me mad!!

    When I tried to restore an item from the recycle bin it went to C:\Users\User\Desktop so didnt appear on the desktop. To see it I had to put it in C:\Users\User\Desktop\Desktop\Desktop

    Anyone find an easy solution, preferably without going into safe mode?

     

     

    Monday, October 27, 2008 7:25 PM
  • The solution to this is simple, all you need to do is find your final 'desktop' folder in your list C:\Users\User\Desktop\Desktop\Desktop (i.e. the bold one) and right click then select 'Properties'. Now select 'Location' and rename is so that it says C:\Users\User\Desktop2 and click 'OK'.
    Note when I did this I could not see it names as 'Desktop2', it remained as 'Desktop', but it can be distinguished by the fact that there is not another folder within.
    Now you should be able to delete the duplicated
    'Desktop\Desktop' folders C:\Users\User\Desktop\Desktop (in bold).
    Now right click on the remaining 'Desktop', select 'Properties' then 'Location'. Now click 'Default' and it should be renamed correctly and you should only have one folder named 'Desktop'.
    This is the only method I am aware of other than a system restore that will fix this problem.
    Friday, October 31, 2008 6:06 PM
  • Many thanks  Guineagoddess I have followed your suggestion and have it almost back as it should be. My desktop is now C:\Users\User\Desktop

    I do have one remaining problem that I cant resolve though. On my desktop screen I now have a folder called Desktop that contains a folder called Desktop. The Desktop folder is empty. I can't delete these as it says The action cannot be completed because the folder is open in another programme. So I still have C:\Users\User\Desktop\Desktop\Desktop.

    Thanks again for your help. Much appretiated.

    Sunday, November 02, 2008 5:45 PM
  • This was great information!!!  I made this mistake today somehow and when I noticed it I was about to pull my hair out you got it right the first time and it was so ez thanks!!!

     

    Saturday, November 29, 2008 2:43 AM
  • I am on Vista, and I went to apply your solution, but do not get the "Location" option; the only options (tabs) I have under properties are General, Sharing, Security and Customize. I noticed that there are Desktop, Desktop2, Desktop3 icons, all with multiple "drill downs" of other Desktop icons. I am at a loss how to restore all this to the default. Can anyone help?
    Wednesday, February 22, 2012 12:43 AM
  • After viewing about 10 different replicated Desktop folders, I did find the "LOCATION" tab under Desktop2 Properties. When I attempted the action as instructed above, I received the following error: "Cannot redirect decendent to parent. The specified path is invalid." It is trying to send it to C:\Users\FREEHRT\Desktop. It currently shows as its location C:\Users\FREEHRT\Desktop\Desktop.

    Any ideas?

    Wednesday, February 22, 2012 12:54 AM