none
How do I remove padlock icon from all my files?

    Question

  • On one of my drives, every single file has a little padlock icon superimposed over the file icon. I recall when I did a clean install of windows 7 RC over my Vista install, I wasn't getting write access to the drive so I had to take ownership of the drive and mess with the security settings before it started working normally.

    I have to admit, I find the security settings in all versions of NT mystifying... For instance, although my account is in the administrators group, having full access to administrators never seems to work. I always have to add my individual user account and explicitly give it full access.

    In any case, I can't remember exactly what it took, but after messing around with the security settings for a while, I eventually was able to have full access to the drive and have no problems reading/writing/deleting files and folders, but there's the padlock icon still on everything.

    Can anyone explain how to get rid of it, and/or maybe point me to a good, clear, understandable guide on how to properly set NTFS permissions.

    Thanks!
    Tuesday, July 21, 2009 2:26 PM

Answers

All replies

  • Hi,

    This is a new feature of Windows 7 RC. If a folder's ownership is SYSTEM, the icon would be appears.

    To remove the icon, please change the ownership of the folders. You may refer the following website.

    Change the permissions and take ownership of your files and folders  Windows Vista for Beginners 

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.


    Arthur Xie - MSFT
    Thursday, July 23, 2009 7:57 AM
    Moderator
  • Hi,

    This is a new feature of Windows 7 RC. If a folder's ownership is SYSTEM, the icon would be appears.

    To remove the icon, please change the ownership of the folders. You may refer the following website.

    Change the permissions and take ownership of your files and folders  Windows Vista for Beginners  

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.


    Arthur Xie - MSFT

    Thanks for the link. I followed the directions but:
    • I was already the owner
    • I re-applied ownership exactly as described but strangely, the icons are gone for subfolders, but all the files/folders in the root folder of the drive still have the icon no matter what I do...
    Thanks.
    Thursday, July 23, 2009 9:35 AM
  • Hi,

    Please change the ownership of the folder. During the process, you may pay attention that a check box on the bottom of the window. Please check it. The box is "Replace owner for subcontainers and objects".


    Arthur Xie - MSFT
    Friday, July 24, 2009 10:01 AM
    Moderator
  • Hi,

    Please change the ownership of the folder. During the process, you may pay attention that a check box on the bottom of the window. Please check it. The box is "Replace owner for subcontainers and objects".


    Arthur Xie - MSFT
    Hi again,

    I did make sure that box was checked but it didn't seem to help. I also have to take back what I said, it's not just in the root folder that I see the padlock icon. It's a number of folders, some have it, some don't. I'm not sure what the pattern is...

    Do I need to change the owner to something other than myself then change it back? Or is this maybe a bug in the RC and I should just wait for the final version to come out?

    Thanks.
    • Proposed as answer by Alekki Saturday, January 25, 2014 12:32 PM
    Friday, July 24, 2009 10:23 AM
  • It is a good idea. Please try that.


    Arthur Xie - MSFT
    Tuesday, July 28, 2009 4:03 AM
    Moderator
  • Actually, I tried that but it didn't work. I'm still seeing the padlock icon on most of the files and folders on that drive. I just can't figure it out. It doesn't really affect anything functionaly but it's a bit annoying and makes it harder to identify filetypes visually by icon...
    Thursday, August 06, 2009 10:45 AM
  • I think I've just found a sol'n. You need to go into the top-level folder's Properties, Security, Advanced, Change Permissions, then check the box "Replace all child object permissions with inheritable permissions from this object".

    • Proposed as answer by mr-b Thursday, August 06, 2009 1:23 PM
    Thursday, August 06, 2009 1:23 PM
  • There doesn't seem to be any logical reason for SYSTEM to have, for example, a file for Favorites. Nor Documents. Nor any of those files with the padlock, since those folders are really for individual users. Surprise: you can't open them but you can delete them!

    Which I did and am waiting to see if the shoe drops. So far the only effect seems to be a cleaner file system.

    No idea why SYSTEM needs user-type files.... Any insights here?
    Monday, December 14, 2009 5:21 PM
  • I have the same issue, I think this is a win 7 feature, and have been unable to find a workaround. I can understand microsoft disabling the average user from accessing certain files, but there should be a way to turn it off for experienced users. We should be allowed full access to our pc's if we want it.
    Wednesday, December 16, 2009 6:40 AM
  • I had the padlock on a folder after trying to share it with the Homegroup feature. Apparenlty if you remove the HomeUser group from having Read & Execute permission to a folder the lock overlay will appear

    And I found this fix on another forum so I will include it here. It sorted me out ok.

    You can remove the lock overlay in this case by resetting the permissions to be inherited, and removing all permissions that are not inherited.
    Right click the folder, click Properties
    Click the Security tab
    Click Advanced
    Click Change Permissions
    Check Both boxes to Include inheritable permissions, and to Replace all child object permissions
    Click Apply then click Yes
    Wait for the list to refresh
    Remove all permissions that say <not inherited>

    That should remove the Lock overlay.
    You may need to Uncheck Use Sharing Wizard in  | Folder Options | View tab to see the Security tab, and may have to boot to Safe Mode as well if running Home Basic or Premium.
    • Proposed as answer by khan4 Wednesday, January 13, 2010 11:00 AM
    Wednesday, December 23, 2009 10:15 PM
  • I've tried this but it says I am not the owner, when I try to take owenership, I receive unable to find file specified. Any ideas?
    Saturday, January 09, 2010 6:40 PM
  • I have posted a question very similar to your last response.
    Thursday, January 14, 2010 11:50 AM
  • The padlock icon appears over files that are private, that is to say that they are only visible by you. My storage drive's permissions have three entries (SYSTEM, Users, and Administrators) and I see no padlocks. Setting your permissions similar to those should solve your problem.

    No idea why SYSTEM needs user-type files.... Any insights here?
    Drive defragmentation, for one. I think there is more but I'm drawing blanks.
    Sunday, January 17, 2010 10:26 AM
  • The only reason the padlock is there is because you are not sharing the folder with anyone.
    If you are not on a network then don't let it worry you but if you are on a network it is so easy to just right click the folder scroll down to "share with" and "hey presto" share it. and the silly padlock is gone.

    Monday, January 25, 2010 8:46 PM
  • I had this exact problem, and I managed to fix it...finally.

    First I took ownership of the whole drive, and used my username directly - I ticked the box mentioned above and applied it to all items.

    But this didn't work, the padlocks were still there. I checked out the permissions of another drive, and I saw the group Authenticated users, this wasn't showing on my problem drive, so I went back to the security tab, created a new permission group and added Authenticated users - again checking the box to apply to all subfolders. Worked like a dream!

    Hope this helps.

    peace
    • Proposed as answer by Perplexer Sunday, March 14, 2010 12:52 AM
    Saturday, January 30, 2010 7:10 PM
  • I had this exact problem, and I managed to fix it...finally.

    First I took ownership of the whole drive, and used my username directly - I ticked the box mentioned above and applied it to all items.

    But this didn't work, the padlocks were still there. I checked out the permissions of another drive, and I saw the group Authenticated users, this wasn't showing on my problem drive, so I went back to the security tab, created a new permission group and added Authenticated users - again checking the box to apply to all subfolders. Worked like a dream!

    Hope this helps.

    peace

    Yep, this is what I have come to in my research as well. The "Authenticated Users" group disappears from the "Security" tab if you remove a user from the window under the "Sharing..." button in Properties -> Sharing tab. The padlock remains even if you completely unshare the folder by unticking the "Share this folder" option in "Advanced Sharing...". Restoring the "Authenticated users" group solves the problem.

    Also, in Windows 7, if you add a user under "Sharing..." it does not get copied to the "Advanced Sharing..." section, and vice versa, as it does in Vista.
    If you remove a user from "Sharing..." button (and with that lose the "Authenticated Users" under Security tab) then the "Advanced Sharing..." button and everything related to that will not work at all.

    This seems to be some sort of a bug in Windows 7 file sharing.
    Sunday, March 14, 2010 12:57 AM
  • Right click upon the folders and go down to share, in the sidebar click homegroup (read/write) should sort it out, just give it 5 seconds to refresh. i had this problem n just figured it out, no idea if someone has told you this already, i cant be bothered checking haha.
    Sunday, May 02, 2010 3:50 PM
  • You need to get rid of all groups then add the group authenticated users and add yourself and admins and assign full control to all groups
    Thursday, June 10, 2010 10:21 PM
  • Granting permissions to the Authenticated Users group can be a security risk if you have IIS services installed.  If so, when someone accesses your web page or FTP site anonymously, the anonymous Internet user account IUSR is automatically added to the Authenticated Users group.  This is a potential hole through which they might be able to gain access to your system.

    Dave Kelly
    Tuesday, June 15, 2010 7:23 AM
  • Well, now!   Not only did/do I have a similar problem but the link above - http://www.vista4beginners.com/Change-permissions-take-ownership gives a very succinct method of eliminating this problem...............but............it doesn't appear to work!

    On one computer upgraded from Vista HP to Windows 7 HP I have three folders which have padlocks on them.    I have no difficulty in opening those folders named $INPLACE.~TR, WINDOWS.~Q  and  MSOcache and accessing all files within them.

    On my other computer upgraded from Windows XP Pro with a clean install of Windows 7 Pro I have two drives with a different OS on each and in both cases my Documents and Settings folders had a padlock on them.   Following various instructions within this forum did not resolve the problem since every avenue attempted was met with a dialogue stating the obvious........"access denied"..........so nothing could be changed in spite of having various "users" listed.

    Following the instructions in the link given was instrumental in removing the padlocks in each case but only at the expense of each respective folder also disappearing!   So!   Now my problem  is that although the folders are missing there is a shortcut showing in each but clicking on the shortcut now brings up the message "Documents and Settings is not available.   Access denied"

    It would appear to me that Windows 7 of any flavour is merely a botched "upgrade"? of the useless old Vista package but with more problems.   If Microsoft were really interested in making an error-free OS then this stupid "glitch" not only would not have occurred but since it did, would have been obviated much more promptly than it has.  Still, I suppose when one is making obscene profits from expensive rubbish nothing else is really of interest is it?

    Sunday, August 15, 2010 2:10 AM
  • In case anybody comes across this thread and has the same problems, here is the solution.

    None of the above theories worked for me. Access Denied messages occurred even while trying to take ownership with elevation. What could easily be done in XP took some figuring out in Win7.

    To fix this issue, Enable the administrator account, login and change the permissions e.g. Everyone, Authenticated Users - Full Control. All of the padlocks disappeared and allowed changes in ownership and permissions.

     

    • Proposed as answer by alfordw Tuesday, January 18, 2011 1:25 AM
    Friday, November 12, 2010 2:59 AM
  • In case anybody comes across this thread and has the same problems, here is the solution.

    None of the above theories worked for me. Access Denied messages occurred even while trying to take ownership with elevation. What could easily be done in XP took some figuring out in Win7.

    To fix this issue, Enable the administrator account, login and change the permissions e.g. Everyone, Authenticated Users - Full Control. All of the padlocks disappeared and allowed changes in ownership and permissions.

     

     

    Oh, yes, it's "The Solution" is it? Well it didn't work for me, so it can't be so wonderful, can it?

    Windows 7 tells me I'm the owner of my Documents and Settings folder, and I've got "Full Control", but it won't let me access it. How sensible is that? I had a red padlock, now I've got a blue arrow (indicating a shortcut?), but I still can't access it. When I log in as another user, the folder doesn't even appear in explorer!

    Can anyone suggest a decent reason why I shouldn't just go back to xp? Anyone from Microsoft reading this?

    Saturday, January 08, 2011 2:09 AM
  • You need to login as Administrator to make these changes. An account with administrator equivalence does not seem to work.

    I can empathise with your frustration, but once you accept the new way the world is going with Win7 things become a lot calmer.

    Now where's my soothing WinXP virtual PC gone to?

    Wednesday, January 12, 2011 2:06 AM
  • After 3 hours of searching the Internet, trying everything I could find, this was the only thing that worked.  Thank you!  I had music files scattered across my mp3 collection with no apparent connection between why some were locked and some weren't.  Winamp and Windows Media Player would not play them.  This fixed the problem completely.  I suspect that when you try to reassign rights when some files are locked and some aren't, Windows will not prompt you during the process to give Admin permission, instead it just gives a warning message.  Using the full Administrator login solves this problem because UAC is not present in any way.
    Tuesday, January 18, 2011 3:50 AM
  • I'm using Win 7 Pro. Open the gold lock file, go to the file icon (far left), then  click on share,  then click on  share with home group everyone read-write. It worked for me, hope it works for you.
    Friday, January 21, 2011 11:40 PM
  • If you right click the file with the padlock, and look under the 'Share With' option, the problem solution will become clear. The file is not shared, and that's why it's 'locked'. It has nothing to do with ownership, it's a share issue.
    • Proposed as answer by BikeAmTn Friday, February 04, 2011 1:19 PM
    Saturday, January 22, 2011 10:11 AM
  • <form id="aspnetForm" action="edit" enctype="application/x-www-form-urlencoded" method="post">
    <input id="__VIEWSTATE" name="__VIEWSTATE" type="hidden" value="/wEPDwULLTEzNzk0MzkwMDlkZD6SorGRLWx4w+alHb7GRMyulXR+" />
    </form>
    Resources for IT Professionals
     
    <form action="/Forums/en/w7itprosecurity/thread/16474fcf-688b-4eae-88f4-804306bafc0f/a9d3326a-9af4-4d81-9f6e-0df9575b4fea/edit" enctype="application/x-www-form-urlencoded" method="post">

    Edit Message

    <textarea cols="100" rows="20" name="body"><blockquote> <p>Hi,</p> <p>This is a new feature of Windows 7 RC. If a folder's ownership is SYSTEM, the icon would be appears.</p> <p>To remove the icon, please change the ownership of the folders. You may refer the following website.</p> <p><a href="http://www.vista4beginners.com/Change-permissions-take-ownership">Change the permissions and take ownership of your files and folders&nbsp; Windows Vista for Beginners</a>&nbsp;</p> <p>Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.</p> <hr> Arthur Xie - MSFT</blockquote> <p>You may call this a feature but I call it rediculous. The security and ownership system deployed in win 7 is beyond belief and horribly BAD!</p> <p>I have files which have disappeared from view under start / all programs which are clearly on my system. They can be seen by an administrator only account but not by a users acccount which has administrator privs. That really makes great since!</p> &nbsp;Returning to Win XP looks like a good option to me. Anyone who changes the ownership of an entire drive is asking for latent problems when various areas within windows needs ownership of SYSTEM or Trustedinstaller and others which were overwritten with the change.</textarea>
    <label for="hasCode">Resource.HasCodeLabel</label><input name="hasCode" type="checkbox" value="true" /> <label for="reason">Reason</label><input name="reason" type="text" />
    <input title="Submit" type="submit" value="Submit" />
    </form>
    <script type="text/javascript"></script> <script type="text/javascript"></script> <script type="text/javascript"></script> <noscript></noscript> <noscript></noscript> This forum even has bugs! look at this mess.
    • Proposed as answer by ML Howard Saturday, January 22, 2011 10:05 PM
    Saturday, January 22, 2011 10:05 PM
  • I would agree; it has to do with ‘Sharing’. Depending on where the file originated and/or where it was transferred/copied/saved to, it will need to have it’s ‘Shared’ properties changed if you wish ‘EVERYONE’ to access it (let’s say; in the Pubic folder). If your going to start changing Permissions (for files/folders), then your maybe heading for trouble down the road.
    Friday, February 04, 2011 1:17 PM
  • Tried that as I am trying to share with my network and all of the fixes mentioned here I have tried and the only way I find I can share is to move the pictures to the public folder.  I wish someone more computer savy than me would figure a workaround this for me.
    Monday, April 25, 2011 10:29 PM
  • Do you know what the locked files were?

    The files were files that could not be written to c:\program Files and were instead written to a subdir within %userprofile%\appdata\local\virtualstore.

    I only found that out two weeks ago! Do a search for virtualstore to find out what it is used for! XMLTVGUI is a prime example of using this virtualstore, but still showing the files in c:\program Files for other apps like TVG.

     

    Jeez Microsoft, why not just link the damn files instead of locking them?



    Tuesday, May 10, 2011 12:31 PM
  • mr-b you are awesome that worked for me I tried all of the other jazz on this forum and nothing was working!! thank you for posting!
    Saturday, May 14, 2011 1:37 PM
  • I would agree; it has to do with ‘Sharing’. Depending on where the file originated and/or where it was transferred/copied/saved to, it will need to have it’s ‘Shared’ properties changed if you wish ‘EVERYONE’ to access it (let’s say; in the Pubic folder). If your going to start changing Permissions (for files/folders), then your maybe heading for trouble down the road.


    I disagree - no matter what I do with "right click" then "sharing" or whom I then try to share with - it does NOT remove the padlock or allow me to access C:/documents and settings. I agree - what was MS thinking? The concept of one Administrator with password access to change ANYTHING, and a bunch of other "users" with varying permissions is a guaranteed recipe for disaster. This should have been fixed ages ago, but I suspect that in order to do so MS would have had to junk Win7 and start all over - obviously not practical. So I guess we all have to suffer until things change.

    And who was the brilliant soul who posted an answer in HTML? I'd rather have an honest answer from MS indicating they goofed rather than have to spend HOURS and HOURS trying to fix something that -= at least for some of us - simply is NOT fixable

    MS ARE YOU LISTENING? ANYONE HONEST AT MS TO EXPLAIN - BUT NOT IN "TECHSPEAK" - WHAT IS GOING ON? GUESS I WON'T HOLD MY BREATH... 

    Where  is good ol' XP when you need something easy to use and relatively reliable? With Win7 MS has invented a disaster!

    Friday, August 12, 2011 5:58 PM
  • There are a number of issues being blurred in this thread, although the padlock suggests that this is a sharing issue, it isn't, it is an OWNERSHIP issue.  You do not own the folder and its contents, this is NOT the same as whatever permissions you think you have.

    I am using a Windows 7 Professional laptop on a company domain, so yours may differ.  I am the domain Administrator and my personal username is in the machines Administrators group.  Please ensure you are a member of the machines Administrators group.

    Right click on the folder

    Choose Properties

    Choose Security

    Choose Advanced

    Choose Owner

    Choose Edit

    Select Administrators (MACHINENAME\Administrators) from the list and check the box Replace Owner on Subcontainers and Objects

    Click Yes to confirm that you want to take ownership

    Click OK to acknowledge the message

    Click OK and OK to close the permissions windows, you must close all of the permissions windows

    The Administrators group is now the owner of that folder and everything within it and has been granted permissions too.  You can now do what you want with that folder and its contents.

    Hope that helps somebody.

     

     

     

     


    Wednesday, August 31, 2011 12:00 PM
  • Here's my contribution. This worked for me - Again, YMMV

    This is Win 7 64 bit on a Workgroup.

    Select the folder with the padlock and rt-click, properties, security, advanced.

    Note that 'Inherited from' displays 'Not Inherited' (Usually displays Inherited from C:\)

    Click 'change Permissions'

    Check 'Include inheritable permissions from this object's parent'

    Click Apply

    In other words the padlock was indicating that the folder was outside the inherited permissions structure?

     

    Likewise, HTH someone

    Wednesday, August 31, 2011 5:29 PM
  • this is a really stupid problem to have.  I just got my win 7 laptop and all was fine.  Then suddenly I'm locked out of my music, my pictures, and my videos folders.  Locked out and unable to access any files in them.  Enabling both types of inheritance under security fixed it.  Makes no sense that it works fine one day and then the next I'm locked out.
    jp
    Tuesday, September 20, 2011 3:24 AM
  • Amen, jpeternel!

    Single user on a home network here, padlocks all over my pics, unable to modify a Word document I just created. Clunky workarounds to unlock every file and image. Just when we thought it was safe to trust Microsoft after Vista... now this.

    Better be solved in Windows next revision or it's off to Apple for me. I've had enough of this nonsense.

    Monday, November 14, 2011 5:01 AM
  • Simon_T, your solution worked perfectly!! I can't thank you enough.
    Saturday, November 26, 2011 2:32 AM
  • hi, yes perfect worked, I used for mac driver
    Thursday, December 22, 2011 9:13 PM
  • Try this little jewel,

    http://www.vistax64.com/tutorials/112795-context-menu-take-ownership.html

     

    Also go to share settings and check all of the boxes for the folder, mucic.....
    • Edited by ThrashZone Friday, December 23, 2011 4:41 PM
    Friday, December 23, 2011 4:36 PM
  • I think your probelm is the same as mine; you must have made a change to the icon on the folder & checked "include all subfolders." Does this sound like its possible? If so, I too am hoping somone can tell me how to undo this icon from my subfolders. I tried restore & all that- it didnt work :-(  Its confusing having so many folders with the same icon on it! HELP!!
    Monday, February 13, 2012 6:58 PM
  • Thanks Hawkeye3813                                                                                                                                "share it" with Nobody.                                                                                                                        This is the best and easiest way to get rid of all (pad)-locks.


    • Edited by 910Naygu Monday, July 09, 2012 10:41 AM
    Monday, July 09, 2012 10:38 AM
  • perfect ! It worked for me...
    Thursday, August 02, 2012 6:21 PM
  • Thanks, this worked perfect for all files & sub folders on my desktop.

    (widows 7 Ultimate x32bit).

    Wednesday, November 07, 2012 1:38 AM
  • I discovered an easier step...

    First select the group of files with the padlock (Windows 7 x 64 bit)

    Then go To Share With

    Specific People

    Type---> Everyone

    Add

    Share

    Then All the padlocks are removed and a last screen with this notification "your files are share", and finally touch "Done" icon


    Friday, December 28, 2012 10:28 PM
  • I had this problem too. It is nothing to do with windows.  On your imac, on top it shows  eg: File, Edit, View, History, Bookmarks etc.

    Just click on File and  it will show Get INFO, unlock box shared and lock, than every thing is unlock in your folders.

    Tuesday, May 14, 2013 4:47 AM
  • Regarding the earlier problem on a PC with the little padlock that appears. I noted in the Security tab of the file/folder that "Authenticated Users" was missing from the file/folder for some reason. All I did was add in "Authenticated Users" and it moved this permission back to the top of the security tab and removed the gold padlock. Im sure there are other ways but this was what worked for me in Windows 7.
    Thursday, July 04, 2013 5:04 AM
  • Dozens and dozens of answers and no one has a solution.  

    I spend a couple hours a week trying to solve one problem or the other caused by this crap company.  Usually I don't even look at the Microsoft forum answers because more often than not, they are so ridiculous -- like this one -- it's a complete waste.  Maybe I should consider someone didn't suggest re-installing Windows, that seems to be a favorite.


    Wednesday, January 29, 2014 1:57 AM
  • I had the same problem and, as usual the Microsoft folks acted as if they had no idea what I was talking about ... "Hey, I think you need to re-install Windows"

    Anyway, I went elsewhere and found this solution which worked quite well for me.

    cut and paste

    http://www.howtogeek.com/howto/17117/remove-the-lock-icon-from-a-folder-in-windows-7/


    Wednesday, January 29, 2014 2:13 AM