none
how to delete file association with an unwanted program (i don't want it associate with any program?)

    Question

  • in Win XP or earlier, we can change / delete file association in File type of "Folder Option".
     
    but found disappeared since Vista.

    Can anyone tell me where to find the same function?

    thanks
    lolojack
    Monday, March 23, 2009 1:29 PM

Answers

All replies

  • P.S.

    I know how to change file asso. with only right click, my question is how to delete??
    i want to make the file type totally without any program asso. with it ..... (like .dat)

    thanks
    lolojack
    Monday, March 23, 2009 2:18 PM
  • Hi,

    This cannot be done directly in Windows, but... there are alternatives like
    http://www.winhelponline.com/downloadattachment.php?aId=9f390841cdbe0c2457898179b80dfce0&articleId=231

    or

    http://www.creativelement.com/powertools/#download

    As far as I know they are freeware allowing some things Vista did not allow. I haven't tested them myself, but they may be useful for you.

    Regards

    Rem
    Monday, March 23, 2009 2:48 PM
  • I take ".dat" for example.
    Go to HKEY_CLASSES_ROOT in the registry.
    Search ".DAT" under this key.
    Click on this key and delete the (Default) value.
    Aski. MVP Desktop Experience
    Tuesday, March 24, 2009 2:51 PM
    Answerer
  • I take ".dat" for example.
    Go to HKEY_CLASSES_ROOT in the registry.
    Search ".DAT" under this key.
    Click on this key and delete the (Default) value.
    Aski. MVP Desktop Experience

    Dear Aski,

    Thank for your help!
    i will try ^^

    regards
    lolojack
    Wednesday, May 06, 2009 3:08 PM
  • Hi,

    This cannot be done directly in Windows, but... there are alternatives like
    http://www.winhelponline.com/downloadattachment.php?aId=9f390841cdbe0c2457898179b80dfce0&articleId=231

    or

    http://www.creativelement.com/powertools/#download

    As far as I know they are freeware allowing some things Vista did not allow. I haven't tested them myself, but they may be useful for you.

    Regards

    Rem
    The First link worked perfectly to remove file association using Windows 7...thanks :)
    • Proposed as answer by L3O Friday, November 11, 2011 12:34 PM
    Friday, August 19, 2011 4:44 PM
  • Hi,

    This cannot be done directly in Windows, but... there are alternatives like
    http://www.winhelponline.com/downloadattachment.php?aId=9f390841cdbe0c2457898179b80dfce0&articleId=231

    or

    http://www.creativelement.com/powertools/#download

    As far as I know they are freeware allowing some things Vista did not allow. I haven't tested them myself, but they may be useful for you.

    Regards

    Rem
    Thank you! First link worked perfectly.
    Friday, November 11, 2011 12:08 PM
  • I take ".dat" for example.
    Go to HKEY_CLASSES_ROOT in the registry.
    Search ".DAT" under this key.
    Click on this key and delete the (Default) value.
    Aski. MVP Desktop Experience
    When I tried, it seemed to only remove the .lnk entry under Control Panel\Programs\Default Programs\Set Associations but make no actual changes :(
    Friday, November 11, 2011 12:33 PM
  • Hi,

    Nice to see that it worked for you. I had forgotten about this thread (it is pretty old).

    As far as crediting octofinger for the link... He copied my input a bit higher up in the thread.

    Cheers

    Rem

    Friday, November 11, 2011 12:40 PM
  • Hi,
    When I tried, it seemed to only remove the .lnk entry under Control Panel\Programs\Default Programs\Set Associations but make no actual changes :(


    Thanks for information and for the test of the Utility.

    Regards


    Cordialement
    Aski - MVP Windows Expert-Consumer
    Forum_Aski
    Friday, November 11, 2011 1:02 PM
    Answerer
  • Try this

    (just now it worked fine with an association I created through Windows Explorer):

    Let .<ext> be the extension you want to deassociate.

    With a registry editor (e.g. regedit.exe),

    1. go to

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\

    remove the subtree .<ext>

    2. go to

    HKEY_CLASSES_ROOT\

    remove the subtree .<ext>

    remove the subtree <ext>_auto_file


    • Proposed as answer by Anders Hartzen Monday, December 05, 2011 6:33 PM
    Sunday, November 13, 2011 4:24 PM
  • Thank you so much for the link! I had so many problems! I love to create email stationery and clipart and would save them as paintshop pro files or photoshop files but when i would open my folder where I saved my clipart the file extension was way different and could not be opened by anything I had. the extention was .#$# i have never seen that before in my life! But i downloaded the software from the link you provided and was able to get rid of it! Thank you!
    Saturday, January 21, 2012 11:46 PM
  • Command Prompt!

    It is 2 years later.... but I found this site anyway.. so for anybody that needs an answer her ya go.

    As I was looking for the answer, I remembered that there was an old command using command prompt to

    solve this little problem. If you don't know how to get to the command prompt, follow this:

    Type the keys: [Win] + "R", which brings up the Run window.

    Type the keys: "cmd", then type [enter]

    You should be looking at that little black box now. Now if you need some help type in these words:

    C:> help assoc

    My particular problem was this: I was looking at C:\windows\prefetch, and all of the files were *.pf, and I accidentially associated all of my prefetch files with a program.

    To undo the association:

    assoc .pf = ""

    now my *.pf files will associate with NO file

    To test what your computer uses to open *doc files type, at the prompt:

    C:> assoc .doc

    .doc=Word.Document.8

    The display states: Word.Document.8 opens your doc files.

    done.

    • Proposed as answer by reecebiddle Saturday, March 10, 2012 12:02 AM
    Friday, February 24, 2012 6:09 AM
  • Thank you! Using the Command Prompt was extremely simple, and it worked perfectly! Why didn't anyone else think of that?
    Saturday, March 10, 2012 12:04 AM
  • The command prompt works unless you had made the file association through the Windows 7 UI, in which case you must edit the registry as described by eykleidhs.  My nightmare with this occured when I associated .py files to python using the Windows 7 and discovered that my command line options were not being passed to python.  Then, I could not remove the association through the Windows 7 UI, and when I tried changing the setting through the command prompt (with admin priv), the changes had no effect because the UI setting took precedence over the command prompt settings.  So, the solution was to use regedit to remove the file association that I made through the UI and then use the command prompt to make the file association.
    • Edited by vlucas0001 Monday, March 19, 2012 10:35 PM
    Monday, March 19, 2012 10:34 PM
  • some programs keep changing the associations so they may need to be removed

    scan you system for malware while you are at it


    Windows MVP 2010-11, XP, Vista, 7. Expanding into Windows Server 2008 R2, SQL Server, SharePoint, Cloud, Virtualization etc. etc.

    Hardcore Games, Legendary is the only Way to Play

    Developer | Windows IT | Chess | Economics | Vegan Advocate | PC Reviews

    Monday, March 19, 2012 10:37 PM
  • This solution is the most complete, and also works with Windows 8.

    Friday, December 14, 2012 8:27 PM
  • This worked like a champ in Win 8.  Association gone!
    Sunday, December 16, 2012 8:12 PM
  • Try this

    (just now it worked fine with an association I created through Windows Explorer):

    Let .<ext> be the extension you want to deassociate.

    With a registry editor (e.g. regedit.exe),

    1. go to

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\

    remove the subtree .<ext>

    2. go to

    HKEY_CLASSES_ROOT\

    remove the subtree .<ext>

    remove the subtree <ext>_auto_file


    this worked great for me, but i also had to uninstall the program to broke the file association (after re-installing the program is no longer associated with the specific file type)

    thanks mate!

    Saturday, January 05, 2013 2:07 PM
  • Try this

    (just now it worked fine with an association I created through Windows Explorer):

    Let .<ext> be the extension you want to deassociate.

    With a registry editor (e.g. regedit.exe),

    1. go to

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\

    remove the subtree .<ext>

    2. go to

    HKEY_CLASSES_ROOT\

    remove the subtree .<ext>

    remove the subtree <ext>_auto_file


    this worked great for me, but i also had to uninstall the program to broke the file association (after re-installing the program is no longer associated with the specific file type)

    thanks mate!


    It just appears like that while the folder is still opened. Killing and starting explorer.exe fixes it.
    Wednesday, May 22, 2013 10:10 PM
  • The first link worked for me like charm!

    Thank you sir!!

    Wednesday, July 10, 2013 7:13 AM
  • Thanks for this, tried the others and they didn't work in Window 8, then tried the cmd prompt and it did. So it might have actually been the combination of all three, regardless my problem is fixed, so thanks.
    Wednesday, August 07, 2013 11:18 PM
  • Thanks eykleidhs.

    I don't understand what's wrong with microsoft, which is removing a lot of features.
    First, I found I cannot list the known wifi network anymore. So it's not possible to remove a known network which is not in range.
    Now this...


    SMS Access API - Windows Phone Dev Feedback

    Sunday, October 20, 2013 7:07 PM
  • I take ".dat" for example.
    Go to HKEY_CLASSES_ROOT in the registry.
    Search ".DAT" under this key.
    Click on this key and delete the (Default) value.
    Aski. MVP Desktop Experience
    Fantastic, my .bin extension is now fixed. Thanks :)
    Thursday, November 21, 2013 3:48 PM
  • Actually there is a command in windows to do just this thing...

    source: http://support.microsoft.com/kb/184082

    assoc /?
    Displays or modifies file extension associations
    
    ASSOC [.ext[=[fileType]]]
    
      .ext      Specifies the file extension to associate the file type with
      fileType  Specifies the file type to associate with the file extension
    
    Type ASSOC without parameters to display the current file associations.
    If ASSOC is invoked with just a file extension, it displays the current
    file association for that file extension.  Specify nothing for the file
    type and the command will delete the association for the file extension.

    Specify nothing for the fileType and the command will delete the association for the file extension.

    e.g.: ASSOC .dat=

    • Edited by srichakradhar Tuesday, December 31, 2013 4:15 AM added link to microsoft page
    Tuesday, December 31, 2013 4:08 AM