none
Problem getting 2nd monitor to be detected

    Question

  • I have an ASUS P5Q-EM motherboard with built-in graphics.  The graphic chip is the Intel G45 chipset.  I'm running Windows Enterprise, 64-bit.

    The second monitor is not being detected.  If I go to Display | Change Display Settings | Advanced Settings, I end up at the property page.  I selected the tab for the Intel Graphics Media Accelerator Driver, and then clicked on "Graphics Properties".  That brought a dialog which a dropown that has "Single Display".  It has no other entry (an entry for "Dual Display" would have been nice.)

    I also tried selecting "Add a Device" from the Control Panel.  That didn't give me any options except to cancel.  And I also tried "Scan for hardware changes" in Device Manager.

    Anyone have any suggestions?

    Richard
    Saturday, December 05, 2009 10:09 PM

All replies

  • What happens if you press the "Windows" key + the "P" key and choose to for example duplicate the output. Does this present an image om both your screens?
    Saturday, December 05, 2009 11:06 PM
  • Andreas,

    I didn't know about the Windows-P combination.  But, to answer your question, unfortunately nothing happens.  And when I press Windows-P again, "Computer Only" is the highlighted option.

    Thanks for the reply anyway.

    Another other suggestions?

    Richard

    Saturday, December 05, 2009 11:13 PM
  • The "Windows" + "P" key is great :)
    Have you downloaded the latest driver for your graphics card? If not try the latest drivers from Intel, http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18336&lang=eng
    Saturday, December 05, 2009 11:33 PM
  • Andreas,

    Gave that try.  It didn't help.  I'm pretty confident the Intel drivers installed because the Intel Graphics and Media Control Panel is completely different.

    The BIOS and the "Starting Windows" screens showed on both monitors, so the hardware/BIOS is apparently recognizing both monitors.  But, once Windows 7 is loaded, it's not detecting the second monitor.  When I go into the Intel Graphics and Media Control Panel, there's a tab for Multiple Displays, but the Operating Mode dropdown still has just the "Single Monitor" entry.

    I also tried the Windows-P, but that didn't help any.

    Interestly, before I installed the Intel drivers, I uninstalled the existing display driver.  When Control Panel finished uninstalling the driver, the display jumped to the second monitor.  Then, after the Intel driver finished installing, the display jumped back to the first monitor.  But, after I rebooted, once again only the first monitor is being recognized by Windows.

    I'm still open to any suggestions,

    Richard
    Sunday, December 06, 2009 12:30 AM
  • Before trying anything else, there seems to be improvements to the "video stability" on the Asus P5Q-EM motherboard in the latest BIOS available. If you are not already using the latest BIOS download it from ASUS download page located at http://support.asus.com/download/download.aspx?SLanguage=en-us

    Sunday, December 06, 2009 9:15 AM
  • I've already checked that.  I updated the BIOS to version 2203 when I originally assembled the machine.
    Sunday, December 06, 2009 5:40 PM
  • Monitor going into Power Savings mode - What worked for me
    Hope this helps someone. I had a problem with one of my monitors going into Power Savings mode. Tried the usual power on/power off, reload drivers, swapped cables, turn of PCI Express Power savings mode, checked monitors for Power Savings feature, still no go. Found this posting on Microsoft Social Technet site;
    http://social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/8a9b5aa7-fe33-4e6d-b39b-8ac80a21fdc2
    A two year long thread describing this problem from a variety of users who have experienced this dreaded feature of Windows 7. I run the same monitors with DVI cables directly plugged into another box with Ubuntu, never had this problem. So the issue is definitely not the monitors. BTW, I am running Windows 7, x64, Pro, SP1, with Nvidea GT 220 graphics card. 2 Monitors plugged into Windows PC, 1 with VGA cable directly, 1 with VGA cable going into the VGA to DVI connector. The 1 going into the VGA to DVI connector seemed to be the problem for me, but as per the Microsoft link, other people had this problem with different setups, like DVI or HDMI cables. I did not create the solution, just want to pass along the info that worked for me.
    I recommend you get an adapter for your cable of choice, then remove the PIN that is related to the Hot Plug Detected/Auto Detect/PNP functionality for the monitor. 
    In my case, one of my VGA monitor's was connected to a VGA to DVI connector going into my graphics card. I simply pulled PIN 12 from the VGA cable going into the VGA to DVI converter, problem solved. Monitor does not go into Power Savings mode, shown as Generic Non-PNP monitor in Device Manager. The signal for Auto Detect/PNP is not transmitted through to the VGA to DVI converter and the problem is gone!!!
    I have included 3 links below, 1 for each cable type that people may come across. Per the Microsoft posting, some people found it useful to disable PIN 12 for VGA monitor cables, some found it useful to disable PIN 16 for DVI cables and some found it useful to disable PIN 19 on your HDMI cable. All this should preferably done on a connector cable which would be cheaper than ruining your only cable, and as someone had suggested, you could tape over the PIN 19 connection on your HDMI cable to solve the issue.
    ===========================================================================
    3 Links for DVI/HDMI/VGA Cable Auto Detect/PNP Pin Location
    ===========================================================================
    ============
    DVI Cable
    ============
    Image Showing PIN 16 location on DVI Cable - Disable PIN 16 to remove Auto Detect/PNP
    http://upload.wikimedia.org/wikipedia/commons/0/03/DVI_pinout.png
    ============
    HDMI Cable
    ============
    Image Showing PIN 19 location on HDMI Cable - Disable PIN 19 to remove Auto Detect/PNP
    http://postimage.org/image/2g8p5dwdg/
    ============
    VGA Cable
    ============
    Image Showing PIN 12 location on VGA Cable – Disable PIN 12 to remove Auto Detect/PNP
    http://3.bp.blogspot.com/_N66od8KlQks/TD-St9qyYEI/AAAAAAAAAVU/K5fH6O4jx-o/s1600/vga_pinout.jpg
    ===========================================================================
    This worked for me, I hope it will help to save someone the time and headache that it provided me with.
    Spend some time helping someone out,
    powderskier9

    • Edited by powderskier9 Thursday, January 05, 2012 1:04 AM Edit
    Thursday, January 05, 2012 1:03 AM
  • Do you have the extended video card adapter for 2 monitor's?

    If yes, use projector mode or clone display or extended desktop option to use 2 monitors.


    Aloysius Jegan
    Thursday, January 05, 2012 5:27 AM
  • I assume you verfied any cables and everything is fine. Now you can force detection by enabling the second monitor anyway and see what happens. To do that, right click on desktop, choose Screen Resolution, then click Detect, now you have an additional monitor named "Additional monitor not detected". Anyway, from the Display dropdown menu select Available Display Output on [your graphics card name], then click Apply. See if you get some image on the secondary monitor. If it's not working, you can wait 15 seconds for automatic revert or you can press Esc to return to normal. This seems to be an issue with Intel Integrated Graphics since 915GMA.

    Hope it works !

    Thursday, January 05, 2012 10:26 AM
  • Thanks Eduard,

    I have tried "detect" from various screens that it shows up on.

    The tab changes shade when I click however nothing else happens.....?

    Regards

    Musch

    Tuesday, March 06, 2012 8:41 AM