none
Windows 7 - Remote Desktop Client - cannot set display at 256 colors

    Question

  • Before Windows 7, I was able to set Remote Desktop client Display at 256 Colors. That option is missing in Windows 7 ( The lowest option is "High Color 15 bit" )

    I need the 256 color option back!!! it is very important to have it back specially if when using a slow network connection.

    Is there any trick or something that allow me to put it in 256 color mode?

    Thanks in advance
    Regards
    Javier
    Friday, March 27, 2009 8:43 PM

Answers

  • You can set this with Group Policy.

    The only requirement seems to be that the policy has to be set on a machine with Server 2008, Vista, or earlier version of Windows.  But then you could also set it in the RDC edit settings.  I tested this connecting from Server 2003 to Windows 7.  8 bit was ugly, as expected.

    If you are connecting from Windows 7 to an earlier version of Windows, you can set a local policy on the target.

    If you are connecting from an earlier version of Windows to Windows 7, you can set a local policy on the machine you are connecting from.

    To create a Local Computer Policy console, first open mmc.  Hit Win+R or Start\Run, and type mmc (enter).  Once the MMC windows opens, you need to select File\Add/Remove Snap-in.

    When the Add/Remove Snap-in dialog opens, chose Add.  In the next dialog, scroll down to "Group Policy Object Editor".  Accept the default of "Local Computer Policy", and OK or close all of the dialogs until the main MMC window is left.  At this point, you can select File\Save As and name it and save it as you chose.

    The policy setting you are looking for is called Limit maximum color depth.  It will be under "Computer Configuration\Administrative Templates\Windows Components\Terminal Services".  In XP or Server 2003, it will be right in that "folder".  In Vista or Server 2008, you have to drill down to "Terminal Server\Remote Session Environment".

    You would want to set at 8 bit, of course.  With Group Policy editor in Windows 7 or Server 2008 R2, 8 bit is not available here either.

    If you need to connect from Windows 7 to Windows 7, you would need to set the policy at the domain level.  You could create a new policy and enable it only on a group of computers, if you want.
    Friday, March 27, 2009 10:55 PM

All replies

  • You can set this with Group Policy.

    The only requirement seems to be that the policy has to be set on a machine with Server 2008, Vista, or earlier version of Windows.  But then you could also set it in the RDC edit settings.  I tested this connecting from Server 2003 to Windows 7.  8 bit was ugly, as expected.

    If you are connecting from Windows 7 to an earlier version of Windows, you can set a local policy on the target.

    If you are connecting from an earlier version of Windows to Windows 7, you can set a local policy on the machine you are connecting from.

    To create a Local Computer Policy console, first open mmc.  Hit Win+R or Start\Run, and type mmc (enter).  Once the MMC windows opens, you need to select File\Add/Remove Snap-in.

    When the Add/Remove Snap-in dialog opens, chose Add.  In the next dialog, scroll down to "Group Policy Object Editor".  Accept the default of "Local Computer Policy", and OK or close all of the dialogs until the main MMC window is left.  At this point, you can select File\Save As and name it and save it as you chose.

    The policy setting you are looking for is called Limit maximum color depth.  It will be under "Computer Configuration\Administrative Templates\Windows Components\Terminal Services".  In XP or Server 2003, it will be right in that "folder".  In Vista or Server 2008, you have to drill down to "Terminal Server\Remote Session Environment".

    You would want to set at 8 bit, of course.  With Group Policy editor in Windows 7 or Server 2008 R2, 8 bit is not available here either.

    If you need to connect from Windows 7 to Windows 7, you would need to set the policy at the domain level.  You could create a new policy and enable it only on a group of computers, if you want.
    Friday, March 27, 2009 10:55 PM
  • Works fine, thanks !

    Is there any way to do this from the client side?

    Regards
    Tuesday, March 31, 2009 1:46 PM
  • You can set a local policy on the client.  The only problem is that it can be pre-empted by a domain policy.
    Tuesday, March 31, 2009 9:24 PM
  • I tried to change this policy from the client side (Windows 7) but the minimun "Limit maximum color depth" choise is 15 bit, and I need to force it to 256 colors (8 bit) to be able to optimize the connection speed. Any suggestion?

    Thanks
    Monday, April 06, 2009 3:54 PM
  • Group Policy sets values in the registry.  The value set by this policy is ColorDepth in the key HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services.

    I have found that the value "5" represents ColorDepth 32.  From the other settings available, Client Compatible, 8, 15, 16, and 24, I would assume a value of 1 would force 8 bit.

    You could set the value with reg.exe, in a command prompt:
    REG ADD "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services" /v ColorDepth /t REG_DWORD /d 1 /f
    
    
    Monday, April 06, 2009 5:20 PM
  • Hi Javier

    Another option is to open the RDP client, and click on options, then click on Save As on the General Tab to save an RDP file to disk.  Drag the .rdp file onto notepad, and look for the line that says:-

    session bpp:i:16

    Change 16 to 8 to get 256-colour.  If you want separate shortcuts for multiple servers, just make copies of the file and change the "full address" line.

    cheers
    Ray
    RayDiack
    • Proposed as answer by Pim81 Wednesday, May 06, 2009 12:27 PM
    Thursday, April 09, 2009 1:34 PM
  • It seems not be running on Windows 7 RC build 7100 ? isn't-it ?

    ColorDeph still run into 15 bits mode.

    Regards

    PIM
    Wednesday, May 06, 2009 12:30 PM
  • Hi Pim

    I am also running RC, build 7100 - just tested again by creating and editing an RDP file, with a line that says:-

    session bpp:i:8

    ... and it launched the session in 256 colour....?

    -Ray
    RayDiack
    Wednesday, May 06, 2009 12:51 PM
  • Hi Ray


    Yes you are right.

    The problem is beetween an windows 7 RC  client and an windows 2000 server  remote connexion (256 color ).
    When minimized the desktop remote connexion become black.
    We have to click several times on the minimized icon to restore the screen display.

    thanks

    PIM
    Wednesday, May 06, 2009 1:10 PM
  • Hi Pim

    Hmm could be due to updated RDP client in Windows 7 RC?  Maybe try running a previous version of mstsc.exe on Windows 7 and see if it exhibits the same behaviour?  A bit of a hack, but it may work....

    -- Ray
    RayDiack
    Wednesday, May 06, 2009 1:13 PM
  • Ray,

    Have you had any further advances on this problem because I'm seeing the same thing too.  Windows 2000 Server and Windows 7 RC1 work fine over RDP but as soon as the rdp session is minimised (English spelling - sorry!) and then restored, it comes back as a black screen and then takes many minutes to redraw itself (if at all).  Big problem as I have customers who are pretty bound to their legacy Win2k stuff. Installing an older version of RDP on all of their machines will be difficult. 

    It would be nice if Microsoft could get this sorted prior to RTM but am I just a dreamer?

    JB
    Tuesday, June 23, 2009 8:44 AM
  • Hey JB

    Hmm weird it works 100% for me - also Windows 2000 server, Windows 7 RC client, RDP version 6.1.7100.  I'm guessing here, but not possibly a Windows 7 driver issue?  Maybe try from a couple of different machines with different drivers?  It is possible to run the RDP client off a network share, so if you can find one that doesn't exhibit the same issues on Windows 7, maybe try that?  Something weird i noticed on my notebook as well - when RDP'ing onto a Windows 2000 server from Windows 7, the rdp client processes uses 50% of my CPU, and my cpu fan goes ballistic - but ONLY for rdp'ing to Windows 2000 - it's fine for 2003 / 2008!?  So it seems the rdp client included with Windows 7 connecting to Windows 2000 server is a bit buggy.

    To run the RDP client off a network share, copy mstsc.exe and mstscax.dll to a folder and run mstsc.exe from there.  I just tried it with version 5.1.2600.2180 and it seems to work fine (and no weird high CPU usage!).

    If you don't want to run it off the share, you could always also download RDP (I think it's natively packaged as an MSI) and deploy it using Group Policy to the windows 7 PC's.  You just need to make sure Windows Updates don't automatically update it... easy enough if you're using WSUS or SSCM for your patching infrastructure.

    hope that helps,
    Ray

    RayDiack
    Tuesday, June 23, 2009 11:48 AM
  • That does not work. Tried adding both to Terminal Services and Terminal Services\Client - no success.
    Friday, May 06, 2011 10:59 AM
  • Thanks, Javier,

     

    That works!

    Friday, May 06, 2011 11:00 AM
  • Does not work on Windows 7 Home Premium.
    Friday, May 06, 2011 11:01 AM
  • There is no direct way to choose 256 colors in the Remote Desktop of Windows 7. But, a remote session can be invoked with 256 colors:

    1. Set all the remote desktop settings for the connection and save it to a RDP (.rdp) file by choosing Save As in the General tab.
    2. Open this .rdp file in a text editor. Find the line that reads session bpp:i:16. The value here will read 15, 16, 24 or 32, depending on the color depth you had chosen while saving the file. Change this line to session bpp:i:8
    3. Use this .rdp file to open a RDP session to the remote computer. This can be done by either opening this file in the Remote Desktop Connection client or by double-clicking this file. The remote session will now use a 8-bit color depth.
    Wednesday, August 03, 2011 3:57 PM