none
How can I associate .jpg files in Windows 7 to open automatically in Photoshop CS2 running in Virtual XP ?

    Question

  • I upgraded my new HP from Windows 7 Home Premium to Windows 7 Professional so I could run the Virtual XP. When I click .jpg files from Windows Explorer they open in a Program called HP Mediasmart Photo. I want them to open in Photoshop CS2 which I am running otherwise successfully in Virtual XP. I went to Control Panel and clicked "default programs", then "Associate a file type or protocol with a program".  when I assigned the .psd files, Photoshop CS2 in virtual xp was a choice available in the change program "Open With" window.  When I try to assign .jpgs to Photoshop CS2 in virtual xp, this option is not available to me in either the" Recommended Programs" or "Other Programs", and when I click "Browse" and go to where I'm pretty sure the program is: Program Files (x86)/Adobe/PhotoshopCS2, neither the program folders nor the .exe programs show.  Nothing shows except two non-related folders in Adobe.  Could if be possible that the Photoshop .exe file is somewhere else?  I'm pretty sure I saw it in the Adobe Folder when installing.

    Before I got this Windows 7 machine, my workflow was much smoother as I could just click a .jpg file from Windows Explorer and it would open up.  It is much more time consuming to have to go into file open in Photoshop CS2 every time I want to process a file. The .psd files work great and load in CS2 when you click them.  Can this also work with the .jpg files?

    Thanks - Richard
    Monday, November 02, 2009 5:57 PM

Answers

  • Hi Flavio - Yes, I got AutoCad 2004 to run in the in the Virtual Environment.  It installed without a hitch.  It also now works great in the Win 7 physical machine.  Since I don't have Adobe Acrobat Professional 9 to use to print to .pdf, I often load Autocad in the virtual machine and print to .pdf in Adobe Acrobat Pro 7, then close the virtual machine and read it in Adobe Reader 9 before sending it to the print shop.
    Did you follow any particular steps to get it installed the way you wanted? I mean, mine is installed too, but I miss the file association thing!

    I think I was able to associate the .dwg files with the virtual machine, but changed them back to the physical machine when I finally got it to install.  Photoshop was my big problem with file associations, and I never was able to make that work.

    Best regards - Richard
    I hope there is somebody somewhere that can tell me how things have to be set up for AutoCAD 2006 on Win7 (running in XPM), because I can't yet afford to buy new license for 2010 Version...

    Thanks,
    F.
    • Marked as answer by RicardoFuerte Wednesday, February 03, 2010 7:21 PM
    Wednesday, February 03, 2010 7:32 AM

All replies

  • First of all, Photoshop CS2 should be the default handler for .jpg files inside the Virtual XP. means when you open the Virtual XP VM in the full desktop mode, and double click a .jpg file "inside" the Virtual XP; it should open in CS2 by default. This you can do by right-clicking a .jpg file in the virtual XP, saying "Open With..." and selecting CS2 as the default application.

    After that restart the Virtual XP VM. When the restart is complete, CS2 should be available as an "Open With..." option for the .jpg files on the host. then you can do the same thing you did you the .psd files to make CS2 the default application for .jpg files.
    Monday, November 02, 2009 7:12 PM
  • Hi Palash Kar - Thank you for your reply.  I did as you suggested and opened a .jpg in the XP Virtual Machine and set .jpg as the default.  When clicked within the Virtual Machine, it loads Photoshop CS2 and the .jpg file as expected.  Hooray!!   I then closed down Photoshop and the Virtual Machine and went to windows explorer in Windows 7 and right clicked on a .jpg file as you suggested. When I clicked "Open With", Photoshop CS2 is not there to choose.  I clicked "Choose Default Program" to see if Photoshop CS2 might be in the next menu, but alas, it is not.  I then rebooted to see if that would help, but it did not.

    I thought that I might just use the Windows Explorer from the Virtual Machine, but it will not lewave the window, so I can't keep it on an adjacent screen which would help my workflow.  What I don't understand is that when choosing other file extensions (.psd), the Photoshop CS2 is available as a choice, but with .jpg it is not.

    I appreciate you trying to assist me with this problem.  do you have any other ideas which might help?  -  Best regards - Richard
    Monday, November 02, 2009 10:13 PM
  • You need to restart the Virtual machine; i mean the VM should go down and then come up. After the VM has fully come up, you should see CS2 as an option for .jpg.
    Tuesday, November 03, 2009 6:07 AM
  • Hi Palash Kar - I have done so but still nothing comes up.  I realized after your reply that I was only hibernating the Virtual Machine and not shutting it down.  I tried logging off and that did not work, so I figured out how to completely shut it down clicking the Ctrl+Alt+Del at the top of the Virtual Machine desktop and choosing "Shut Down".  I did this twice to no avail.  I then shut it down and completely rebooted.  Still no CS2 in the choices when I right click on the 'jpg file and click "Open With".  Do you have any other ideas? - Best regards - Richard
    Tuesday, November 03, 2009 1:19 PM
  • ok. There is a slight catch here. The way file association replication works is that the file handler for an extension should be the default inside the VM. Also this default should be in the system wide context. What this means that now if you logoff yourself from the VM and log in as somebody else; double-clicking the .jpg file should still open it in CS2. "Open With..." association might be creating the association only for that user.

    you have to figure out some way to make this association system wide. There might be some option in CS2 to take over the association of all image files in the VM.
    Tuesday, November 03, 2009 1:48 PM
  • You cannot vote on your own post 
    Hi Palash Kar - I looked all throught the menus in CS2 and there is nothing that appears that it would alter the problem.  Searching the Help in CS2 yielded no responses.  From the blogs that I have read, Adobe no longer supports CS2 since CS5 is about to come out, and will provide no insight regarding compatibility with Windows 7.  I tried assigning a .tif file and I get the same results as with .jpg.  The choice does not exist in the "Open With" menu. I do not understand why it gives me the choice in .psd files, but not in .jpg files.  I tried logging off and setting up another user and reinstalling XP Virtual in that user and going out again, but that did not help.  I did not reinstall CS2 in that virtual machine, though.

    Thanks again for your help.  I would really like to get this to work, as the inability to click on a file and have it load in CS2 is severly hampering my workflow.

    Best regards - Richard
    Tuesday, November 03, 2009 2:54 PM
  • Here's a hack that you can try using the registry, but DO REMEMBER THAT MODIFYING THE REGISTRY IS DANGEROUS. you should be very careful while doing this. The best would be to enable undo disks on your VM before you attempt.

    Open the VM in the desktop mode, run regedit and navigate to HKLM\Software\Classes. observe the registry key for .psd and see how is it associated to be opened with CS2. There would be a default string value with a progid of CS2. try to replicate that for the .jpg file on the same HKLM\software\classes.

    This should cause the system wide association of the .jpg file with CS2. Now restarting the VM should cause the association to reflect on the host.

    Hope this helps.

    I would like to reiterate that touching the registry is unadvisable and very dangerous so do take all precautions.

    • Proposed as answer by pacificwalker Monday, July 12, 2010 10:26 AM
    Wednesday, November 04, 2009 6:23 AM
  • Hi Palash Kar - Thanks for the reply.  I have opened the registry. 

    In .psd There are two files: "ab icon "(Default)"", Type: "REG_SZ", Data: "Photoshop.Image.9" AND "ab icon "(Default)"", Type: REG_SZ, Data: "Image" AND two subfolders "PersistentHandler" with files  "ab icon "(Default)"", Type: "REG_SZ", Data: {098f2470-bae0-11cd-b579-08002b30bfeb} AND subfolder "ShellNew"  with files "ab icon "(Default)"", Type: "REG_SZ", Data: "(value not set)" AND  "ab icon "NullFile"", Type: "REG_SZ", Data: -blank-

    In .jpg there are three files:  "ab icon "(Default)"", Type: "REG_SZ", Data: "jpegfile"  AND  "ab icon "Content Type"", Type: "REG_SZ", Data: "image/jpeg" AND  "ab icon "Perceived Type", Type: "REG_SZ", Data: "image" AND two subfolders "OpenWithProgids" with two files:  "ab icon "(Default)"", Type: "REG_SZ", Data: "value not set" AND  "0ll ll0 icon "jpegfile"", Type: "REG_NONE", Data: "(zero-length binary value" AND subfolder "PersistentHandler" with a file: "ab icon "(Default)"", Type: "REG_SZ", Data: {098f2470-bae0-11cd-b579-08002b30bfeb}

    The .jpe, .jpeg, .tif, & .tiff folders are identical to the .jpg. - What should I do? - Thanks - Richard
    Wednesday, November 04, 2009 3:00 PM
  • try to replace "jpegfile" with "Photoshop.Image.9". Do have undo disks enabled so that if anything goes wrong then you can discard the undo disk.
    Wednesday, November 04, 2009 6:18 PM
  • You cannot vote on your own post 
    Hi Palash Kar - How do I prepare an "Undo Disk" ?  How would I use it if there were a problem? - Best regards - Richard
    Wednesday, November 04, 2009 11:48 PM
  • Hi Palash Kar  - I went into the registry of my old XP machine which worked with the "Open With" Phortoshop CS2. The Data Line there is "ROXIOPS7.JPG on .jpg, .jpeg., and jpe files, not "Photoshop.Image.9".

    Thanks - Richard
    Thursday, November 05, 2009 12:43 AM
  • Hi Palash Kar  - I now have my AutoCAD 2004 program up and running in Win7Pro XP Virtual Machine.  Its behavior in File Association is very similar to the behavior of .jpg files and Photoshop CS2 in Win7Pro XP Virtual Machine.  Therefore this cannot be a problem with Photoshop CS2 as you have proposed.  It has become clear to me that it is NOT possible to associate programs which are running in XP in the Virtual Machine with files as they are shown in the Win7 Explorer.  THIS IS A MAJOR GLITCH IN WINDOWS 7 and needs to be addressed by Microsoft. No solution has been forthcoming from Microsoft in this discussion.  This error on the part of Microsoft has seriously negatively affected normal workflow in these programs running in the Virtual Machine, and Microsoft has clearly misrepresented the seamlessness of using old programs in Windows 7.  This fault needs to be immediately addressed. - Do you have any other ideas in working around this major glitch in Windows 7? - Thank you - Richard
    Saturday, November 07, 2009 6:05 PM
  • Hello everyone. I was also having a problem with windows file assocations in Windows 7. Even after double clicking on the Photoshop.exe file it would put the program into the list of available programs to choose. I found a solution! Download a utility called OpenWithAdd. Google it, it will be within the first few links. Download that, and it will allow you to add programs to the open with dialog. I added Photoshop, and within seconds I was able to choose Photoshop as an available option for file assocations. I hope this helps somebody because I was getting pretty frustrated myself!

    ~Jon

    Saturday, November 14, 2009 10:49 PM
  • Hi Jon - Unfortunately this does nothing to help.  The OpenWithAdd won't see the Virtual Machine "C" drive any more than Win 7 will, and since my Photoshop CS2 and Autocad 2004 had to be installed on the cirtual C Drive to work, that is where the .exe files for those programs are. They do not seem to be able to be accessed in Win 7, except on the Win 7 Virtual Drive XP Menu.  Microsoft has misrepresented the seamlessness of XP on the Win & platform, It is NOT seamless.  Had I known how distressing this would be to my workflow, I would have not waited for Win 7, I would have had a machine built with XP. - Thanks - Richard
    Sunday, November 15, 2009 4:21 PM
  • Funny - I'm having the same problem as you except for me I use Corel Photo-Paint (my version of it doesn't work in 7 - just xp).  I would love to know if anyone found a solution to this as well??

    Ricardo, as of now the best solution I've found is that I leave the program open and instead of doing a file:open from within the program I just right click the image icon (if say it was on my desktop) and click copy - and then I paste in photo-paint. It seems to work well and brings it in as the actual name so when you save you can overwrite the previous pretty easily.  This is obviously not the way I'd like to do it but the best solution for me so far.
    Sunday, November 15, 2009 11:55 PM
  • Hi anythinggi - Thank you very much for your reply.  You solution helps me quite a lot in my workflow.  I was going crazy keeping a Windows Explorer open just to see what I was doing and opening one file after another from the File Open menu of CS2.  It's not a perfect solution, but it sure speeds things up. I do product photography to put on my website store and eBay store - usually 6 to 12 items in a series.  I load all of the files at once and process them, minimizing them in CS2 so I can compare them before closing.  It's still a bit of a pain to copy and paste so many times per run, but many fewer strokes than the way I was doing it.

    What confuses me about this is that Microsoft has made it possible to associate .psd (Photoshop) files from the host machine to the virtual machine - the choice is there when you right click a .psd.  I have made Photoshop the default for .psd and it works perfectly.  The Photoshop option is not available for any of the other file types I use.  The fact that one can paste to a shortcut to a program in the Virtual Machine underlines the fact that this is not a limitation of Win7, just a glitch - a shortcoming that one would think Microsoft would have thought out first, since .jpg's is the most usual graphics format. 

    I even tried associating the Photoshop shortcut to the .jpg, but that doesn't work.  I hope somebody at Microsoft understands what we are going through and works out this problem soon.

    Thanks again for your help. - Richard
    Tuesday, November 17, 2009 2:04 AM
  • Hi anythinggi -  I have just discovered something which might help you with your Corel Photo-Paint, and if it does, will make moot the concerns for associating .jpg files to the Virtual Machine (not that Microsoft doesn't owe us a solution).  When I read the instructions for running old programs in Win7 Compatibility Mode I misunderstood the instructions on how to do it.  The command to run in Compatibility Mode must be made when installing the program, not when running it.  I tripped over this blog for CS2 and it worked in allowing me to run CS2 in Win7.  I tried it on my AutoCad 2004 and it worked, too, even though it became clear that it was less compatible than the CS2 because most of the choices for Compatibility Mode were grayed out.  Both programs worked perfectly in Win7.  Here is the blog website I found:  http://social.answers.microsoft.com/Forums/en-US/w7programs/thread/6f1b4955-7166-4b8f-ad9b-5d19150f803f  The instructions were a little hard to understand so I amended them a little:

    (Capital letters my additions)
     
    LOAD THE INSTALLATION CD
    IN WINDOWS EXPLORER OPEN THE CD TO LIST THE FILES THEREIN
    Right click on the executable INSTALLATION FILE
    Select Properties
    Click on the Compatibility Tab
    Use the drop down menu to select XP SP3 mode (OR IN THE CASE OF MY AUTOCAD 2004: "Previous version of Windows")
    Check the box for Run as Admin (OR IN THE CASE OF MY AUTOCAD 2004: "Run as admin" was grayed SO I IGNORED)
    Click OK
    RETURN TO WINDOWS EXPLORER
    CLICK ON THE EXECUTABLE INSTALLATION FILE
    CONTINUE THE INSTALLATION NORMALLY


    I hope this works for you for your Corel Photo-Paint.  I really want to thank you for your suggestion for copy/pasting on the Shortcut.  I still use it when I load an extra Photoshop in the Virtual Machine, which also has its advantages if I'm doing two projects simultaneously.

    Best regards - Richard
    Monday, November 23, 2009 8:00 PM
  • Hy Ricardo, I stumbled across your latest suggestion because I migrated from XP to Win7 (64bit) and need to use AutoCAD LT 2006. I managed to install it in XP Mode, but I'm missing file associations to DWG files.

    I wanted to ask you if you successfully installed AutoCAD (2004 in your case) in a Virtual XP Environment (XP Mode) or rather in native Win7 environment, because I'm not clear about this...

    Thanks and regards,
    Flavio.
    Tuesday, February 02, 2010 10:04 AM
  • For AC2006LT you're going to need to run it with the IC disabled, not in the seamless integrated mode, as AC2006 requires true color.
    Tuesday, February 02, 2010 6:27 PM
  • Hi Flavio - Yes, I got AutoCad 2004 to run in the in the Virtual Environment.  It installed without a hitch.  It also now works great in the Win 7 physical machine.  Since I don't have Adobe Acrobat Professional 9 to use to print to .pdf, I often load Autocad in the virtual machine and print to .pdf in Adobe Acrobat Pro 7, then close the virtual machine and read it in Adobe Reader 9 before sending it to the print shop.

    I think I was able to associate the .dwg files with the virtual machine, but changed them back to the physical machine when I finally got it to install.  Photoshop was my big problem with file associations, and I never was able to make that work.

    Best regards - Richard
    Tuesday, February 02, 2010 7:25 PM
  • For AC2006LT you're going to need to run it with the IC disabled, not in the seamless integrated mode, as AC2006 requires true color.
    Hello smjain,

    what is IC and how to disable it?
    And would this affect file association?

    Regards,
    F.
    Wednesday, February 03, 2010 7:29 AM
  • Hi Flavio - Yes, I got AutoCad 2004 to run in the in the Virtual Environment.  It installed without a hitch.  It also now works great in the Win 7 physical machine.  Since I don't have Adobe Acrobat Professional 9 to use to print to .pdf, I often load Autocad in the virtual machine and print to .pdf in Adobe Acrobat Pro 7, then close the virtual machine and read it in Adobe Reader 9 before sending it to the print shop.
    Did you follow any particular steps to get it installed the way you wanted? I mean, mine is installed too, but I miss the file association thing!

    I think I was able to associate the .dwg files with the virtual machine, but changed them back to the physical machine when I finally got it to install.  Photoshop was my big problem with file associations, and I never was able to make that work.

    Best regards - Richard
    I hope there is somebody somewhere that can tell me how things have to be set up for AutoCAD 2006 on Win7 (running in XPM), because I can't yet afford to buy new license for 2010 Version...

    Thanks,
    F.
    • Marked as answer by RicardoFuerte Wednesday, February 03, 2010 7:21 PM
    Wednesday, February 03, 2010 7:32 AM
  • Hi Flavio - Is it my understanding that you would like to install your AutoCad 2006 in the physical machine rather than the virtual machine?  If so, please refer to the steps I set out in my response of November 23rd of 09 above.  You should be able to  install AutoCad 2006 in the physical machine if you do the compatabilty tab thing on installation.  If the program is in the physical machine there will not be a problem at all with file association.  Just right click on a file, selct "open with" and proceed until you get to the default program with which to open.  I hope this helps. - Richard

    Wednesday, February 03, 2010 7:22 PM
  • LOAD THE INSTALLATION CD
    IN WINDOWS EXPLORER OPEN THE CD TO LIST THE FILES THEREIN
    Right click on the executable INSTALLATION FILE
    Select Properties
    Click on the Compatibility Tab
    Use the drop down menu to select XP SP3 mode (OR IN THE CASE OF MY AUTOCAD 2004: "Previous version of Windows")
    Check the box for Run as Admin (OR IN THE CASE OF MY AUTOCAD 2004: "Run as admin" was grayed SO I IGNORED)
    Click OK
    RETURN TO WINDOWS EXPLORER
    CLICK ON THE EXECUTABLE INSTALLATION FILE
    CONTINUE THE INSTALLATION NORMALLY

    Hello Ricardo,
    I just wanted to walk through the instructions you reported, but still AutoCAD 2006 doesn't install in *native* Win7.

    Just wanted to get assured that I'm doing it right: when you say "Right click on the executable INSTALLATION FILE", which file do you mean? I did it with the setup.exe stored in the root of the CD.

    When I subsequently start the installation process, it wants to install .NET 1.1, but then stops with this error:

    http://yfrog.com/4jautocadp

    Translated it is telling me that AutoCAD 2006 installation has been cancelled, I should check that log file for details, but there is *no* such log file at all!

    Do you have other suggestions for me?

    Many thanks again!
    F.


    Thursday, February 04, 2010 3:27 PM
  • Hi, Flavio -

    First of all, let me make it clear that I am not a computer guru, I was just able to get this stuff to work by doing that which you are doing now - reading the blogs and asking for help.  I was never able to find anyone who had done it, but by gleaning several unrelated bits of information from various sites and hours of trial and error, I finally was able to make it work.

    Now, don't forget that I am in ACAD 2004, so your 2006 may have some differences. The setup.exe file definitely does not work.  The executable installation file that worked for me I found in a folder on the installation disk called AdminImage.  The installation file is called ACAD.MSI.

    I hope this helps.  I must tell you that it is so much easier working in the physical machine.  I do hope this works for you.  I think they keep this information from us as a conspiracy to make us buy new software. Please let me know.

    Best regards - Richard 
    Thursday, February 04, 2010 6:40 PM
  • IC are integration components, you need them to run in seamless mode which is how the file associations work.

    To run your version of Autocad, you're not going to be able to do it except with the VM running in a window.  In seamless mode, i.e. what would launch the app from a file extension, you get 16bit color by default and can hack VPC to get to 24bit color, but in order to get 32bit true color, you need to disable the integration components.
    Do disable the integration components from the Tools menu on the VM window.
    Thursday, February 04, 2010 7:11 PM