none
Windows 7 x64 now stuck on low resolution non-PNP monitor.

    Question

  • I recently rebooted my Windows 7 x64 system with the monitor turned off. When I turned it on, it came up at a much lower resolution.

    Since then, I have raised the resolution as high as it will go, but 1600x1200 is very blurry on my 1920x1200 monitor. Windows 7 insists my monitor is non-PNP which is ridiculous, it is a high end monitor, a Viewsonic VP2330wb.

    I have gone into Screen Resolution->Advanced and Windows 7 simply refuses to pick up the monitor. It insists it is a Generic non-PnP. I forced the nVidia drivers to allow non-supported resolutions, which allowed me to choose 1920x1200, which stuck after reboot. But this is a lie, the monitor is still running at blurry old 1600x1200 and is annoyingly telling me so at regular intervals.

    I have cycled power on both monitor and the Windows 7 system. My Linux box has no problem recognizing my monitor for what it is.

    I am running the Windows 7 provided nVidia drivers for my 8800 Ultra.

    How do I force Windows 7 to talk PNP to my monitor?
    Friday, January 22, 2010 3:06 AM

Answers

  • Hi kmarsh8,
    Hopefully you still have the disk that was provided with the monitor as Viewsonic shows no support for drivers for the monitor. In Devices and Printers, right-click the Generic PnP monitor and update drivers and point it to any .inf file that you have on the disk.

    The monitor EDID and the new Win 7 nVidia drivers won't play together nicely until you tell it what monitor is there. Have you contacted Viewsonic support? I had the same issue on a Lenovo 2440 and used the Vista .inf.

    Good Luck! 
    Friday, January 22, 2010 12:31 PM
  • Hi kmarsh8,

    1. Try to roll back the driver to the previous version:

    1) Click the Start Button, type Device Manager in the Search bar and press "Enter". Click Continue if necessary.
    2) Double click to expand the Display adapters.
    3) Right click the Nvidia GeForce 8800 Ultra and click "Properties".
    4) Click the "Driver" tab and click "Roll Back Driver".

    If the issue persists, please continue the following steps.

    2. Uninstall the graphic driver and monitor driver, then update the drivers to the latest version.

    To download the graphic driver: GeForce/ION Driver Release 196. Or you can test other previous versions as well.
    To download the monitor driver, just manually click update driver in Properties. Or contact ViewSonic for support.

    3. As a work around, you can use the 3rd party software PowerStrip to support multiple resolutions.

    Please note: we provide the 3rd party link for references only. There may be some changes without notice, Microsoft doesn't gurantee any accuracy on contacting information.

    Best Regards
    Dale
    Tuesday, January 26, 2010 2:32 AM

All replies

  • Nvidia has been having some issues with video drivers and X64 systems. At this point I can only think of a couple of suggestions - one is to go into device manager and try rolling back the video driver. Did that work?

    If that doesn't work, uninstall/remove the Nvidia driver and let Windows Update Catalog select a driver - Did that work?
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Friday, January 22, 2010 3:15 AM
  • Hi kmarsh8,
    Hopefully you still have the disk that was provided with the monitor as Viewsonic shows no support for drivers for the monitor. In Devices and Printers, right-click the Generic PnP monitor and update drivers and point it to any .inf file that you have on the disk.

    The monitor EDID and the new Win 7 nVidia drivers won't play together nicely until you tell it what monitor is there. Have you contacted Viewsonic support? I had the same issue on a Lenovo 2440 and used the Vista .inf.

    Good Luck! 
    Friday, January 22, 2010 12:31 PM
  • Hi kmarsh8,

    1. Try to roll back the driver to the previous version:

    1) Click the Start Button, type Device Manager in the Search bar and press "Enter". Click Continue if necessary.
    2) Double click to expand the Display adapters.
    3) Right click the Nvidia GeForce 8800 Ultra and click "Properties".
    4) Click the "Driver" tab and click "Roll Back Driver".

    If the issue persists, please continue the following steps.

    2. Uninstall the graphic driver and monitor driver, then update the drivers to the latest version.

    To download the graphic driver: GeForce/ION Driver Release 196. Or you can test other previous versions as well.
    To download the monitor driver, just manually click update driver in Properties. Or contact ViewSonic for support.

    3. As a work around, you can use the 3rd party software PowerStrip to support multiple resolutions.

    Please note: we provide the 3rd party link for references only. There may be some changes without notice, Microsoft doesn't gurantee any accuracy on contacting information.

    Best Regards
    Dale
    Tuesday, January 26, 2010 2:32 AM
  • It is your video drivers, download the latest from the Nvidia website and install them should fix that right up :) you do not need a driver for your monitor to work properly
    • Proposed as answer by finchy1978 Wednesday, April 28, 2010 9:07 AM
    Tuesday, January 26, 2010 3:03 AM
  • Ok I may have a fix.  My problem much the same as most above.  I have Win 7 X64 with nvidia Quadro card and HP L2045W lcd monitor with native res of 1680x1050 connected by VGA cable.  Everything was working fine then suddenly windows / nvidia didn't recognise my monitor as HP reset it back to Generic Non PNP and changed the resolution down which made it quite blurry.  Spent all of yesterday trying everything including the add resolutions proposed above.  I install latest drivers for nvidia and the monitor but made no difference at all.  The fix for me was simple.  I unplugged the VGA cable and then opened the nvidia Control panel (this only displayed the laptop display as expected) and then plugged the cable back in.  The screen went blank for a second and then the nvida control panel popped back up now showing the eternal monitor as HP L2045W and set to it's native resolution.  I can't believe it was this simple.  BTW I had already tried unplugging the cable and restarting and plugging back in but this didn't work.  It would seem having the nvida control panel open at the time was necessary.  With any luck this would also work with the win 7 display resolution screen in much the same way.  Help this helps. 
    • Proposed as answer by Ryanssuperman Thursday, June 10, 2010 6:55 PM
    Wednesday, April 28, 2010 9:08 AM
  • Just so everyone knows: Finchy's plan works. I had this exact problem, unplugged the monitor from my tower, plugged it back in, then opened nvidia control panel which reset the monitor and the control panel's resolutions...everything is fine.

     

    Thanks alot Finchy.

    Thursday, June 10, 2010 6:55 PM
  • Okay, none of the above has worked for me while my problem seems to be quite similar.

     

    I'm running win 7 x64 with a geforce 8800GT and a dual monitor set-up. This was working good untill a few days a go. My main monitor is a BenQ e2200 which normally runs at a 1900x1200 resolution. It was recognized as the proper monitor before. But now it shows as a Generic non-PnP monitor and has a max resolution of 1600x1200, and my secondary monitor doesn't do anything anymore. I tried rerolling the drivers, uninstalling/reinstalling but nothing seems to work. I replaced my VGA cables but this also makes no difference. I can play some graphic power demanding games on the 1600x1200 resolution so i'm guessing my gfx card isn't toast either. When i try to customize my resolution manually my monitor gives me an out of range error.

    Any suggestions? Appreciated!

    Sunday, March 13, 2011 10:50 PM
  • Thanks for the quick response!

    I thought it wouldnt be possible for me to play any games in any resolution if my video card was dead.

    Sunday, March 13, 2011 11:36 PM
  • I'm having similar issues where I simply replaced the VGA cord and now my Compaa 615 won't pick up the characteristics of my 2nd monitor which is my HD Aquos TV... I went back to the store to replace the cord but still getting the non-PNP monitor issue (Before it display the name Sharp)... any ideas?

    Thanks for your help!

    Kevin

    Wednesday, September 14, 2011 12:48 PM
  • I have had a similiar issue. 

    The machine in question is a Dell Optiplex GX270 with the dreaded Intel Integrated 82865G graphics and a Yusmart monitor. 

    I installed a new copy of Windows 7 Ultimate 32bit on this machine that had been running Linux. With a 22in monitor running @ 1680x1050.

    After installation of W7, it was nessersary to install an older Dell driver for the integrated graphics, I grabbed several builds from Dell [driver here]  

    All this went nicely and I had my monitor now running @ 1680x1050 on my 82865G with full Intel Extreme Graphics 2 control panel. All was well until I installed W7 SP1 .. after rebooting my resolution had been set to 640x480 and my only choices were 1600x1200 and so on, no 1680x1050 option at all, in fact all the 1152, 1440 and so on were missing. The monitor was now registered as 'Generic Non-PnP Monitor'

    I tried to re-install the previous graphics drivers by first removing them and then going through the same process as before the SP1 update as I thought it might be the graphics drivers at fault. I right clicked on the Setup.exe after unzipping to \dell\drivers\ and ran 'Troubleshoot Compatibility' which ran without error and the drivers installed. I installed R79733, R106458, R126991 over several hours but unfortunately none proved to solve my issue, my resolutions were still set to 1024, 1280, 1600, 1900 and so forth. No 1152, 1680, 1440

    I then turned my attention to trying to locate a monitor driver for the Yusmart, which didn't go well!

    I then downloaded PowerStrip and built a custom driver for my monitor .... still no joy. 

    At this stage it was unclear whether it was my graphics card or my monitor at fault or indeed Windows. 

    As a last ditch effort I unplugged the Yusmart monitor and plugged a HP L1706 into the machine, it immediately reset the resolution correctly and registered the monitor as a generic PnP monitor. After a few minutes I plugged the Yusmart monitor back in and success, all the resolutions were available once again and my Yusmart was correctly registered as 'Generic PnP' 

    Insane, no?

    Sometimes, its the simple and all too obvious  fix that wins the day. 

     


    • Edited by Lofizz Thursday, November 03, 2011 9:48 AM
    Thursday, November 03, 2011 9:46 AM
  • Solved: After struggling a lot it seems my problem was the cable. In my case i had to use a VGA-VGA cable with a VGA-DVI-A adapter. It seems the cable i had VGA DVI-I was sending signals to the notebook. One i replace the cable with a simple VGA-VGA + adapter the monitor was immediately recognized 
    Thursday, December 29, 2011 4:44 AM
  • The most common issues with high res PnP monitors are :-

    1. Screen using Displayport interface not recognised as PnP & drops res to only 640*480.
        Solution. Power cycle the Screen. ie: Turn off power at the wall OR unplug the power at the back of the screen. This "hard reset" seems to solve a variety of other errors too.

    2. High Res screens (27" & 30") don't display the full resolution they are capable of.
        Solution. Don't use HDMI or VGA cables (even if you put a VGA-DVI adaptor). They aren't capable of reaching 2560*1440. Use only DVI or Displayport or Thunderbolt (Apple)

    3. Wrong, Old or no device driver.
        Solution. Find the latest device driver for your video card. Preferably download it from the OEM card manufacturers web site.

    So before you try a range of software solutions. First try troubleshooting via connecting with a high quality Dual DVI cable & then turn on the power at the wall. It seems to do the trick in 4 of every 5 cases.

    • Proposed as answer by DavidLean Sunday, August 26, 2012 1:09 AM
    Saturday, August 25, 2012 2:43 PM
  • 1. Power up the computer
    2. Press F2 to enter BIOS
    3. Scroll down and select INTEGRATED DEVICES (LEGACY SELECT OPTIONS) and press ENTER on keyboard
    4. Scroll down to ONBOARD VIDEO BUFFER and change value to anything other that 1 MB. e.g. change value to 8 MB. (to change the value, use the right and left arrow keys)
    5. Press ESC twice
    6. Save BIOS configuration
    7. Voilla!!!!!!!!!!!!!!
    • Proposed as answer by sETH aDU-aSARE Monday, January 07, 2013 8:42 PM
    Monday, January 07, 2013 8:42 PM
  • None of these suggestions helped me at all.  

    The problem for me was the AMD Vision control center built into my laptop.  Even though i have the HP driver installed for my monitor, the native resolution is 1920x1200 and it would only let me go to 1600x1200.

    Over VGA the vision control center did not recognize my monitor no matter what i tried.  So going into the control center you have to find your VGA display, go into properties and uncheck "use EDID(extended display identification data)".  This allows you to manually set your max resolutions available in windows control panel. Once i unchecked that, i went back into windows display properties and the option for the correct resolution was available.  Everything works as intended now. 


    Wednesday, March 13, 2013 5:00 PM
  • @ Dale Qiao

    Thanks SO much for suggesting a program that installs malware. Here I am with major screen resolution issues and you suggest a freaking bug?!

    Whoever reads this guy's post, do NOT install PowerStrip under ANY circumstances.

    Have a good life pal. Or get one at least.


    • Edited by WJTDude Monday, October 14, 2013 6:28 AM Responding to Dale Qiao
    Monday, October 14, 2013 4:50 AM
  • This is so typical for Microsoft. Windows 7 does something random for no apparent reason and it's the vendors fault.  Well I disagree: No, it's Microsoft's fault for writing shitty software.


    • Edited by Bill-777 Monday, November 11, 2013 9:42 PM
    Monday, November 11, 2013 9:40 PM
  • Because I use a KVM switch, I often see the same problem. If Windows 7 boots without my 23" monitor connected to it, it comes up as the dreaded "Generic Non-PnP Monitor" in 1600 x 1200 resolution and I am not allowed to change it to the native 1920 x 1080. The two workarounds I have found are: 1) reboot with the monitor connected, or, 2) disconnect the VGA cable for a few seconds and re-attach it. Neither procedure is very convenient.

    Tuesday, January 07, 2014 5:02 PM