none
Why does Network Discovery refuse to stay "On"? I am not able to communicate with the other systems on my network.

    Question

  • Tried it several time.  Gone into the Advanced Sharing to enable Network Discovery and after I click "Save" I go back and it's disabled.

    Why?

    This is driving me nuts.
    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansign Speakers...
    Tuesday, May 26, 2009 12:58 AM

Answers

  • Okay.

    I figured it out.

    Had nothing to do with Windows 7 at all...I think.

    It was ESET Smart Security's Firewall.

    Apparently, the Firewall's Automatic Mode setup includes some strict pre-defined rules and that is what was keeping me from seeing the other systems on the network.  I had to go into the advanced setup and change the Firewall to Automatic with exceptions (User defined rules) and add either individual IP addresses or an IP address range.  I put in a range of IP addresses and after that all the running systems on the network were included in the Network map.  Was able to set up the printer (for testing), shared a few files....everything appears to working now, network-wise.

    I had no idea that ESET Smart Security's Firewall Automatic Mode was so strict.  I installed the same thing when I had XP Pro SP3 up and running and was always able to see the other systems on the network without having to make up any custom rules.

    I've put this question up in the ESET Forum:  did ESET Smart Security set up such strict Firewall Automatic Mode rules by default or was it Windows 7 thing?
    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansign Speakers...
    Tuesday, May 26, 2009 2:50 PM

All replies

  • Your Network Type is set to Home or Work, yes?  Discovery is disabled (obvious reasons, I hope) while on a Public network.

    -Chris


    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, May 26, 2009 3:53 AM
  • I have a Home network setup.

    No public network.

    Not in a HomeGroup.

    All systems are in the same Workgroup:MSHOME
    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansign Speakers...
    Tuesday, May 26, 2009 9:54 AM
  • Okay.

    I figured it out.

    Had nothing to do with Windows 7 at all...I think.

    It was ESET Smart Security's Firewall.

    Apparently, the Firewall's Automatic Mode setup includes some strict pre-defined rules and that is what was keeping me from seeing the other systems on the network.  I had to go into the advanced setup and change the Firewall to Automatic with exceptions (User defined rules) and add either individual IP addresses or an IP address range.  I put in a range of IP addresses and after that all the running systems on the network were included in the Network map.  Was able to set up the printer (for testing), shared a few files....everything appears to working now, network-wise.

    I had no idea that ESET Smart Security's Firewall Automatic Mode was so strict.  I installed the same thing when I had XP Pro SP3 up and running and was always able to see the other systems on the network without having to make up any custom rules.

    I've put this question up in the ESET Forum:  did ESET Smart Security set up such strict Firewall Automatic Mode rules by default or was it Windows 7 thing?
    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansign Speakers...
    Tuesday, May 26, 2009 2:50 PM