none
Windows Explorer Refuses to Open Folders In Same Window

    Question

  • I have Windows Vista Ultimate SP1. Under Organize->Folder and Search Options->Browse folders I have the radio button, "Open each folder in the same window" checked. However, Vista refuses to do so and opens each folder in its own window. This does not work well for me because I end up with tons of open windows and its a pain to close them. This behaviour just started. Yesterday it did not do this. This is a fresh install with only Visual Studio 2005, Visual Studio 2008, SQL Server 2005, Expression Studio 2, Adobe CS3 and InstallAware installed.

    Also worth noting is that if I right click on a folder, the default action of Open is in bold. If I click it then it will open the folder in the same window. However, every time I double click it opens a new window.

    Please help as I really don't want to have to switch to a third party file management tool over this.

    Thanks!
    Thursday, October 09, 2008 9:00 PM

Answers

  •  

    you may try enabling the navigation pane (organize -> layouts - and enable navigation pane). with that enabled, I see things behaving as they should
    Sunday, October 12, 2008 3:35 AM

All replies

  • this is exact opposite of what i am seeing. if i right click and select open it opens in a new folder, else it opens in the same window

     

    Friday, October 10, 2008 6:10 AM
  • Yes, if you have the the Folders tree open in Windows Exporer it will default to Explore. However, if you have the Folders tree hidden it will default to Open.

    The problem I'm having is that even though it shows the correct default choice when I right click, it does not perform that action when I double click.
    • Proposed as answer by DaTechKing Wednesday, January 19, 2011 6:43 PM
    Friday, October 10, 2008 2:53 PM
  •  

    you may try enabling the navigation pane (organize -> layouts - and enable navigation pane). with that enabled, I see things behaving as they should
    Sunday, October 12, 2008 3:35 AM
  • Hi,

    Thanks for the reply. I have tried with the Navigation Panel enabled and disabled. Neither option has any effect.

    I'm convinced that is has nothing to do with the settings of Windows Explorer itself. I have two machines both of are displaying this same behavior and both have Windows Vista Ultimate with pretty much the same software installed. My first machine started doing this after a full reinstall of Vista Ultimate. I then reformatted, reinstalled Vista and tried again. After I finish installing all my software, listed above, the problem started again. A second machine which has been running fine for a year or more now, started showing this behavior after I installed Crystal Reports 2008. This makes me think it has something to do with the combination of software I'm using.

    I'm going to do some tests to see if I'm on to something. I'll post my results here. In the mean time any suggestions are welcome.

    Monday, October 13, 2008 3:06 PM
  • Hi, I solve the problem.

     

    go to register (regedit)

     

    Expand
    HKEY_USERS\S-1-5-21-3831040691-3390046849-3855596486-1000\Software\Microsoft\Windows\CurrentVersion\

     

    Find "Explorer" and delete this and your children it will be created again.

     

    Logoff and Login.

     

    It will solve problem!

    • Proposed as answer by Manuel Alves Wednesday, April 29, 2009 8:14 PM
    Wednesday, December 10, 2008 2:45 AM
  • You should try this:
    • Open regedit
    • Open HKEY_CLASSES_ROOT\Folder\shell\explore\command
    • In the Default registry key replace /separate with /same like this:
    %SystemRoot%\Explorer.exe /separate ,/idlist,%I,%L  ->  %SystemRoot%\Explorer.exe /same ,/e,/idlist,%I,%L
    • Proposed as answer by razerkid99 Wednesday, February 22, 2012 1:52 PM
    Thursday, April 09, 2009 4:52 PM
  • You diamond mkaija - been bugging me this one!! Damn IE8.
    Wednesday, April 29, 2009 5:50 PM
  • Yes, this worked for me.  Thx
    Wednesday, May 06, 2009 11:15 PM
  • Damn, this didn't work for me in Windows 7 (RTM)!
    Really frustrating, having same original problem as norad00
    Wednesday, August 12, 2009 1:53 PM
  • Hi, I solve the problem.

     

    go to register (regedit)

     

    Expand
    HKEY_USERS\S-1-5-21-3831040691-3390046849-3855596486-1000\Software\Microsoft\Windows\CurrentVersion\

     

    Find "Explorer" and delete this and your children it will be created again.

     

    Logoff and Login.

     

    It will solve problem!


    I was struggling with this for weeks.  This solution worked great for me.

    Thanks.
    Monday, September 14, 2009 6:36 PM
  •  

    I found out, that after installing SourceVault (version 3), it "corrupted" an area of the registry. Please see this forum:
    http://support.sourcegear.com/viewtopic.php?f=5&t=12332

    Solutions were to either run this command:
    regsvr32 "C:\Program Files (x86)\Internet Explorer\ieproxy.dll"

    or to put the following (in italics) in a .reg file and run it to import the contents in to the registry (which I tried first and worked for me):
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Interface\{6D5140C1-7436-11CE-8034-00AA006009FA}]
    @="IServiceProvider"

    [HKEY_CLASSES_ROOT\Interface\{6D5140C1-7436-11CE-8034-00AA006009FA}\NumMethods]
    @="4"

    [HKEY_CLASSES_ROOT\Interface\{6D5140C1-7436-11CE-8034-00AA006009FA}\ProxyStubClsid32]
    @="{A4A1A128-768F-41E0-BF75-E4FDDD701CBA}"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Interface\{6D5140C1-7436-11CE-8034-00AA006009FA}]
    @="IServiceProvider"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Interface\{6D5140C1-7436-11CE-8034-00AA006009FA}\NumMethods]
    @="4"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Interface\{6D5140C1-7436-11CE-8034-00AA006009FA}\ProxyStubClsid32]
    @="{A4A1A128-768F-41E0-BF75-E4FDDD701CBA}"

    • Proposed as answer by baker_tony Tuesday, September 15, 2009 8:54 AM
    Tuesday, September 15, 2009 8:54 AM
  • Thank you Tony, your solution worked for me!
    Saturday, October 17, 2009 1:07 AM
  • WHATEVER YOU DO, DO NOT FOLLOW THE DIRECTIONS OF SCOTTCLI. I DELETED THE EXPLORER FOLDER, AND THIS DAMAGED THE ENTIRE REGISTRY. THIS IS A VERY IMPORTANT FOLDER COME TO FIND OUT. IT TOOK ME TWO WEEKS TO FIGURE OUT HOW TO REVERSE WHAT I DID MY DELETING THE EXPLORER FOLDER. THIS SOLUTION WORKS UNTIL YOU RESTART YOUR COMPUTER. I HAD TO DO A SYSTEM RESTORE 2 WEEKS BACK UNTIL IT REPLACED MY REGISTRY AGAIN. YOU SHOULD NEVER TOUCH THE REGISTRY WITHOUT KNOWING WHAT YOUR DOING. THIS SOLUTION WAS IRRESPONSIBLE WHICH IS WHY I AM WARNING YOU NOT TO DO IT. THIS FOLDER CONTAINS EVERYTHING SUCH AS FILE EXTENSION INFORMATION ETC. BY THE WAY, IF YOU DO HAVE TO TOUCH THE REGISTRY, YOU SHOULD FIRST EXPORT IT TO A FILE AND BURN IT TO A DISK. THIS WILL BACKUP THE REGISTRY SO YOU CAN RESTORE IT. AGAIN, DO NOT FOLLOW THE INSTRUCTIONS TO DELETE THIS FOLDER!!!! I AM RUNNING WINDOWS VISTA BTW.

    NICK
    Tuesday, November 03, 2009 4:17 PM
  • Thanks a lot Tony, fixed my very annoying problem!
    Friday, November 27, 2009 7:35 AM
  • Moacir, this worked for me, but i had many errors in windows afterwards, so i restored my computer to a time before i deleted the Explorer folder i Registry.

    Are there a file in the registry or something i can delete instead? Because i think this will damage my system.

    I use Windows 7 Proffesional
    Wednesday, December 02, 2009 1:10 PM
  • Did you read the rest of the thread?
    See Tuesday, September 15, 2009 8:54 AM
    Wednesday, December 02, 2009 1:43 PM
  • thanks for solution \

    this worked for me...

    see what happens after restarting pc..

     

    Monday, April 19, 2010 7:14 PM
  • It seems nobody get the answer from Microsoft. What a shame.......
    Friday, May 28, 2010 3:53 AM
  • Hi Andy, the problem is caused by installs of software like Source Vault corrupting the registry.

    Is a shame no one from MS had a solution but the fixes in this forum do work.

    Friday, May 28, 2010 10:37 AM
  • Make Sure your "c:\Program files\Internet explorer" directory is accessible.
    Otherwise reinstall IE8

    Monday, June 21, 2010 9:49 PM
  • Make Sure your "c:\Program files\Internet explorer" directory is accessible.
    Otherwise reinstall IE8

    This help me resolve my problem.... I try to block Internet Explorer Using Comodo defense+.... After I unblock it, back to normal again....
    • Proposed as answer by ChrisProdanov Monday, December 02, 2013 9:35 AM
    Sunday, July 04, 2010 4:39 PM
  • Had this problem in Windows Server 2008 today.  Tried the simpler reg fix in the thread (from mkaija) and a regsrvr fix I found elsewhere.. all to no avail.  I then noticed a reference to IE8.  I uninstalled that, plus the associated hotfixes that come along with it and rebooted.  Problem solved.
    Tuesday, January 18, 2011 6:53 PM
  • I didn't mean to propse norad00's reply as the answer, I meant to propose mine lol.

    Well anyways, I believe I found the solution to norad00's original problem.  I had this problem for 9 months, and today I was just screwing around with the registry today after finding this thread, when I found the right value, key, and data in the registry to fix it (HKEY_CLASSES_ROOT\Folder\shell).

     

    1.  Start>Run>Type "regedit.exe"  (withoutquotes)

    2.  On the left pane of the window, double-click "HKEY_CLASSES_ROOT"

    3.  Scroll down and look for "Folder" double-click it.

    4.  Single-click "shell"

    5.  On the right pane of the window, double-click the registry string (there should only be one).  Delete anything that is in there (it should say "open" if you are having this problem), and press OK.

    That should solve your problem.

    Here is a screen shot:

    http://i34.photobucket.com/albums/d150/Reddeye69/Regedit.jpg

    • Edited by DaTechKing Wednesday, January 19, 2011 8:13 PM Fixed link.
    • Proposed as answer by DaTechKing Wednesday, January 19, 2011 8:15 PM
    Wednesday, January 19, 2011 8:05 PM
  • try running IE8 as an administrator. 

    I had the same problem and that resolved it for me after trying all the regedits/etc to no avail.

    Friday, February 04, 2011 7:24 PM
  • This solution 100% works , i made a video >> http://youtu.be/xsW1cglRE-Y
    • Proposed as answer by RAPIDComm Thursday, April 28, 2011 7:41 PM
    Tuesday, April 12, 2011 2:17 PM
  • [Download RegisterActxprxyAndIeproxy.cmd]

    100% working

    worked for me first time ----- just click the link above and open it

    BANG. PROBLEM FIXED.

    • Proposed as answer by GoodBoyRobot Tuesday, April 03, 2012 11:51 PM
    Friday, April 29, 2011 11:40 PM
  • This worked in our Windows 2008 Server box, after trying lots of regedits, etc.Thanks a lot!
    Wednesday, May 11, 2011 3:25 PM
  • [Download RegisterActxprxyAndIeproxy.cmd]

    100% working

    worked for me first time ----- just click the link above and open it

    BANG. PROBLEM FIXED.

    Monday, July 18, 2011 7:18 PM
  •  

    [Download RegisterActxprxyAndIeproxy.cmd]

    100% working

    worked for me first time ----- just click the link above and open it

    BANG. PROBLEM FIXED.

     

     Problem FIXED !!!

    Thanks a lot !

    Monday, July 18, 2011 7:20 PM
  • Thanks Tony, working for me today after I upgraded Vista to Windows 7 Ultimate. Thanks mate!
    Wednesday, July 27, 2011 5:21 AM
  • [Download RegisterActxprxyAndIeproxy.cmd]

    100% working

    worked for me first time ----- just click the link above and open it

    BANG. PROBLEM FIXED.


    thanx brother,

    i think you also faced the same problem, found the solution and then posted the solution for others. thats very nice of you. i especially registered to thank you for the solution.

    thanx again.

    Saturday, November 05, 2011 11:44 AM
  • Guys,

    This problem has been driving me nuts for weeks now. I've cruised this and several other forums, and tried every damn "fix" out there.

    WINDOWS 7 HOME PREMIUM (All updates applied)

    I've done registry edits, registered .dll files, changed folder option settings back and forth, uninstalled software, re-installed software,  etc, etc.. Ad nauseam. (I don't have IE8 or Source Gear Vault) Although both of these seem to come up often in these discussions. 

    I bumbled into something on one these forums, and    ** I FOUND THE SOLUTION!**

    1. It is very easy to do
    2. Presumably SAFE (It comes from Microsoft) 
    3. I suggest you bookmark this site for future use. (I did, and plan on using it for some of my clients computers when having weird problems)

    Go to this web site: http://support.microsoft.com/fixit/

    Then, in section 2 click on "Use desktop features, or open programs and files"

    In the window below will be a list of solutions. Simply "Run Now" the one called : Diagnose and repair Windows File and Folder Problems automatically  After running the "fixit" my problem of a new window opening all the time in Windows Explorer went away! Worked perfect!

    Ps.  In my Browser rather than running when I clicked "Run",  it downloaded the file. So I ran it locally. No big deal, they suggest doing that anyway if you need the file to run on a computer that is not online. When I ran the program I chose the second option, which is to NOT fix the problem automatically, but to see a list of repair options first. (rather than choosing to repair automatically)

    My results were two things:

    1. Rebuild my icon cache (didn't really have troubles with that anyway)
    2. Repair folder options

    I decided to let it "fix" both problems, even though I haven't had any problems with icons. After the program finished (about 20 sec) I checked and no longer had the problem of a new window opening in explorer, however the acid test was going to be will it continue to work properly after I re-boot. Guess what? PROBLEM WAS FINALLY SOLVED!

    Anyway, I hope this works for any of you guys too. I see that "some" of these other solutions worked for some of you, but none of them worked for me until I ran the "FIXIT" program from Microsoft. There is also a ton of other AUTOMATIC FIXIT's on the site for various other computer problems. I hope they all work as well as this one did! (I'll try to post this in some of the other forums, but feel free to do so yourself)

    Good luck everyone.....

    Mark

     

     

    Thursday, November 17, 2011 11:45 PM
  • I do not have that registry key in my windows 7 system
    Monday, February 13, 2012 7:51 PM
  • THAT DIDN'T WORK IT JUST BROKE MY COMPUTER!
    Saturday, February 18, 2012 1:07 AM
  • Worked for me ... very frustrating ... happend after i updated ie
    Wednesday, February 22, 2012 1:53 PM
  • This worked for me, on Windows 7 32 bit. The problem seemed to occur after a windows update. Thanks a bunch!
    Tuesday, April 03, 2012 11:52 PM
  • It worked for me. It was great
    Friday, December 07, 2012 3:49 PM
  • go to register (regedit)

     

    Expand
    HKEY_USERS\S-1-5-21-3831040691-3390046849-3855596486-1000\Software\Microsoft\Windows\CurrentVersion\

     

    Find "Explorer" and delete this and your children it will be created again.


    This is a bit like using a nuclear bomb to kill a single man. To avoid all hell breaking loose like it did for at least one poor guy who followed this advice, do the following instead.

    1. Expand this key: HKEY_USERS\<User's SUID>\Software\Microsoft\Windows\CurrentVersion\Explorer\CabinetState
    2. Select and edit the "Settings" value
    3. Clear the current value and enter the following value:   0c 00 02 00 0a 01 12 00 60 00 00 00
    4. Save the change and logoff/logon to test it.

    Note: The '0a' value above is the part of the hex that controls the setting for whether or not opening a folder launches a new window or not. This is the setting in Windows XP Professional SP3, but Windows Vista/7 should be the same. YMMV.

    When in doubt, use Process Monitor to capture registry changes while simultaneously flipping the setting in Windows Explorer. That will show you what the registry value is being set to, and is how I discovered exactly which reg value controls this setting.

    • Proposed as answer by eddieQbernard Wednesday, July 16, 2014 3:17 PM
    Friday, January 18, 2013 10:47 PM
  • that worked for me too!
    Sunday, July 07, 2013 5:46 AM
  • I agree with Nick.  

    I went WHAT??? DELETE THE WHOLE EXPLORER KEY? the moment I saw it.  DO NOT DO THIS!!! and a few more !!!!!

    • Edited by D Horse Wednesday, July 24, 2013 1:04 PM Do not delete explorer key
    Wednesday, July 24, 2013 1:01 PM
  • This solved my problem on Windows Server 2008 Standard x64.
    Friday, July 26, 2013 1:57 PM
  • Hi friends,

    I dont know is what i did right but i downloaded ieproxy.dll from internet ,copied it to internet explorer folder in program files and registered it with regsvr32. After restart then everything worked well for me. But i don't think downloading dll files like this would be trust able but that was my last shot.

    Now folder on doubleclick opens all in the same window

    Saturday, September 28, 2013 4:12 AM
  • Make Sure your "c:\Program files\Internet explorer" directory is accessible.
    Otherwise reinstall IE8

    This help me resolve my problem.... I try to block Internet Explorer Using Comodo defense+.... After I unblock it, back to normal again....
    I knew it! Comodo is the problem. And the desapering of my printers. Again Comodo...
    Monday, December 02, 2013 9:38 AM
  • Thanyou so much - really hacked off with this. Thankyou thankyou thankyou
    Friday, December 06, 2013 10:53 PM
  • thanks its working...
    Monday, December 23, 2013 3:49 PM
  • This fixed it for me:

    Unpin the Windows Explorer icon from the task bar
    and start menu, do a properties on the icon located in start-->accessories.

     paste "C:\WINDOWS\explorer.exe " over the top of the existing target (Essentially
    restoring it to default) and it worked perfectly and immediately without having to reboot.

    Monday, April 07, 2014 6:02 PM
  • Thank you worked perfectly for me
    • Edited by raycrs Wednesday, June 04, 2014 11:32 PM
    Wednesday, June 04, 2014 11:31 PM