none
LSI 1394 OHCI Compliant Host Controller

    Question

  • I have a new HP and since I installed Windows 7 my firewire will not work and the diagnostic test says the following:
    PCI LocationPCI bus 1, device 5, function 0
    1394 Bus Reset Test
    Test Started 8/6/2009 1:25:06 PM
    Warning MessageBus 0, Internal return code 0, Error code 08/6/2009 1:25:06 PM
    Test FinishedInternal Error8/6/2009 1:25:07 PM


    It worked fine in Vista Home Premium

    Here are some other specs
    -Intel(R) Core(TM)2 Quad CPU Q6700 @ 2.66GHz
    -8 GB DDR2-SDRAM (PC2-6400 / 800 MHz)
    System Board
    ChipsetIntel G31/G33/P31/P35
    SouthbridgeIntel 82801IR (ICH9R)
    ManufacturerPEGATRON CORPORATION
    ProductBenicia
    HP Model No m9340f

    Everything else passes.  Device Manager is showing the Controller installed and working properly. I checked the driver and it appears to be the most current. However I have not checked the drivers for the Mother Board and Chipset as I don't want to create more severe problems by messing with those drivers.  Like I said, all other hardware is functioning without problem.  Anyone have any ideas?
    Thank you
    Thursday, August 06, 2009 9:14 PM

Answers

  • Try changing your firewire driver. There's 3 drivers bundled in windows 7, change the driver to the one that has (Legacy) at the end of the name.
    Thursday, September 03, 2009 7:52 PM

All replies

  • Try changing your firewire driver. There's 3 drivers bundled in windows 7, change the driver to the one that has (Legacy) at the end of the name.
    Thursday, September 03, 2009 7:52 PM
  • Can you please try this on win7-RTM build (if you've access)?

    • Proposed as answer by Gene Dodge Friday, July 23, 2010 11:48 PM
    Monday, September 21, 2009 9:50 PM
  • It was tested on build 7600.
    Tuesday, September 22, 2009 12:46 PM
  • I'm sorry but I am not sure how to find that driver.  It is using 1394ohci.sys.

    I am not sure how to gain access to win RTM build 7600.  I am using build 7100
    Sunday, November 01, 2009 10:53 PM
  • Found it and installed it and PASSED.  Thank you kindly :)
    Sunday, November 01, 2009 11:04 PM
  • Glad it worked for you ;-)
    Monday, November 02, 2009 8:45 PM
  • Hi,

    I tried this thing, but it still isnt working for me :( I tried all 3 drivers. No result

    I have a new HP computer with Win7.
    Friday, November 20, 2009 3:06 PM
  • DevNi, what is your system model?
    Sunday, November 22, 2009 6:34 PM
  • http://forum.tcelectronic.com/viewtopic.php?id=3062

    "Those who are trying to get firewire interfaces working (without success) may find the following steps useful: it’s what I had to do to get mine up and running.

    Right click on the firewire host controller entry in the device manager and choose Update Driver Software…

    Browse my computer for driver software

    Let me pick from a list of device drivers on my computer

    Select 1394 OHCI Compliant Host Controller (Legacy) and then Next"

    Monday, November 23, 2009 4:04 AM
  • Try changing your firewire driver. There's 3 drivers bundled in windows 7, change the driver to the one that has (Legacy) at the end of the name.

    Hi,

    I already tried it and some other drivers to. Windows 7 Ultimate x64 manages to recognize my external drive, but after copying some bigger files the data transfer speed dops to zero and I can't abort the copying process. So it's more or less stuck until I unplug my drive.

    My FireWire interface consits of this PCI express card:
    http://www.logilink.org/showproduct/PC0036A.htm

    This is my external drive:
    http://www.lacie.com/de/products/product.htm?pid=11064

    I know that the FireWire of the drive works, because I also tested it on my old computer who has built in FireWire. When I tested the card with Vista x86 I had the same issues.

    What's wrong and how can I fix it?
    Wednesday, December 02, 2009 11:17 AM
  • Thank you very much. That fixed my issue on Windows 7 Professional 64-bit.
    Tuesday, December 08, 2009 8:40 AM
  • Wednesday, December 30, 2009 4:04 AM
  • Legacy driver worked for me, thank you!
    Tuesday, March 23, 2010 9:24 PM
  • Can anyone explain why the Legacy driver is "better" that the standard driver in this context?
    Friday, April 02, 2010 9:00 AM
  • A HP driver had finally gotten rid of my headache!

    http://h10025.www1.hp.com/ewfrf/wc/genericSoftwareDownloadIndex?cc=uk&dlc=en&lc=en&softwareitem=ob-74849-1&jumpid=reg_R1002_UKEN

    I do not have a HP computer but the driver still works!

    The legacy driver did not work for; the uninstall/install does not work for but the HP driver did!!

    Tuesday, January 25, 2011 5:45 AM