none
Windows 7 and 2008 R2 sees network shares but they are empty

    Question

  • I have a Windows 7 Pro 64bit system.  I need to access a NAS via UNC.  It sees the shares, but they are empty.  I can map a drive to the share and all files are seen.  The application requires the use on UNC.
    A Windows 2003 server can see the files inside the share with no problem.  A Windows 2008 R2 server cannot see the files either.
    I have set the MTU to 1450.  That has not helped.
    Wednesday, November 21, 2012 8:13 PM

All replies

  • There may be NAS specific problem. Give a try to NAS support forum for help.

    Here is one possibility of trouble

    https://communities.ca.com/web/ca-recovery-management-storage-global-user-community/message-board/-/message_boards/view_message/99452435;jsessionid=C787902A92968EE704E33058BB00449B.usilap723?&#p_19

    Regards

    Milos

    Thursday, November 22, 2012 7:18 AM
  • Hi,

    Does this issue occur to all network shares? Have you tried another shared folder for a test?

    What is the result when you test in safe mode with networking?

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    Thursday, November 22, 2012 8:55 AM
  • This only happens to the NAS and all shares on the NAS.  XP systems work well.  Win7 and 2008R2 systems have this issue.  Safe mode has the same results.  What I don't understand is why a mapped drive to the share works?  What is the difference?
    Friday, November 23, 2012 9:34 PM
  • Hi,

    You could try the following method to see how it works:

    Open Group Policy editor, navigate to the following path:

    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Network security: LAN Manager authentication level

     

    Change to "Send LM & NTLM - use NTLMv2 session security if negotiated".

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    Monday, November 26, 2012 3:23 AM
  • I thought you had the answer.  I made the policy change.  Rebooted.  It still fails.  I verified the setting was still in place.

    Thanx for your advice.

    Monday, November 26, 2012 4:08 AM
  • Hi,

    I would like to confirm the following questions:

    Do you mean this issue still exists?

    What is the meaning of the setting was still in place?

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    Monday, November 26, 2012 8:47 AM
  • I set Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Network security: LAN Manager authentication level Change to "Send LM & NTLM - use NTLMv2 session security if negotiated".  After rebooting, it was still set that way.  Have you ever rebooted a computer and settings changes were back to their original state?  The test failed.  I wanted to make sure the policy change was still in place.  Your next post would have been to verify this.

    It means the issue still exists.  Problem not solved.

    Monday, November 26, 2012 1:09 PM
  • Hi,

    What about using IP address to access the share?

    You can try this first,

    1. Disabled offline files caching of the share if you use this feature.

    2. In the command prompt on the file server, type in the following commands,

    netsh interface tcp set global autotuning=disabled 

    netsh interface tcp set global chimney=disabled 

    netsh interface tcp set global rss=disabled



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, November 27, 2012 10:02 AM
  • In my environment when i used FQDN for mapped drives on the NAS device it would not work properly.

    Then i switched to just to UNC without FQDN and it started working. It looks like that the NAS has it's own name resolution system that doesn't like FQDN.

    Adding this key into the combo seemed to help as well

    Hive                       HKEY_LOCAL_MACHINE
    Key path    SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    Value name  EnableLinkedConnections
    Value type REG_DWORD
    Value data 0x1 (1)
    Tuesday, November 27, 2012 2:29 PM
  • Actually, I've been using the IP address.  The problem still exists.
    • Edited by Jim Grisham Monday, December 03, 2012 1:41 AM
    Monday, December 03, 2012 1:40 AM