none
Windows Media Center Video Error

    Question

  • Whenever I try to open a video file with Windows Media Center, a message pops-up saying " VIDEO ERROR - Files needed to display video are not installed or not working correctly. Please restart Media Center and/or restart the computer." I did restart the computer, and installed my graphics drivers. It still does not work. What should I do?
    Monday, July 03, 2006 3:17 PM

Answers

  • WINDOWS MEDIA CENTER _ VIDEO ERRORS

     

    First undo any other application as being the default player, eg: Divx, ITunes, RealPlayer, Quicktime, VLC Player......

     etc  etc.

     

    search your documents find Videos and delete or move ones you do not wish to be displayed in windows media centres library.

     

    Remember Windows Media Center runs off the MEDIA PLAYER LISTINGS so do it from there. open Videos in MEDIA PLAYER LIBRARY. be sure to remove any DIVX Videos and put them in a seperate location, even though MEDIA PLAYER will play them where as WINDOWS MEDIA CENTER does not have the codec, and will have trouble creating thumbnails.

     

    Some may be experiencing a problem when going into WINDOWS MEDIA CENTER/ VIDEO LIBRARY. you will most probably see it shutdown saying it has stopped working and is trying to find a solution...well it won't it will only restart media centre again and the same thing occurs, just cancel the solution message.

     

    You have to choose whether or not you like MEDIA PLAYER OR MEDIA CENTER for your video files, i have a few divx files and vob files and avi and mpeg movies on my PC and found especially if i removed the divx, and Vob Files out of the MEDIA PLAYER / VIDEOS folder it works fine, i just use Media Player to play Divx in the MEDIA PLAYER LIBRARY.

     

    I have opened the Windows Media Center after doing this and MEDIA CENTERS VIDEO LIBRARY works fine with Mpeg, and Avi and Quicktime.

     

    However open other types with their own programs or MEDIA PLAYER ONLY.

     

     

    Monday, November 19, 2007 7:13 AM

All replies

  • Hi

    This could be that a codec neded to play the file is not installed on the system. While vista includes a dvd decoder (which earlier versions did not) A seperate 3d party decoder will still be needed to play Divx, vob or other "less standard" video files. hope this helps.

    Sunday, July 09, 2006 4:11 PM
  • Yeah, I thought of that too, but I was just trying to play a WMV file. Shouldn't Windows itself have it's Windows Media Video codec already installed?

    Weird problem, but I still can't play any video files on Windows Media Center.

    Monday, July 10, 2006 2:06 AM
  • I'm getting the exact same error from a brand new clean install.  An even more interesting thing is when I then try to play a DVD using the windows Media Player in vista, I get an out of memory error.  I'm using an HP DV6000 laptop which is an AMD DUO core TL56 running at 1.8ghz.  I have 2GB's of ram and a 100gb harddrive 42gb allocated for Vista.  Can someone please investigate this problem or speak up so that we can get it resolved?  Someone else has to be seeing the same thing. 

     

    I've tried to play Ghost Busters, Ghost Busters II All 3 of the Matrix movies, and a host of other popular DVD's including the mummy, scorpion king etc etc.

    Thursday, November 23, 2006 6:03 PM
  • Please install or upgrade my window media so i can see video
    Thursday, November 23, 2006 8:06 PM
  • Try to move your system date before 31 October 2006 and have a try. It may work.
    Friday, November 24, 2006 3:22 PM
  • Your not the only one with this problem Doc!

    Mine is doing the same thing and everytime I try to run Win Media Center to play DVDs it crashes.

    So does anyone know what is going on?

    Monday, November 27, 2006 4:32 PM
  • I'm having the same problem where I can't use Media Player to diplay any video (or recorded TV from Media Center) because it says that I'm running low on memory (but I've got 1.5 GB of memory).  I can't watch any video in Media Center (there's no sound even though the sound works for music and system sounds) and Live TV just displays an image and no sound.  I've re-installed from scratch twice (formatted the HD once) and it is still doing this.  Everything was working before and then all of a sudden about 2 weeks ago it stopped working.  Since everything was working before I don't think that it is a driver error or anything (I've tried updating everything).

    HELP!

    Friday, December 01, 2006 2:29 PM
  • Thanks jrobert39! After spending a whole day updating drivers, windows and finally resorting to the Dell Pc Restore, none of which corrected my problem, I stumbled upon your post and tried your date rollback advice. It worked. Do you know if this is something that MS is working to correct or is there something on my system messing things up? Is there a setting I can adjust instead of leaving my computer set in October? I find myself frustrated with this since my Dell DimensionE510 WinXP MediaCenter is only 4 months old. I bought it specifically for the media center to watch DVD's and that magically stopped functioning on Dec 1. I don't know how this forum works but if you have any further info you wouldn't mind sharing my email is wolf42f at yahoo.com. Thanks again, you saved me from another day of messing around with this computer.
    Saturday, December 02, 2006 7:46 PM
  • I am having exactly the same problem too!

    Sunday, December 03, 2006 9:38 PM
  • The Media Center codec provided in Windows Vista RC1 and RC2 has expired.  That's the reason you are getting this error message and the reason Media Center works just fine if you roll your system clock back to an earlier date.  I've not come across a solution other than waiting for the RTM version to hit the store shelves the end of this month.  I've read that the RTM version includes a codec that doesn't expire.
    Saturday, January 06, 2007 1:09 AM
  • After Reading the forums, Someone gave me a little idea to try out. I Installed Cyberlink PowerDVD v7.2.. And hey presto, DVD and Live TV now work on my Vista RC2 Windows Media centre. I was having the same decoder error in Media Centre as everyone else was describing. I know that PowerDVD isn't free unless OEM, however, it is a short term fix, as it installs it's own Decoders etc ;)

     

    Hope this helps some others out... My hardware for your infor:

    AMD 64 3200+ (running Vista 32bit RC2)

    Pinnacle Studios 300i DVB-T Card

    Using Windows XP MCE drivers for card.

    :)

     

    Mikey

    Thursday, January 18, 2007 2:05 PM
  • Playing movies in the Vista media centre on the pc work fine BUT

     

    when I try to play them through an extender (xbox 360 in this case) i get this error message on the xbox.

     

     I convert the files to one that works with the xbox, Videora, that worked perfectly fine with XP and media center 2005.

    You can play them on WMP and WMC on the ost PC but when trying to play them through media centre on the Xbox you get this error message.

    I connect via wireless from xbox to PC and it is a very good signal. As I say this worked previously on XP but not now.

     

     

     

     

    Monday, September 17, 2007 5:42 PM
  • Someone please let me know what to do?

    Monday, November 19, 2007 4:24 AM
  • WINDOWS MEDIA CENTER _ VIDEO ERRORS

     

    First undo any other application as being the default player, eg: Divx, ITunes, RealPlayer, Quicktime, VLC Player......

     etc  etc.

     

    search your documents find Videos and delete or move ones you do not wish to be displayed in windows media centres library.

     

    Remember Windows Media Center runs off the MEDIA PLAYER LISTINGS so do it from there. open Videos in MEDIA PLAYER LIBRARY. be sure to remove any DIVX Videos and put them in a seperate location, even though MEDIA PLAYER will play them where as WINDOWS MEDIA CENTER does not have the codec, and will have trouble creating thumbnails.

     

    Some may be experiencing a problem when going into WINDOWS MEDIA CENTER/ VIDEO LIBRARY. you will most probably see it shutdown saying it has stopped working and is trying to find a solution...well it won't it will only restart media centre again and the same thing occurs, just cancel the solution message.

     

    You have to choose whether or not you like MEDIA PLAYER OR MEDIA CENTER for your video files, i have a few divx files and vob files and avi and mpeg movies on my PC and found especially if i removed the divx, and Vob Files out of the MEDIA PLAYER / VIDEOS folder it works fine, i just use Media Player to play Divx in the MEDIA PLAYER LIBRARY.

     

    I have opened the Windows Media Center after doing this and MEDIA CENTERS VIDEO LIBRARY works fine with Mpeg, and Avi and Quicktime.

     

    However open other types with their own programs or MEDIA PLAYER ONLY.

     

     

    Monday, November 19, 2007 7:13 AM
  • Digital Media Tech that didn't help. I'm still looking for a solution for this. Anyone? So freakin annoying!!
    Saturday, December 08, 2007 11:30 AM
  • This may help you, at first i was not having problem with using most of the video and Internet TV.  Then i had to move and i had to save most of my files to my hard drive and when i did that for some reason the Windows Media Center would not work.  I when to a Tech center and they said that i didn't have any thing wrong with it and that very thing work fine, but when i went back home the Windows Media Center didn't work. So i took my other hard drive out and was going to up grade my music, the reason was that i but more music on my hard drive.  So i took al my music and picture/video picture and put they all on the other hard drive and for some reason the Windows Media Center is working.  In my opinion i think if you move all of your videos and picture videos that you made to another folder other then My picture, My Videos, My Music, or My documents then it should work. Or you can do what i did and my another drive and put all of your videos and Music on it.
    Tuesday, January 08, 2008 3:01 AM
  • I downloaded this program for $20.  After I installed it the Media Center video started working again.

    http://www.nvidia.com/object/dvd_decoder.html

     

    NVIDIA® PureVideo™ Decoder software, a plug-in for Microsoft® Windows® Media Player and Media Center Edition.
    Friday, February 08, 2008 6:30 AM
  • The same problem happened to me some random day media player and media center just decided to stop playing DVDs and tells me that there is a DVD error while the DVD plays fine in other players... I wish we could just reset media center or update its mpeg 2 drivers.
    Thursday, March 20, 2008 3:53 AM

  • I just reformatted my hard drive on a dell inspiron 1521 and now Media Center doesn't work.  Also, media player has a hard time keeping up with movie files.  It is fine if I don't display it in full screen, but once I go into full screen it gets really jerky.  After reformatting my graphics rating in the windows experience index has dropped from somewhere around 3.2 to 1.0 with no explainable reason, and I've downloaded all the latest drivers.  In media center, every file I run tells me that the files needed to display the video or not there or not working.

    Any help would be awesome!




    Wednesday, April 09, 2008 9:05 AM
  • Please try to install or re-install the Display Card Driver.

    Sunday, April 20, 2008 8:42 AM
  • Does anyone know what Codec is neede to run VOB files from the hard disc.  I have downoladed Codec packages that have a warning to uninstall applications that run with Codecs - then I guess reinstall them.  Not only do I not know all the applications, this seems to be an extraordinarily complex solution.  If I know whose codec pack would enable this feature, I prefer to surgically add the ones I need.

     

    Wednesday, August 27, 2008 7:36 PM
  • I have FFDSHOW and Vista Codec Pack installed and I can play VOB files in both Realplayer and Media Center.

    http://www.softpedia.com/get/Multimedia/Video/Codec-Packs-Video-Codecs/Advanced-Vista-Codec-Package.shtml


    Wednesday, August 27, 2008 8:21 PM
  • I had a customer with the same problem and here's the fix for her issue. She had been saving TV shows to the point of her disk becomming full (140 megs of free space left) I deleted 5 gigs of video, restarted Media Center and all worked fine. Of course I used the Windows XP Decoder checkup utility to verify I had the proper codec installed as most forums pointed to this as the fix.
    Sunday, December 07, 2008 8:55 PM
  •  I am having this problem on my Xbox 360 extending Media Center 2005.  So far it has only happened with one channel in HD.  I am watch the program after it has been fully recorded.  When it shows up on the screen all I have to do is hit play and it will start playing again.  Also, while I am watching the screen will go black for a second and then come back with audio returning delayed.  Any ideas?

    GX2
    Thursday, March 05, 2009 7:15 PM
  • I get the same error but may be due to a different reason. Seems like this is a broad generic error that MCE puts out when things don't work for it.

    I have an Intel MB with G33 gpu. It uses the system ram for processing. I can set it up to 256MB.

    When I start the Vista WMC it gives me a warning that WMC requires a minimum of 64MB RAM for the graphics card. Then when say OK, it lauches itself. And then when I try to play or record it gives me the Video error.

    What I do to make this work is reboot, goto BIOS, change the G33 settings (some times I set the RAM to 128MB sometimes 256MB & sometimes I change other G33 setting). So Windows thinks that a new graphics card has been added and when WMC starts I don't get the 64MB limitation warning. But after working for some time or days, WMC reportes that the recording couldn't be done because TV signal is not available and restart WMC. On a restart I start getting the dreaded generic "Video error".

    As a last resort I may have to buy a dedicated HD graphics card to see if the video error goes away. Right now I don't want to do that because G33 is a very good on board graphics controller (even for HD content).

    Does WMC have a log I can look at for errors?

    Aside, I have a fast core 2 duo  pentium processor and an equally good intel motherboard. Around 600 GB of hardisk space free and 2GB RAM.
    • Edited by SochGuru Saturday, May 09, 2009 10:38 PM server specs.
    Saturday, May 09, 2009 10:33 PM
  • I Have an Acer 8920g " VIDEO ERROR - Files needed to display video are not installed or not working correctly. Please restart Media Center and/or restart the computer."
    1 check your vidoe card (make sure it the one that came with your computer and not a copy windows use to display)
    I have an nvida card windows placed a stander card causing the video not to work.
    2 Check your ethernet control for it id name and not stander control
    Download all your driver by name.ie Nvida 9500ms card and it works out find for me
    Wednesday, November 18, 2009 6:19 AM
  • This will fix your problem:

    http://sourceforge.net/projects/ffdshow-tryout/files/ (be sure to download for your correct platform, i.e. x64 if you have 64-bit)

    It enables divx among other 3rd party video codecs within windows media center.  Part of the problem is that media center crashes when it tries to load thumbnails for any divx movies, as it can't play them by default.  This plugin will fix the thumbnails as well as let you play the divx files.

    Once you have installed the ffdshow, you may also want to download and install this nifty plugin: http://damienbt.free.fr/index.php , which will improve video quality, and add features such as fast forward/rewind, resume, switch subtitle streams, etc. for ANY video format within media center.


    best of all, its all FREE!!!

    *sparx*
    • Proposed as answer by limesparks Saturday, February 20, 2010 8:27 AM
    Saturday, February 20, 2010 8:27 AM
  • Limesparks,
     This was the solution that I have been looking for. This not only allows divx and much more in Windows 7 Media Player, but also MTS (AVCHD) files.
    Thanks so much for the valuable help.

    jlynnwatts
    Wednesday, March 03, 2010 12:41 AM
  • Hi Sparx

    Great information..being fairly new when I went to
    http://sourceforge.net/projects/ffdshow-tryout/files/ I saw several different files and requirements. I am just a little confused over which of these files I need for Windows 7 64 bit. One of the hi lite files at the top for 64bit, or one of the many beneath the 2 hilited? One file is over 1gb in size.

    In anticipation of a reply

    Thanks

    Stu

    Friday, June 11, 2010 1:34 AM
  • I bought an XP MCE 2005 at a Garage Sale, in the process of running every Windows update available I installed Media Player 11.  This overwrote all media files as defaulting to open in Media PLAYER.  I went into Folder options - and any file that was set to open in Media PLAYER I changed to default to Media CENTER. 

     

    This worked.  I believe the two most important extentions are the two that start with DVR.

     

    Hope this works for all of you.

    Friday, July 16, 2010 2:08 AM
  • I have a Vista 32 Media Center, and it had developed a problem (after removing a codec) where accessing "My Videos" would cause a crash. As above, I set Windows Media Center as the default player for .avi (they are all divx) and the problem went away. Before that I had tried many different codecs, system restores, updates, etc. Thanks to all for your suggestions, a simple fix for a frustrating problem.
    Tuesday, July 20, 2010 12:15 PM
  •  I had this issue with my xbox media center extender going to my Vista Ultimate 64 when trying to watch recorded tv. The error was the one in the original title of this thread. Video error.....files needed to display etc etc.

    I worked on this for 2 days and finally I looked in my system log on the Vista machine and found an error at the exact time the error came up on the xbox. 

    I found it in the event viewer and it was this.....

    Log Name Application

    Source LoadPerf

    Event ID 3001

    That was all I needed to track this and get an answer. Below is the fix.

    Details
    Product: Windows Operating System
    Event ID: 3001
    Source: LoadPerf
    Version: 5.2
    Symbolic Name: LDPRFMSG_REGISTRY_COUNTER_STRINGS_CORRUPT
    Message: The performance counter name string value in the registry is incorrectly formatted. The bogus string is %1!s!, the bogus index value is the first DWORD in Data section while the last valid index values are the second and third DWORD in Data section.
       
    Explanation

    All performance counter names and explain text are maintained in string tables managed by the performance counter subsystem (Perflib).

    The current contents of the performance counter string tables are corrupted and cannot be displayed. To correct the problem, rebuild the string tables.

       
    User Action

    To rebuild the string tables, on the computer that displayed the message, at the command prompt, type Lodctr /r
    The contents of the string tables are automatically rebuilt.

    For more information about the Lodctr command, see Help and Support.

     

    You have to run command prompt in administrator mode and just type in what it says. It takes about 10 seconds to reply and then it will work perfectly.

    The xbox is playing recorded and live tv now through the media extender from my Vista machine that has archived the recorded tv to a WHS server. It runs perfectly.

    Hope this helps someone with the same problem.

     


    Old Guy
    Friday, March 18, 2011 2:21 AM
  • Im not very computer savy so how do I undo other applications as being default players?
    Monday, October 17, 2011 9:38 PM