none
Virtual PC cannot create any virtual machines after install

    Question

  • Installed KB958559-x64, I see Windows virtual PC in the start menu, click on Virtual Machines and there is no option to Create a virtual machine from the toolbar.

    Am I missing something?

    Installed on a Dell Latitude E6500, on Win7 x64 RC.

    Saturday, July 04, 2009 9:10 AM

Answers

  • Also have you done upgrade from Vista? This is known issue in that case. To fix do following

    Copying following content to a file. Save it as .reg

    ================
    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU]

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags]

    [-HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\BagMRU]

    [-HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\Bags]

    [-HKEY_CURRENT_USER\Software\Classes\Local
    Settings\Software\Microsoft\Windows\Shell\BagMRU]

    [-HKEY_CURRENT_USER\Software\Classes\Local
    Settings\Software\Microsoft\Windows\Shell\Bags]
    ===============

    Run this reg file, restart the Windows 7. This should fix it.
    Thanks, -Vinod -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Saturday, July 04, 2009 5:36 PM
    Moderator

All replies

  • If you go to your Contacts folder, do you see "New Contact" in toolbar? Meanwhile you can do "Create Virtual Machine' wizard by running "%windir%\System32\VPCWizard.exe".


    Thanks, -Rahul -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Saturday, July 04, 2009 12:38 PM
  • Also have you done upgrade from Vista? This is known issue in that case. To fix do following

    Copying following content to a file. Save it as .reg

    ================
    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU]

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags]

    [-HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\BagMRU]

    [-HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\Bags]

    [-HKEY_CURRENT_USER\Software\Classes\Local
    Settings\Software\Microsoft\Windows\Shell\BagMRU]

    [-HKEY_CURRENT_USER\Software\Classes\Local
    Settings\Software\Microsoft\Windows\Shell\Bags]
    ===============

    Run this reg file, restart the Windows 7. This should fix it.
    Thanks, -Vinod -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Saturday, July 04, 2009 5:36 PM
    Moderator
  • Installed and restarted the system, right?
    Thanks, Praveen "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Sunday, July 05, 2009 7:30 AM
    Moderator
  • I have the same issue (the virtual machines folder lost it's special state)  and this fix didn't help.
    Sunday, October 18, 2009 11:55 AM
  • Have you checked what it looks like if you create another Administrative user rather than using your current one?

    Try running ChkDsk to check your drive for errors. Right-click your Drive icon/ Properties/ Tools/ Error Checking.  Try it first by not checking either box (this will run it in a Read-only mode) to see if it flags any hard drive or file problems.  If it does, restart  it by ticking both boxes, and rerun it to allow it to attempt to fix any found problems.
    Sunday, October 18, 2009 6:33 PM
  • If you go to your Contacts folder, do you see "New Contact" in toolbar? Meanwhile you can do "Create Virtual Machine' wizard by running "%windir%\System32\VPCWizard.exe".


    Thanks, -Rahul -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."


    Hi Rahul,

    I have this same problem, however, I did not upgrade from Vista, I did a clean install.
    I checked the "Contacts" folder under my profile, and NO I DO NOT HAVE THE BUTTON for "Create a New Contact"

    thanks for your help,
    Paul

    humpty dumpty is sleepy
    Wednesday, November 11, 2009 10:04 PM

  • Do you have the Button for "New Contact", not "Create....."?  What Buttons do you have?


    How to repair the operating system and how to restore the operating system configuration to an earlier point in time in Windows Vista
    http://support.microsoft.com/kb/936212/#appliesto







    What version of Virtual PC are you using, Virtual PC 2007, or Windows XP Mode?  Or which version of Windows 7 are you running?

    See if Control Panel/ Folder Options/ View "Reset Folders" gets your "Create Virtual Machine" option back?


    If you like and it is only a recent problem, using System restore might bring back the "Create Virtual Machine" option.

    Otherwise you may have to live with the missing option until the next time you install Windows 7 but you can try this workaround.

    vpcwizard.exe  typed in the Start Search, or Start Run box, should give you access to the Create Virtual Machine Wizard.

    Virtual PC cannot create any virtual machines after install
    http://social.technet.microsoft.com/Forums/en/w7itprovirt/thread/24ae635f-41a7-4c50-bcae-81cba3112b32

    Windows Virtual PC: Unable to create new virtual machines
    http://social.answers.microsoft.com/Forums/en-US/w7programs/thread/0768cebb-b8ce-4f9a-b2d1-f02cc910539e

    How to Create a Virtual Machine in Windows Virtual PC
    http://www.sevenforums.com/tutorials/8254-windows-virtual-pc-create-virtual-machine.html

     

     

    Thursday, November 12, 2009 4:44 AM
  • Hi Linney,

    ANSWERS to your Q's:
    • I did not have any of the special buttons on explorer, in any folder
    • I'm on win 7 enterprise
    • I had clicked on vpc (not the xpm object) from the start menu, which of course opened explorer to the dir
      "C:\Users\[my acct, a mem of local admins]\Virtual Machines"
    • vpcwizard.exe was running fine, but I wanted the explorer toolbar buttons
    • so I imported the reg keys (per above comment) and now all toolbar buttons are back

    ====================================

    On a totally different note, here is what may have caused my problem.
    I imported a reg file that fixed alot of my headaches in explorer when I was on Vista.
    This is what I like to see in explorer:

    DETAILS view, with SORT by name & GROUP by type
    -----------------------
    FOLDER A <---------------AT THE TOP NO MATTER WHAT
    FOLDER B <---------------AT THE TOP NO MATTER WHAT
    FOLDER C <---------------AT THE TOP NO MATTER WHAT
    ...
    FOLDER Z <---------------AT THE TOP NO MATTER WHAT
    -----------------------
    file type 1 with name beginning in A
    file type 1 with name beginning in B
    file type 1 with name beginning in C
    ...
    file type 1 with name beginning in Z
    -----------------------
    file type 2 with name beginning in A
    file type 2 with name beginning in B
    file type 2 with name beginning in C
    ...
    file type 2 with name beginning in Z
    -----------------------
    file type 3 with name beginning in A
    file type 3 with name beginning in B
    file type 3 with name beginning in C
    ...
    file type 3 with name beginning in Z

    ============================================

    Bottom line, is that in Vista, I used the below reg import to fix the F-ed up auto-sorting:
    (folder settings would often "switch" back to their preferred state, even after I hit "apply to all folders")

    ============================================
    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\BagMRU]
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\Bags]
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU]
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags]

    [-HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\BagMRU]
    [-HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags]

    [HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell]
    "BagMRU Size"=dword:00004e20

    [HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags\AllFolders\Shell]
    "FolderType"="NotSpecified"
    ============================================

    I sure wish there was an ezy reg fix for Win 7, like the above that I used for Vista.
    I don't want to make a bunch of templates, and besides, they don't work for lots of system dir's

    Best Regards,
    Paul


    humpty dumpty is sleepy
    Thursday, November 12, 2009 7:37 PM
  • Funny...  The way I ready it, that registry fix IS for Win7.  But the assumption was that it was Win7 from a Vista upgrade.

    Nevertheless, I gave it a try, and it worked.  I got back all the missing buttons in Explorer using it when nothing else worked.

    Thanks Vinod!

    - Dayton - Sat. 11/14/2009 @ 09:24:30

    Saturday, November 14, 2009 4:24 PM
  • I too had this problem.  I ran the registry update and it worked.  Thank you!

    Config:
    Upgrade from Vista Ultimate x64 to Windows 7 Pro x64, clean install, used Windows 7 Easy Transfer Wizard to backup and restore data.
    Wednesday, December 30, 2009 5:33 PM