none
Keyboard won't work in Windows 7 if I touch the touchpad after being in Ubuntu

    Question

  • Problem: After being in ubuntu and rebooting into windows 7 all is fine in windows until I touch the touchpad.

     If I touch the touchpad at all, I am not able to type anything at all in windows.

    If I boot in, and just use the usb mouse, that's ok it always works fine, and the typing is fine...until I touch the touchpad!

     
     If I reboot a 2nd time then everything is normal.

    This is a fresh install on windows 7 with ubuntu 9.04. Anybody have any clue at all why this is happening??
    Monday, November 30, 2009 5:00 PM

Answers

  • Hi Dale,

    It doesn't happen in Ubuntu. I came to a workaround. I downloaded the dell support utility and it had an option for disabling the trackpad when a mouse is present, so I did that. The only caveat is that when typing in my password I have to be careful not to touch the touchpad, but after I'm at the desktop I can without consequences. Someone on the ubuntu forums said they have the same problem and just have to live with it.

    I also went into the device manager and don't see any option for the touchpad.

    Marc
    Thursday, December 03, 2009 1:54 AM

All replies

  • Have you tried uninstalling then reinstalling the latest touchpad driver for your laptop?


    Monday, November 30, 2009 11:36 PM
  • No but I will try that now.
    Tuesday, December 01, 2009 11:40 PM
  • TrekDozer is right, it can be related to incompatible touchpad driver in Windows 7. Please go to manufacturer's website for the updated driver. If the manufacturer hasn't released any Windows 7 compatible driver, though I can't guarantee, you may try to install Windows XP/Vista driver in Windows Compatibility mode.

    BTW, what is the computer specification? Does this issue occur in ubuntu?

    Best Regards
    Dale

    Wednesday, December 02, 2009 6:39 AM
    Moderator
  • Hi Dale,

    It doesn't happen in Ubuntu. I came to a workaround. I downloaded the dell support utility and it had an option for disabling the trackpad when a mouse is present, so I did that. The only caveat is that when typing in my password I have to be careful not to touch the touchpad, but after I'm at the desktop I can without consequences. Someone on the ubuntu forums said they have the same problem and just have to live with it.

    I also went into the device manager and don't see any option for the touchpad.

    Marc
    Thursday, December 03, 2009 1:54 AM