none
RDP from Windows 8 to 2011 Standard RWW

    Question

  • I have 2 machines, 1 running Windows 8 and the other running Preview 8.1.  Both fail connecting via RDP through a 2011 Standard RWW web portal.  I CAN Connect via Win 7 with IE9 & XP with IE8 using the same login credentials so RWW is working.

    From Windows 8 & IE10, I can login to RWW, choose the PC, choose the workstation, pop up for login, I provide my confirmed working credentials, and then it bounces back with "Your computer can't connect to the remote computer because the Remote Desktop Gateway server is temporarily unavailable.  Try reconnecting later or contact your network administrator for assistance."  From Windows 8.1, I can login to RWW, choose the PC, but it immediately comes back with the same message before even requesting credentials.

    YES, I found other forum posts dealing with this issue, the 1 was closed to new comments (from Jan 2013) and the rest did not fix the issue.  I am listing the fixes I have tried, but the fixes didn't help.  Please do not post a link to forum posts that have any of these as a fix.

    Here is what I have tried as suggested from other posts:

    • Change IIS default site to use Anonymous Authentication only - Did not fix
    • Put the rww domain into compatibility View in IE10 & 11 on the client system - did not fix
    • Put the https://remote.domain.org into the Trusted sites in IE settings on the client system - did not fix
    • I found an article about RDP connections within GPO, but the path/setting is not available on 2011: Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Connection Client.

    I believe this is IE10+ issue, but am posting in this forum as maybe this is an overall Win 8 RDP issue?  IE10 is updating automatically now, and Windows 8 is being used more, I need a fix ASAP.

    Tuesday, September 10, 2013 6:50 PM

Answers

  • Hi,

    Regarding current situation, it may be caused by firewall settings in Windows 8:

    Please follow these steps to check firewall settings:

    Please follow these steps to check firewall settings: 
    1.       Open Windows Firewall by swiping in from the right edge of the screen, tapping Search (or if you're using a mouse, pointing to the upper-right corner of the screen, moving the mouse pointer down, and then clicking Search), entering firewall in the search box, tapping or clicking Settings, and then tapping or clicking WindowsFirewall.
    2.       Tap or click Allow an app or feature through Windows Firewall.
    3.       Tap or click Change settings.   You might be asked for an admin password or to confirm your choice.
    4.       Under Allowed apps and features, select Remote Desktop, and then tap or click OK.

    Please also try steps here:

    Fix IE10 and SBS 2008 RWW error

    http://kwsupport.com/2013/04/fix-ie10-and-sbs-2008-rww-error/

    Also, I suggest we try to update all certificate for Windows 8 to check the results:

    Windows Root Certificate Program members

    http://support.microsoft.com/kb/931125/en-us

    Please let me know what’s going on.

    Keep post.


    Kate Li

    TechNet Community Support

    • Marked as answer by DJ Debugger Tuesday, September 24, 2013 9:52 PM
    Wednesday, September 11, 2013 1:45 PM
    Moderator

All replies

  • Hi,

    Regarding current situation, it may be caused by firewall settings in Windows 8:

    Please follow these steps to check firewall settings:

    Please follow these steps to check firewall settings: 
    1.       Open Windows Firewall by swiping in from the right edge of the screen, tapping Search (or if you're using a mouse, pointing to the upper-right corner of the screen, moving the mouse pointer down, and then clicking Search), entering firewall in the search box, tapping or clicking Settings, and then tapping or clicking WindowsFirewall.
    2.       Tap or click Allow an app or feature through Windows Firewall.
    3.       Tap or click Change settings.   You might be asked for an admin password or to confirm your choice.
    4.       Under Allowed apps and features, select Remote Desktop, and then tap or click OK.

    Please also try steps here:

    Fix IE10 and SBS 2008 RWW error

    http://kwsupport.com/2013/04/fix-ie10-and-sbs-2008-rww-error/

    Also, I suggest we try to update all certificate for Windows 8 to check the results:

    Windows Root Certificate Program members

    http://support.microsoft.com/kb/931125/en-us

    Please let me know what’s going on.

    Keep post.


    Kate Li

    TechNet Community Support

    • Marked as answer by DJ Debugger Tuesday, September 24, 2013 9:52 PM
    Wednesday, September 11, 2013 1:45 PM
    Moderator
  • Firewall was set on Win 8 to allow Remote Desktop App.

    The Fix IE10 and SBS 2008 RWW error link you sent me to speaks of using compatibility for IE10, as I stated I already did this.

    I updated the Windows Root Certificates via http://support.microsoft.com/kb/931125/en-us.  I had to close IE, then re-open, and this did fix my issue.  BUT I tried from the another Win 8 machine and it wouldn't open as I did not do the patch.

    Is there a possible server side fix or a way to push these Root Certs?  Clients use this RWW connection and to have to modify each Win 8 machines that comes into the OU or personal/public machine they might use unknowning if there connection will work unlike Win7 is disconcerning.


    • Edited by DJ Debugger Friday, September 13, 2013 6:03 AM results changed
    Friday, September 13, 2013 5:55 AM
  • Hi, 

    In order to better serve you, please contact Small business server support for help. 

    http://social.technet.microsoft.com/Forums/en-US/home?forum=smallbusinessserver

    Thanks for your cooperation.

    Kate Li

    TechNet Community Support

    Saturday, September 14, 2013 3:08 PM
    Moderator