none
Homegroup connect IPv6 no network connectivity

    Question

  • Laptop & Desktop using Win7, cannot connect to Homegroup on the desktop because IPv6 is not enabled.  I check the adapter and it shows a checkmark next to IPv6 protocol yet the troubleshooter tells me I need to enable IPv6.  What am I not doing correctly?
    • Moved by Novak Wu Monday, November 09, 2009 6:02 AM (From:Windows 7 Miscellaneous)
    Saturday, November 07, 2009 8:21 PM

Answers

  • Hi,

     

    Based on my research, I would like to explain that IPv6 was depended on by the RNRP service. To troubleshoot the issue, let's refer to the following steps.

     

    1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

     

    2. Verify relevant services

    =========================

    a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Networking Grouping" service and choose Properties.

    c. Please check if the service is started; if not, please click the Start button and see if it works.

    d. You may also choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps with another service: PNRP Machine Name Publication Service.

     

    3. Modify IPv6 registry key to enable IPV6

    ==========================

    a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

     

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue. 

     

    b. Locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

     

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

     

    d. Double click the "DisabledComponents" registry key and modify the value to 0.

     

    (If the key doesn't exist, please create the key above and assign the value 0)

     

    e. Exit Registry Editor, and then restart the computer.

     

    For more information, we can refer to the link below:

     

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

     

    Thanks,

    Novak

     

     

    • Marked as answer by Novak Wu Monday, November 16, 2009 2:17 AM
    Monday, November 09, 2009 6:00 AM

All replies

  • Open regedit and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters
    If you have a key labeled DisabledComponents delete it. Reboot your computer after removing it and see if it works.
    Saturday, November 07, 2009 9:22 PM
  • Hi,

     

    Based on my research, I would like to explain that IPv6 was depended on by the RNRP service. To troubleshoot the issue, let's refer to the following steps.

     

    1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

     

    2. Verify relevant services

    =========================

    a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Networking Grouping" service and choose Properties.

    c. Please check if the service is started; if not, please click the Start button and see if it works.

    d. You may also choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps with another service: PNRP Machine Name Publication Service.

     

    3. Modify IPv6 registry key to enable IPV6

    ==========================

    a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

     

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue. 

     

    b. Locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

     

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

     

    d. Double click the "DisabledComponents" registry key and modify the value to 0.

     

    (If the key doesn't exist, please create the key above and assign the value 0)

     

    e. Exit Registry Editor, and then restart the computer.

     

    For more information, we can refer to the link below:

     

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

     

    Thanks,

    Novak

     

     

    • Marked as answer by Novak Wu Monday, November 16, 2009 2:17 AM
    Monday, November 09, 2009 6:00 AM
  • I have the same problem.  I have 4 home computers at win7 home premium and 3 I can get to join.  But one I get the "TCP/IPv6 not enabled" even though the property is checked for the adapter. I have tried all the steps in Novak's posting with the same result?  Any suggestions
    Bob
    Sunday, December 06, 2009 9:27 PM
  • Thank you this fixed the issue and I can now use the Homegroup.
    Thursday, December 17, 2009 3:48 AM
  • Open regedit and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters
    If you have a key labeled DisabledComponents delete it. Reboot your computer after removing it and see if it works.
    Pasha11's advice fixed my issue
    Thursday, December 17, 2009 3:51 AM
  • Of all the suggestions on the net on how to fix the ridiculous problem, this was the only solution that worked.
    After 10 hours for research and trying I finally have a home network that works very well. Thank you, you have no idea how happy you have made me. However it really should not be this hard with all the so called experts at MS and their flashy new Win7. Don't get me wrong, I really like the operating system but it just shouldn't have such basic bugs especially when the hype for Win 7 Pro is that it makes networking easy! If this is easy I would hate to see tough.
    Thank you again Novak. I have no idea how you came up with the solution and tell who ever is paying you, you are worth more money
    Sunday, January 24, 2010 5:31 AM
  • Well, it seems I was somewhat premature in my excitement.
    When I rebooted yesterday all the regestry entries had been changed back and needed changing again,
    However the changes don't last, something goes in and changes them back even after having deleted
    the whole line, it magically returns. So back to square one with no local network.
    Internet is fine with good speeds just the PC and 2 laptops can't stay in contact.
    I did have them seeing each other for a while but after a while it changed.
    Monday, January 25, 2010 9:14 PM
  • Hello,

    is anyone reading this? I am getting no where with this and Google and Forums have heaps of suggestions but no answers.

    I went to the trouble of installing Network magic pro and after initial success I am now back to square 1.

    It worked well for a while but once I rebooted both the PC and laptop no luck. They could see the other computer was there but could not access it. Internet was fine so modem router is working fine. I tried a second one just inn case. I took my laptop around to another firends place who has a homegroup running and I could join it just fine?? Crazy huh??

    I uninstalled both Zone Alarm and AVG antivirus both resulted in the same problems. I ran spyware adware malware antivirus you name it I have run and checked it.
    Being new computers I doubted there would be anything wrong. This fault is now on 2 PC's and 3 laptops most of which are Brand new.

    I am planning on contacting MS locally by phone, is about my last hope.
    Wednesday, January 27, 2010 11:19 AM
  • Just in case anyone is reading this and I can help here I hope finally is the solution.

    After 2 hours working through a process of elimination, it seem it is Zonealarm that is continually changing the registry setting after you apply the change above.
    thus re-introducing this frustrating problem.

    In the end it was just 2 things we had to do in Win 7. Uninstall ZA not just disable it. Looks like until ZA fix this issue I will have to rely on Win 7 Firewall.
    Secondly when accessing the regedit area do so as administrator using the following method. I assumed I was always logged in as administrator but for a lot of the system
    programs you need to "Run as administrator. Click on the start button type in regedit it the "Search programs and files" area find the link in the pop up screen and right mouse click on it and click on "Run as administrator" This was the system will retain the changes you make as per the instructions above. So far now all is good. Fixed my friends computers as well.

    Thank you to the friendly patient Local Microsoft technition.
    Thursday, January 28, 2010 8:36 AM
  • Hi,

     

    Based on my research, I would like to explain that IPv6 was depended on by the RNRP service. To troubleshoot the issue, let's refer to the following steps.

     

    1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

     

    2. Verify relevant services

    =========================

    a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Networking Grouping" service and choose Properties.

    c. Please check if the service is started; if not, please click the Start button and see if it works.

    d. You may also choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps with another service: PNRP Machine Name Publication Service.

     

    3. Modify IPv6 registry key to enable IPV6

    ==========================

    a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

     

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue. 

     

    b. Locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

     

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

     

    d. Double click the "DisabledComponents" registry key and modify the value to 0.

     

    (If the key doesn't exist, please create the key above and assign the value 0)

     

    e. Exit Registry Editor, and then restart the computer.

     

    For more information, we can refer to the link below:

     

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

     

    Thanks,

    Novak

     

     

    Thanks Novak you are a genius I have been trying to sort this out for months. 

     

    Monday, May 03, 2010 2:01 PM
  • Hi,

     

    Based on my research, I would like to explain that IPv6 was depended on by the RNRP service. To troubleshoot the issue, let's refer to the following steps.

     

    1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

     

    2. Verify relevant services

    =========================

    a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Networking Grouping " service and choose Properties.

    c. Please check if the service is started; if not, please click the Start button and see if it works.

    d. You may also choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps with another service: PNRP Machine Name Publication Service .

     

    3. Modify IPv6 registry key to enable IPV6

    ==========================

    a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

     

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue. 

     

    b. Locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

     

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

     

    d. Double click the "DisabledComponents" registry key and modify the value to 0 .

     

    (If the key doesn't exist, please create the key above and assign the value 0 )

     

    e. Exit Registry Editor, and then restart the computer.

     

    For more information, we can refer to the link below:

     

    How to disable certain Internet Protocol version 6 (IPv6) components in Windows Vista, Windows 7 and Windows Server 2008

     

    Thanks,

    Novak

     

     


    It still works almost a year later,  Thanks

    Fred S

    Tuesday, July 13, 2010 12:11 PM
  • I have tried and tried this. I am about ready to blow up everything. :)  I restored  hd to manufacture out of box and tried again.

    This is what everything looks like :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

    (Default)  REG_SZ   (value not set)
    Dhcpv6DUID REG_BINARY   00 01 00 01 14 3c b9 9a 00 26 22 ff ed fb
    DisabledComponents REG_DWORD 0x00000000 (0)

    IN Services (Local)

    Peer Networking Grouping Enabled            Started
    PNRP Machine Name Publication serives       Started



    Try using config free
    This computer failed to connect
    WPS Access Point Not found (Error 101)
    Connectivity Doctor
    Wireless Lan  RED X
    Lan Red x



    Lan
    Adapter Name : Realtek PCIe FE Family Controller
    Adapter Status : Enabled
    mac address 002622FFEDFB


    Wireless

    Adapter Name : Realtek RTL8191SE Wireless 802.11n PCI-E nic
    Adapter Status : Enabled
    mac address: 701A04B35388



    Satellite L550D  PSLXJC-00Q005
    Product # PSLXJC-00Q005
    Serial # 1A203944k


    When I click on create homegroup
    Your network connection must have IPv6 enabled to create or join a homegroup. To enable IPv6, start the Homegroup troubleshooter.

    Maybe I am  missing something here.

     

    Thanks for any help

    Tuesday, October 05, 2010 4:32 PM
  • Thank you very very much. I have been trying to solve this problem over 2 weeks now.
    Thursday, November 04, 2010 10:00 PM
  • Hey, I followed all your steps, and my netbook still isn't connecting to my home's network.

    I have 2 other laptops and 2 Xboxs connected to the smae network and they all work perfectly.

    This is the newest machine and it's using windows 7, and this is also the first problem we've had with this Netbook. 

    The problem says that the IPv6 has no Internet connection, and I think that the IPv4 and v6 are conflicting. 

    Any other ideas?

    Thursday, November 18, 2010 8:27 PM
  • This did the trick.  I spent hours trying to figure this out. It was so simple once I did these steps to fix my registry.  

    I also had to have the other computers in the house "leave" the homegroup so I could set mine as the central one. Mine was the last to upgrade to Windows 7 even though we had used it as the center of our home network when we had Vista.  When they plugged their computers in they setup a Homegroup, so when I upgraded it kept telling me that I was being invited to join.  I finally had everyone leave the homegroup so I could establish it from my computer.

    Finally, things are working well!

    Saturday, January 15, 2011 3:14 AM
  • 2 HP Computers: 1 all in one, other Pavilion dm4, both windows 7 premium (bought in Jul 10').

    I did all of this (below) + uninstall macafee & NO LUCK! EVEN THE HP PERSON TOLD ME TO DO EXACTLY AS DESCRIBED BELOW. Note, i had to create a DisabledComponents key b/c it wasn't there. the PIv6 says "no network access" when I look at the status of my connection.


    If i connect the two computers via ethernet, they will recognize each other/list each other under"network" to the left when you're looking at all your folders, etc. When they are connected via ethernet, the option under homegroup for my laptop changes from "create a homegroup" to join a homegroup. (note, i have no problem creating a homegroup on my desktop) Upon entering the password it says "homegroup can only be created on a home network." IT IS ON A HOME NETWORK!!!! ???? So confused! It tells me to go and change the settings.

    Upon unplugging the ethernet cord, the laptop goes back to not recognizing the desktop and vice versa under "network"

     

    Other notes: did all of the above w/ firewall disabled. homegroups have worked for 6months or so, and one day they were just gone. GONE!

     

    ANY IDEAS????

    1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

     

    2. Verify relevant services

    =========================

    a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Networking Grouping " service and choose Properties.

    c. Please check if the service is started; if not, please click the Start button and see if it works.

    d. You may also choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps with another service: PNRP Machine Name Publication Service .

     

    3. Modify IPv6 registry key to enable IPV6

    ==========================

    a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

     

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue. 

     

    b. Locate and then click the following registry subkey:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters

     

    c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.

     

    d. Double click the "DisabledComponents" registry key and modify the value to 0 .

     

    (If the key doesn't exist, please create the key above and assign the value 0 )

     

    e. Exit Registry Editor, and then restart the computer.

     


    Tuesday, February 22, 2011 3:06 AM
  • I have performed all these steps as an admin, with no effect whatsoever. The changes to services and registry hold, but IPv6 continues to show as not enabled. It is checked everywhere. I need additional suggestions, not the same steps repeated.
    Wednesday, April 25, 2012 2:32 PM
  • I needed to use this fix and it worked perfectly for me also. Thank you.
    Tuesday, January 01, 2013 5:56 PM