none
XP x64 SP3 "invalid updatebr.inf" when trying to install SP3.

    Question

  •  

    Hi,

     

    When trying to install SP3, the installer extracts all the files to my hard disk, then gives the error message "invald updatebr.inf". I have tried installing from a .iso and from windows update. I noticed some people suggesting that SP3 does not work on XPx64, however the microsoft website lists this as a compatible OS. Does anyone have any suggestions?

    Monday, May 19, 2008 7:35 AM

Answers

  • There's no SP3 for Win XP x64. Check http://windows.microsoft.com/en-IN/windows/help/learn-how-to-install-windows-xp-service-pack-3-sp3

    For x86, we do have SP3.

    For win 8, you may format and install the system.


    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, July 21, 2013 8:42 AM
  • If you are having a problem with X64 this is not the forum for solution.

      X64 has been and always will be w2k server based. No attempt to force Sp3 Xp will work. The latest version for x-64 version is the service pack2 listed by Microsofts update service.

     

      If X64 is throwing an error it may be missing dot net, 1.0 Sp1, MsXml or dot net 3.0, or 3.5. Best way to check on this is look into the adminstrative options and see if there are any application errors, or system error events in the log. And doing a search for the error.

     

    Keith
    Tuesday, July 22, 2008 3:21 AM

All replies

  • Don't know where you saw XP X64 listed - Microsoft have said many times that this Service Pack is only for 32-bit. The X64 version of XP is a derivative of Windows Server 2003, so 'under the hood' is completely different from all the 32-bit versions of XP. I think I read there's a Service Pack due out soon for Server 2003, which will also be for XP X64.

    Monday, May 19, 2008 9:55 AM
  • I get the same error installing SP2.  The problem I'm trying to fix is I get no ODBC options outside MS SQL in the dropdown.

    Monday, July 21, 2008 8:47 PM
  • If you are having a problem with X64 this is not the forum for solution.

      X64 has been and always will be w2k server based. No attempt to force Sp3 Xp will work. The latest version for x-64 version is the service pack2 listed by Microsofts update service.

     

      If X64 is throwing an error it may be missing dot net, 1.0 Sp1, MsXml or dot net 3.0, or 3.5. Best way to check on this is look into the adminstrative options and see if there are any application errors, or system error events in the log. And doing a search for the error.

     

    Keith
    Tuesday, July 22, 2008 3:21 AM
  • I have to argue with you guys here I have xp pro 64 bit and I was able to get sp3 installed and running on here before i computer problems and had to reinstall the OS.  It does work I just dont know how

     

    Friday, October 03, 2008 12:44 AM
  • Hi Joe,

    I ran into the same problem as you.  I just installed Windows XP Professional 64 bit SP1 and I download sp2 for WinXP and got the "invalid updatebr.inf" message when running the installer (after the bar gets to the end after extraction the error message pops up).  Turns out the reason I was getting that error was because I was using the wrong SP2 installer.  There is a separate SP2 installer for 64 bit versions of windows. 

    Here's the location for the 64 bit version of sp2:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=893FD6C0-6283-44C3-BB84-B2F0315B2AE6&displaylang=en

    Here's the location for the 32 bit version of sp2:
    http://www.microsoft.com/DOWNLOADS/details.aspx?displaylang=en&FamilyID=049c9dbe-3b8e-4f30-8245-9e368d3cdb5a

    I haven't looked into SP3 yet, but I imagine this is why you were getting the error message (trying to apply the wrong SP).

    Hope this helps,


    Patrick
    Thursday, October 01, 2009 9:40 PM
  • Thank you for this! I was so frustrated. All I wanted to do was install Win XP on my Mac so I can hack my phone (all of the hack tutorials are Windows-based). I had an old (very old, apparently) XP cd and thought, great! Now I don't need to run out and spend my hard-earned dough on Vista or Win 7 when I am perfectly happy with my OS X 99.99999% of the time. Then I installed it, but couldn't install the drivers via Boot Camp because it was SP1 (ooollllldddd). Then I tried to install SP2 and got that error. And then I visualized throwing my computer against the wall...but then I found this thread. So...here's a giant virtual hug from a perfect stranger.  ((((HUG))))  ¡¡¡¡TYVM!!!!
    Monday, December 13, 2010 3:50 PM
  • hey guys, my name is jalaj and i'm also facing a problem in installing sp3. as you said that there is no sp3 for xp x64 then howcome my windows 8 setup is telling me that i need sp3 to install windows 8. pls. help i've spent 9000 on windows 8.
    Sunday, July 21, 2013 7:40 AM
  • There's no SP3 for Win XP x64. Check http://windows.microsoft.com/en-IN/windows/help/learn-how-to-install-windows-xp-service-pack-3-sp3

    For x86, we do have SP3.

    For win 8, you may format and install the system.


    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, July 21, 2013 8:42 AM