none
[RESOLVED] msg.exe XP -> Windows 7 Error [1722]:The RPC server is unavailable.

    Question

  • Hi..

    i've been directed here from the Microsoft Answers networking forums.

     

    I'm having some problems using the msg utility between Windows XP and Windows 7.

     

    I have two computers on the network. PC1 is dual boot between XP Professional SP3 (x86) and Windows 7 Ultimate SP1 (x64). PC2 has Windows XP Professional SP3 (x86) installed.

     

    msg works without a problem from PC1 Windows 7 --> PC2 XP.

     

    It also works from PC1 XP --> PC2 XP and vice versa.

     

    However, I can't get things working from PC2 XP to Windows 7....I always get the following error:

    Error opening Terminal server PC1

    Error [1722]:The RPC server is unavailable.

     

    I've tried disabling the firewalls on both computers but the error persists. I've also tried booting Windows 7 into safe mode with networking and then trying with Windows Firewall enabled and disabled but it still doesn't work.

     

    I'm thinking that it may be something to do with a setting in Windows 7 considering PC1 XP to PC2 XP and vice versa works ok.

     

    All OSs have ESET Smart Security installed and there is nothing in the logs to suggest that anything is being blocked...and as things didn't work in Safe Mode when ESET wasn't running, I don't think it's related to ESET.

     

    The AllowRemoteRPC registry value is present and correct on all computers.

     

    If anyone has any suggestions, that would be great. If you need more info, i'll be happy to provide.

     

    Cheers..

     

    Nick


    • Edited by Nick-UK Thursday, January 19, 2012 9:54 AM
    Wednesday, January 18, 2012 11:39 AM

Answers

  • I managed to resolve the issue. It was a registry setting.

    All I had to do was change the following:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

    fDenyTSConnections

    to 0

    Hope that helps others.

    Nick

    Thursday, January 19, 2012 9:54 AM

All replies

  • I managed to resolve the issue. It was a registry setting.

    All I had to do was change the following:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

    fDenyTSConnections

    to 0

    Hope that helps others.

    Nick

    Thursday, January 19, 2012 9:54 AM
  • Thanks, it works.

    XP->XP, AllowRemoteRPC=1 only
    Win7->Win7, AllowRemoteRPC=1 only
    Win7->XP, AllowRemoteRPC=1 only
    XP->Win7, AllowRemoteRPC=1 and fDenyTSConnection=0

    Thursday, September 20, 2012 2:22 AM