none
Task Scheduler (Win7) error message

    Question

  • Upgraded from Vista to Windows 7 - Task Scheduler has error messages on start.  "The selected task "0" no longer exists.  When I "display running tasks" another error popup says "Catstrophic failure (Exception from HRESULT:0x8000FFFF (E_UNEXPEDTED))
    At this point I really don't want to start over with a clean install! Suggestions welcome.
    Monday, January 04, 2010 11:19 PM

All replies

  • Something I found somewhere, so no guarantees it will work for you

    Now for a concise fix here so folks don't have to take the jump and read more gobbledygook that necessary. The Catastrophic error that you and I and everyone else are seeing is TOTALLY DIFFERENT than the normal corrupt msfeeds update fix so please try that fix if you wish but don't expect positive results. The cause here is a bad task somewhere else in the chain. Sadly, there is no easy to way to determine this so you're gonna need to do some hunting and pecking. Please perform the following steps:

    1. Go to C:\Windows\system32\Tasks and make a backup of all the tasks there somewhere else on your drive. I copied the whole folder content to my Documents folder.

    2. Take a quick look and see if there are any rogue tasks there that look like they're old XP leftovers that snuck in somehow during your Vista install and subsequent restore of stuff you used on your old XP box. The author at the link above found UniBlue's SpeedUpMyPC task caused his problem. In my case, the cause was a GoogleUpdateTaskUser task that was incompatible with Vista's Task Scheduler. IF you spot those off the bat easily, just delete it and see if your TS works properly again. In my case, the deletion of that one simple file fixed me completely.

    3. If you are not fortunate enough to find a rogue task off the bat, you will have some work ahead of you. Please delete everything in your Tasks directory (safe since you DO have a backup from step 1) and see if your Task Scheduler starts normally. It's virtually impossible it won't at that point and if it doesn't, then this technique is not for you and I would put everything back the way it was and continue to work with MS Support. Provided it does work normally, the work begins.

    4. Begin adding everything from your Task directory backup into the System32\Tasks directory ONE BY ONE. Tedious, yes, but the only way you'll find out what's causing problems. So add each task back in, fire up your scheduler and see if it behaves. Provided it does, continue adding until you find the broken task. You may have several so take your time! Once your done, keep those bad tasks out of that directory and seek fixes from the applicable software provider.


    From another web site where a user went from XP to Vista which seems to me to be very similar since you went from Vista to Windows 7 so you probably had tasks already set that are not compatible in Windows 7
    Another source said this -
    I upgraded this computer to Vista from XP. In the process, it transferred all of my XP tasks to the Vista Task Scheduler. However, some of those tasks weren't compatible with Vista's Task Scheduler. To fix the problem, go into your Windows directory (usually C:\Windows\system32\Tasks) and make a backup of any tasks that say they were created before you upgraded to Vista and send those backed-up files tot he desktop or somewhere where you know they are located. Then delete the files in the Tasks folder. Open up Task Scheduler and see if you get the error message. If not, then you can add each task back to the Tasks folder one by one to see which one is causing the problem.


    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    • Proposed as answer by kenpmason Monday, July 12, 2010 3:37 AM
    Tuesday, January 05, 2010 12:28 AM
  • I deleted a folder in the scheduled task folder "WPD" and the TS started up a bit better. "The selected task "0" no longer exists. But the catastrophic error disappeared.
    So tried to create a basic task to run a BAT file.  New error message: "MMC detected an error in the snap-in... unload ..." The task was created (folder in /tasks but did not run.)
          TS screenshot  http://web.ncf.ca/pat/ts-screenshot.jpg
    Thursday, January 07, 2010 12:01 AM
  • Forgot to mention the opening windos shows
    ------------------
    Overview of Task scheduler
    Task Status
         Task that have started...
         Reading data failted
    Active tasks
         Active tasks that are currently enabled..
         Reading data failted
    ------------------
    Thursday, January 07, 2010 12:07 AM
  • I created a basic task and it works!   Unfortunately I am still getting the error message "The selected task "0" no longer exists." when I start up Task Schedulter.  Can't I remove something in the registry to get rid of that. If these type of errors are transferred from Vista I might as well throw in the towel and do a clean install - that will use up at least a week of my time.
    Monday, January 11, 2010 2:13 AM
  • "The selected task "{0}" no longer exists."
    I found a solution to this. There appears to be a shortcoming with Win7 Task Manager (TS) if you do an "upgrade" from Vista.  I assume all the tasks I deleted were incompatible with Win7 but got transferred over anyway.  Nice.
    The procedure is painful but here it is.

    Open  C:\Windows\System32\Tasks\ on one side of your screen so you can return to it to delete folders and/or files.
    **Make a copy of the entire Tasks folder in another location.

    1. Run Task Scheduler (TS) in a window on the other side of your screen.
    2. When the error appears, click OK for each until it stops.
    3. Click the + symbol to open the Windows task lists: Task Scheduler Library >> Microsoft >> Windows
    4. Click on each task in the list until you get the error message. At this point note any items in the
        right pane - these you might want to keep.
    5. Exit TS
    6. In the Tasks folder, delete the folder (or just the files that were missing).
    Go back to #1 and repeat until you don't get any error messages  clicking any task.

    This took me more than an hour to delete 38 folders/files until I could finally start TS without errors.  Do this procedure for any other folders under Task Scheduler Library - in my case there was a "Hewlett-Packard" folder with one task.  I will return here to report if my system is now non-functional.  There doesn't seem to be any relation between the number of error messages when you first start TS as reported in the discussion found here:
    http://social.answers.microsoft.com/Forums/en-US/w7performance/thread/01e60fa1-8004-40b4-9cf0-247fb80edb56

    Here is the list of Folders I deleted:    * indicates deletion of just file(s) in a folder.
    *AppID         PolicyConverter
    Applicaton Experience        AitAgent, ProgramDataUpdater
    Bluetooth    UninstallDeviceTask
    *CertificateServicesClient (SystemTask ok)        UserTask, UserTask-Roam
    Customer Experience Improvement Program        Consolidator, KernelCeipTask, UsbCeip
    Defrag        ScheduleDefrag
    Diagnosis    Scheduled
    DiskDiagnostic    Microsoft-Windows-DiskDiagnosticResolver,  Microsoft-Windows-DiskDiagnosticDataCollector
    Location    Notifications
    Maintenance    WinSAT
    Media Center    Only InstallPlayRead, UpdateRecordPath listed
    Memory Diagnostic (2)
    NetTrace    GatherNetworkInfo
    NetworkAccessProtion    {EMPTY}
    PerfTrack        BackgroundConfigSurveryor
    PLA\System        ConvertLogEntries
    Power Efficiency Diagnostic    AnalyzeSystem
    RAC            RacTask
    Ras            MobilityManager
    Registry        RegIdleBackup
    RemoteApp and Desktop Connections Update    {EMPTY}
    Remote Assistance    RemoteAssistanceTask
    *Shell            CrawlStartPages
    SoftwareProtectionPlatform    SrcRestartTask
    SyncCenter        {EMPTY}
    Task Manager        Interactive
    UPnP            UPnPHostConfig
    User Profile Service    HiveUploadTask
    WDI            ResolutionHost
    Windows Filtering Platform:  BfeOnServiceStartTypeChange
    Windows Media Sharing    UpdateLibrary
    WindowsBackup        ConfigNotification
    WindowsCalendar        {EMPTY}

    • Proposed as answer by Jimsrply Thursday, February 25, 2010 5:33 PM
    Tuesday, January 12, 2010 8:23 PM
  • Please disregard  "Proposed as answer by Jimsrply" in message by PDrummond my mistake in trying to reply.
    I was trying to add comment here goes :-

    I recently sent this email to microsoft...................................................................................

                                                          Technical query
                     

    To Microsoft ,                                                                                       
                                           Re:- Windows 7 Task Scheduler


    I recently purchase Windows 7 Pro and Home Premium since installing them I have come
    across   what appears to be a problem with a task in TASK SCHEDULER . The following message
    displayed  when I opened Task Scheduler:-                                                                                                                        TASK SCHEDULER
    The select task  “{0}” no longer exists to see the current tasks, click Refresh.
    This occurs on Win7Pro and Home Premium.
    Are you aware of this problem ?
    If not this is what I did to stop it.
    The problem appears to be associated with the setting of the ScheduledDefrag task because
    I changed the setting from Weekly to Monthly. When reverted back to Weekly the problem
    disappeared  .
     
    When the error  occurs no information is diplayed when opening the Task Scheduler.
    Once the Task  Scheduler  is working I displayed the history which showed  the error
    was  EVENT ID 146 Task loading at service startup failed.
    Additional Data :  error value 2147942487

    I have not tried Daily or any the setup details in the actual task, all I know is it works
    fine set at Weekly but would prefer Monthly.
    If you know of the problem could you send me the patch or update or where I could
    download it, if its not already on  your update site.

    I have included 3 Problem Stop Recorder files which will show you better then my
    description.
    File 1  scheduler_okay.zip
    2 scheduler_read_data_failed.zip
    3 scheduler ERROR EVENT 146.zip


    ---------------------------------------------------------------------------------------------------------


    Hope some one can confirm or throw out.

    Cheers

    Jim.
    • Proposed as answer by canoetoday Saturday, November 13, 2010 1:03 AM
    Thursday, February 25, 2010 5:49 PM
  • Thank You. I'm down to many fewer tasks, but at least the ones I have work without crashing the task scheduler.
    Thursday, September 23, 2010 4:53 AM
  • Hi Jim @ jimsrply

    "The problem appears to be associated with the setting of the ScheduledDefrag task because I changed the setting from Weekly to Monthly. When reverted back to Weekly the problem disappeared."

    This solves the problem.


    I had also changed it to monthly and never thought it would kill the Task Scheduler. It's beyond belief just a simple setting change which is in the drop down menu for the ScheduledDefrag would destroy another part of the OS.
    Thanks for posting your solution because I found it quickly with only 2 Google searchs.
    http://www.google.com/search?hl=en&source=hp&biw=1176&bih=598&q=event+id+146+task+scheduler+error+value+2147942487&aq=f&aqi=&aql=&oq=&gs_rfai=CT2M74d_dTPuXIoPIMrSdvPoOAAAAqgQFT9DZ3vc.

    And your post was the first one.

    Thanks,
    canoetoday

    Saturday, November 13, 2010 1:02 AM
  • Hi canoetoday,

    Glad it was helpful, have not had much feedback so to see your reply brought a smile

    to my face. Are you using Windows 7 ?

    Was beginning to think it was only my machines behaving this way.

    I'm  only guessing now but wondering if there is a conflict between Disk Defragmenter service

    and the Task Scheduler service ?

    Thanks for taking the time to reply.

    Regards

    Jim.

     

     

     

     

    Thursday, November 25, 2010 1:36 PM
  • Hi Jim,

    I'm using W7. Can't be set on a monthly schedule because of a defect in Windows.
    Will run this monthly from now on using the Disk Defragmenter GUI in Windows and  manually clicking the box defragment disk. To remind me I set my calendar. 

    Only reason I wanted a monthly schedule was to prevent wear on the HDD. 
    I had wanted to only Defrag C and not the D partition. 

    I tried  Piriform \Defraggler\ http://www.piriform.com/defraggler and that worked great except it would only schedule a complete defrag.
    So now I'm good - Task Scheduler works again and I just click a few icons.  Should never have had this issue but I'm glad you helped solve it.


    Thanks,
    canoetoday

    Tuesday, November 30, 2010 6:39 PM
  • Hi canoetoday,

    Just a quick update to "The select task  “{0}” no longer exists to see the current tasks "

    Have loaded the SP1 on windows 7 32bit  all went well but the problem STILL EXISTS.

     

    Regards

    Jim.

     

    Wednesday, March 23, 2011 12:31 PM
  •  

    I also have the "The select task  {0} no longer exists to see the current tasks" error.

    Here is my way to rebuild my Scheduled Tasks cleanly (it take some times but I found no other working solution up to now) :

         Full export of all my tasks in an XML file :

         ==========================

         1) From a DOS cmd , I exported in a TXT file all my tasks

                  schtasks /Query /FO LIST /V > C:\all_tasks.txt

         2) If in this file I find something like :

              ERROR: Task cannot be loaded: XXXX

              ERROR: The task image is corrupt or has been tampered with.

             Then :

             2.1) I look in HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree for the entry XXXX and I note its key Id {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX}.

             2.2) I remove :

             HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\XXXX

             HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks\{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX}

             HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Plain\{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX}

             HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Logon\{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX}

             HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Boot\{XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX}

         3) From a DOS cmd , I exported in a XML file all my tasks

                  schtasks /Query /XML > C:\all_tasks.xml

                 (If you don't do step 2, this export could be broken and incomplete)

         4) In all_tasks.xml, I replace all instances of <UseUnifiedSchedulingEngine>true</UseUnifiedSchedulingEngine> by <UseUnifiedSchedulingEngine>false</UseUnifiedSchedulingEngine>

     

         Full import of all my tasks from the XML file :

         ==========================

         5) I completely remove HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache

         6) I completely remove everything under C:\Windows\System32\Tasks

         7) I launch Computer Management\System Tools\Task Scheduler panel (It should not contain any tasks because of step 6)

         8) I recreate all the directory structure for the tasks (for me, Microsoft\Windows\...). The XML file contains the URI for each task to help you.

         9) For each task :

                9.1) I extract from C:\all_tasks.xml the <task>...</task> sub-structure to a file C:\one_task.xml

                9.2) I import the file C:\one_task.xml from Task Scheduler panel in the right sub-directory, and I give it the right name intead of one_task

    Of course, be careful and make a backup of both C:\Windows\System32\Tasks and HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache before.

     


    • Edited by pcjco Friday, January 13, 2012 11:12 PM
    Friday, January 13, 2012 7:15 PM