none
Windows Media Player Cannot rip one or more tracks from the CD

    Question

  • http://farm3.static.flickr.com/2443/5710817524_d48bd2f72e_b.jpg

    http://farm4.static.flickr.com/3136/5710819548_669c665675_b.jpg

    http://farm4.static.flickr.com/3473/5710257413_9c6e03214e_b.jpg

     

    I have tried to fix it. However, it is not work. The methods i have used which are 

     

    (from: DT20Three) open windows media player, click Organise -> Manage Libraries -> Music and make sure you aren't referencing any unavailable locations. For me, I was referencing an old hdd location for my music. Remove this dead location and update your default save location and all is good.

    (From Vivian Xing) You can also try the following steps:

    1. Load Windows Media Player.

    2. Click Tools\options\devices\ then choose properties of the CD reader and enable Digital for both ripping and playback, uncheck "Use error correction", click OK.

    3. Click Rip music tab, change the Audio Quality to another value (higher or lower than 128kbps). Click OK and then try to rip.

    (from Roi A. _) Edit: Also there is a problem with the Rip music tab: 1- nothing happens when i click change save location and it doesn't show the place where it saves now. 2- if I change a setting in the Rip tab and click save or apply, it says "The settings for ripping music could not be applied."

    (from Vivan Xing) I suggest resetting it as below:

    1. Open Control Panel/Programs and Features.

    2. Click "Turn Windows features on or off" in the left pane.

    3. Expand "Media Features", uncheck "Windows Media Player". Click "Yes" to continue, and click OK to quit. Then Restart.

    Note: If you turn off WMP, Windows Media Center will be turned off either. You may need to re-configure settings for Windows Media Center after re-enabling it.

    4. Open "Turn Windows features on or off" again. Turn on the features "Windows Media Player" and "Windows Media Center". Restart.

    5. Launch Windows Media Player, initialize the program.

    You can also try restoring Media Library as Zachd mentioned.

     

    [The only one method I didn't try is Insert the Windows 7 DVD, it is because I scared if I click install, I might loose all the files in my computer]

    Please, I hope there is someone can solve my problem.

    Thank you.

     


    Wednesday, May 11, 2011 5:39 PM

All replies

  • First, please also check the locations of the other libraries (Videos, Pictures, Recorded TV).

    If that doesn't help, close WMP, open Windows Explorer, right-click the Music library, select Properties, and click Restore Defaults. After that, make sure that a save location is set (as indicated by a checkmark).
    Tim De Baets
    http://www.bm-productions.tk
    Wednesday, May 11, 2011 6:47 PM
  • I have already tried to select Origanize --> Manage Libraries --> Music but, there is nothing happen and appear.

    I also did the second method, this is not help either.

    Thank you very much.

    I hope you have another method to recommend me

     

     

    Thursday, May 12, 2011 2:30 AM
  • Looking at your last screen capture I noticed you do not have a folder designated for the ripped files to be sent to (in the rip music to this location) try setting one or replace the default one that should be in

     

    c:\users\yourname\music

    Another thing you can try is this link from microsoft that will autofix (most) issues in media player.

    http://support.microsoft.com/mats/windows_media_player_diagnostic/

     


    Please remember to flag a post that helps you as "answer" so that it may help others with same problems.
    • Edited by DirtyOleBeggar Thursday, May 12, 2011 3:02 PM added linkto MS support
    Thursday, May 12, 2011 11:56 AM
  • Please try deleting the Music library in Explorer, and then restoring the default one (your actual music files won't be deleted). See the following article:

    http://www.winhelponline.com/blog/fix-error-library-ms-is-no-longer-working-windows-7

    Does that help?


    Tim De Baets
    http://www.bm-productions.tk
    Thursday, May 12, 2011 1:44 PM
  • To DirtyOleBeggar and Tim De Baets.

    I did tried both the suggestions but, the problem still here.

    It makes me headache, I have already tried many different ways, I'm really have no idea what happen of my computer.

    Oh my god, I'm afraid that i can't solve it.

    Please smart guyz, give me more suggestions that I can fix it one day.

    Thank you all the people who gave me suggestions.

    Thursday, May 12, 2011 4:48 PM
  • To DirtyOleBeggar and Tim De Baets.

    I did tried both the suggestions but, the problem still here.

    It makes me headache, I have already tried many different ways, I'm really have no idea what happen of my computer.

    Oh my god, I'm afraid that i can't solve it.

    Please smart guyz, give me more suggestions that I can fix it one day.

    Thank you all the people who gave me suggestions.

    did you try this link to microsofts autofix program?

    http://support.microsoft.com/mats/windows_media_player_diagnostic/

    have it reset mediaplayer completely


    Please remember to flag a post that helps you as "answer" so that it may help others with same problems.
    Thursday, May 12, 2011 5:09 PM
  • Check this link also if the reset diagnostic program don't work for you, someone who was having the same issue as you asked this on another microsoft forum and it was fixed.

     

    http://answers.microsoft.com/en-us/windows/forum/windows_7-sound/cannot-rip-cd-cannot-change-album-info/07fb8c99-9a7b-4456-9633-1f487d5f7a42

     


    Please remember to flag a post that helps you as "answer" so that it may help others with same problems.
    Thursday, May 12, 2011 5:24 PM
  • Yup, I definately followed the step and reset my media player already.
    Thursday, May 12, 2011 6:42 PM
  • You still can't go to Organize - Manage libraries - Music in WMP?

    It might be necessary to delete the current Pictures and Videos libraries too and restore the default versions, by following the same instructions as I posted previously.


    Tim De Baets
    http://www.bm-productions.tk
    Friday, May 13, 2011 2:30 PM
  • Yup, I definately followed the step and reset my media player already.

    OK I'm stumped the things we have told you should have fixed this issue.....

     

    OK this is odd cause when we started trying to help you with this I had no problem with my Rip music to this location.... It now shows no location available and clicking change does absolutely nothing.

    The only thing I've done different on my machine since the start of trying to help you is setup windows media center, it may have something to do with this issue since it does tend to turn my screensaver on every time I open it even though I prefer it turned off at all times.


    Please remember to flag a post that helps you as "answer" so that it may help others with same problems.
    Friday, May 13, 2011 2:57 PM
  • I GOT IT!!!!

    It is in media center where the problem originates... (that is 2 things media center messes with that it shouldn't touch, media player RIP settings, and screensaver enabling/disabling)

    OK do these steps:

    Open Media Center on your PC not from your TV.

    Click "Music" in the menu

    Select the Music Library

    In here right click the screen and select Manage Library

    NOW in here you will need to click Add folders to Library

    Next select On this Computer

    Now click the plus sign next to  C: first

    Scroll down to Users and click that plus sign

    Click the plus sign next to your name

    Scroll down till you see My Music and place a check in the box to the left of it

    Now select next at the bottom of the screen and follow it through till the end.

    Reboot your machine and then check your media player settings, you should now be able to change the selected Rip folder to anywhere you want on the machine.

    TADAAAaaaa   :)

    Boy that was tough to figure out till it happened on my machine...... I refuse to be beaten by an Operating system hahaha.

     

     


    Please remember to flag a post that helps you as "answer" so that it may help others with same problems.
    Friday, May 13, 2011 3:24 PM
  • I GOT IT!!!!

    It is in media center where the problem originates... (that is 2 things media center messes with that it shouldn't touch, media player RIP settings, and screensaver enabling/disabling)

    OK do these steps:

    Open Media Center on your PC not from your TV.

    Click "Music" in the menu

    Select the Music Library

    In here right click the screen and select Manage Library

    NOW in here you will need to click Add folders to Library

    Next select On this Computer

    Now click the plus sign next to  C: first

    Scroll down to Users and click that plus sign

    Click the plus sign next to your name

    Scroll down till you see My Music and place a check in the box to the left of it

    Now select next at the bottom of the screen and follow it through till the end.

    Reboot your machine and then check your media player settings, you should now be able to change the selected Rip folder to anywhere you want on the machine.

    TADAAAaaaa   :)

    Boy that was tough to figure out till it happened on my machine...... I refuse to be beaten by an Operating system hahaha.

     

     


    Please remember to flag a post that helps you as "answer" so that it may help others with same problems.

    Hello, DirtyOleBeggar

    Thank you for your advice. However, after I did the step which you gave me. It is still not working.

    hahaha sorry for that I can't flag this post yet :p

    Saturday, May 14, 2011 2:45 PM
  • well bugger.... I'm sure now it has to be one of the setting inside window media center that is causing this problem. are there any other possible folders you may have removed in media center settings to keep them from showing up in selections?

    P.S. I am NOT talking about media player (just in case you think I am)

     

    In case nothing I mentioned works check this link below its all I have left for you :(  I hope it helps cause I'm drawing a blank now.

    http://answers.microsoft.com/en-us/windows/forum/windows_7-sound/cd-wont-rip-using-windows-media-player-in-windows/96afeb65-4a6d-4559-af83-c9b52e42a938

     


    Please remember to flag a post that helps you as "answer" so that it may help others with same problems.
    Saturday, May 14, 2011 3:05 PM
  • I was inserting an audio cd to rip to WMP and it gave me the error message "WMP cannot rip one or more tracks from cd". I struggled with this for months until today. I went to clicked on Music. Then i clicked on Library. Afterwards you're given a list as follows: Recently added, artist, album, songs, genre, year, rating and finally the title of the cd inserted in the drive. I right clicked on that title and went to properties. In the rip collumn marked digital, the "use error correction" box was unchecked. I checked it and ever since i've been ripping cd's successfully. Hope this helps.

    • Proposed as answer by Gushubirix Saturday, March 08, 2014 9:06 PM
    Sunday, November 06, 2011 1:02 AM
  • http://farm3.static.flickr.com/2443/5710817524_d48bd2f72e_b.jpg

    http://farm4.static.flickr.com/3136/5710819548_669c665675_b.jpg

    http://farm4.static.flickr.com/3473/5710257413_9c6e03214e_b.jpg

     

    I have tried to fix it. However, it is not work. The methods i have used which are 

     

    (from: DT20Three) open windows media player, click Organise -> Manage Libraries -> Music and make sure you aren't referencing any unavailable locations. For me, I was referencing an old hdd location for my music. Remove this dead location and update your default save location and all is good.

    (From Vivian Xing) You can also try the following steps:

    1. Load Windows Media Player.

    2. Click Tools\options\devices\ then choose properties of the CD reader and enable Digital for both ripping and playback, uncheck "Use error correction", click OK.

    3. Click Rip music tab, change the Audio Quality to another value (higher or lower than 128kbps). Click OK and then try to rip.

    (from Roi A. _) Edit: Also there is a problem with the Rip music tab: 1- nothing happens when i click change save location and it doesn't show the place where it saves now. 2- if I change a setting in the Rip tab and click save or apply, it says "The settings for ripping music could not be applied."

    (from Vivan Xing) I suggest resetting it as below:

    1. Open Control Panel/Programs and Features.

    2. Click "Turn Windows features on or off" in the left pane.

    3. Expand "Media Features", uncheck "Windows Media Player". Click "Yes" to continue, and click OK to quit. Then Restart.

    Note: If you turn off WMP, Windows Media Center will be turned off either. You may need to re-configure settings for Windows Media Center after re-enabling it.

    4. Open "Turn Windows features on or off" again. Turn on the features "Windows Media Player" and "Windows Media Center". Restart.

    5. Launch Windows Media Player, initialize the program.

    You can also try restoring Media Library as Zachd mentioned.

     

    [The only one method I didn't try is Insert the Windows 7 DVD, it is because I scared if I click install, I might loose all the files in my computer]

    Please, I hope there is someone can solve my problem.

    Thank you.

     


    (from: DT20Three) open windows media player, click Organise -> Manage Libraries -> Music and make sure you aren't referencing any unavailable locations. For me, I was referencing an old hdd location for my music. Remove this dead location and update your default save location and all is good.

    Thanks a lot you were very helpfull for me thanks againn .

    Ah sorry for my impolite . HUPPY NEW YEAR MY FRIEND FROM GREECE

    Monday, January 02, 2012 2:33 PM
  • You just saved me so much time. Thanks so much for posting this little tidbit online.
    Saturday, February 04, 2012 12:28 AM
  •  thankyou thankyou thankyou thankyou thankyou thankyou thankyou thankyou thankyou thankyou thankyou thankyou thankyou!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Monday, October 29, 2012 11:12 AM
  •  thankyou   thankyou    thankyou    thankyou    thankyou   thankyou  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Monday, October 29, 2012 11:19 AM
  • Thanks Tim! Occam's Razor prevails. The simplest answer was the right one.

    It's much appreciated.

    Swaman

    Thursday, October 17, 2013 6:50 PM
  • Bless you! Thank you so much omg
    Saturday, March 08, 2014 9:06 PM