none
WPA security Types are missing after upgrading to Windows 8.1

    Question

  • After upgrading from Windows 8 Pro 64bit to Windows 8.1 Pro 64bit on my Sony Vaio Duoe 13, I could not find WPA security type while configuring Wireless network manually. (only WPA2 and 802.1X are available).

    I have done a lot of troubleshootings like

    1-Reinstall Wirless original driver

    2-Updating the wireless driver to the latest

    3-Uninstall and reinstall windows 8 then upgrading again to windows 8.1

    But the same.

    Is there any way to add WPA to the security type?

    Wednesday, October 23, 2013 10:56 AM

Answers

  • Yes! It works!

    To recap : My laptop has an Atheros AR9002WB-1NG adapter, windows 8.1. Even when it had windows 8, it was unable to connect, but unlike now, I didn't look closely enough about the type of network. Originally I thought it was this problem. But they confirmed that others with windows 8 had no issues with this. Then , when I tried configuring the network manually, I could not find the WPA-enterprise option at all, only the WPA2-enterprise.

    So here I was, and Greg Seth's answer gave me an idea.

    In the following instructions, some commands are obvious, so I won't explain unless necessary. So here's what you do :

    0) Go to command line, preferably Administrator (not tried without).

    1) C:\Windows\System32> cd \Users\<User>\Documents

    2) C:\Users\<User>\Documents> netsh

    3) netsh> wlan

    4) netsh wlan> show profiles

    5) delete profile name=<yournetwork>
    Enclose the name of network within quotes, this is to ensure that you can cleanly set up the right profile. Don't close the netsh, we'll need it some more. If you do, just reach there the same way as before.

    6) Right click the connection icon in lower right corner > open Network and Sharing Center > Set up a new connection or network > Manually connect to a wireless network

    7) Try to create a profile, and try to get as many details to correspond with your requirement. The rest we'll edit in command line, so let's make it as easy as possible.

    8) Do the same at the next screen. Edit Network settings > change all the parameters that you can, to match the requirement. My university tech support has a detailed document listing the options to choose, usually for windows 7, or even windows 8. get as many of them as possible.

    9) Finish. Move back to your netsh terminal

    10) netsh wlan> show profile <profilename>
    without quotes this time. This should show your previous attempt at creating a profile in the GUI dialog boxes. In my case, it had WPA2 and AES. It has to become WPA and TKIP. I also set my authMode to userOnly, since I hadn't done it right in the dialog box before.

    11) netsh wlan> set profileparameter
    displays a humongous list of parameters with detailed options, just carefully examine the syntax. It's all here.

    12) netsh wlan> set profileparameter name=<profilename> authentication=wpa encryption=tkip authMode=userOnly

    13) netsh wlan> set profileparameter
    Don't exit this yet.

    14) Now click the connection icon, and connect to the network. It will ask you the username and password in a different style, that was my clue something was different this time.

    15) It should connect. In my case atleast, it did. Verify by browsing.

    16) netsh wlan> export profile name=<profile name>
    In order that you're not put through this ordeal again, export the profile safely to a file. Again, the profile name in quotes.

    17) Wonder why microsoft makes things difficult for us!

    Thursday, October 24, 2013 1:27 PM
  • Are you referring to the "set up a network" dialog that is illustrated here?  We removed the WPA option in Windows 8.1 for two reasons:

    • WPA is less secure than WPA2.  Most devices support WPA2, so there's little reason to use the less-secure encryption of WPA.
    • The Wi-Fi Alliance international standards organization released a new 2.0 version of the WSC protocol.  Version 2.0 removes support for WPA, so new 2.0-compliant devices may not be able to support WPA.  It would be misleading if Windows showed the option when the option would probably just fail on 2.0 devices anyway.

    I'm sorry that you had to go through all that trouble of reinstalling things.  If you do require WPA, you can usually set up your network using an alternate technique that lets you use the old WPA option.

    What you need to do is connect to the network using the steps outlined here.  Specifically, you want to use http://192.168.0.1 or http://192.168.1.1 (keep trying 0 through 9 for the second-to-last number).  You'll be taken to a website on the wireless access point itself, where you can configure all the possible wireless settings.

    This website varies by manufacturer, and so I can't provide specific advice on how to use it.  But you can look up the documentation for your wireless access point to get more information.

    Thursday, October 24, 2013 1:21 AM

All replies

  • Are you referring to the "set up a network" dialog that is illustrated here?  We removed the WPA option in Windows 8.1 for two reasons:

    • WPA is less secure than WPA2.  Most devices support WPA2, so there's little reason to use the less-secure encryption of WPA.
    • The Wi-Fi Alliance international standards organization released a new 2.0 version of the WSC protocol.  Version 2.0 removes support for WPA, so new 2.0-compliant devices may not be able to support WPA.  It would be misleading if Windows showed the option when the option would probably just fail on 2.0 devices anyway.

    I'm sorry that you had to go through all that trouble of reinstalling things.  If you do require WPA, you can usually set up your network using an alternate technique that lets you use the old WPA option.

    What you need to do is connect to the network using the steps outlined here.  Specifically, you want to use http://192.168.0.1 or http://192.168.1.1 (keep trying 0 through 9 for the second-to-last number).  You'll be taken to a website on the wireless access point itself, where you can configure all the possible wireless settings.

    This website varies by manufacturer, and so I can't provide specific advice on how to use it.  But you can look up the documentation for your wireless access point to get more information.

    Thursday, October 24, 2013 1:21 AM
  • Hi, I have the exact same problem.

    The thing is the WiFi router configuration is a company policy and I have no other way than to comply with it. I just want the connect to the network. If the hardware can support it there is no reason *at all* to prevent people to use a feature.

    FYI, I bypassed this 8.1 "improvement" by exporting the profile ( netsh wlan export profile ) on a configured 8.0 machine and importing it on the 8.1 one.

    • Proposed as answer by Greg Seth Friday, October 25, 2013 9:43 AM
    Thursday, October 24, 2013 7:12 AM
  • Do you mean that despite the option not showing in the field of the dialog box, using the imported profile works?

    That means, I can just create the profile programmatically with the right parameters.I have the same problem at my university.

    Thursday, October 24, 2013 12:18 PM
  • Yes! It works!

    To recap : My laptop has an Atheros AR9002WB-1NG adapter, windows 8.1. Even when it had windows 8, it was unable to connect, but unlike now, I didn't look closely enough about the type of network. Originally I thought it was this problem. But they confirmed that others with windows 8 had no issues with this. Then , when I tried configuring the network manually, I could not find the WPA-enterprise option at all, only the WPA2-enterprise.

    So here I was, and Greg Seth's answer gave me an idea.

    In the following instructions, some commands are obvious, so I won't explain unless necessary. So here's what you do :

    0) Go to command line, preferably Administrator (not tried without).

    1) C:\Windows\System32> cd \Users\<User>\Documents

    2) C:\Users\<User>\Documents> netsh

    3) netsh> wlan

    4) netsh wlan> show profiles

    5) delete profile name=<yournetwork>
    Enclose the name of network within quotes, this is to ensure that you can cleanly set up the right profile. Don't close the netsh, we'll need it some more. If you do, just reach there the same way as before.

    6) Right click the connection icon in lower right corner > open Network and Sharing Center > Set up a new connection or network > Manually connect to a wireless network

    7) Try to create a profile, and try to get as many details to correspond with your requirement. The rest we'll edit in command line, so let's make it as easy as possible.

    8) Do the same at the next screen. Edit Network settings > change all the parameters that you can, to match the requirement. My university tech support has a detailed document listing the options to choose, usually for windows 7, or even windows 8. get as many of them as possible.

    9) Finish. Move back to your netsh terminal

    10) netsh wlan> show profile <profilename>
    without quotes this time. This should show your previous attempt at creating a profile in the GUI dialog boxes. In my case, it had WPA2 and AES. It has to become WPA and TKIP. I also set my authMode to userOnly, since I hadn't done it right in the dialog box before.

    11) netsh wlan> set profileparameter
    displays a humongous list of parameters with detailed options, just carefully examine the syntax. It's all here.

    12) netsh wlan> set profileparameter name=<profilename> authentication=wpa encryption=tkip authMode=userOnly

    13) netsh wlan> set profileparameter
    Don't exit this yet.

    14) Now click the connection icon, and connect to the network. It will ask you the username and password in a different style, that was my clue something was different this time.

    15) It should connect. In my case atleast, it did. Verify by browsing.

    16) netsh wlan> export profile name=<profile name>
    In order that you're not put through this ordeal again, export the profile safely to a file. Again, the profile name in quotes.

    17) Wonder why microsoft makes things difficult for us!

    Thursday, October 24, 2013 1:27 PM
  • "Most devices" is not "All devices".

    My router (Comtrend 5813, property of the carrier I use, Movistar, in Spain) only has the options "Disabled", "WEP" and "WPA".

    ¿What are my posibilities?

    - Buy another route for my web navigation use (WPA is not the best option, but enough security for me). I won't (we are in crisis, do you remember?)

    - Call my carrier and tell them that I cannot use the router they put two weeks ago at home because MS decided that "WPA is less secure than WPA2", so I cannot use it. I won't, because my carrier only has two models for optical fiber, and the other one does not allow me to connect to my office (PPTP connection)

    - Downgrade to 8.0. I won't, because I never uninstall or downgrade (I don't know how the system will be affected), and sould do to a much better windows: 7.0 (my PC is not a mobile, so don't apply mobile designs).

    - Change to any OS that can connect to an "insecure" WPA. I will think about it.

    - ¿Any other option?

    ¿WHY YOU DIDN'T ASKED FOR A CONFIRMATION BEFORE "UPGRADE"? (Can we consider "upgrade" an update that forces me to use the wire).

    PS: I've been reading at the 8.1 news at MS Spain, and I can't see anything about you decided to disconnect me.

    Thursday, October 31, 2013 11:11 AM
  • 17) Wonder why microsoft makes things difficult for us!

    You seem to hava a better temper then I do. To me this is an insult to the user and a recommendation, to switch to any other OS. I lost one whole day, because I thought, I was missing some drivers (LEAP / WPA /...). But hey, it is just microsoft beeing stupid and not showing them (they are not even greyed out...) while they actually ARE on the system

    Monday, December 09, 2013 5:46 PM
  • Oh my! 

    1) Well you left WEP... VERY consistent indeed. If you remove it, it might be a consideration to "grey stuff out" instead of just not showing it.

    2) "so there's little reason to use the less-secure encryption of WPA" well yeah! Exept, you might want to connect to a company / school / university network that actually DOES use it... And then - well I guess it's a feature, that you cant, because it is soooo much safer, not to... "You'll be taken to a website on the wireless access point itself, where you can configure all the possible wireless settings" lol - great idea! Hack the password and just hope, the admin wont catch you!

    Just assume: There are networks you do not have controll over. And then it actually might come in handy, to give people the chance to decide, whether to use it or not to. 

    Well you still can, using import / export and modify the keys manually. Well this is VERY user friendly. Just like telling people to uninstall , reinstall and then upgrade a OS to get a freakin WLAN connection to work. Sound's a bit like running twice arround the world to buy a piece of bread...

    I guess the missing lan connection interface is a feature too?

    Monday, December 09, 2013 9:14 PM
  • "It would be misleading if Windows showed the option when the option would probably just fail on 2.0 devices anyway."

    This very statement contradicts wireless connections when using Windows.  When given a list of wireless securities to choose from when connecting to a wireless network, only one of them will work anyway!  Depending on the wireless network one wants to connect to, they may need to choose from a list of the different securities, and only one of them will work!  Why in the world would you remove these two choices?  If they fail to connect then so be it, they will be on the list with the 5 others that didn't work as well!  Please patch this "feature" with an update that brings it back.  The fact you didn't advertise this "feature" speaks volumes.

    This is unfortunately going to become another brick in the wall against 8.1 acceptance.  Notice many posters here said they couldn't connect at school or at work - this is your bread and butter market you are disconnecting with a "feature".  Yes, ours included...

    Tuesday, December 10, 2013 7:40 PM
  • milindsmart's answer didn't work for me. Instead, what I had to do was delete the old profile, and create a new one. I did this via the add command to import a wireless profile xml. I created it without the key and with the nonbroadcast property. Not sure if it was because it was a nonbroadcasting SSID. When I tried to do it milindsmart's way, I got an error, "802.1X disabled when it is required to be enabled."

    my blog

    Friday, December 27, 2013 11:13 AM
  • After upgrading from Windows 8 Pro 64bit to Windows 8.1 Pro 64bit on my Sony Vaio Duoe 13, I could not find WPA security type while configuring Wireless network manually. (only WPA2 and 802.1X are available).

    I have done a lot of troubleshootings like

    1-Reinstall Wirless original driver

    2-Updating the wireless driver to the latest

    3-Uninstall and reinstall windows 8 then upgrading again to windows 8.1

    But the same.

    Is there any way to add WPA to the security type?

    I've figured a way to fix this, go to Intel website and download Intel PROSet Wireless Connection Utility, use the utility to configure the WPA Settings.

    Regard,

    Wayne Yong 

    http://www.wayneyong.com Email: admin@wayneyong.com

    • Proposed as answer by Wayne Yong Thursday, January 23, 2014 4:20 AM
    Thursday, January 23, 2014 4:14 AM
  • Removing WPA PSK and leaving in WEP is completely idiotic and just shows how increasingly out of touch Microsoft is with the real world.

    FYI, I know at least 300 businesses with thousands of access points using WPA-PSK because they depend on devices that don't support WPA2 and will cost millions of dollars to replace.

    They certainly won't be upgrading to Windows 8.1 any time soon.


    Network and Systems Manager

    Tuesday, March 04, 2014 11:18 PM
  • I am facing the same problem on newly bought Windows 8.1 hybrid. I tried the commands but when I keyed in:

    netsh wlan> set profileparameter name=<profilename> authentication=wpa encryption=tkip authMode=userOnly, I got an error: "The OneX setting in profile <profilename> on interface "Wi-Fi" is not enabled."

    What does it mean?

    The authentication still remains as "WPA2-Personal".

    How do I change it WPA-Personal?


    Valuable skills are not learned, learned skills aren't valuable.

    Monday, March 24, 2014 2:57 PM
  • this does not work for me. When I run step 12 I get the message " the OneX setting on profile <my profile> on interface "WiFi" is not enabled. " I tried to add UseOneX=no in front of authMode but got the same error. What do you suggest I do?
    Tuesday, April 22, 2014 12:38 PM
  • So what are my options now that the WPA option is no longer available on Windows 8.1?

    I have a client who has an older router that does not want to pay me to install and configure a new router, but now I cannot setup his new laptops on his network because the WPA option is not available. 

    Do I take his laptops back to Windows 8?

    I also don't understand why WPA is not an option while WEP (which is completely unsecure) is?



    Tuesday, April 22, 2014 4:26 PM

  • 12) netsh wlan> set profileparameter name=<profilename> authentication=wpa encryption=tkip authMode=userOnly

    13) netsh wlan> set profileparameter
    Don't exit this yet.

    What is that second "set profileparameter" for? Is it necessary?
    Wednesday, April 30, 2014 6:57 PM
  • Microsoft needs to understand that users do not control network settings.  I now have no way to access the Internet when I visit friends who have older wireless routers.  Considering my new laptop doesn't even have an Ethernet port, we need the maximum FLEXIBILITY when it comes to wireless connectivity.

    I've tried the above fixes to no avail but I'll run through it one more time to make sure.  I know this worked before the 8.1 update.

    How do we get Microsoft feedback so that they understand the significance of this one?

    Friday, May 23, 2014 10:39 PM
  • "So what are my options now that the WPA option is no longer available on Windows 8.1?"

    If you have a another Windows XP or Windows 7 device already configured on the same network, you can export the WiFi connection profile and import on the 8.1 device.  I did it (exported from WIN7 laptop) to an ASUS T100TA running 8.1. Took 2 minutes and it worked first time with no issues.  My "network" showed up in the list of Wireless Networks eligible to connect to as soon as I imported.  Mat need to log off/ on or reboot if it does not show up. All that was left was to right click the connection and add the key / pass phrase, as this was not carried over as part of the export-import

    You can search for "export wireless network profile" if you are not familiar with the process.

    Here is a good example: http://www.home-network-help.com/export-wireless-network-profile.html

    Hope this at least gets you up and running until your infrastructure is upgraded to WPA2 or other.

    Cheers

    Tuesday, June 03, 2014 12:01 PM
  • "So what are my options now that the WPA option is no longer available on Windows 8.1?"

    If you have a another Windows XP or Windows 7 device already configured on the same network, you can export the WiFi connection profile and import on the 8.1 device.  I did it (exported from WIN7 laptop) to an ASUS T100TA running 8.1. Took 2 minutes and it worked first time with no issues.  My "network" showed up in the list of Wireless Networks eligible to connect to as soon as I imported.  Mat need to log off/ on or reboot if it does not show up. All that was left was to right click the connection and add the key / pass phrase, as this was not carried over as part of the export-import

    You can search for "export wireless network profile" if you are not familiar with the process.

    Here is a good example: http://www.home-network-help.com/export-wireless-network-profile.html

    Hope this at least gets you up and running until your infrastructure is upgraded to WPA2 or other.

    Cheers
    Tuesday, June 03, 2014 12:02 PM
  • Fuel for the Apple platform. The OS is now too smart for the users? I choose MS because we have the power to configure.  Well I used to. I now I am supposed to ask my network admin to dumb down our entire WiFi network with 300 plus users connected to WEP or increase security to WPA2, thereby possibly knocking off key administrative personnel, both options are unacceptable.

    How about this, allow the wireless network device do what it is advertised to do on the box, by design, and let me set my network security to what I need to do my job.

    Just a thought.  

    Bottom line, Good intentions, not practical.

    I smell a fresh MS update brewing.

    And how exactly do I export a network profile?

    Tuesday, August 12, 2014 1:46 PM
  • Well tell me how I can logon to ad-hoc???? All I get back for the following is the help screen; and yes I entered the profile name and passphrase.

    netsh wlan set profileparameter name=[profile name] ConnectionMode=manual authentication=open encryption=WEP keyType=passphrase keyIndex=1 keyMaterial=<string>

    Sunday, August 31, 2014 7:20 PM
  • All of those who posted here have forgotten there are many using Windows XP with wireless cards and drivers which only support WPA as they were manufactured before WPA2 was invented. Equipment supporting only 802.11b (11Mbps) and some early 802.11bg (11 and 54 Mbps) only support WPA.

    I have several Windows XP laptops (yes I know Microsoft has declared XP as end of life) so most of the access points I set up for personal use are setup for WPA. When setting up wireless access points professionally the first question is do you have Windows XP computers requiring support. If the answer is yes each unit is verified each is capable of WPA2 otherwise WPA is used.

    Please take this in account with replies....

    Wednesday, September 10, 2014 11:01 PM
  • The person who decided this move is probably the same person who decided that users migrating from Win 7 to Win 8.1 directly no longer needed any way to read their "official Windows 7-sanctioned OS method" of making backup data. See: http://www.edandersen.com/2013/09/15/windows-8-1s-user-hostile-backup-story

    Their reply was basically: "Since the OLD way we were telling users to back up their data actually sucks, in this NEW version we have, we shall just remove all support completely so that users who ACTUALLY were dumb enough to have listened to us previously can now wean off the wrong ideas that we told them before... and we won't be bothering about giving them an optional tool for download to solve this issue etc. because there are probably users out there who STILL HAVEN"T UPGRADED TO WIN 8.1 ANYWAY (they can solve the issue indirectly if they still had another Win 7 computer)... "

    Hmmm wonder why so many people keep blasting MS or were so reluctant to upgrade???

    Also now this issue for win update: http://www.infoworld.com/t/microsoft-windows/microsoft-confirms-its-dropping-windows-81-support-240407

    I know I'm a bit off-topic here, but imagine my disgust when I was just dealing the above issue a few weeks ago and today I found out that I could not log in to the COUNTRY's free wireless network (Singapore's Wireless@SG network) with Win 8.1 (which I could in Win7) because MS disabled our ability to choose TKIP (and because apparently the government didn't anticipate MS doing stunts like this and upgraded our hardware to use AES instead), because they felt that we needed to be weaned off obsolete technologies, nevermind if there are still millions of dollars worth of infrastruture that hasn't been dumped in the e-waste garbage dump yet.

    Saturday, September 13, 2014 4:54 AM