none
Windows Update error 8024402C

    Question

  • I have a Visa Home premium desktop and am getting Windows Update error 8024402C when ever I try to run automatic updates. I first noticed this problem because my AVG would not update and when I looked into my Security center I also found that Windows Denfender was also not updating. I then thought to try running Windows update and that is when I got this error. In both cases, (AVG and Windows Update) the help directs to allow SVCHOST, or AVGINST.EXE to access the internet. I then turned off the windows firewall and connected my cable directly into my dsl router, bypassing my router, this did not help. I then thought Virus, so I checked how old my definitions are on both AVG and Windows Defender, and both were not more than three weeks old, so I ran scans using both and neither of them found anything. My IE LAN settings are already set to automaticly detect, and just to be sure, I unchecked clicked OK and then rechecked it, did not help. I also checked the Application and System logs and all I found was that my Search index was currupted, so I rebuilt the data and that did not help either. I also read all the other forum's relatlating to this topic and none of those ideas worked either.

     

    I am stumpted, Please help

     

    Saturday, January 12, 2008 5:26 AM

Answers

All replies

  • I'm sorry I cannot offer you any help but can share in your misery. If there is anyone out there that has a solution please share. I am a new computer owner and tis is making me crazy!!!

     

    Sunday, April 20, 2008 2:16 PM
  • This means that your local Windows Update client can't see the WU servers.  You might try this site for troubleshooting steps:

     

    http://windowshelp.microsoft.com/Windows/en-US/Help/261ae42d-8c84-496e-88cb-a46dff5504611033.mspx

     

     

     

    Monday, April 21, 2008 12:38 AM
  •  

    I have the same problem.  My windows were succesfully updated till SP1 update. After that i receive 8024402C error every time i try to connect WU Sad
    Sunday, May 04, 2008 5:26 PM
  • I guess this info should make me feel better.  I haven't been able to receive an update since a definition update to Windows Defender on March 13, 2008.  I'm stressing out from all the attempts to solve the problem.  Will somebody please HELP me? .....Who needs updates anyway?.....meeeee 

     

    Sunday, May 18, 2008 9:11 AM
  • I had the same issue. Drove me crazy too. It turned out my ADSL router (Netcomm NB5Plus4W) wasn't dealing with the DNS for Microsoft update properly. Changing to use a public DNS (I used https://www.opendns.com/start) fixed the issue for me.

    See http://forums.whirlpool.net.au/forum-replies-archive.cfm/866277.html for a story on one person's frustration, and http://forums.whirlpool.net.au/forum-replies-archive.cfm/839546.html for some clear instructions on changing your DNS settings if it isn't something you have done before.

     

     

    • Proposed as answer by Cappe97 Thursday, July 24, 2014 10:18 AM
    Tuesday, May 20, 2008 11:48 PM
  • I followed the advice about LAN Settings, Automatically detect, did not work. Turned OFF Windows Firewall -> worked like a charm. Wish Microsoft would detect its own Firewall was the problem and show an appropriate error message such as turn off the firewall.

    Sunday, October 26, 2008 4:44 PM
  • TRIED ALL PREVIOUS ADVICE FROM KNOWLEDGE BASES >> DID WHAT THIS GUY DID. TURNED FIREWALL OFF COMPLETELY>>>>> PROBLEM SOLVED!

    Sunday, November 23, 2008 3:04 AM
  • You can try this, it helped me in overcoming the same error code.

    1. Turn off your windows update service from Control Panel  --> Administrative tools --> Services  --> Windows update

    2.  Turn back on the same.

    3.  Now try to update 


    • Edited by varunviii Saturday, September 14, 2013 6:49 PM
    Saturday, September 14, 2013 6:48 PM
  • This is an old post, but came up first when searching on same issue.  I found the below to work for me.

     Open registry editor (Start menu –> Run –> regedit)

    Find the following path HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    Change the value of the UseWUServer from 1 to 0 (double click on it, change the value and click OK)

    Restart Windows Update service (Start menu –> Run –> services.msc, find the Windows Update service and click on Restart)

    Wednesday, June 11, 2014 1:28 PM