none
Layout.ini

    Question

  • I am using Windows 7 SP1 and the Prefetch folder does not have layout or layout.ini and I need to re-insert it for defragmenting purposes. Help

    Friday, March 25, 2011 11:41 PM

Answers

  • Thanks.  A bit of due diligence and I sorted out the problem.  The CMD instruction above did not resolve though I admit it may have contributed to the solution

     

     

    • Marked as answer by Vivian Xing Monday, April 04, 2011 9:18 AM
    Tuesday, March 29, 2011 11:17 AM

All replies

  • 1. Rundll32.exe advapi32.dll,ProcessIdleTasks will rebuild the layout.ini file,
    even if it has been deleted from %windir%\Prefetch. 

    Or

    2. Manually create a layout.ini.
    Paste these two lines in Notepad, including the brackets[]

    [OptimalLayoutFile]
    Version=1

    Save the file as layout.ini in %windir%\Prefetch

    Saturday, March 26, 2011 5:17 AM
  • Sadly although I ran it in CMD nothing happened and layout.ini has not re-appeared
    Saturday, March 26, 2011 5:51 AM
  • Did you try to manually create it? Also please check is your Task Scheduler service not disabled and running?
    Saturday, March 26, 2011 6:04 AM
  • Have you stopped the Superfetch Service?
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Saturday, March 26, 2011 12:43 PM
  • Sorry

     

    I have no idea what the task schduler is, nor SuperFetch service and why do I need to install RSAT

    All I know is that in the Prefetch folder there is no  layout.ini showing and I want to re-isert it.

    Saturday, March 26, 2011 5:41 PM
  • You don't need RSAT. This is my signature :D

    Run the services MMC Snapin and look if the Superfetch service is running.


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Saturday, March 26, 2011 8:52 PM
  • Hi,

     

    To ensure Prefetch folder works properly, please check the following registry.

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters]

     

    EnablePrefetcher"=dword:00000003

     

    Also make sure the task scheduler service is running.

     

    1. Click Start, type Services.msc in Start Search bar, and then press Enter.

    2. In the right pane, double-click task scheduler.

    3. In the Startup type list, click Automatic, click Apply, click Start, and then click OK.

     

    After that, click Start -> type CMD in the search box -> right click CMD in the list and choose Run as administrator. Then type the following command.

     

    rundll32.exe advapi32.dll,ProcessIdleTasks

     

    After booting 3 times, the Prefetch folder will be rebuilt.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, March 29, 2011 8:19 AM
  • Thanks.  A bit of due diligence and I sorted out the problem.  The CMD instruction above did not resolve though I admit it may have contributed to the solution

     

     

    • Marked as answer by Vivian Xing Monday, April 04, 2011 9:18 AM
    Tuesday, March 29, 2011 11:17 AM
  • and what was the solution?
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Tuesday, March 29, 2011 1:12 PM