none
DHCP is not enabled for wireless network

    Question

  • Hi all,

    I'm having internet connection problems and a lot of the time the Windows Networks Diagnostics says "DHCP is not enabled for wireless network",it then fixes the problem but I lose connection several times a day and each time do the same fix over again.

    I have checked the device manager settings and DCHP is started and set to automatic,I also ran CMD>ipconfig/all and can paste the results if need be.

    I use a VPN and never had any connection issues before with it and it seems to be equally hard to connect whether the VPN is on or off.

    Also recently I had the "security defender" virus which was removed successfully,the day after it was removed all the network adapters were messed up,I uninstalled and re-installed them but that did not work so I restored my system and that seemed to fix the issue,my computer does not seem to run as smoothly after the virus as before so I'm wondering if it has any bearing on my current problem.

    I'm using a Toshiba Satellite Pro 660D and Windows 7.

    Sunday, January 27, 2013 11:38 PM

Answers

All replies

  • Hi,

    Please disable all the security software and firewall and verify if the issue happens in Clean Boot mode and safe mode.

    Also, uninstall and reinstall the latest version of network adapter drivers and check if it helps.


    Tracy Cai

    TechNet Community Support

    Tuesday, January 29, 2013 7:38 AM
  • Hi and thank you for your answer.

    I did as you suggested over the weekend,disabled all security and updated the drivers,everything seemed fine Sunday and Monday but about an hour ago the problem returned.

    Is it possible the virus although removed has caused the issue?

    Tuesday, February 05, 2013 7:48 PM
  • Is there any interference between you and the access point? A cordless phone, fish task, microwave? How about connecting another device to the wireless router... Will the same thing happen? If so, the router may have the problem.
    Wednesday, February 06, 2013 5:01 PM