none
XP Mode issue: Printer will not auto switch to letter/legal paper size

    Question

  • I have Windows 7 64 bit set up with XP mode and I’m having some printing issues. From Windows 7 it prints fine (Switching from Legal and Letter). From the virtual machine, it prints only legal. The printer is an HP Laserjet P2055dn with the PCL 6 universal driver connected via Ethernet. I have to open the legal tray to get it to not print legal by default. The printer is set up to auto detect which paper size to use and this was not a problem on our old xp machines. Any help would be appreciated!
    Tuesday, February 28, 2012 4:24 PM

Answers

  • When using the HPUPD it is always a good idea to get the printer to discover the settings of the printer itself, this is done by bring up the properties of the printer and then device settings and automatic configuration - select update now and let it do its thing. Once complete on the "genera"l tab select "printing preferences" and select your options then configure the same options from the "advanced tab" and "printing defaults". Also assuming that your Windows XP mode is 32 bit you will also need the 32 bit drivers installed on your host, "sharing" tab, "additional drivers".

    Hope this helps in some way or points you in the right direction.

    Thursday, March 01, 2012 2:54 PM

All replies

  • Try to download the driver from the following website and install it.

    http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=3662058&prodTypeId=18972&prodSeriesId=3662052&swLang=8&taskId=135&swEnvOID=228


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Thursday, March 01, 2012 10:13 AM
    Moderator
  • I've tried the driver in the link and it is still printing from the legal tray by default.
    Thursday, March 01, 2012 2:36 PM
  • When using the HPUPD it is always a good idea to get the printer to discover the settings of the printer itself, this is done by bring up the properties of the printer and then device settings and automatic configuration - select update now and let it do its thing. Once complete on the "genera"l tab select "printing preferences" and select your options then configure the same options from the "advanced tab" and "printing defaults". Also assuming that your Windows XP mode is 32 bit you will also need the 32 bit drivers installed on your host, "sharing" tab, "additional drivers".

    Hope this helps in some way or points you in the right direction.

    Thursday, March 01, 2012 2:54 PM