none
Available Networks window does not appear when clicking Network Activity icon

    Question

  • Hello,

    when I left click on my network activity icon in Windows 7 (Pro, 64bit), nothing appears now.  When I first setup the computer, I clicked on it, and the list of available network connections would appear.  Now, I click, and nothing appears.  If I right click, I can get to Network and Sharing Centre, and then click Connect to a Network to get the same spot, but it's 3 extra clicks.

    What I've done as a workaround is create a batch file that runs:
    rundll32.exe van.dll,RunVAN

    and then that makes the window appear.

    Also, when I resume for sleep mode or hibernation, I cannot automatically reconnect to my home network.  It tries and tries, and tries, but with no joy.  I can only reconnect when I run my batch file above and double click my network name in the list.

    Any ideas how to reset the properties of the network activity icon so that it displays the available networks list when clicked?

    Regards,
    Ben
    Friday, February 12, 2010 11:47 AM

Answers

  • Hi Ben,

     

    Based on my research, I would like to suggest the following:

     

    1.    Please boot the system to Safe Mode with networking and check if the Available Networks window will appear by clicking the Network icon.

     

    2.    Check the issue in Clean Boot environment:

     

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

     

    3.    Regarding the issue that you could not reconnect to the network after sleep mode or hibernation, I would like to know what kind of connection you are connecting to, wired, wireless, VPN or etc.

     

    If you are using wireless connection, please remove and re-create the wireless profile of your home network to see how it works:

     

    1)    Go to Network and Sharing Center.

    2)    Click “Manage wireless networks”.

    3)    In Manage Wireless Networks window, remove the wireless profile of your home network.

    4)    Disconnect your wireless network and reconnect.

    5)    The go to Manage Wireless Networks window, you can see the profile for your wireless network created just now

    6)    Double click on the profile, and on Connection tab, please ensure “Connect automatically when this network is in range” is selected.

    7)    Switch to Security tab, ensure that the settings are proper and click “Advanced settings”.

    8)    In Advanced settings, please also check the settings refer to your network configuration.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Monday, February 15, 2010 6:07 AM
    Moderator