none
Command line hybrid sleep

    Question

  •  

    Hi,

    I was looking for a way to use the command line to put the computer into hybrid sleep mode.  shutdown is a command I have looked at with the closest option there being hibernate.  I'm looking to have the computer go to sleep after a backup task so it wont just be idle until the power settings put it to sleep.

     

    Thanks

    Thursday, October 02, 2008 3:27 AM

Answers

  • Hi

     

    If you have the Hybrid Sleep mode enabled in the power configuration options, you should be able to use the following command.

     

    rundll32 powrprof.dll,SetSuspendState

     

    This command should invoke whatever settings that you have configured in the Control Panel/Power Options component.

     

    You can also create a desktop shortcut for this command.

     

    Hope this helps.

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.
    By marking a post as Answered, you help others find the answer faster.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Thursday, October 02, 2008 4:45 PM
    Moderator

All replies

  • Hi

     

    If you have the Hybrid Sleep mode enabled in the power configuration options, you should be able to use the following command.

     

    rundll32 powrprof.dll,SetSuspendState

     

    This command should invoke whatever settings that you have configured in the Control Panel/Power Options component.

     

    You can also create a desktop shortcut for this command.

     

    Hope this helps.

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.
    By marking a post as Answered, you help others find the answer faster.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Thursday, October 02, 2008 4:45 PM
    Moderator
  • No the rundll32 command does not put my Vista to hybrid sleep, even though hybrid sleep is enabled and I can put the computer to hybrid sleep manually via the start menu.  Instead the computer enters hybernation in my case, not hybrid sleep.
    Tuesday, March 24, 2009 12:43 PM
  • Make sure you have enabled correct ACPI option in bios and as Ronnie says it invokes your configured power settings..
    (I know it was solved but somtimes bios setting is not enabled)

    http://blogs.msdn.com/justsean/archive/2006/12/08/vista-notes-episode-2-sleep-vs-hybrid-sleep.aspx
    Saturday, March 28, 2009 1:24 PM
  • In the DELL Precision 650 that I am talking about there are 2 suspend modes: S1 and S3.  Currently it is set to S3 with the LowPower Mode enabled.  In spite of that, rundll32 /d powrprof.dll,SetSuspendState forces the computr to hybernate and not enter hybrid sleep.  At the same time I can put it into hybrid sleep manually by pressing the start menu power button.
    Saturday, March 28, 2009 2:43 PM
  • Awesome! that works in my vista.
    Tuesday, December 15, 2009 12:28 PM