none
DETAILED QUESTION Windows could not start the Print Spooler service on Local Computer ERROR 1068 (Windows 7)

    Question

  • **DEVICES INVOLVED:   
    COMPUTER -- HP G60-535DX running original OEM of Windows 7 Home Premium (64-bit)
    PRINTER: -- HP Deskjet F4440 (Brand New)

    I'm trying to install a printer for the first time on my laptop. (it's a second-hand laptop, but I don't see any other printers installed by the previous owner)

    (SPECIFIC INFO TO MY INSTALL)
    I haven't plugged the usb cable in yet, (as per the printer manufacturer's instructions) and I'm using the install CD first. During installation, the software says that the Print Spooler service is stopped - and needs to be manually restarted before installation can continue.
    It gives instructions to go to the "Services" area in the Windows' Computer Management window. It says to right-click your Print Spooler service and click "Start".

    (GENERAL PROBLEM)
    When I do this, Windows 7 gives me the error message, "Windows could not start the Print Spooler service on Local Computer. ERROR 1068: The dependency service or group failed to start."

    I looked in the properties of the Print Spooler service. Under the "Dependencies" tab it lists:

    >HTTP
    >Remote Procedure Call (RPC)
        |__>DCOM Server Process Launcher
        |__>RPC Endpoint Mapper

    Under the "General" tab, it lists the Path to executable as "C:\Windows\System32\spoolsv.exe".
    It lists the Startup type as "Automatic".
    Only the button for "Start" is available, and it gives that 1068 error when pushed.

    I tried using the utility that comes with Windows 7 to check the integrity of all system files and it returned no errors. There is also no error data regarding the printer in the Windows "report.wer" file in the C:\ProgramData\Microsoft\Windows\WER\ReportQueue.

    I checked for installed drivers at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3 and the values are:
    (Default) = "(Value Not Set)"
    Directory = "3"
    MajorVersion = "0x00000003 (3)"
    MinorVersion = "0x00000000 (0)"

    I also checked HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3 and the values were the same. HOWEVER there were two folders under the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3:
     |__>Microsoft Shared Fax Driver
     |__>Microsoft XPS Document Writer

    I've read many other threads, and I'm attempting to be as detailed with my question as possible. I suspect one of the other Services which the "Print Spooler" service relies on is NOT working. I also don't think any manufacturer-specific drivers are installed. However, I don't know how to find which "Dependency Service" is missing/not working or how to further diagnose/fix this issue.

    Wednesday, May 12, 2010 2:24 AM

Answers

  • PROBLEM SOLVED!

    **One thing I noticed is that my print spooler service says it depends on HTTP and Remote Procedure Call . The Remote Procedure Call service is started, but I do not even see the HTTP service on the "Services" list (Services.msc).

    I tried removing the HTTP service from the list of dependencies for the print spooler. I know Linda Yan said both HTTP AND Remote Procedure Call should be in the "DependOnService" values BUT even without the HTTP service..... it worked! I reset the computer and the print spooler came online perfectly.

    And to Labocaloca: Once the http service was removed from the print spooler dependencies (via regedit.exe) and the computer restarted, ALL of the options were opened up and available to change. Also , under the "Log On" tab, "Local System account " was already selected after the computer restarted and I didn't need to change anything.

     

     

    • Marked as answer by 100thVisitor Thursday, May 27, 2010 10:32 PM
    Thursday, May 27, 2010 9:08 PM

All replies

  • In general, this kind of issue is most likely caused by the incorrect registry values.

     

    You can try the following suggestions and see if the issue can be resolved:

     

    1.     Click Start, type services.msc in the Start Search box.

    2.     Right click on Services.msc and then click "Run as administrator".

    3.     Double click the service "Remote Procedure Call (RPC)".

    4.     Click on the "Log On" tab, please ensure the option "Local System account" is selected and the option "Allow service to interact with desktop" is unchecked.

    5.     Click on the "General" tab; make sure the "Startup Type" is "Automatic". Then please click the button "Stop" under "Service Status" to stop the service.

    6.     Then please click the button "Start" under "Service Status" to start the service.

    7.     Please repeat the above steps to start Print Spooler Service.

     

    Please check if our issue can be resolved. However, if the issue persists, let's go to Suggestion 2.

     

    1.     Click Start then type regedit in the Start Search box.

    2.     Right click on regedit.exe and then click "Run as administrator".

     

    3.     Expand the "+" to the following keys.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Spooler

     

    4.     Right click on "Spooler", click "Export", and then save it to the C:\ drive as a backup. (In case we need to undo the modification, we can double click it to restore the registry key).

     

    5.     The DependOnService value by default should be set to

     

    RPCSS

    http

     

    6.     Delete any improper values, such as "lexbce".

    7.     Quit the Registry Editor and restart your computer.

     

    Hope this helps.

     

    Regards,

    Linda

     

    Thursday, May 13, 2010 7:57 AM
  • Ok, it seems like we may be closer to the problem. I was following your suggestion #1: pulled up Services.msc as an Administrator. Went to the Properties of "Remote Procedure Call (RPC)" and went to the "Log On" tab.

    However, the radio button is set to "This account:" with "Network Service" typed in the text box. The text boxes for "Password" and "Confirm Password" are filled in with those anonymous character dots. BUT all of the options including the radio button above for "Local system account" and the check box for "Allow service to interact with desktop" are grayed out and unable to be changed! :(

    Also, on the "General" tab: Startup type is listed as "Automatic", Service status is listed as "Started", and the 'Start' 'Stop' 'Pause' and 'Resume' buttons are all grayed out as well. :(
    The "Path to executable:" is set to "C:\Windows\system32\svchost.exe -k rpcss".

    How should I proceed to unlock the options in the Properties of "Remote Procedure Call (RPC)"?

    Thursday, May 13, 2010 3:07 PM
  • What is the result after checking the registry key value? If the issue still exists, refer to this knowledge base (KB) article: Fix printing problems by resetting the print spooler

     

    Also, here is an article from HP website: 'Error 1068 - Print Spooler Error' Message Displays in Windows Vista when Installing or Uninstalling HP Software

     

    • Marked as answer by Linda Yan Tuesday, May 18, 2010 1:34 AM
    • Unmarked as answer by 100thVisitor Friday, May 21, 2010 7:23 PM
    Friday, May 14, 2010 2:21 AM
  • I have the same problem.  It arose after a Windows Update on May 12, 2010.  Followed the procedure suggested and the radio buttons are grayed out.  HOW DO I GAIN ACCESS???? My RPC service is set to Network Service while the Print Spooler is set to Local System.  Help please.  The KB article did not help.
    Tuesday, May 18, 2010 7:19 AM
  • The Registry key values are correct , I checked them. They are "HTTP" and "Remote Procedure Call".

    The problem is that windows is not giving access to the options for the"Log On" tab of the RPC Properties dialog box. (as discussed in Suggestion # 1)
    How do I free this up?

    I cannot (at this point):

    Quote from Linda Yan:

    "4.     Click on the "Log On" tab, please ensure the option "Local System account " is selected and the option "Allow service to interact with desktop" is unchecked.

    5.     Click on the "General" tab; make sure the "Startup Type" is "Automatic ". Then please click the button "Stop " under "Service Status" to stop the service.

    6.     Then please click the button "Start " under "Service Status" to start the service. "

     

     

    (check my previous post for details I posted)

     

    Any idea how to unlock those options/radio buttons? It seems i'm not the only one experiencing these problems...

    Thanks
    Friday, May 21, 2010 7:36 PM
  • The Remote Procedure Call (RPC ) service is configured as

    NetWork Service

    It is not supposed to be Local System.  The configuration on the machine which I am currently using is this way.

    I don't have a solution for you unless you are booted to save mode where the spooler sevice will not start and it does return error 1068.

    run the system file checker tool

    in an Admin elevated command prompt type

    SFC /SCANNOW

     


    Alan Morris Windows Printing Team; Search the Microsoft Knowledge Base here: http://support.microsoft.com/search/Default.aspx?adv=1
    Saturday, May 22, 2010 6:00 AM
  • As I said in my original question:

    "I tried using the utility that comes with Windows 7 to check the integrity of all system files and it returned no errors.
    There is also no error data regarding the printer in the Windows "report.wer" file in the C:\ProgramData\Microsoft\Windows\WER\ReportQueue."

    So I can try safe mode. Now, do you mean to put in safe mode and then try making changes to the settings there?

    Which settings would I change?

    Saturday, May 22, 2010 11:28 PM
  • The spooler is not started in safe mode.  Normally the 1068 error is generated after removing a Lexmark or Dell printer which have added dependencies to spooler that are not removed when removing the printer but the services not longer start because the printer is gone.  Search through the registry for Lexmark or Dell.  Since the computer was previously owned by someone else verify they did not have some Lexmark or Dell printer software installed.

    Export the registry contents of

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print

    and copy to the skydrive associated with the live account and send the link

    Look for spoolsv.exe.org in c:\windows\system32.  If you have this file then something changed the name of spoolsv.exe. 


    Alan Morris Windows Printing Team; Search the Microsoft Knowledge Base here: http://support.microsoft.com/search/Default.aspx?adv=1
    Sunday, May 23, 2010 5:31 AM
  • Thank you for your continued dedication to this issue!
    I checked the c:\windows\System32 and it did have the spoolsv.exe alone, not the spoolsv.exe.org. Good-to-go on that point. :)

    The link to my exported HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print is:

    http://cid-00b27f2f5e217d72.skydrive.live.com/self.aspx/.Public/HKEY^_LOCAL^_MACHINE^_SYSTEM^_CurrentControlSet^_Control^_Print.reg

    I hope you can find something in there.

    Sunday, May 23, 2010 4:18 PM
  • PROBLEM SOLVED!

    **One thing I noticed is that my print spooler service says it depends on HTTP and Remote Procedure Call . The Remote Procedure Call service is started, but I do not even see the HTTP service on the "Services" list (Services.msc).

    I tried removing the HTTP service from the list of dependencies for the print spooler. I know Linda Yan said both HTTP AND Remote Procedure Call should be in the "DependOnService" values BUT even without the HTTP service..... it worked! I reset the computer and the print spooler came online perfectly.

    And to Labocaloca: Once the http service was removed from the print spooler dependencies (via regedit.exe) and the computer restarted, ALL of the options were opened up and available to change. Also , under the "Log On" tab, "Local System account " was already selected after the computer restarted and I didn't need to change anything.

     

     

    • Marked as answer by 100thVisitor Thursday, May 27, 2010 10:32 PM
    Thursday, May 27, 2010 9:08 PM
  • To 100thVisitor:  Dude!  Great call on removing the http dependency.  Removed it, rebotted, and the spooler started back up.  Thanks/
    Saturday, June 12, 2010 6:41 AM
  • Anyone else having this problem? It's worth having a read at

    http://h20338.www2.hp.com/hpsub/downloads/UPD_Microsoft_Driver_Isolation_Mode.pdf

     

    Friday, January 14, 2011 11:30 AM
  • I know this thread is now over 2 years old but this solution worked !! (Win 7 Pro, 32-bit, SP1)

    I scoured all of the forums and solutions FAQs for an answer and spent the better part of a day trying to solve this issue when my Print Spooler went offline giving an error 1068. Nothing was working and I was ready to throw the CPU out of the window when I stumbled upon this fix. It worked like a charm!

    Are there any know issues with deleting http from the dependencies? Everything seems to be working perfectly but messing with the registry always gives a tech-naive user like me anxiety. 

    Wednesday, January 23, 2013 6:27 AM