none
How to get rid of Liraries and Homegroup Icons from Windows 7 Home Premium

    Question

  • I am running Windows 7 Home Premium on my Desktop and Windows 7 Professional on my Laptop.  My desktop PC's homepage has icons for Libraries and Homegroup which I don't need.  These do not appear on my Laptop's homepage.  How can I get these off my PC?  There seems to be no easy, obvious solution to delete these.  Thanks.
    Monday, November 02, 2009 1:47 AM

Answers

All replies

  • Hi Jacjon,

    If "Homegroup" and "Libraries" you mentioned is the left side of Windows Explorer, we can disable the list with click Organize --- Layout --- uncheck Navgation pane.

    If i'm incorrect please just let me know.
    Monday, November 02, 2009 6:18 AM
    Moderator
  • For homegroups, go to network and sharing, leave your home group, then start, run, services.msc and disable and stop homegroup provider and homegroup listener services. THis will disable homegroups. Even with navigation pane enabled, homegroup will no longer show in navigation and open dialogs.
    Monday, November 02, 2009 6:25 AM
  • Sorry, but that did not work. 

    Monday, November 02, 2009 7:25 AM
  • Thanks.  That worked.  Now, do you have a way to get rid of libraries also?

    JJ
    Monday, November 02, 2009 7:26 AM
  • No, i havent found a way to get rid of libraries yet. I hate them too.
    Monday, November 02, 2009 7:44 AM
  • Jacjon,

    Actually, here you go..

    As with anything registry related, make sure you take a backup.

    http://www.askvg.com/how-to-disable-libraries-feature-in-windows-7/

    Monday, November 02, 2009 8:10 AM
  • Thanks.  That was very easy and painless.  It worked.  Thanks everyone for your help.

    JJ
    • Proposed as answer by cellproject Wednesday, December 23, 2009 5:04 PM
    Monday, November 02, 2009 2:23 PM
  • the homegroup icon appeared on my desktop, and it will not let me delete it, does anyone know how to get it off of the desktop but leave it in the folder options, it doesnt bother me that it is in the folders, but i dont like having icons clutter up the desktop.
    Wednesday, December 23, 2009 5:06 PM
  • Hey guys and gals,

    My biggest frustration with this new libraries junk is that now when I click my "Documents" folder/button on my start menu, I have to click down one more level before I can actually see my documents.  Before, it used to be Start > Documents > DocSubFolders.  Now it's Start > Documents > MY Documents > DocSubFolders.  This is obnoxious!  I tried importing the registry file but it didn't do away with the library part of the Start Menu Documents folder.  Can someone PLEASE tell me how to skip this extra drilldown step to get to My Documents?  Thank you!!

    Regards,

    Maximillian C.
    Seattle, WA
    Maximillian R. Carper
    Friday, February 19, 2010 5:51 AM