none
Windows 8.1 RDP Virtual Memory Error

Answers

  • In solved in this way:

    Open regedit, set to 0 this key:

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Gateway\Messages\<Domain>\<USERNAME>\UserPreferenceOption

    The problem is the option "Do not ask again unless changes to policy occur" in the "LogOn Message".

    Monday, October 21, 2013 1:18 PM

All replies

  • Hi,

    Since I cannot repro this issue, I considered that following factors may cause this issue:

    1.        Paging file value setting is too low.
    2.        RAM issue

    First, I suggest we try following steps to check the issue:

    Step 1: Increase page file size:

    How to Change The Size of Virtual Memory (pagefile.sys) on Windows 8 or Windows Server 2012 http://blogs.technet.com/b/danstolts/archive/2013/01/07/how_2d00_to_2d00_change_2d00_the_2d00_size_2d00_of_2d00_virtual_2d00_memory_2d00_pagefile_2d00_sys_2d00_on_2d00_windows_2d00_8_2d00_or_2d00_windows_2d00_server_2d00_2012.aspx

    Step 2: Run Memory diagnostic tool:

    1.        From Start, type mdsched.exe, and then press Enter. Normally, text that you type on Start is entered into the Apps Search box by default.
    2.        Choose whether to restart the computer and run the tool immediately or schedule the tool to run at the next restart.
    3.        Windows Memory Diagnostic runs automatically after the computer restarts and performs a standard memory test. If you want to perform fewer or more tests, press F1, use the up and down arrow keys to set the Test Mix as Basic, Standard, or Extended, and then press F10 to apply the desired settings and resume testing.
    4.        When testing is complete, the computer restarts. You’ll see the test results when you log on.

    If this issue still persists after above steps, I recommend you helping to do following test and let me know the results:

    Start Windows in Clean boot mode, and open Remote desktop and see what’s going on:

    How to perform a clean boot to troubleshoot a problem in Windows 8, Windows 7, or Windows Vista

    http://support.microsoft.com/kb/929135  

    Keep post.


    Regards,

    Kate Li

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Friday, October 18, 2013 2:30 AM
  • Hi,

    Thanks for the reply. I tried all these steps but unfortunately it didn't make any difference.

    The Windows Memory Diagnostic tested the computer's memory and detected no errors

    I think the key to my problem is the connection that doesn't work is using RD Gateway Server settings. I use many other direct RDP connections and these all work fine - this one using RD Gateway is the only one that doesn't work.

    I have checked this connection on many other machines - Windows 7, Windows 8 and it works fine. It only fails on Windows 8.1.

    Have you any other suggestions?

    Thanks,

    Ryan

    Monday, October 21, 2013 7:39 AM
  • I have just noticed this in the event viewer...

    Log Name:      Security
    Source:        Microsoft-Windows-Security-Auditing
    Date:          21/10/2013 11:39:44
    Event ID:      4648
    Task Category: Logon
    Level:         Information
    Keywords:      Audit Success
    User:          N/A
    Computer:      XXX
    Description:
    A logon was attempted using explicit credentials.

    Subject:
     Security ID:  XXX
     Account Name:  XXX
     Account Domain:  XXX
     Logon ID:  0x3C659
     Logon GUID:  {00000000-0000-0000-0000-000000000000}

    Account Whose Credentials Were Used:
     Account Name:  XXX
     Account Domain:  XXX
     Logon GUID:  {00000000-0000-0000-0000-000000000000}

    Target Server:
     Target Server Name: XXX
     Additional Information: XXX

    Process Information:
     Process ID:  0x1a40
     Process Name:  C:\Windows\System32\mstsc.exe

    Network Information:
     Network Address: -
     Port:   -

    This event is generated when a process attempts to log on an account by explicitly specifying that account’s credentials.  This most commonly occurs in batch-type configurations such as scheduled tasks, or when using the RUNAS command.

    Monday, October 21, 2013 10:43 AM
  • More progress... I have discovered the RDP works under other logons to the machine. So I am guessing something has happened to the stored credentials under my own logon for this RDP. I just can't quite figure out what I need to change.
    Monday, October 21, 2013 11:05 AM
  • In solved in this way:

    Open regedit, set to 0 this key:

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Gateway\Messages\<Domain>\<USERNAME>\UserPreferenceOption

    The problem is the option "Do not ask again unless changes to policy occur" in the "LogOn Message".

    Monday, October 21, 2013 1:18 PM
  • Brilliant! This solved my problem! Many thanks!
    Monday, October 21, 2013 1:25 PM
  • Worked for me as well.

    Thanks!!

    Wednesday, October 23, 2013 2:14 PM
  • Fixed issue for me too!!

    When are Microsoft going to fix this issue? It is not a problem in Windows 8.0

    Monday, October 28, 2013 8:10 AM
  • Perfect fix, thank you VERY MUCH... this worked immediately.
    Monday, October 28, 2013 1:27 PM
  • Thanks Fabio!

    Kate, when will this bug be covered by an update?

    We have users installing the 8.1 update at home and they can't get connected anymore...

    Monday, November 04, 2013 2:03 PM
  •  Many thanks you VERY MUCH... this worked perfectly!!!

    Jorge

    Thursday, December 19, 2013 9:03 PM
  • Thanks Fabio,

    Your solution works!

    Thursday, January 30, 2014 7:59 PM
  • What is the actual value for this? Is it a registry value called "LogOn Message" that I change to 0. Or do I change the default value of the registry key "UserPreferenceOption"? Is the value a DWORD or a String?. Can someone screen shot the end registry key so I can make sure this is correct? Thanks in advance.
    Tuesday, February 11, 2014 2:43 AM
  • Don't remember the value before changing it.

    You have to edit the dWord value UserPreferenceOption and set it to 0:

    As changing this value for home workers isn't a solution, we temporarly disabled the welcome message on the Gateway, so users don't need to use registry.

    Tuesday, February 11, 2014 8:07 AM
  • I do not even have Terminal Server Gateway in the registry.
    Thursday, June 19, 2014 1:52 PM