none
How to start Windows Virtual PC at Startup without login user

    General discussion

  • I need start virtual machine after startup computer before login user.

     

    Start programs after Startup is possible to make as a service (using srvany.exe) or using Task Scheduler (Activating Event – After Startup) or using StartUp script. I think the Task scheduler in Windows 7 is best solution. So, I create Virtual Machine and plan task with MyVM.vmcx. This task work fine only if I choose “Start only if user is logged on”. But I need start it independence of logging user. I try to start virtual machine thru many methods (using VMWindow.exe, VPC.exe, using object VirtualPC.Application, …). In all ways machine doesn’t start with error Access Denied.

     

    Problem is in DCOM component Virtual PC. In property page Identity is selected to start only Interactive User. Unfortunately is not possible to change values…

     

    So, I make these steps:

    1. Open registry editor.
    2. Search for HKCR\VirtualPC.Application\CLSID and copy Default Value ({9a1774b7-8251-4468-a214-61dcaed9ac2f}).
    3. Search for this in HKCR\CLSID and copy value of AppID ({f375390d-5d01-4106-ae15-674be971c676}) – this is to see in Component management too.
    4. Search for this in HKCR\CLSID and on key name right click and choose Permisions…
    5. Because only TrustedInstaler have right to change this key and subkeys I take ownership of this object and enhance rights for me.
    6. Delete Value RunAs (Interactive User).
    7. Restart computer.
    8. Open Component Services and navigate to This Computer – DCOM configuration – Virtual PC.
    9. In property dialog I check bookmark Identity – selection Starting User (or This User and fill credentials).
    10. On bookmark Security I add right user account to Start, Acces and Config.

     

    Then I try to start my Task in task scheduler and – It’s WORKING!

    Then I restart computer, not log on and from other computer I try to remote connect to virtual machine – It’s WORKING!!!

     

    P.S. Sorry for my English and not right labels – I have Czech edition of Windows 7.

    Thursday, November 25, 2010 2:08 PM

All replies