none
Lord of the Rings Online (LOTRO) works with windows 8 but you need the 1.1 net framework installed.

    Question

  • Only error I ran into was on initial start-up I was informed that the 1.1 net framework was required to run. Clicked on install now which sent me to the appropriate place to download and install. The installer did warn about potential compatibility issues, I ignored the warning and proceeded anyway.

    The game seems to run just fine now.

    I hope this helps any other LOTRO players out there.

    Sunday, October 28, 2012 12:24 AM

Answers

All replies

  • When I try to install the 1.1 framework, it simply fails with "Microsoft .NET Framework Setup failed. If this problem continues, contact Product Support Services". 
    Friday, November 02, 2012 9:12 PM
  • When I try to install the 1.1 framework, it simply fails with "Microsoft .NET Framework Setup failed. If this problem continues, contact Product Support Services". 
    Same here....
    Friday, November 30, 2012 1:12 PM
  • Same here.
    Wednesday, December 05, 2012 7:43 PM
  • Same here.
    Thursday, December 06, 2012 12:38 PM
  • Open the .config file which has the same name like the Exe and edit the supportedruntime entry and change 1.1 to v4.0. Does it now run?

    "A programmer is just a tool which converts caffeine into code"


    Thursday, December 06, 2012 3:44 PM
  • Open the .config file whcih has the same name like the Exe and edit the supportedruntime entry and change 1.1 to v4.0. Does it now run?

    "A programmer is just a tool which converts caffeine into code"

    Or in the case you just have the dotnetfx.exe file, just use WinRAR (or your program of choice) to extract the files to a new folder. After that run manually the netfx.exe file, it will say it might have compatibility issues but just go ahead and install it.

    Worked for me.

    Wednesday, December 19, 2012 5:03 PM
  • Clever solution. In my case, it was steam that was the problem. So I opened the local files, opened both the config files for the Invoker and the Launcher, and changed both version numbers in each from 1.x.xxxx to 4.0. Viola. Worked like a charm. Thanks for the the quick fix.
    Saturday, December 22, 2012 9:20 PM
  •  Worked like a charm. Thanks for the the quick fix.

    You're welcome :)

    "A programmer is just a tool which converts caffeine into code"

    Sunday, December 23, 2012 5:16 AM
  • Works!
    Tuesday, December 25, 2012 12:38 AM
  • does not work for me changed it to 4.0 in the config files and when starting the launcher it changes it back to 1.1. Tried making it read only but then just fails with can not patch
    Sunday, July 07, 2013 7:41 PM
  • Open the .config file which has the same name like the Exe and edit the supportedruntime entry and change 1.1 to v4.0. Does it now run?
    Works like a charm!  Thanks for the fix!
    Friday, November 08, 2013 9:57 PM