none
How do I remove a virtual CD drive in Windows 8?

    Question

  • One of my friends used my computer to download Sims 3, and now I have a virus. It seems to have created a whole virtual CD drive (J:) on my computer, and I can't delete any of it. The drive won't eject or delete. I followed the instructions in another page of the forum under "windows 8 disk management remove basic virtual disk," but it doesn't see (J:). It sees several other drives, just not that one. The virus is on this drive, and Norton isn't seeing it elsewhere, so I can't just delete that either, as it's showing the "disk" as read-only. Do you have any suggestions on how to fix this problem?

    Thank you so much!

    PS: I have a screenshot if that would help. The forum won't allow me to post it here.

    PPS: The instructions I followed from the other forum page are: "If you don't want the virtual hard disk any longer, all you have to do is delete it.  You don't give specifics, so I will have to guess. 

    If this is a virtual hard disk used by a VM you tried to create in Hyper-V, first go into Hyper-V and delete the VM.  That just deletes the VM - not the disk.  After deleting the VM, there should be no process using the virtual hard drive, so you just have to delete it.

    Another thing you might have done is to create the VHD and mounted it to Windows 8.  In this case, you can't delete it because Windows 8 owns it.  Start computer management (compmgmt.msc).  Go to Disk Managment.  Find the entry for your VHD.  Right-click and detach it.  Then you can delete it.

    If it is not one of these things, you are going to have to give a more complete description of your environment and what is preventing you from deleting it.  .:|:.:|:. tim"


    Saturday, September 14, 2013 7:43 PM

Answers

  • OP Here: 
    Yes.

    Right click on the drive.
    Click Properties.
    Open the Hardware tab.
    Click Properties.
    Go to the Driver tab.
    Click Disable.
    Click Uninstall.
    It will prompt you to restart your computer.

    Once you're back in, repeat the process. 
    The drive will still show (I haven't figured out how to remove it), but without drivers, it can't harm the computer.

    Norton no longer sees backdoor.graybird or any other threats on the drive.


    • Marked as answer by Kateri87 Thursday, June 12, 2014 2:43 AM
    Thursday, June 12, 2014 2:42 AM

All replies

  • Rightclick on the drive J: and select "eject". Does this work?

    "A programmer is just a tool which converts caffeine into code"

    • Marked as answer by Niki HanModerator Thursday, September 19, 2013 2:48 AM
    • Unmarked as answer by Kateri87 Thursday, June 12, 2014 2:43 AM
    Saturday, September 14, 2013 7:51 PM
  • Go to Device Manager, check if the virtual CD drive is available. If yes, disable or uninstall the device.

    Niki Han
    TechNet Community Support

    • Marked as answer by Niki HanModerator Thursday, September 19, 2013 2:48 AM
    • Unmarked as answer by Kateri87 Thursday, June 12, 2014 2:43 AM
    Monday, September 16, 2013 3:10 AM
    Moderator
  • Hi, I've had the exact same problem, have you worked out how to delete it?
    Tuesday, January 21, 2014 11:23 PM
  • I have same problem too. I see this virtual drive only in My Computer, not in Disk management and Device manager, and I can't eject it, drive is empty and I getting "An error occured while ejecting 'CD Drive (G:)' error.
    Thursday, January 30, 2014 12:46 PM
  • OP Here: 
    Yes.

    Right click on the drive.
    Click Properties.
    Open the Hardware tab.
    Click Properties.
    Go to the Driver tab.
    Click Disable.
    Click Uninstall.
    It will prompt you to restart your computer.

    Once you're back in, repeat the process. 
    The drive will still show (I haven't figured out how to remove it), but without drivers, it can't harm the computer.

    Norton no longer sees backdoor.graybird or any other threats on the drive.


    • Marked as answer by Kateri87 Thursday, June 12, 2014 2:43 AM
    Thursday, June 12, 2014 2:42 AM
  • OP Here: 
    Yes.

    Right click on the drive.
    Click Properties.
    Open the Hardware tab.
    Click Properties.
    Go to the Driver tab.
    Click Disable.
    Click Uninstall.
    It will prompt you to restart your computer.

    Once you're back in, repeat the process. 
    The drive will still show (I haven't figured out how to remove it), but without drivers, it can't harm the computer.

    Norton no longer sees backdoor.graybird or any other threats on the drive.

    Thursday, June 12, 2014 2:42 AM
  • Hi I was having the same issue and when I go to do these steps as confirmed by the OP the option to disable the drive is un-clickable (greyed out). Any ideas?

    Thanks :)

    Tuesday, July 08, 2014 3:02 PM
  • To disabled a mounted disc image, do this:
    In the new task window, select the Disc Utilities option and then Virtual Drive.
    The Power2Go Virtual Drive window displays.
    Select the Disable virtual drive option.
    Click on OK.
    • Proposed as answer by Nami Yuu Sunday, August 03, 2014 8:13 AM
    Sunday, August 03, 2014 8:13 AM
  • I had the same problem. Showed up as a station but had no properties en could not delete it. Turned out it was created by PowerIso. Removed PI because it was a trial version I never used it anymore. The virtual station

    disappeared immediately. If this is also your problem you can try to look in the options of PI the solve it.


    Monday, August 25, 2014 6:47 PM
  • remove powerdvd8 sorted mine out

    Saturday, September 06, 2014 10:09 PM