none
Canon PIXMA MP150 Scanner driver won't install

    Question

  • I have a Canon MP150 multifunction printer that worked fine with Win98SE. Since changing to Vista on a Dell laptop the scanner driver will not install. The printer installs and works OK but each time Vista tries to install the scanner driver it says "File not found". I have the latest driver file from the Canon website (1.10b) and Canon have suggested a few things  but nothing works.

    Tuesday, December 02, 2008 10:43 AM

Answers

All replies

  • David

     

    Go to the following website.

     

    Windows Vista Compatibility Center:
    http://www.microsoft.com/windows/compatibility/Default.aspx?type=hardware

     

    Type the product name in the Search Box and press GO.

     

    In the results, select the 'Learn More' link for the product.

     

    The resulting page will have information about the compatibility of that product and any links to software/drivers that are required for compatibility with Vista.

     

    If the status is listed as "unknown", see the instructions in the 'Related Questions' section for "Where do I find updated drivers for my laptop or desktop".

     

    Hope this helps.

     

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Tuesday, December 02, 2008 8:11 PM
  •  

    Hi,

     

    I understand that error message "File not found" was received when trying to install the driver. Could you please let me know the detail error message? Such as the file name. Thank you for your cooperation.

     

    After I get the message ,I will do a further research on the problem.

     

    Thanks.

    Thursday, December 04, 2008 8:00 AM
  • Canon MP150 is in the list of compatible hardware. Does this mean the problem is with the Dell laptop? Dell would not provide any assistance unless I paid for software support.

    Thursday, December 04, 2008 10:32 PM
  • Unfortunately no file name is given just the message "File not found" when trying to install the scanner driver. The printer driver installs successfully and works fine.

     

    Thursday, December 04, 2008 10:35 PM
  • David

     

    Go back to the Hardware Compatibility website. Locate the device and click on the Learn More link.

     

    If the resulting page has a link, such as Dowload Required, click that link and it should take you to the manufacturers website.

     

    Follow the instructions on that website to download the latest compatible driver for Vista. There should also be instructions there for installing the driver.

     

    Hope this helps.

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.


    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience

    Friday, December 05, 2008 1:29 AM
  • Hi Davidslicer,

     

    Thank you for your update.

     

    Given the current situation, I suggest you try to install the scanner driver again and collect the following log for me. Thank you for your cooperation.

     

    C:\WINDOWS\INF\setupapi.dev.log

     

    Please upload the file to the following link:

     

    https://sftus.one.microsoft.com/choosetransfer.aspx?key=cb392893-1c76-43b9-a14d-df28ca88c852

     

    Password: 6@wDyqO4[#d$$9*

     

    Thank you for your cooperation. 

     

    Friday, December 05, 2008 9:36 AM
  • Hi Ronnie,

     

    Went through this but with same result.  While going through the installation process the status shows that the printer driver is found in the preconfigured driver folders while Vista searches the folders and then online for the scanner driver suggesting the driver is not present in the download or is installed in the wrong folder. Here is the information from the Windows Error Report.

     

    David

     

    Product

    Driver software installation

    Problem

    Could not install driver software for device

    Date

    6/12/2008 9:17 PM

    Status

    Not Reported

    Description

    Windows encountered a problem while installing device drivers for your MP150

    Problem signature

    Problem Event Name: PnPDriverInstallError

    Architecture: x86

    Win32 error: 00000002

    Inf name: mp150sc.inf

    Driver Package hash: b2c863e7a219862b2fe36234120163b597095665

    DDInstall section name: CNCInstall_XP

    OS Version: 6.0.6001.2.1.0.768.2

    Locale ID: 3081

    Files that help describe the problem

    DMI32C7.tmp.log.xml

    oem4.inf

     

     

     

    Saturday, December 06, 2008 10:30 AM
  • Hi Robinson,

     

    This log does not exist, I have found C:\WINDOWS\INF\setupapi.dev with a change date corresponding to my last attempt to install the driver I tried to download that file but got the message "No workspace was found corresponding to the supplied password. The password or web page address (URL) may be incorrect. Please verify the password with a Microsoft Support Professional."

     

    David

     

    Saturday, December 06, 2008 10:33 AM
  •  

    Hi David,

     

    Yes, the setupapi.dev file is setupapi.dev.log. Windows hide .log extension since it is a known file type.

     

    Regarding the password, please try to use the following password to try again.

     

    eEgv%0ZpdUe)IfH

     

    Thank you for your cooperation.

     

    Monday, December 08, 2008 7:57 AM
  • Robinson,

     

    I have uploaded my setupapi.dev.log.

     

    Many thanks,

     

    David

     

     

    Tuesday, December 09, 2008 1:24 AM
  • Hi David,

     

    Thank you for your cooperation. I have received the log file.

     

    After check the log file, I found following message:

     

         inf:                               {Install Inf Section [CNCInstall_XP.NTx86.CoInstallers] exit (0x00000000)}

    !!!  flq:                     SPFILENOTIFY_NEEDMEDIA: returned FILEOP_ABORT.

    !!!  flq:                     Error 2: The system cannot find the file specified.

     

    The error message means a specified file cannot be found in copy process.

     

    I also noticed the error message you previously posted is:

     

    DDInstall section name: CNCInstall_XP

     

    Given the situation, could you please confirm if you are using latest MP150 driver for Windows Vista?

     

    If not, I suggest you download the latest driver from Canon official website:

     

    PIXMA MP150

    http://www.usa.canon.com/consumer/controller?act=ModelInfoAct&fcategoryid=116&modelid=12764#DownloadDetailAct

     

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Then, please try to install the latest driver.

     

    Hope it helps.

     

    Tuesday, December 09, 2008 6:56 AM
  • Hi Robinson,

     

    I have downloaded the latest driver for Vista "mp150vst110bea13.exe". I tried using the driver for XP and 2000 (this does work on my Win98SE machine) and got the same result. The interesting thing is that at www.fixya.com a number of others have the same problem.

     

    David

     

    Wednesday, December 10, 2008 4:46 AM
  • Hi David,

     

    Could you please send the latest setupapi.dev log file to me?

     

    Thanks.

     

    Thursday, December 11, 2008 9:10 AM
  •  

    Hi,

     

    Could you please check if the usbscan.sys file exists in C:\Windows\INF folder.

     

    Thank you for your cooperation.

    Tuesday, December 16, 2008 9:52 AM
  • I have a hp pavilion and I tried to instal the mp navigator from the printer canon pixma mp 150 and when I'm going to use it, the computer stops working. Would you help me?

    Thanks,
    Ana.

    Monday, January 19, 2009 2:59 AM
  • Thanks Robinson,

    That was the problem, I copied usbscan.sys from my system folder to inf and the driver installed. I can now scan!

    David
    Thursday, February 19, 2009 3:13 AM
  • Hi, I have the same problem as David, can you tell me where to get the usbscan.sys file?  I searched my computer and such a file does not exist in my computer (Dell Vostro 1400 running on MS Vista Home Basic).  It seems the fix was copying this file into the c:\windows\inf folder.

     

    Thanks.

    Saturday, February 19, 2011 11:26 PM