none
The MSSCRIPT.OCX (COM script control) that ships with build 7100 will not load

    Question

  • No matter where I try to use it, MSSCRIPT.OCX either won't load properly, or completely fails to, whereever I try:

    VB9/SP1 and VB6/SP6 give an error like this when I try: "...Windows\System32\msscript.ocx" could not be loaded
    VBA (in Excel 2003) doesn't disoplay an error when added o the toolbox of a user form, but the tool icon mouseover text says "Unknown", and you can't use it when you try to place it on a form

    Just to make sure, I did a fresh install of Win7 on a different computer... Loaded Office '03... Loaded VB6+SP6 and skipped VB9 to save time. XL03 and  VB6 behaved the same way as before.

    That control, and the app that requires it, was developed on a box running '08 Server, and all works well there...

    -NK


     
    Tuesday, September 15, 2009 5:06 PM

Answers

  • I've found a workaround to this issue:

    1- Run: Regsvr32 msscript.ocx
    2- Run: Regedt32.exe and go to HKCR\TypeLib\(0E59F1D2-1FBE-11D0-8FF2-00A0D10038BC)\1.0\0\
    3- Right click on the "Win32" Node, and select Permissions and set Full Control to the Administrators group
    4- Inside the Win32 Node, edit the default key erasing the two quotes

    .. it worked excelent with my win7 & vb6
    Wednesday, September 16, 2009 5:08 PM
  • Hello NK,

    Before run Regsvr32 msscript.ocx, you first need to make sure the msscript.ocx file is in c:\windows\sytstem32 folder.

    Then follow these steps to run Regsvr32:

    Step 1:
    ========
    1. Click the Start button, then in the "Start Search" box, type CMD but DO NOT press Enter yet.
    2. In the list above, under "Programs" right-click on CMD that appears above and choose "Run as Administrator" and click "Continue".
    3. In the open window, type the following command and press Enter:

    Regsvr32 msscript.ocx

    Step 2:
    =======
    1 Run regedit.exe, locate the registry Key[HKEY_CLASSES_ROOT\Typelib\{0E59F1D2-1FBE-11D0-8FF2-00A0D10038BC}\1.0\0\Win32]
    2 On the right pane, right click on the Default string value and select Permissions.
    3 Give Administrators Full Control, assuming you are logged in as an Administrator.
    4 Now edit the path of the Default String Value and remove the double quotes. If the msscript.ocx file is in c:\windows\sytstem32 folder, the path should be C:\Windows\system32\msscript.ocx

     


    Thomas Lin
    Thursday, September 17, 2009 9:48 AM

All replies

  • i'm having the same problem.. i've updated the control, but it's still not working.. any workaround?
    Wednesday, September 16, 2009 4:18 PM
  • I've found a workaround to this issue:

    1- Run: Regsvr32 msscript.ocx
    2- Run: Regedt32.exe and go to HKCR\TypeLib\(0E59F1D2-1FBE-11D0-8FF2-00A0D10038BC)\1.0\0\
    3- Right click on the "Win32" Node, and select Permissions and set Full Control to the Administrators group
    4- Inside the Win32 Node, edit the default key erasing the two quotes

    .. it worked excelent with my win7 & vb6
    Wednesday, September 16, 2009 5:08 PM
  • Hello NK,

    Before run Regsvr32 msscript.ocx, you first need to make sure the msscript.ocx file is in c:\windows\sytstem32 folder.

    Then follow these steps to run Regsvr32:

    Step 1:
    ========
    1. Click the Start button, then in the "Start Search" box, type CMD but DO NOT press Enter yet.
    2. In the list above, under "Programs" right-click on CMD that appears above and choose "Run as Administrator" and click "Continue".
    3. In the open window, type the following command and press Enter:

    Regsvr32 msscript.ocx

    Step 2:
    =======
    1 Run regedit.exe, locate the registry Key[HKEY_CLASSES_ROOT\Typelib\{0E59F1D2-1FBE-11D0-8FF2-00A0D10038BC}\1.0\0\Win32]
    2 On the right pane, right click on the Default string value and select Permissions.
    3 Give Administrators Full Control, assuming you are logged in as an Administrator.
    4 Now edit the path of the Default String Value and remove the double quotes. If the msscript.ocx file is in c:\windows\sytstem32 folder, the path should be C:\Windows\system32\msscript.ocx

     


    Thomas Lin
    Thursday, September 17, 2009 9:48 AM
  • Excellent solution - This worked for me. I followed the instructions above precisely. Many thanks.
    Monday, February 27, 2012 5:26 PM