none
Default printer keeps changing

    Question

  • I've noticed an issue happening with a few Windows 7 machines. They are all running Windows 7 Enterprise. Recently we had moved from a Server 2003 box to a Server 2008 R2 box as our print server. This issue seems to be happening on desktops that don't have location-aware printing.

    On the old print server, to deploy a printer we would go into print management, select the printer, then deploy via group policy. To my knowledge there's no way to define a default printer using that method(nor would I want to), and we're not using group policy preferences to deploy these. What happens is every single day people will change their default printer to the printer they want only to find the next day it has changed back to something else (in our case it's usually CutePDF or XPS). This is getting extremely annoying, is there any way to fix this?

    Thursday, July 28, 2011 6:43 PM

Answers

  • I have found a way that has fixed this issue for everyone who is experiencing it at my company.

    I had to go and edit the users registry hive:

    HKEY_USERS\USERS_SID_HERE\Printers\Connections

    I inevitably found old printer connections there that were no longer valid.  Upon clearing those out, after a reboot, the problem went away.

    I also cleared out the HKEY_USERS\USERS_SID_HERE\Printers\Settings key - the users had old printer setting sin there also.
    • Proposed as answer by Althornin Wednesday, November 09, 2011 3:12 PM
    • Edited by Althornin Wednesday, November 09, 2011 3:15 PM
    • Marked as answer by ajcrutch Wednesday, June 13, 2012 1:52 PM
    Wednesday, November 09, 2011 3:12 PM

All replies

  • If it helps, i'm seeing a ton of 823 Event IDs in the event viewer on the specific machine i'm looking at.

    "The default printer was changed to Adobe PDF,winspool,Ne03:. See the event user data for context information."

     

    DefaultPrinterSelectedBySpooler 1
    OldDefaultPrinter \\XXXXXXXX\mihq-printer120
    NewDefaultPrinter Adobe PDF,winspool,Ne03:
    Status 0x2
    Module spoolsv.exe

     

     

    Thursday, July 28, 2011 6:55 PM
  • Also, I am able to replicate this issue. I set the default to what I want, then restart the print spooler service, and the default will change back almost right away. Something I noticed though is that when it changes, connections to network printers have a yellow exclamation point next to them, I assume that means there are connections issues.
    Thursday, July 28, 2011 7:45 PM
  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    Please go to Devices and Printers, right click on your default printers and set it as default.

     

    If it does not work, please navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows

     NT\CurrentVersion\Windows\Device, export this registry from another working administrators profile, and import it to the problematic machine.

     

    Please be noted that registry modification may endanger Windows functionality severely, please do make a backup of the registry before performing the above steps.

    Meanwhile, please make sure you have installed the latest Adobe update. 

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, July 29, 2011 7:41 AM
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, August 02, 2011 8:16 AM
  • Since you are pushing the printer installation out by GPO, I believe you have mistakenly added the option to the GPO.  This might not have been an issue in XP, but your Windows 7 machines are using the preference.

    http://blogs.technet.com/b/grouppolicy/archive/2009/06/24/gp-preferences-set-a-default-printer.aspx

    Try setting the computer to a test GPO and see if it is resolved.

    Dave

    • Proposed as answer by McCue Monday, August 15, 2011 6:03 PM
    Tuesday, August 02, 2011 6:33 PM
  • This is not relevant for many reasons.

    1) This issue is pretty narrow, it affects very few Windows 7 machines in our environment. If defaults were set by preference, a lot more people would have this issue.

    2) This isn't how we map printers anyway. If you go into Print Management on the print server, right click the printer, then select deploy with group policy. There's no way to define a default printer when done this way.

    • Proposed as answer by ellenz Tuesday, September 10, 2013 7:22 PM
    Thursday, August 04, 2011 1:35 PM
  • I think the issue is related to group policy.  Run GPResult /H GPReort.html from an elevated command prompt to obtain the RSOP for the user and computer and see if that gives you information to resolve this.

     

    for reference: http://www.404techsupport.com/2010/05/11/rsop-and-gpresult-must-know-tools-when-using-group-policy/ 

    Dave

    Thursday, August 04, 2011 4:40 PM
  • Hi,

    How is it going?

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, August 10, 2011 4:33 AM
  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    Please go to Devices and Printers, right click on your default printers and set it as default.

     

    If it does not work, please navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows

     NT\CurrentVersion\Windows\Device, export this registry from another working administrators profile, and import it to the problematic machine.

     

    Please be noted that registry modification may endanger Windows functionality severely, please do make a backup of the registry before performing the above steps.

    Meanwhile, please make sure you have installed the latest Adobe update. 

    Best Regards

    Magon Liu

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tnmff@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    This did not resolve the issue.
    Monday, August 15, 2011 7:23 PM
  • Typically, the default printer changes when using a Terminal Server because Great Plains loads before the printers are loaded. To resolve this issue, we:

    1. Mapped the printer to the Terminal Server.
    2. Set the mapped printer as the Default Printer.
    3. When opening the Remote Desktop Connection we clicked ‘Options’ to check your settings
    3a. We selected the ‘Local Resources Tab’
    3b. We unchecked Printers
    4. We logged into the Terminal Server and found the correct printer was chosen as the default.
    5. We closed GP and the Remote Desktop Connection.
    6. We setup the Remote Desktop Connection to start GP upon login.
    7. The correct printer was still selected as the Default Printer.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, August 17, 2011 10:43 AM
  • Hello everyone following this thread,

    I have a suggestion, but unfortunatley, it is not a solution to the problem.

    This won't allow the enduser the ability to set the default printer according to their preference. (atleast, not easily .. they will need to be able to modify the script)

    It's a kludge.

    Run a dot bat file at login. Here is the single line of code:

    cscript c:\windows\system32\prnmngr.vbs -t -p \\printserver\printqueue

    This line of code is for XP. You will need to modify slightly for Win7.

    SookieSam

    Thursday, August 18, 2011 4:23 AM
  • I have this very similar problem to my network. I've tried pretty much everything found on google the last couple months but haven't got any luck. I know if I re-image the pc it would no longer reset the default printer but that would be giving up too easy. Does anyone get any luck? 
    Tuesday, October 11, 2011 6:14 PM
  • Remember Adobe PDF, CutePDF or XPS are considered local printers so they would show up on each profile; network printers are more volatile.   This might be the Issue too.

     

     

    Tuesday, October 11, 2011 11:06 PM
  • I found this on another forum and test it on 5 workstations. 2 of them actually gave good result the other 3 remain resetting default printer every time. I hope someone will have better luck. 

    Add this registry key:

    GpNetworkStartTimeoutPolicy  DWORD 

    set value at 120 decimal for 120 seconds

    to this

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\

     Since it's not gonna do any harm to the others, I'm gonna push it out globally to all workstations in our domain (about 400 pc) and see how many of them actually get fix (about 200 of them have this issue)

    If you have any idea, please let me know as this thing drives me nut the last few months. 

    Thanks

     

    Wednesday, October 19, 2011 8:17 PM
  • Woainot,

    You can set that via GPO:

    Setting Path:
    Computer Configuration/Administrative Templates/System/Group Policy/Startup policy processing wait time

    However, I think you'd be better off setting the following as well:

    Setting Path:
    Computer Configuration/Administrative Templates/System/Logon/Always wait for the network at computer startup and logon

    If the "Always wait" policy is applied, the machine will wait for the network to be fully initialized before  logon occurs.

     

    However, even given both of these, I have a few users that have this issue (every reboot or logon/logoff thier default printer gets reset to some other random printer).

    I have found no sure-fire fix.  If I look in the event log, i can see that it is the spooler service resetting their default printer, right after logon.  Makes no sense.

    • Proposed as answer by Althornin Wednesday, November 09, 2011 3:12 PM
    • Unproposed as answer by Althornin Wednesday, November 09, 2011 3:12 PM
    • Proposed as answer by Anuron Friday, April 27, 2012 2:42 PM
    • Unproposed as answer by Anuron Friday, April 27, 2012 2:43 PM
    Thursday, October 20, 2011 3:44 PM
  • I have found a way that has fixed this issue for everyone who is experiencing it at my company.

    I had to go and edit the users registry hive:

    HKEY_USERS\USERS_SID_HERE\Printers\Connections

    I inevitably found old printer connections there that were no longer valid.  Upon clearing those out, after a reboot, the problem went away.

    I also cleared out the HKEY_USERS\USERS_SID_HERE\Printers\Settings key - the users had old printer setting sin there also.
    • Proposed as answer by Althornin Wednesday, November 09, 2011 3:12 PM
    • Edited by Althornin Wednesday, November 09, 2011 3:15 PM
    • Marked as answer by ajcrutch Wednesday, June 13, 2012 1:52 PM
    Wednesday, November 09, 2011 3:12 PM
  • I have found a way that has fixed this issue for everyone who is experiencing it at my company.

    I had to go and edit the users registry hive:

    HKEY_USERS\USERS_SID_HERE\Printers\Connections

    I inevitably found old printer connections there that were no longer valid.  Upon clearing those out, after a reboot, the problem went away.

    I also cleared out the HKEY_USERS\USERS_SID_HERE\Printers\Settings key - the users had old printer setting sin there also.

    Fantastic. Let me give this a try on a few users, hopefully this fixes it.
    Wednesday, November 09, 2011 3:38 PM
  • Eureka!  Thanks much - that's awesome - worked like a charm ...in my instance the legacy printer remnants were at only the HKEY_USERS\USERS_SID_HERE\Printers\Settings key


    Dale Unroe

    ...well actually that worked for that moment - later it was discovered that due to the way that VMware Fusion was default configured, the underlying Mac OS was pushing it's default printer up to the Windows 7 OS - disabled that 'feature' and everything now stays put

    • Edited by Dale DU-IT Friday, April 27, 2012 2:46 PM
    Friday, January 06, 2012 6:03 PM
  • I have found a way that has fixed this issue for everyone who is experiencing it at my company.

    I had to go and edit the users registry hive:

    HKEY_USERS\USERS_SID_HERE\Printers\Connections

    I inevitably found old printer connections there that were no longer valid.  Upon clearing those out, after a reboot, the problem went away.

    I also cleared out the HKEY_USERS\USERS_SID_HERE\Printers\Settings key - the users had old printer setting sin there also.

    THANKS !!! This should be marked as the answer. 

    Checked HKEY_USERS\USERS_SID_HERE\Printers\Connections, found and old driver and deleted the driver. Everything is fine after restart.

    Friday, January 20, 2012 1:25 AM
  • Thank you so much!!!
    • Proposed as answer by Anuron Friday, April 27, 2012 2:43 PM
    • Unproposed as answer by Anuron Friday, April 27, 2012 2:43 PM
    Friday, April 27, 2012 2:43 PM
  • Do you have to remove the invalid printers from the local client's registry or from the Remote Desktop server's registry?

    Wednesday, June 13, 2012 1:32 PM
  • This worked for me! Thanks Althornin
    Tuesday, April 09, 2013 10:29 PM
  • Using wmic is a much better option, as it's also just one (very similar) line, but should work the same from Win2000 up.

    This still isn't a solution, but rather a workaround.

    Friday, July 05, 2013 7:23 PM
  • Hello,

    That didn't work because old printers are cleaned. But gave me another way to resolve the issue.

    A DWORD key was created on HKEY_USERS\USER SID\Printers\Defaults. Name of this key DisableDefault with (1) value.

    I deleted the DWORD et voila ! My network printer stayed as the default printer !

    Tuesday, July 09, 2013 3:48 PM
  • Go to printers and faxes

    press shift and right click on the printer that you want to DELETE

    RUN AS administrator

    Go to PROPERTIES

    SHARING

    tick do not share this printer

    GO back to printers and faxes

    delete the printer from there

    Right click on the one you want and set it as default

    Log off and log back in

    It worked for me guys !!

    Cheers, 

    Paul 

    Wednesday, August 21, 2013 3:24 AM
  • I seem to be having the same problem. I have Windows 7 Enterprise and Windows 2008 R2 Server. I set the printers using PrintManager and Deploy with GP. Random users get their default printers changed to random ones on login. I tried to add the printers instead using the Group Policy mentioned in article

    http://blogs.technet.com/b/grouppolicy/archive/2009/06/24/gp-preferences-set-a-default-printer.aspx

    But then for some reason the printers actually disappeared from the users. Hopefully someone has an answer for this.

    I also checked the user registry as someone suggested under Printers/Connections and Printers/Settings for old printers. But that is not my case. The users only have my 5 printers that are current on the network.


    Thanks.

    Thursday, January 30, 2014 3:57 PM
  • This article contains the answer I was looking for:

    http://windows.microsoft.com/en-us/windows7/automatically-switch-default-printers-between-home-work-or-school

    Specifically:

    To manage location-aware printing settings

    1. Open Devices and Printers by clicking the Start button, and then, on the Start menu, clicking Devices and Printers.

    2. Click a printer, and then click Manage default printers on the toolbar.

    • If you don't want Windows to change your default printer settings when you move from place to place, click Always use the same printer as my default printer in the Manage Default Printers dialog box, and then click OK.


    Tuesday, February 18, 2014 12:32 PM
  • Is there a way to complete this using GPP?  I have been trying with no luck thus far.

    Here is what I have thus far:

    %LogonUserSid%\Printers\Connections\,,oldprintserver,%TraceFile%

    I would like to have the GPP remove any Registry Key, based on the logged on user and if they any old keys relating to both our old print servers.

    Wednesday, July 30, 2014 8:29 PM