none
Copy locked files ("Files In Use")

    Question

  • In Vista I was able to copy files with locking handles.
    Example of a third party software: http://ccollomb.free.fr/unlocker/
    Namely, files which WinExplorer can not copy can be copied by third party software (for example).
    WinExplorer says:
    "File In Use
    The action can't be completed because the file is open in <LockFile app>
    Close the file and try again."

    But in Seven I can not copy such files - all third party software apps say that no locking handles are found.
    I need to to perform mentioned copying for software testing purposes.

    Please clarify is there a possibility to copy such files?

    I understand and agree with the fact that Microsoft does not support any third party software.
    Is there some possibilities to copy mentioned files using Microsoft software?

    If no I need help to localize the problem.

    May be it is related to new file processing in Windows 7 but I could not find any information about this.

    It can be related to my system environment - access restrictions, settings etc. 
    But I have no idea why it is not working now - I have admin rights, UAC is turned off...

    Thanks in advance for answers.

    Tuesday, February 09, 2010 3:53 PM

All replies

  • Hi

    I have not experienced any problems copying files in Windows 7, even when they are in use?

    Are these Windows System files?

    Can you give us an example of a file, the location of the file and how you are performing the copy.

    Regards,

    Thank You for using Windows 7


    Ronnie Vernon MVP
    Tuesday, February 09, 2010 4:32 PM
  • Hi, Ronnie

    I can reproduce mentioned problem for example with fla14.tmp file in C:\Users\<UserName>\AppData\Local\Temp which is created by Internet Explorer while it is playing some video from internet using Flash player.
    This is just an example.

    I also have a small application which can lock any file in the same way as IE in the example above.

    And I used the mentioned third party software to copy such files.

    Actually I need to check some files which are locked by some apps (for testing purposes).
    So I have to create copies of these files while locking app is still "holds" them because if the app "releases" them then they are immediately deleted.

    And please note - this problem is actual for Windows 7 only (Windows XP and Windows Vista have no issue like this).

    Tuesday, February 09, 2010 5:07 PM
  • Hi,

    Please also try the suggestions from the following article:

    Folder is in use

    Thanks,
    Novak
    Thursday, February 11, 2010 6:09 AM
  • I tried to resolve the problem using information in the mentioned topic but with no success.

    'Always show icons, never thumbnails' - checked
    'Display file icon on thumbnails' - unchecked
    'Show preview handlers in preview pane'  - unchecked

    But I still observe the problem with above mentioned *.tmp files.

    Tuesday, February 16, 2010 2:47 PM
  • Hi,

    Does the issue only occur on certain *.tmp file? Since the temp files are uesless for the system, you can skip them and transfer some other files for a test. The temp files are usually used by certain background application and the symptom is normal when copying these temp files.

    Thanks,
    Novak
    Monday, February 22, 2010 7:21 AM
  • Hi,

    Excuse me, but I need to copy mentioned files without any "transfer some other files for a test".
    Any locked file can not be copied.

    As I mentioned, any file can be locked in the same way. I can even simulate this situation and show how it can be reproduced in Windows 7 but can not be reproduced in Vista/XP.

    Sorry, but it is more useful to get answer 'it can not be resolved' instead 'why do you need this?' or 'try to think you do not need this'...
    Monday, February 22, 2010 8:06 AM
  • hi sergego

    I'm pretty sure I'll know what you're trying to do... I was in the same situation recently with my Win7 Ultimate 64bit...
    however, the only really WORKING solution I found so far is the following cmd-line app... (everything else outer there won't work, at least not in 64bit)

    Download:   http://sourceforge.net/projects/wangdera/files/HoboCopy/
    Homepage:   http://alt.pluralsight.com/wiki/default.aspx/Craig/HoboCopy.html
    A HowTo:   http://www.howtogeek.com/howto/windows-vista/backupcopy-files-that-are-in-use-or-locked-in-windows/

    it works, I have it already tested, also with an flv opened in ie8 too... ;)

    good luck! ^^
    Tuesday, March 02, 2010 10:35 PM
  • Sorry but HoboCopy crashes (please note vcredist_x86.exe is installed).
    Although I've marked your comments as answer to my question.
    Thank you for ideas - I'll try to compile source codes and look what's a problem.


    Problem signature:

    Problem Event Name: APPCRASH

    Application Name: HoboCopy.exe

    Application Version: 0.0.0.0

    Application Timestamp: 459ea97d

    Fault Module Name: VSSAPI.DLL

    Fault Module Version: 6.1.7600.16385

    Fault Module Timestamp: 4a5bdb24

    Exception Code: c0000005

    Exception Offset: 0002ee89

    OS Version: 6.1.7600.2.0.0.256.4

    Locale ID: 1058

    Additional Information 1: 0a9e

    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

    Additional Information 3: 0a9e

    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Thursday, March 04, 2010 9:22 AM
  • hi

    strange... what kind of w7 do you use? there is an 32 and 64bit version of hobocopy available...

    however, hobocopy64 was running fine just from the beginning with my win7 ultimate 64bit... if you use w7 32bit you could try runtime's shadowcopy (<tt>http://www.runtime.org/shadowcopysetup.exe</tt>) also... but remember: it's meant for 32bit (xp, vista, w7) only at the moment...

    bye

    sparksman
    Thursday, March 04, 2010 5:46 PM