none
Windows 7 - Auto-Connect to Network

    Question

  • I've had an issue where I set a wireless connection (WPA2-AES) to automatically connect to the network.  I have the correct Passkey in there.  When I reboot the machine, the system will not auto-connect to the network.  However, if I bring up the list of networks, I click the Connect button (do not need to enter the key again) and it connects.

    I've fixed this before on another machine, but can't remember how.

    I seem to remember that somewhere there was a registry key to fix this, can anyone help me remember what the fix was?

     

    Monday, July 19, 2010 4:45 PM

Answers

  • Hi,

     

    Please test the following solution:

     

    Windows 7 and the WiFi connection that wouldn’t connect!

     

    Please note: we provide the third party link for technical use only. There may be some changes without notice, Microsoft doesn’t guarantee any accuracy on contacting information.

     

    Best Regards

    Dale

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by drazzst550 Monday, July 26, 2010 12:02 PM
    Monday, July 26, 2010 2:47 AM
    Moderator

All replies

  • Hi,

     

    Ensure that you created the Wireless Network Profile and select the “Start this connection automatically” check box.

     

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, July 21, 2010 2:22 AM
    Moderator
  • That was the first thing that was done.  I've also tried removing the checkbox, rebooting, restoring the checkbox, rebooting, as suggested in another article, and that didn't work either.
    Wednesday, July 21, 2010 12:10 PM
  • The auto-connect behavior will not function until the WLAN service is restarted. To properly ensure wireless connection behavior, you should:

    1. make sure the wireless networks you want to connect to automatically are listed in the proper order (most preferred at the top) when viewing your wireless networks
    2. make sure the "connect to a more preferred network" option is selected on all networks you want Windows to abandon if it finds a higher priority wireless network in range.
    3. make sure that the WLAN service is set as Automatic and started.
    4. update your wireless network card driver to the latest version.

    Best Regards
    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, July 22, 2010 2:52 AM
    Moderator
  • The WLAN service is started, that is what is interesting.

     

    1.  That was already done

    2.  There is only one network setup, so there can't be a more preferred network

    3.  as I mentioned, the WLAN service is started and running (and Automatic)

    4.  Already got the latest version of the drivers.

     

    I ran into this once before, there is a XML file or a Registry setting that I think needs to be adjusted.

    Sunday, July 25, 2010 2:05 PM
  • Hi,

     

    Please test the following solution:

     

    Windows 7 and the WiFi connection that wouldn’t connect!

     

    Please note: we provide the third party link for technical use only. There may be some changes without notice, Microsoft doesn’t guarantee any accuracy on contacting information.

     

    Best Regards

    Dale

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by drazzst550 Monday, July 26, 2010 12:02 PM
    Monday, July 26, 2010 2:47 AM
    Moderator